• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] LineageOS 18.1 UNOFFICIAL - 1.0 [2021-01-17]

Search This thread

LYSZY6

New member
Oct 10, 2020
4
2
Hi,
Do you know how to enable VoLTE for China Unicom?
Chinese:默认设置就可以正常使用(没有视频通话),但是有时候volte会不工作。另外2月份的时候这个rom刷入opengapps后会不定时死机,不知道现在还会不会。
English:The default Settings will work (no video calling), but sometimes Volte won't work. In addition, this ROM crashed irregularly after flashing OpenGAPs in February,I dont know whether it will happen now.
 

davestuarts

Senior Member
Sep 28, 2010
187
28
I think I'm too late late to party on this one. I had installed this rom on my sisters phones several months ago, and she always got the IMS service switcher prompt and often has issues with connection and sees the promt sim not in service, though sometimes she can make calls but doesnt have data and then sometimes nothing, this happens a lot.
I've clean installed the rom a few times but same problerms.
Today Iooked at the install guide and realised the biggest faux pas, I did not upgrade the firmware! I suppose these contained updated drivers etc?

Is it possible to apply the upgrade firmware procedure on top of her installed rom and continue as normal?
It's because her phone is all setup and she doesn't want me to start again, or will I have to upgrade firmware first, then install rom from scratch?

Thanks
 

davestuarts

Senior Member
Sep 28, 2010
187
28
Hi @derf elot, hope you're well. I know you're/were working on a few devices for LOS 18.1 so probably not easy managing multiple devices, but just wondering if any updates are comiung to 18.1 for Sony XZ1? Or is the project now defunct?

Thanks.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    LineageOS 18.1 for Sony Xperia XZ1

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1, offering several privacy features.

    Please report any issues you observe apart from the ones listed below. Logs are needed for me to fix anything (preferably dmesg and logcat). I can't test NFC very thoroughly, to please report your findings.

    FEATURES
    • Signed with dev keys
    • Up-to-date kernel
    • WireGuard kernel support

    DOWNLOAD

    You can download the latest releases here:

    poplar (G8341):
    twrp-3.5.0-0-20210117-poplar
    lineage-18.1-20210117-UNOFFICIAL-1.0-poplar

    poplar_dsds (G8342):
    twrp-3.5.0-0-20210117-poplar_dsds
    lineage-18.1-20210117-UNOFFICIAL-1.0-poplar_dsds

    poplar_canada (G8343):
    twrp-3.5.0-0-20210117-poplar_canada
    lineage-18.1-20210117-UNOFFICIAL-1.0-poplar_canada


    Check the ChangeLog below for firmware requirements!

    INSTALLATION

    Put the zip file of the ROM on your sdcard or internal storage, boot into recovery and flash. When coming from stock: boot into TWRP, format data, reboot to recovery and wipe all internal partitions. Then flash the ROM, GApps (if needed) and root (if needed).

    Note: There is not going to be a LOS su addon anymore. If you need root, flash a root manager of your choice. No guaranteed support from LOS for this.

    When updating from builds, simply dirty flash the ROM.

    If coming from 17.1, please see advice below in second post ("UPGRADE LINEAGEOS").

    KNOWN ISSUES
    • WFD is not working yet (waiting for new non-BSP blobs)
    • Stock camera is not working anymore due to incompatibility of stock library (libimageprocessorjni.so) with new libgui
    • You tell me...

    Contributors
    derf elot, modpunk, Rooted_Ansh

    Thanks to the testers
    coin3x, feduss, GiaSen, Gizanagi, hsheemi, kaancaliskan, sohrab1985

    Source Code
    poplar:
    https://github.com/whatawurst/android_device_sony_poplar
    poplar_dsds: https://github.com/whatawurst/android_device_sony_poplar_dsds
    poplar_canada: https://github.com/whatawurst/android_device_sony_poplar_canada

    kernel: https://github.com/whatawurst/android_kernel_sony_msm8998

    Rom Information
    ROM OS Version:
    Android 11
    ROM Kernel: Linux 4.4

    Version Information
    Status:
    Stable
    Current Stable Version: 1.0
    Stable Release Date: 2021-01-17

    Thread Information
    Created
    2021-01-17
    Last Updated 2021-01-17
    22
    SECURITY ADVICE

    Don't flash ROMs or Magisk modules which set SELinux to permissive or you welcome malware on your device!


    UPGRADE LINEAGEOS


    I have not tried upgrading the device from 17.1 and cannot guarantee that it will work - you should do a backup just in case. If things go wrong, flash it as if coming from stock (see instructions in OP).

    The following steps should work though:
    • Flash new twrp and boot into it
    • Flash new rom, opengapps and any updated root solution you use
    • Optional: Clear cache
    • Reboot
    Note: When updating form Lineage 17.1, you maybe have to once change your preferred network type from 3g back to 4g/LTE.

    UPGRADE FIRMWARE

    • Grab the Sony Stock firmware using e.g. XPeriFrim. You should always flash the firmware matching the LOS build.
    • Grab newflasher and put it in the same folder as the firmware files.
    • Read the newflasher original post on XDA for general instructions!
    • Remove the following from the folder so they won't get flashed:
      • all *.ta files (keep the one in the boot/ directory)
      • cache*.sin
      • fotakernel*.sin
      • kernel*.sin
      • system*.sin
      • userdata*.sin
      • vendor*.sin
    • Turn off your phone
    • Hold the volume down button and attach it via USB to your system till you see LED turning green
    • Run newflasher from within this directory to flash the remaining files
      You can say yes to the first optional step, in case you don't have working drivers installed.
      Skip the second optional step (dumping of trim area), it's useless if your bootloader is unlocked already and takes a long time.

    How to get root?

    As mentioned before, there will not be an official su addon from LOS anymore. If you need root, flash an unofficial solution.

    Google Apps

    You can download and install the Google Apps from opengapps.org. You need ARM64 and 11.x. I suggest to *always* use the pico or nano package. If you need additional apps you find them in the Play Store.

    Open GApps for Android 11 is still in beta. You can download those releases here

    MicroG

    This ROM doesn't support Signature Spoofing. However we are watching MicroG and check if they provide newer builds e.g. for Android 11.
    16
    REQUIRED FIRMWARE: 47.2.A.11.228

    CHANGELOG

    2021-01-17 | 1.0| 47.2.A.11.228

    • Initial release
    6
    Thanks @derf elot ! For all your and the rest of the Dev team's efforts.

    What can we (the community) do to help get the camera back up and running?

    Unfortunately, I am not sure there is much that we can do. The stock library that we need for the stock camera app to work properly (libimageprocessorjni.so) is not liking the new Android 11 libgui. We (also with the help of @j4nn ) tried to fix these issues in various ways, including shimming and forcing the use of the 10 libgui but haven't managed to get it working properly yet. Maybe we'll have a crack at it again at some point, but I wouldnt get my hopes up too much. It also doesn't help that the XZ2/3 series is not getting an official Android 11 update. Opencamera is a decent alternative, although it does lack some of the stock camera options.

    Ok THIS WAS THE BEST BIRTHDAY PRESENT EVER... I'll test it asap:)

    Happy birthday. I hope you enjoy :)
    3
    Using this ROM for 2 months now...
    Pros:
    + Mostly stable, except for very specific case (see cons)
    + Almost no bloatware (microg, vendor-specific apps etc) - modem switcher notifications are disableable at last
    + Passes SafetyNet with minimal handwaving
    + All hardware stuff appears to be working

    Cons:
    - High power consumption, discharge from full to 30 percents in 10 hours (was about 16 hours on LOS 17.1)
    - Sudden freezes when making partial screenshots (short-press vol down + power)
    - Camera app does not actually save to SD card
    - Weird recovery - had to manually patch kernel image file for Magist setup, then install (written above, pg2 or 3 of this thread), looks like recovery coming with this ROM does something wrong - autopatch via recovery kills kernel, regardless which Magisk version do I pick