• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread

wirdSchoon

Senior Member
Nov 8, 2017
139
29
You can change the notification light color for each app under "Notification light" using "Use custom value* and adding the app with the + button top right.
I also had the problem that notifications where not working, a clean reinstall of the ROM solved the problem.

I've searched for it so far in vain...
In LOS 16 I had already made these settings and in LOS 17.1 these changes were even applied. I have now deleted the personal changes of the LED color and blinking speed and entered them again.
The LED now works again with all apps except FairEmail. The developer of FE has added a workaround which causes his app to respond to the LED again, but he suspects that our LOS 17.1 does not work properly at this point.
 

FFW

Member
May 24, 2020
44
32
I've searched for it so far in vain...
In LOS 16 I had already made these settings and in LOS 17.1 these changes were even applied. I have now deleted the personal changes of the LED color and blinking speed and entered them again.
The LED now works again with all apps except FairEmail. The developer of FE has added a workaround which causes his app to respond to the LED again, but he suspects that our LOS 17.1 does not work properly at this point.

I have the customised notifications LED in use on 1.2 - it works fine and reliable for me. Go to Apps & Notifications, tap on Notifications, scrol down to "more" (? unsure if I translated this correctly, in german it says "erweitert"), tap in "Notification LED", activate "App customisation" (again unsure if I translated this correctly...) and tap on the "+" symbol on the top right to add apps.
 

wirdSchoon

Senior Member
Nov 8, 2017
139
29
I have the customised notifications LED in use on 1.2 - it works fine and reliable for me. Go to Apps & Notifications, tap on Notifications, scrol down to "more" (? unsure if I translated this correctly, in german it says "erweitert"), tap in "Notification LED", activate "App customisation" (again unsure if I translated this correctly...) and tap on the "+" symbol on the top right to add apps.

I've looked for it so far in vain.
Excuse me - it should say:
I had looked for it in vain...
so I found it and found out that the settings made in LOS 16 were still there.

Does the notification LED also work correctly with FairEmail?
 

mulcahey

Senior Member
May 4, 2016
78
9
Loving this rom!

I can't launch the camera using the camera button when the phone is locked. I saw that this was mentioned ITT in April. Has anyone found a workaround?

Alternatively, is there a way to add a "launch camera" button to the lockscreen?
 

landsome

Senior Member
May 4, 2015
362
89
Just made the switch to LOS. Great ROM, thank you and congrats.

Only problems so far (besides the camera button, which does not work to open the cam at all, but that's not an issue):
- For some reason AccuBattery, with all the needed permissions granted, seems to occasionally reset itself when the phone is charging.
- Also, charging is relatively slow compared to stock.
- Finally, Light Flow Pro (but it's also true of legacy) does not change led color (at all).

And a question for those who know the ROM better:
- Are the color profiles (sRGB, DCP) calibrated in any way; do they use the stock ROM settings?
 

fred0r

Senior Member
Nov 23, 2011
108
25
Hamburg
I try to not wipe system and data, it will result cannot connect to Wi-Fi in LineageOS rom even I enter correct Wi-Fi password.
I had the same Problem and tried with deleting cache/dalivk first, but nothing worked
ended up with formatting everything before installing this rom and then i was able to connect via Wi-Fi, but i first used Titanium-Backup to backup my Apps.
 
Last edited:

techno-viking

Member
Oct 8, 2019
32
19
Canada
The clock application no longer works for me with this 1.3 version. All other previous versions it worked. I just flashed this on top of version 1.2 and wiped cache, dalvik

Just flashed Version 1.3 over Version 1.2 and wiped cache/dalvik as well. The clock (timer, stopwatch etc), camera, and other stock apps are fortunately working for me.

Maybe try to reflash to see if that fixes it? :fingers-crossed:
 
  • Like
Reactions: i.j

toejam119

Senior Member
Jun 30, 2018
63
42
Flashed 1.3 on top of 1.2:
- Stock camera app starts straight up fine (no tweaks/hacks needed so far), works good and I am now able to save images straight to SD card!
- Alarm works perfect now. (bug ref: https://forum.xda-developers.com/showpost.php?p=82966629&postcount=493)
- Stock calendar app works perfect now. (bug ref: https://forum.xda-developers.com/showpost.php?p=82202173&postcount=183)
- Still missing Holo Blue keyboard theme. Maybe it was removed on purpose? The Material theme is good too but I liked the Holo theme's clear layout a bit more. (bug/feature ref: https://forum.xda-developers.com/showpost.php?p=82706273&postcount=374)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Still EAS kernel? Is 18.1 also?
    The EAS kernel is awesome!
    Yes. Both use the same kernel
    1
    Select 'Access Point Names' and right up select + and configure You own apn.
    1
    Hey guys, first off thanks a lot to modpunk and flamefire and everyone else here to put in the energy to keep our beloved phones updated.

    This weekend I installed the very latest 18.1 from flamefire and it works fine so far. (I installed it clean, no dirty flash, completely started over with the Sony stock ROM via EMMA and then did a clean 18.1 install following all the right steps)

    Now there is one major bug that I somehow cannot find a solve for and I hope someone could help me please. Sometimes and all of a sudden the mobile network just disappears and it says 'the cellular network is not available'. I cannot even select it under Settings to switch between 3G and LTE as it is grayed out. After I restart it comes back though.

    Now, what is odd is under 'Settings / Wireless & Internet / Mobile Network' I cannot select and manually define the Advanced settings for the carrier AT&T (see 2 attached screenshots at the bottom). There for whatever reason it only says 'To disable this SIM, remove the SIM card'.

    Shouldn't there be a menu similar to the TELUS screenshot that let's me define the preferred network type, calling, Network access and so on?

    I know some people here had the same issue, but was wondering how it has been solved.

    Thanks a lot!



    (Edited: Wording, sorry I did not mean APN but the 'Advanced' settings for the network carrier)
    I see that effect after inserting ("hotplugging") a SIM card without rebooting.
    1
    Well "preferred network" and "APNs" is there in the screenshots. If it is VoLTE which is missing, then I guess the SIM doesn't support it and/or IMS has been disabled in XperiaParts
    1
    Wow, this ROM (18.1 Flamewire) is too fast :D Thank you! Only thing I found : Gabeldorsche Bluetooth stack is not working (one from developer options)
  • 81
    LineageOS 17.1 for Sony Xperia XZ1 Compact

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    FEATURES
    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included

    DOWNLOAD

    You can download the latest release here. Check the ChangeLog below for firmware requirements!

    INSTALLATION

    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!

    KNOWN ISSUES

    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    Contributors
    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Stable
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    41
    REQUIRED FIRMWARE: 47.2.A.11.228

    CHANGELOG


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements


    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    26
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    20
    Version 1.4 is out with fixes for camera and GPS.
    18
    Version 2.0 based on LineageOS 18.1 is out! Have fun.