• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread

derf elot

Senior Member
May 7, 2011
842
1,833
strange, BT audio should be back to how it was originally. and at least on poplar it was reported that it works fine now.

is this file present?

/vendor/etc/bluetooth_audio_policy_configuration.xml

Sent from my SM-G970F using XDA Labs

---------- Post added at 10:54 AM ---------- Previous post was at 10:45 AM ----------

Thank you! Is VoLTE operational in 1.5?

no, im still working on it

Strange that PLATFORM_SECURITY_PATCH is still 2020-08-05.

The September Android security patches have apparently not been applied upstream yet. (Confirmed just now by checking LineageOS/android_frameworks_base for one of this month's ASB patches. The lineage-17.1 branch has not been patched.)

yes, it is scheduled to be merged to los tomorrow
 

k_oile

New member
Oct 13, 2018
1
0
+1 on BT-Issue. Updated from 1.4 to 1.5 via TWRP (Wiped Cache and Darlvik). I don't have GAPPS.
Removed and Paired again Airpods and LibreELEC on RPi4. Both show as connected but sound still comes from the buildin speakers...

My /etc/vendor doesn't have a ***_audio_policy_configuration.xml just a "vintf" dir. I checked this out via TWRP Filemanager.

If you need more info for debugging pleas tell.

BTW: Thanks for the great job in general!
 

DPLZ

New member
Aug 11, 2014
2
0
There is another BT Problem:

I have an old Nokia play 360 speaker(actually two of them). These BT speakers has apt-x codex but in one of the two, I don't know why, isn't coming anything in output. The solution is to select SBC audio and start work again.
In Bluetooth settings, there is possibility to toggle off Bluetooth Audio HD. When toggle off, speaker has loop of disconnect and connect and it won't work. That's a stupid thing. But happens with all my apt-x receiver. If I disable Audio HD (or apt-x) toggle, there is a loop connection.
 

baboon23

Senior Member
Apr 9, 2020
149
37
+ Bluetooth audio plays through speaker.
Any chance to push a 1.55 tomorrow with the september update and this fix ?

GPS works BEAUTIFULLY at last, incredible ! I get a fix in seconds, without any gapps/location services ! Bloody genius.
 
Last edited:

Dean F

Senior Member
Sep 12, 2016
169
79
Taipei
Sony Xperia XZ1 Compact
Hi Just adding my name here:

I download the update this morning, flashed it - Bluetooth audio no longer works. The my Sony WI-XB400 earbuds connect successfully - but the audio is playing from the phone speakers, not the Bluetooth speakers.

Tried re-pairing, tried turning HD audio on/off in the settings. Still doesn't play through the bluethooth headset.
 

YamiYukiSenpai

Senior Member
Oct 7, 2014
305
35
Can you explain that one? Is it the issue with Netflix not playing any videos?

---------------------------------

Regarding the Bluetooth earphones issue, fingers crossed it gets fixed soon. In the meantime, I have to downgrade to previous version because Bluetooth earphones are essential for me (if I wasn't working at a place that required me to wear a suit, I would've just stuck with wired earphones).
 
Last edited:

threesea

Member
Sep 12, 2020
11
0
I got everything installed without zip signature, but the notification LED doesn't work like it does on stock anymore. It used to show a red light when charging, and slowly blinks white when the phone receives an important notification.
Now, it shows a mix of all lights (white, red, green, blue) when charging, and notifications no longer work with the LED.
Any way to get the LED back to how it used to work?
 

Petr 78

Member
Jul 13, 2019
31
7
Plzen
I got everything installed without zip signature, but the notification LED doesn't work like it does on stock anymore. It used to show a red light when charging, and slowly blinks white when the phone receives an important notification.
Now, it shows a mix of all lights (white, red, green, blue) when charging, and notifications no longer work with the LED.
Any way to get the LED back to how it used to work?

This works (color, interval time, time,...) on Havoc OS
 

Dean F

Senior Member
Sep 12, 2016
169
79
Taipei
Sony Xperia XZ1 Compact
@modpunk Hey man. Thanks for the release to 1.5. The whole lineage 17.1 just feels so solid now. It's a pity about the Bluetooth.

I noticed your said you will be gone until end Oct. Given your timeline, should those of us using bluetooth audio rollback to 1.4 first? Or if its gonna be a quick fix for you, we could all just wait a couple days and grab the patched version?
 

derf elot

Senior Member
May 7, 2011
842
1,833
@modpunk Hey man. Thanks for the release to 1.5. The whole lineage 17.1 just feels so solid now. It's a pity about the Bluetooth.

I noticed your said you will be gone until end Oct. Given your timeline, should those of us using bluetooth audio rollback to 1.4 first? Or if its gonna be a quick fix for you, we could all just wait a couple days and grab the patched version?

given that you need a build with his dev keys, yes should probably roll back.

edit: looks like I finally managed to fix the issues with the CustomizationSelector and modem-switcher. IMS should be back soon as well hopefully, also dynamically adjusting to sim card inserted


Sent from my SM-G970F using XDA Labs
 
Last edited:

Dean F

Senior Member
Sep 12, 2016
169
79
Taipei
Sony Xperia XZ1 Compact
given that you need a build with his dev keys, yes should probably roll back.

edit: looks like I finally managed to fix the issues with the CustomizationSelector and modem-switcher. IMS should be back soon as well hopefully, also dynamically adjusting to sim card inserted


Sent from my SM-G970F using XDA Labs


Ah sorry i tagged modpunk, i meant to tag you @derf elot! Thanks for the reply, Rolling back.
 

baboon23

Senior Member
Apr 9, 2020
149
37
given that you need a build with his dev keys, yes should probably roll back.

edit: looks like I finally managed to fix the issues with the CustomizationSelector and modem-switcher. IMS should be back soon as well hopefully, also dynamically adjusting to sim card inserted


Sent from my SM-G970F using XDA Labs

So great to hear !!
Indeed, this and the GPS are the only things keeping this phone from Legendary historical status :)
 

__raptor__

Senior Member
Sep 29, 2012
73
19
Stuttgart
+1 bluetooth audio issue. Not sure if usefull but found this in the adb logcat:
09-13 19:37:17.792 799 799 D audio_hw_primary: out_set_parameters: enter: usecase(0: deep-buffer-playback) kvpairs: routing=2
09-13 19:37:17.792 799 799 D audio_hw_primary: select_devices for use case (deep-buffer-playback)
09-13 19:37:17.794 877 877 D AudioPolicyManagerCustom: setDeviceConnectionStateInt() device: 0x80, state 1, address EC:66:D1:11:1C:A9 name P7 Bowers & Wilkins format 0x20000000
09-13 19:37:17.794 877 877 E APM::HwModule: createDevice: could not find HW module for device 0080 address EC:66:D1:11:1C:A9
09-13 19:37:17.794 1402 1705 E AudioSystem-JNI: Command failed for android_media_AudioSystem_setDeviceConnectionState: -38
09-13 19:37:17.795 799 799 D audio_hw_primary: adev_set_parameters: enter: A2dpSuspended=false
09-13 19:37:17.795 799 799 D audio_hw_extn: audio_extn_set_anc_parameters: anc_enabled:0
09-13 19:37:17.796 1402 1705 D BluetoothA2dp: getCodecStatus(EC:66:D1:11:1C:A9)
09-13 19:37:17.797 23090 23109 D A2dpService: getCodecStatus(EC:66:D1:11:1C:A9)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Ok got it working and running the new 17.1 for a day now on my phone, have it here: https://www.androidfilehost.com/?fid=14943124697586359584

    - June security patches
    - 4.4.272 kernel (thanks to derfelot)
    - Usual modifications to pass SafetyNet w/o Magisk
    - Few fixes related to GApps permissions (maybe)
    - New/Updated APNs (thanks to LOS and linckandrea)

    The 18.1 version with the same changes is at: https://www.androidfilehost.com/?fid=14943124697586359658

    Again: I only tested the 17.1 build. The 18.1 should work but may bootloop or have other issues.
    I recommend (for both builds) that you have flashed TWRP to the recovery partition on the phone and have a working ROM zip on the SD card (e.g. what you currently use) to be able to boot the phone back to recovery and reflash the old ROM in case of bootloops etc.
    And as usual: Have your data backed up!
    1
    Ok got it working and running the new 17.1 for a day now on my phone, have it here: https://www.androidfilehost.com/?fid=14943124697586359584

    - June security patches
    - 4.4.272 kernel (thanks to derfelot)
    - Usual modifications to pass SafetyNet w/o Magisk
    - Few fixes related to GApps permissions (maybe)
    - New/Updated APNs (thanks to LOS and linckandrea)

    The 18.1 version with the same changes is at: https://www.androidfilehost.com/?fid=14943124697586359658

    Again: I only tested the 17.1 build. The 18.1 should work but may bootloop or have other issues.
    I recommend (for both builds) that you have flashed TWRP to the recovery partition on the phone and have a working ROM zip on the SD card (e.g. what you currently use) to be able to boot the phone back to recovery and reflash the old ROM in case of bootloops etc.
    And as usual: Have your data backed up!
    Thanks. Dirty flashed the 17.1 and it seems to work well.

    Will try the 18.1 soon. How should I install it? Would dirty flashing it over 17.1 work?

    LATER: Happy to report dirty flash of 18.1 worked well. I see no major changes except for stock LOS camera (which, like on most Sony 18.1 ROMs, has a problem with auto exposure). Otherwise, looks very promising.
    1
    Still EAS kernel? Is 18.1 also?
    The EAS kernel is awesome!
    Yes. Both use the same kernel
    1
    Select 'Access Point Names' and right up select + and configure You own apn.
    1
    Hey guys, first off thanks a lot to modpunk and flamefire and everyone else here to put in the energy to keep our beloved phones updated.

    This weekend I installed the very latest 18.1 from flamefire and it works fine so far. (I installed it clean, no dirty flash, completely started over with the Sony stock ROM via EMMA and then did a clean 18.1 install following all the right steps)

    Now there is one major bug that I somehow cannot find a solve for and I hope someone could help me please. Sometimes and all of a sudden the mobile network just disappears and it says 'the cellular network is not available'. I cannot even select it under Settings to switch between 3G and LTE as it is grayed out. After I restart it comes back though.

    Now, what is odd is under 'Settings / Wireless & Internet / Mobile Network' I cannot select and manually define the Advanced settings for the carrier AT&T (see 2 attached screenshots at the bottom). There for whatever reason it only says 'To disable this SIM, remove the SIM card'.

    Shouldn't there be a menu similar to the TELUS screenshot that let's me define the preferred network type, calling, Network access and so on?

    I know some people here had the same issue, but was wondering how it has been solved.

    Thanks a lot!



    (Edited: Wording, sorry I did not mean APN but the 'Advanced' settings for the network carrier)
    I see that effect after inserting ("hotplugging") a SIM card without rebooting.
  • 81
    LineageOS 17.1 for Sony Xperia XZ1 Compact

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    FEATURES
    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included

    DOWNLOAD

    You can download the latest release here. Check the ChangeLog below for firmware requirements!

    INSTALLATION

    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!

    KNOWN ISSUES

    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    Contributors
    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Stable
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    41
    REQUIRED FIRMWARE: 47.2.A.11.228

    CHANGELOG


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements


    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    26
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    20
    Version 1.4 is out with fixes for camera and GPS.
    18
    Version 2.0 based on LineageOS 18.1 is out! Have fun.