• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread


Nov 5, 2018
Can you please point me where can I download a stock image

Got my image using XperiFirm: https://forum.xda-developers.com/cr...xperifirm-xperia-firmware-downloader-t2834142
Make sure to check "Unpack firmware automatically" in the settings.

After that you also need UnSIN to follow the guide. https://forum.xda-developers.com/crossdevice-dev/sony/tool-unsin-sin-v3-unpacker-t3128106
Last time I used UnSIN, I only got it working using Windows.


Aug 17, 2019


Senior Member
Oct 7, 2014
How can I make the pictures I take show up on the camera. I always have to leave the camera app in order to check the photos.

Also, how can I install Sony's gallery app? I installed a module that allowed it to spoof the Play Store in order for it to think it's an official Sony ROM, but it caused it to bootloop (can't remember which one, but I did it before COVID quarantine hit).


Senior Member
Mar 2, 2018
After a couple of days of perfect performance my phone started to show some issues with IMS registration. Things seem to go wrong on (re)boot. I tend to switch the phone off over night and back on the next morning. When I did so yesterday and today, it did not find any signal. I first had to manually switch to 3G in settings, where it did get a signal, then wait for IMS registration to complete, and switch back to LTE.

While the phone is in the no network state, I noticed that it also looses WiFi ever few seconds, although I am only a meter away from the access point. Once IMS registration has taken place, everything is back to normal, smooth and steady.

Anyone else having these issues?
Any suggestions how to permanently fix them?
Anything I can provide to help identifying the issue?

This is really getting annoying as it happens every time I switch the phone off.

Is there any way to get around this, @derf elot? Flash modem.sin again? Reset customization selector?
Last edited:


May 20, 2018
I did as you said the microg is working! Thank you :) I did not uninstall the default UnifiedNlp because when I tried to do that, it bootlooped.
What should I enable here in location services? I live in EU See screenshot. View attachment 5128891

EDIT: Well eventually I may not use microg because in my case it is not able to obtain the background location access permission (that's important I guess), and it is not able to obtain sms receiving permission.
Moreover, GCM is not working, I can't enable it. I planned to use microg without logging into google account, but the only thing it improved is that an app I sometimes use now start correctly. Another cons is that OneDrive app does work with microg, but works without it.
I will try to get good location without microg at this point, using the system UnifiedNLP

I had the same problem (MicroG missing location access permission and SMS), I solved it thanks to that post. The issue can arise in several situations, but usually it can be solved running :
pm install -r /data/adb/modules/NanoDroid/system/priv-app/GmsCore/GmsCore.apk
I have now a working MicroG (with push notification working through GCM), quick GPS fix (thanks to the ROM developpers!), but still no luck with SafetyNet. However, this is not related to the ROM, but to MicroG (see #24).

I just realized, after having moved my SIM card to this phone, that I have no data access through my SIM carrier (Orange, France). I can call, send SMS, but no Internet access. When the phone boots, I get a notification from NetworkSwitcher, stating that it was a successful configuration (with no IMS available). I don't know if it is linked. I tried to switch from 4G to 3G and 2G. In any case I get a signal, but no data access. I tried to reconfigure the APN manually, but no luck either. Does someone have an advice?
  • Like
Reactions: allerd and TheArt.


Apr 14, 2014
Wifi not working

EDIT: Nevermind, got it working! Just redid everything from scratch, I may've done things out of order the first time.

Hey everyone. I just installed the latest 17.1 version (first time) and I'm not able to get wifi working (it can detect the networks but doesn't connect to any of them). I'm also getting the following persistent notification:

Status: success (0)
Config: amss_fsg_lilac_tar.mbn
Ims: Not available (default modem)

Any ideas where I went wrong? This is the firmware version I installed when going through the root instructions:

Device: Xperia XZ1 Compact (G8441)
CID: 1310-4371
Market: United States
Operator: Customized US
Version: 47.2.A.11.228-R7C
Last edited:


Senior Member
Mar 2, 2018
This is really getting annoying as it happens every time I switch the phone off.

Is there any way to get around this, @derf elot? Flash modem.sin again? Reset customization selector?

I believe I found a logic to when this issue strikes. If I turn the phone off over night, and turn it back on the next morning, I get a signal almost instantly again. So this seems all good.

However, if I plug the phone in to charge, then switch it off, keep it on the charger over night, and switch it on the next morning I need to manually switch to 3G to get it to work.

Does that make a difference? I always thought that there is no difference whether it is charging while powered down or not.

I am confused now.


Apr 14, 2014

Anyone else able to get MicroG to work with this ROM version? I tried last night, and couldn't enable spoofing. Apps I tried to use (like WhatsApp) were all complaining about not having play services. Did the install fresh along with 17.1 before booting for the first time.

Top Liked Posts

  • There are no posts matching your filters.
  • 81
    LineageOS 17.1 for Sony Xperia XZ1 Compact



    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included


    You can download the latest release here. Check the ChangeLog below for firmware requirements!


    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!


    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    REQUIRED FIRMWARE: 47.2.A.11.228


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements

    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    Version 1.4 is out with fixes for camera and GPS.
    Version 2.0 based on LineageOS 18.1 is out! Have fun.