• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread


Oct 10, 2018
Sony Xperia XZ1 Compact
Please everyone who updated about Flamefire 20210422 to 20210603 share a short review with the community, thank you.
I've dirty updated over latest 17.1 from modpunk.

On the first boot phone seemed to have gone into a bootloop even though I've wiped cache/dalvik.

Second boot went fine. No obvious problems encountered.

The video recording still doesn't work for me, but I guess my camera hardware is just broken.

Would be interesting to see if there are any changes to GPS performance, which sucked over the last year or so.


Oct 10, 2018
Sony Xperia XZ1 Compact
What I know: First boot may take a long time, especially when dalvik is wiped. It is basically compiling all packages.
Could be. I've waited several minutes and tried attaching `adb logcat` to see if I'm looping or not, but that wasn't successful, so I've just rebooted.

UPD: yep, it was a loop caused by EdXposed Magisk module. Switching to LSPosed allowed me to continue to enjoy the bunch of good old hacks.
Last edited:


May 24, 2020
dirty flashed from Flamefire 20210422 to 20210603. As result lost vibration at all - in incoming calls, messages, silent mode, touch vibrations. :(
Vibration for calls/notifications works for me (dirty flashed as well from 20210422 as mentioned above), but the haptic feedback seems weaker than before. I did not really notice that since I have it on a very low setting anyway.

And you cannot change the vibration intensity in the "Vibration and Haptic Strength" setting, you can only turn it on or off. I cannot tell if this when this was changed or if is a change in the latest version though since I had set this setting quite some time ago and never looked at it after that.

Does anyone know if "Vibration and haptic strength" allows changing the vibration strength on a fresh install?


Senior Member
Jul 18, 2019
I upgraded from a Flamefire furnace, thank you for sharing your development ;)
17.1-210422 > 17.1-210603
ga-nano 210424 > 210617
magisk 22.1 > 23.0
The vibration is not gone! This does not vibrate in power save mode, did not change.
There is a huge change that has completely disappeared the Performance Profiles.
This is certainly due to the EAS kernel, whether it is good we will experience it.
Fingerprint is perfect without intervention, even though it was previously modified by me.
Of course, the magisk is essential for complete happiness which hides the open loader.

LineageOS Adding New Advanced Battery Saver Menu with Performance Profiles - Copy.jpg
Last edited:


Senior Member
Jul 26, 2013
Sony Xperia XZ1 Compact
There is a huge change that has completely disappeared the Performance Profiles.
This is certainly due to the EAS kernel, whether it is good we will experience it.
Fingerprint is perfect without intervention, even though it was previously modified by me.
Of course, the magisk is essential for complete happiness which hides the open loader.
Yes the performance profiles were an addition by LineageOS. Changing those basically affects the CPU and GPU frequencies. This is now done automatically by the new power manager which reacts on the current task.

What exactly do you need magisk for? This ROM passes CTS test without it :)


New member
Jun 19, 2020
hey guys, thanks for this mod.
I just dirty flashed from 17.1 20201217 to Flamefire 17.1 20210603. Only wiped cache/dalvic after installing. (no root mod installed)
Seems to work fine. Vibration, Cam working. Cant say if the gps performance is better now... needs testing outside.
Cheers /Hendrik/


Senior Member
Jul 18, 2019
I looked for kernel changes and saw what you wrote there but since you didn't indicate it in the log I didn't know it was already active
Down with the hat You and derfelot put together some very brilliant ruins, of course that modpunk has laid the groundwork.
I'm just amazed and staring and of course thanks for sharing.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Still EAS kernel? Is 18.1 also?
    The EAS kernel is awesome!
    Yes. Both use the same kernel
    Select 'Access Point Names' and right up select + and configure You own apn.
    Hey guys, first off thanks a lot to modpunk and flamefire and everyone else here to put in the energy to keep our beloved phones updated.

    This weekend I installed the very latest 18.1 from flamefire and it works fine so far. (I installed it clean, no dirty flash, completely started over with the Sony stock ROM via EMMA and then did a clean 18.1 install following all the right steps)

    Now there is one major bug that I somehow cannot find a solve for and I hope someone could help me please. Sometimes and all of a sudden the mobile network just disappears and it says 'the cellular network is not available'. I cannot even select it under Settings to switch between 3G and LTE as it is grayed out. After I restart it comes back though.

    Now, what is odd is under 'Settings / Wireless & Internet / Mobile Network' I cannot select and manually define the Advanced settings for the carrier AT&T (see 2 attached screenshots at the bottom). There for whatever reason it only says 'To disable this SIM, remove the SIM card'.

    Shouldn't there be a menu similar to the TELUS screenshot that let's me define the preferred network type, calling, Network access and so on?

    I know some people here had the same issue, but was wondering how it has been solved.

    Thanks a lot!

    (Edited: Wording, sorry I did not mean APN but the 'Advanced' settings for the network carrier)
    I see that effect after inserting ("hotplugging") a SIM card without rebooting.
    Well "preferred network" and "APNs" is there in the screenshots. If it is VoLTE which is missing, then I guess the SIM doesn't support it and/or IMS has been disabled in XperiaParts
    Wow, this ROM (18.1 Flamewire) is too fast :D Thank you! Only thing I found : Gabeldorsche Bluetooth stack is not working (one from developer options)
  • 81
    LineageOS 17.1 for Sony Xperia XZ1 Compact



    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included


    You can download the latest release here. Check the ChangeLog below for firmware requirements!


    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!


    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    REQUIRED FIRMWARE: 47.2.A.11.228


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements

    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    Version 1.4 is out with fixes for camera and GPS.
    Version 2.0 based on LineageOS 18.1 is out! Have fun.