[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread

landsome

Senior Member
May 4, 2015
509
123
Some Sony g8441 devices have GPS issues of unknown origin. I've watched logs and tinkered around a lot, actually for over a year now, but I could not find any clue. The XZ1C of a friend, on the other hand, has perfectly working GPS running exactly the same LineageOS builds and software as I do.

This applied to at least LineageOS version 16, 17.1 ans 18.1. So I'm pretty sure it has nothing to do with the operating system, it rather might be a hardware issue. Maybe some g8441 just have faulty GPS receivers.
I have 3 xz1cs in the house, my wife's (running stock) and two of mine (running custom). Two have flawless GPS under any ROM. A third one has finicky GPS also irrespective of ROM, custom or stock. It sometimes loses signal and more generally locks in with some delay.
 

gladykov

Member
Jul 12, 2010
35
5
Thank you, thank you, thank you! As I go for a small trip, I will be able to dirty flash after the weekend from 18.1 January to latest 18.1 one
 

loiselqw

Member
Jul 18, 2017
29
6
smswld
Please everyone who updated about Flamefire 20210422 to 20210603 share a short review with the community, thank you.
Dear Community, thx to flamefire keeping 17.1 branch alive!

I used for one month the june build and installed yesterday july build from here: https://androidfilehost.com/?fid=14943124697586359584

Everything works fine except Android Auto functionality. The car tries to connect to the mobile phone, where Android Auto is started, but after some connection negotiation the connection process fails...

Anybody having same issues with
  • lineage-17.1-20210702-UNOFFICIAL-lilac or​

  • lineage-17.1-20210603-UNOFFICIAL-lilac​

are there some ideas existing how this behaviour could be solved? I was thinking about fresh flashing of opengapps?

Thx a lot in advance
 

paulquappe

Member
Apr 24, 2018
22
3
I have a question for those that are running 18.1: Is anyone using Android Auto including mirroring to the car screen?

I updated a few months back, but couldn't get the above szenario to work. The app itself (and everything else) ran fine on the phone, but I never got a connection to the car display so I reverted to 17.1 for now.

If yes, which OpenGapps did you flash? 20210130-test?

I'm wondering if it was just a glitch in my case or if it's a general problem. Thanks in advance for any info you can give!

Edit: After some more searching, I found that it seems to be a general problem with all recent OpenGapps builds. The solution seems to be to either use the MindtheGapps package or use the fix described here. I'll update once I've had time to test.

It works! The update with a dirty flash of 18.1/2.0 along with opengapps 11 beta from 20210130 went without problems. The fix from the above link then gave me working AA. Maybe it helps someone else as well

There were a few posts about android auto in the past.
It is for 18.1 but maybe still helps...
 
Jun 3, 2016
23
9
Ok got it working and running the new 17.1 for a day now on my phone, have it here: https://www.androidfilehost.com/?fid=14943124697586359584

- June security patches
- 4.4.272 kernel (thanks to derfelot)
- Usual modifications to pass SafetyNet w/o Magisk
- Few fixes related to GApps permissions (maybe)
- New/Updated APNs (thanks to LOS and linckandrea)

The 18.1 version with the same changes is at: https://www.androidfilehost.com/?fid=14943124697586359658

Again: I only tested the 17.1 build. The 18.1 should work but may bootloop or have other issues.
I recommend (for both builds) that you have flashed TWRP to the recovery partition on the phone and have a working ROM zip on the SD card (e.g. what you currently use) to be able to boot the phone back to recovery and reflash the old ROM in case of bootloops etc.
And as usual: Have your data backed up!

Dirty flashed the 18.1-20210703 over the 18.1-20210120 (after a backup, just in case) and everything works fine! Thanks for keeping the XZ1C alive!
 

Rubik.Orange

Senior Member
Mar 5, 2010
192
32
Busan
cant't make a call on 17.1 20210702 build. IMS is enabled.
phone automatically hang up after few seconds, and can't hear any dial sound.
 

Attachments

  • logcat2.txt
    579 KB · Views: 7

maarek7

Member
Mar 12, 2021
13
1
Apps & Games
Is there any issue with Magisk v23 and SafetyNet on 18.1 (2.0)? I cannot past it - CTS Profile match fails.
MagiskHide Props Config is installed, but still cannot past it.


Edit:
I've changed fingerprint manually to Pixel 5 (since there is an Android 11 fingerprint available) and I'm able to pass CTS profile match (using SafetyNet Test app, not in Magisk).
But as soon as I'm trying to add a Google Pay card it fails and then SafetyCheck fails as well...

Edit 2:
Ok, so this is how it looks: Just after reboot I'm able to pass SafetyNet, but as soon as I'm running test again after few seconds it fails. Any ideas?

Edit 3:
This helped:
 
Last edited:

Flamefire

Senior Member
Jul 26, 2013
213
476
Sony Xperia XZ1 Compact
Is there any issue with Magisk v23 and SafetyNet on 18.1 (2.0)? I cannot past it - CTS Profile match fails.
MagiskHide Props Config is installed, but still cannot past it.


Edit:
I've changed fingerprint manually to Pixel 5 (since there is an Android 11 fingerprint available) and I'm able to pass CTS profile match (using SafetyNet Test app, not in Magisk).
But as soon as I'm trying to add a Google Pay card it fails and then SafetyCheck fails as well...

Edit 2:
Ok, so this is how it looks: Just after reboot I'm able to pass SafetyNet, but as soon as I'm running test again after few seconds it fails. Any ideas?

Edit 3:
This helped:
If you don't need root you don't need magisk. The rom I uploaded already passed safetynet, see the notes... And yes it uses the kdrag0n patch
 
Last edited:

BWRainbow

Member
Jun 8, 2021
29
3
Sorry for bothering you but could you please tell me which versions of XZ1 Compact are compatible with rooting/TWRP/Lineageos please? Thank you in advance.
 

7alvoo

Senior Member
Jul 18, 2019
157
50
Sorry for bothering you but could you please tell me which versions of XZ1 Compact are compatible with rooting/TWRP/Lineageos please? Thank you in advance.
- sim-lock free
- bootloader unlock: allowed
- contains original pie already 47.2.A.11.228
- don't forget to remove any google account / pin / pattern etc.

psi:
- If You opening the bootloader you will lose the option to use the strong device identification 'TEE' and official DRM keys
- never reflash the persist.sin file

- Root solution is the Magisk of every Lineageos version.
 
Last edited:

shadowbird

Member
Jul 13, 2021
6
0
Hey guys, first off thanks a lot to modpunk and flamefire and everyone else here to put in the energy to keep our beloved phones updated.

This weekend I installed the very latest 18.1 from flamefire and it works fine so far. (I installed it clean, no dirty flash, completely started over with the Sony stock ROM via EMMA and then did a clean 18.1 install following all the right steps)

Now there is one major bug that I somehow cannot find a solve for and I hope someone could help me please. Sometimes and all of a sudden the mobile network just disappears and it says 'the cellular network is not available'. I cannot even select it under Settings to switch between 3G and LTE as it is grayed out. After I restart it comes back though.

Now, what is odd is under 'Settings / Wireless & Internet / Mobile Network' I cannot select and manually define the Advanced settings for the carrier AT&T (see 2 attached screenshots at the bottom). There for whatever reason it only says 'To disable this SIM, remove the SIM card'.

Shouldn't there be a menu similar to the TELUS screenshot that let's me define the preferred network type, calling, Network access and so on?

I know some people here had the same issue, but was wondering how it has been solved.

Thanks a lot!



(Edited: Wording, sorry I did not mean APN but the 'Advanced' settings for the network carrier)
 

Attachments

  • Screenshot_20210713-013625_Settings.png
    Screenshot_20210713-013625_Settings.png
    76.3 KB · Views: 44
  • Screenshot_20210713-013640_Settings.png
    Screenshot_20210713-013640_Settings.png
    73.9 KB · Views: 46
  • Untitled2-473x1024.png
    Untitled2-473x1024.png
    233.4 KB · Views: 42
Last edited:

shadowbird

Member
Jul 13, 2021
6
0
Select 'Access Point Names' and right up select + and configure You own apn.
Thanks for your quick reply. Sorry I used the wrong wording (corrected it already in my post). I did not mean the APN settings but the advanced network settings which should be available at the bottom but are not in my case and it only reads 'To disable this SIM, remove the SIM card' instead of showing the settings.
 

[email protected]

Senior Member
Jul 26, 2019
71
62
Hey guys, first off thanks a lot to modpunk and flamefire and everyone else here to put in the energy to keep our beloved phones updated.

This weekend I installed the very latest 18.1 from flamefire and it works fine so far. (I installed it clean, no dirty flash, completely started over with the Sony stock ROM via EMMA and then did a clean 18.1 install following all the right steps)

Now there is one major bug that I somehow cannot find a solve for and I hope someone could help me please. Sometimes and all of a sudden the mobile network just disappears and it says 'the cellular network is not available'. I cannot even select it under Settings to switch between 3G and LTE as it is grayed out. After I restart it comes back though.

Now, what is odd is under 'Settings / Wireless & Internet / Mobile Network' I cannot select and manually define the Advanced settings for the carrier AT&T (see 2 attached screenshots at the bottom). There for whatever reason it only says 'To disable this SIM, remove the SIM card'.

Shouldn't there be a menu similar to the TELUS screenshot that let's me define the preferred network type, calling, Network access and so on?

I know some people here had the same issue, but was wondering how it has been solved.

Thanks a lot!



(Edited: Wording, sorry I did not mean APN but the 'Advanced' settings for the network carrier)
I see that effect after inserting ("hotplugging") a SIM card without rebooting.
 
  • Like
Reactions: shadowbird

aidaho

Member
Oct 10, 2018
10
1
Sony Xperia XZ1 Compact
GPS does seem to be a hardware issue. In a last year or so my running tracks are not great at all and in cloudy/rainy weather the accuracy is either atrocious or there is no reception at all.

When running GPS for hours it can sometimes lock up and lose all the satellites. Going in and out of Airplaine mode usually does the trick. If it doesn't, one has to reboot.

After my last long run in the pouring rain I've noticed condensation behind the selfie camera glass. So perhaps water is making it's way in and screwing the hardware.

Running FW from @Flamefire for the past few weeks, I've had no problems in my day-to-day use.
As for the EAS kernel, I honestly can't tell the difference.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 83
    LineageOS 17.1 for Sony Xperia XZ1 Compact

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    FEATURES
    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included

    DOWNLOAD

    You can download the latest release here. Check the ChangeLog below for firmware requirements!

    INSTALLATION

    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!

    KNOWN ISSUES

    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    Contributors
    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Stable
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    41
    REQUIRED FIRMWARE: 47.2.A.11.228

    CHANGELOG


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements


    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    26
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    20
    Version 1.4 is out with fixes for camera and GPS.
    18
    Version 2.0 based on LineageOS 18.1 is out! Have fun.