• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread

BWRainbow

Member
Jun 8, 2021
29
3
- sim-lock free
- bootloader unlock: allowed
- contains original pie already 47.2.A.11.228
- don't forget to remove any google account / pin / pattern etc.

psi:
- If You opening the bootloader you will lose the option to use the strong device identification 'TEE' and official DRM keys
- never reflash the persist.sin file
Thank you! But that is not what I was asking :p
 

CherAlban

Member
Nov 30, 2014
39
21
Hannover
I have two more general question:

A) Which partitions should be selected in TWRP to create a true full 17.1 backup? Is it enough to just backup system, data and boot? Is it also possible to backp data in TWRP?

B) If I just occasionally need root, is it OK to install Magisk and enable/disable root, or will an installed Magisk with disabled root also prevent passing SafetyNet?
 

7alvoo

Senior Member
Jul 18, 2019
118
26
I have two more general question:

A) Which partitions should be selected in TWRP to create a true full 17.1 backup? Is it enough to just backup system, data and boot? Is it also possible to backp data in TWRP?

B) If I just occasionally need root, is it OK to install Magisk and enable/disable root, or will an installed Magisk with disabled root also prevent passing SafetyNet?
My advice create all partiton backup individual pack without password, because the twrp not perfect, contains some bug's and restore them are more likely to succeed.

The Magisk does not obstruct the SafetyNet in any way especially in hidden mode.
 

shadowbird

Member
Jul 13, 2021
6
0
Aye, seeing that on latest 17.1 also. I don't think this is software dependent, though. Some parts of the hardware might need a power cycle to bootstrap the SIM.

Even after several reboots / wiping dalvik and so on the problem is still there and I cannot access these settings which is not so good. Especially since occasionally the SIM just disconnects altogether and does not come back on :(
 
Last edited:

shadowbird

Member
Jul 13, 2021
6
0
It is essentially 2 things: sometimes the
What setting exactly are you missing that isn't already there?

It is essentially 2 things:

Sometimes all of a sudden the mobile network just disappears and it says 'the cellular network is not available' and it does not come back until restarting. Only Wifi works then and I cannot make or receive phone calls.
This can be replicated by manually removing the SIM card and putting it back in again. It will not recognize the SIM card until reboot.

The other thing is that under 'Settings / Network & Internet / Mobile Network' at the very bottom where it says ‘Advanced’ I cannot select and manually define the advanced settings for the carrier (like AT&T). If I click there it only says ‘To disable this SIM, remove the SIM card’
 

Flamefire

Senior Member
Jul 26, 2013
112
173
Sony Xperia XZ1 Compact
Don't know about the missing network. I only had that when changing the sim while the phone was on. Switching to 3G and back helped there.

And you misunderstood the question: "advanced" is a category, not a setting. What exactly is the setting you expect to find there which isn't already above?
 

[email protected]

Senior Member
Jul 26, 2019
65
57
At least some options under Advanced seem to be dependend on SIM card.

Using a SIM by 1&1, I can see "all" options, including VoLTE and such. Another by Lycamobile, I get "APN selection" as the only option.
 

shadowbird

Member
Jul 13, 2021
6
0
Don't know about the missing network. I only had that when changing the sim while the phone was on. Switching to 3G and back helped there.

And you misunderstood the question: "advanced" is a category, not a setting. What exactly is the setting you expect to find there which isn't already above?


I think it is the settings in the red circle? Or am I wrong?

And the other thing is that the cellular network occasionally disappears and only comes back after reboot.

But what I love and can tell already about 18.1 it is blazing fast and the battery life is HUGELY improved to all previous roms that I used before.
 

Attachments

  • Untitled2-473x1024.png
    Untitled2-473x1024.png
    296.6 KB · Views: 97

Flamefire

Senior Member
Jul 26, 2013
112
173
Sony Xperia XZ1 Compact
I think it is the settings in the red circle? Or am I wrong?
Again: You still didn't say which setting you are missing.
In the circle I see "preferred network type" and "APNs" which both is already above that in recent ROMs.
I don't know what else is supposed to be there, because the screenshot only shows the category, not the settings (only a very reduced preview of them, to be exact).

I suggest you look around if you find the setting you are missing somewhere else now
 

maarek7

Member
Mar 12, 2021
10
1
I think it is the settings in the red circle? Or am I wrong?

And the other thing is that the cellular network occasionally disappears and only comes back after reboot.

But what I love and can tell already about 18.1 it is blazing fast and the battery life is HUGELY improved to all previous roms that I used before.
Hi, have You tried to enable "Service" option in the Xperia Parts?
 

da_las

Member
Jul 8, 2018
7
1
Works for me in the rare cases the VoLTE modem driver decides to work on its own, yes. Then it takes a minute or so after unlocking the card and the phone or switching back from airplane mode to get the mobile network running. Otherwise, waiting (tested up to 10 minutes) does not help.

But this just got me to play a little more with this issue - and it seems I was able to find a hint that might help to narrow down the problem a tiny bit:
On my phone, I use a password for the SIM card and a password to unlock the phone, so I have to enter both after booting before the launcher is started. I do not use Google Smart Lock or smilar tools. This is what the mobile network does during this time:
  • 3G connects the mobile network directly after I unlock the SIM card (but do not unlock the phone - both done with a code, not with the fingerprint sensor) after a boot
  • LTE with amss_fsg_lilac_telekom_tar.mbn connects a minute or so after I unlock the SIM card after a boot, regardless of whether I enter the unlock password
  • LTE with amss_FSG_lilac_telekom_germany_volte_vowifi_tar.mbn seems to never connect (at least, I did not observe any successful attempts until now) after I unlock the SIM card after a boot but do not enter the phone password. And: the longer I wait with unlocking after a boot, the less the chances seem to be for LTE to work without doing the "switch to 3G - wait until network icon flickers - switch back to LTE" process.
This finding let me try to turn off the unlock password prompt and the SIM card password prompt when using the VoLTE modem config - and suddenly the phone connected to LTE after reboot using the amss_FSG_lilac_telekom_germany_volte_vowifi_tar.mbn modem config three times in a row! :D

Then I reactivated both password prompts and LTE instantly went back to the previous nonfunctional state on the next reboot.
Other options tested (all three times in a row and with some seconds waiting before typing in the passwords) to exclude accidential connects):
  • SIM password prompt removed, phone password prompt active: LTE connects, even before entering the phone password
  • SIM password prompt active, phone password prompt removed: LTE does not connect
So this "LTE with VoLTE modem config does not connect" issue is - at least on my phone - triggered by the SIM password being requested upon boot. Can anyone else confirm this?
(Edit: if I am very quick in typing in the SIM password, I have a chance of LTE functioning as well.)
(2nd edit: slightly rephrased to make it more clear what I did)

Update three weeks later: not a single LTE problem since I wrote this post. Problem solved :)
I have a similar issue with the version 2020-12-17 | 1.7 | 47.2.A.11.228 with mobilcom-debitel / O2 germany.

Unfortunately it never ever connects in a way that mobile data is transferred. I can do phone calls and the phone looks as if it is connected with 4G or 2G. I did switch on/off flight mode and removed the sim pin password request. But with no success.

The best result (Phone calls possible without mobile data) Is a combination of firmware G8441_o2 DE_47.2.A.11.228-R2C and the modem driver amss_fsg_lilac_telefonica_germany_volte_vowifi_tar.mbn

Of course I did a backup, but TWRP can no longer decrypt the storage (internal as well as the sd card). It is not asking for a password and if I try to do it manually via terminal it fails. I've tried to upgrade to the latest TWRP version but fastboot fails to detect the device after booting into the bootloader.

In addition I wanted to follow the steps to install the stock rom to let it start once and install the latest modem driver but I cannot find the instructions in the forum thread.

Any ideas what I could do to proceed (other than buying a new phone) or how I could get TWRP to work would be very welcome.

Thanks in advance,
Lars
 

Top Liked Posts

  • There are no posts matching your filters.
  • 81
    LineageOS 17.1 for Sony Xperia XZ1 Compact

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    FEATURES
    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included

    DOWNLOAD

    You can download the latest release here. Check the ChangeLog below for firmware requirements!

    INSTALLATION

    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!

    KNOWN ISSUES

    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    Contributors
    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Stable
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    41
    REQUIRED FIRMWARE: 47.2.A.11.228

    CHANGELOG


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements


    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    26
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    20
    Version 1.4 is out with fixes for camera and GPS.
    18
    Version 2.0 based on LineageOS 18.1 is out! Have fun.