[ROM] LineageOS 18.1 UNOFFICIAL - 2.0 (Update: 2021-01-20)

Search This thread

rkantos

Senior Member
Jun 22, 2010
117
2
Does someone or @modpunk know whether it would be possible to enable ANT+ on the Compact XZ1? The Qualcomm MSM8998 chipset should have support for it as should all Qualcomm chipsets as far as I am aware. The Sony devices had ANT+ in the past but not after around 2014 AFAIK.

 

kdolum

Member
Sep 19, 2019
16
9
I feel like I've been posting around over the last few days, but I just wanted to see if anyone following this thread has an SO-02K on Lineage?

Replying to a rather old post, but maybe that will help people find it. I am running Lineage 18.1 from here on an SO-02K. Here's what I did.
I generally followed the instructions of mortalgen here. First I backed up my drm keys following the procedure of j4nn. Then I paid for and used S1 unlock tool to set bootloader unlock allowed, unlocked by usual Sony procedure, and restored my drm keys. Now I'm supposed to install Lineage over the latest stock, so I downloaded SO-02K_NTT DoCoMo JP_47.2.B.5.38-R11C using Xperifirm and upgraded to that. (Should I have used the latest G8441 build instead?) Then I installed TWRP (listed for "XZ1 compact" with no distinction between SO-02K and G8441) and used that to install lineage-18.1-20210120-UNOFFICIAL-v2.0-lilac.zip. Now my phone says it is a G8441. I installed Magisk using the boot image patching procedure.
Generally things are working very well. I had two problems. First, my phone was using too much CPU and running down the battery. This was caused by some problem with NFC. I think it was repeatedly starting NFC processes that immediately crashed. Since I don't care about NFC, I deleted it using terminal_debloat, and that problem was fixed. Now I'm getting about 2%/hour battery drain, which is better but not great. Probably there are other improvements to make.
(Before trying LIneage I tried Havoc, and that had an even worse problem with high CPU usage, and I was not able to find the cause.)
The other problem is that LTE doesn't work after booting unless I switch to 3G and back to LTE, as discussed in this thread. I set up the "network switcher" service under Xperia Parts settings, and that does this automatically. But now I'm worried. Does this have to actually establish a 3G connection to work? If so, I won't be able to use LTE after the 3G shutdown is complete, which is the purpose for which I bought this phone. Thanks.
 
  • Like
Reactions: PakSayur

kdolum

Member
Sep 19, 2019
16
9
I'm now trying to use Tello (MVNO for T-mobile) on my SO-02K using this ROM (lineage-18.1-20210120-UNOFFICIAL-v2.0-lilac.zip) and getting nowhere. Before this (see above message) I was using Black Wireless (MVNO for AT&T). This worked for everything everything except voice calls, which were immediately disconnected. But this is not surprising because AT&T apparently only allows a specific list of models. So I borrowed a Tello SIM. When I put it in and started my phone it said something like "your phone will now restart to work with your carrier". It restarted and now the customization selector says that the configuration is "amss_fsg_lilac_tmobile_us_ims_tar.mbn". So at some point it recognized this as a T-mobile SIM. But after restarting it cannot read the SIM at all. SIM status says everything is not available.

Any ideas? I'd appreciate any help before I give up on this phone and this ROM.
 
  • Like
Reactions: 4qx

norabitox

Senior Member
Dec 13, 2020
153
37
61
Hello everyone
Teach me Please.

Unlocked the boot loader.
At the beginning, it was the startup screen of the unlocked mark.

While installing Rom many times,
It had changed to a yellow triangular Maark.

What is the difference between the two marks?

Regards.
 

Attachments

  • キャプチャ2.PNG
    キャプチャ2.PNG
    92 KB · Views: 20
  • キャプチャ.PNG
    キャプチャ.PNG
    132.9 KB · Views: 20
Last edited:
  • Like
Reactions: 4qx

f000bar

Member
May 4, 2021
15
8
Hello everyone
Teach me Please.

Unlocked the boot loader.
At the beginning, it was the startup screen of the unlocked mark.

While installing Rom many times,
It had changed to a yellow triangular Maark.

What is the difference between the two marks?

Regards.

I believe it has to do with which bootloader your phone has installed. The original (8.1/Oreo) one was the lock, and the 9/Pie update changed it to the warning triangle - probably because it was implying that you could re-lock it (which you cannot).
You could probably roll it back by downgrading your phone (using Xperifirm) but you probably want the updated one if you're using a newer ROM.

It always suggested to me that there might be a way to remove/hide the warning, but it's a very scary change to test, since if you flash the wrong thing to your bootloader you completely brick the phone...
 
  • Like
Reactions: 4qx and norabitox

mxbndr

Senior Member
Sep 29, 2010
52
5
I managed to install 18.1 successfully. Thanks for all your effort!

I have a minor bug, where some settings reset when the phone reboots. The most prominent is that system-wide dark theme resets. Occasionally, my third party launcher also gets reset.

This might be due to Magisk or full gApps, but I'm not sure. Is there a config or something that I can change to prevent this issue?
 

gladykov

Senior Member
Jul 12, 2010
64
13
I managed to install 18.1 successfully. Thanks for all your effort!

I have a minor bug, where some settings reset when the phone reboots. The most prominent is that system-wide dark theme resets. Occasionally, my third party launcher also gets reset.

This might be due to Magisk or full gApps, but I'm not sure. Is there a config or something that I can change to prevent this issue?
@mxbndr You are replaying to an ancient thread. Go one level up and you will find fresh versions of 18.1 and even 19.1 - hopefully this will solve some of your problems
 
  • Like
Reactions: Flamefire

mxbndr

Senior Member
Sep 29, 2010
52
5
Thanks, but I'm staying on Android 11 on purpose. For what it's worth, I solved my issue by making a Tasker command that activates Dark Mode on boot. :)

The other thing that seems to have been lost is Wi-Fi calling. I'm on Google Fi, which doesn't allow voLTE on Pie for the XZ1C (it does for Oreo), at least with a mixed firmware that combines US and other firmware to get the fingerprint working, but does allow Wi-Fi calling. However, on this ROM voLTE works great with Fi, but Wi-Fi calling doesn't. :-/
 

gladykov

Senior Member
Jul 12, 2010
64
13
Thanks, but I'm staying on Android 11 on purpose. For what it's worth, I solved my issue by making a Tasker command that activates Dark Mode on boot. :)

The other thing that seems to have been lost is Wi-Fi calling. I'm on Google Fi, which doesn't allow voLTE on Pie for the XZ1C (it does for Oreo), at least with a mixed firmware that combines US and other firmware to get the fingerprint working, but does allow Wi-Fi calling. However, on this ROM voLTE works great with Fi, but Wi-Fi calling doesn't. :-/
@mxbndr The other thread I mention has much more updated Android 11 == 18.1 , with many fixes. You are in 18.1 old thread.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 83
    LineageOS 17.1 for Sony Xperia XZ1 Compact

    logo.png


    RELEASE

    This is an alternative ROM for the Sony Xperia XZ1 Compact. It offers several privacy features and F-Droid App Store preinstalled. If you're coming from LineageOS 17.1 you can simply update! No need to wipe anything.

    FEATURES
    • Signed with dev keys
    • FDroid preinstalled
    • FDroid Privilege Extension
    • Well tested but some bugs maybe included

    DOWNLOAD

    You can download the latest release here. Check the ChangeLog below for firmware requirements!

    INSTALLATION

    Put the zip file of the ROM on you sdcard or internal store and boot into recovery. If you use my TWRP recovery, you should use that one to flash the ROM.

    Make sure you select Zip signature verification.

    This will make sure the zip file has not been altered!

    KNOWN ISSUES

    • UnifiedNlp doesn't work with LineageOS 18.1 yet
    • Spell checking doesn't switch if you change keyboards

    Contributors
    modpunk, derf elot
    Source Code: https://github.com/whatawurst/

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Stable
    Current Stable Version: 2.0
    Stable Release Date: 2021-01-20
    42
    REQUIRED FIRMWARE: 47.2.A.11.228

    CHANGELOG


    2020-01-20 | 2.0 | 47.2.A.11.228
    • Update to LinageOS 18.1/Android 11
    • Update to Linux Kernel 4.4.251
    • Updated sdfat Kernel driver
    • Update Wireguard to v1.0.20201221
    • XperiaParts improvements
    • Stock camera is gone due incompatibility of camera libs in android 11, alternatively you can use OpenCamera or Snap (in-built) for stock quality photos
    • WFD is still work in progress

    2020-12-17 | 1.7 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.243
    • Updated WireGuard to .0.20201112 snapshot
    • Added XperiaParts app
    • Improved IMS support

    2020-10-26 | 1.6 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.240
    • Updated WireGuard to 1.0.20200908 snapshot
    • Added Seedvault (Video)
    • Fixed bluetooth regression
    • Removed LOS Snap in favor of stock camera. That fixes issues with launching the camera from lockscreen using the camera button.
    • Added IMS support (again) (thanks again to @Rooted_Ansh and also @Shujath for the help)
    • Boot improvements


    2020-09-11 | 1.5 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.235
    • Updated graphics stack
    • Fixed GPS issues
    • Fixed DRM issues
    • Fixed issues with bluetooth audio

    2020-08-09 | 1.4 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.232
    • Fixed camera memory leak
    • Updated camera app to the one from XZ2c
    • Fixed GPS issues

    2020-07-14 | 1.3 | 47.2.A.11.228
    • Update to XZ2 stock camera app (does not fix the memory leak)
    • Update to latest LinageOS security release

    2020-06-07 | 1.2 | 47.2.A.11.228
    • Update to latest LinageOS security release

    2020-05-29 | 1.1 | 47.2.A.11.228
    • Update to Linux Kernel 4.4.224
    • Update to Wireguard 1.0.20200520
    • Fixed wifi driver (should be fast again)

    2020-04-11 | 1.0 | 47.2.A.11.228
    • Update to Linux 4.4.214
    • Updated Wireguard to 1.0
    • Updated wifi driver
    • Moved to AOSP bluetooth audio HAL v2
    • Enabled wifi 2.4GHz channel bonding (increase wifi speed)

    2020-02-28 | RC0 | 47.2.A.11.228
    • Update to kernel 4.4.213
    • Initial release
    26
    I've just released version 1.7.

    This will be the last release for lineage-17.1. The next release will be lineage-18.1 ...
    20
    Version 1.4 is out with fixes for camera and GPS.
    18
    Version 2.0 based on LineageOS 18.1 is out! Have fun.