• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Rom]Lineageos 18.1 with microG for OnePlus 5 & 5T

Search This thread

bonswouar

Member
Mar 3, 2016
49
11
something is wrong with the lineage updater
then you have to install it manually
That's a bit unfortunate, this updater is a pretty cool functionality.
Although I confirm it works flawlessly simply flashing the zip (& clear cache/dalvik), didn't need to reflash magisk or anything.

EDIT
I have found the error and that is by type microG (G) is large that must be small :mad:
Haha that kind of mistake, so annoying, fortunately you found it!
 
  • Like
Reactions: Exodusnick
so now everything is ok update is displayed again
 

Attachments

  • Screenshot_20210714-163823_Updater.png
    Screenshot_20210714-163823_Updater.png
    98.2 KB · Views: 65
  • Like
Reactions: bonswouar

imtmh

Member
Sep 9, 2011
11
0
Is anyone facing issues with incoming calls?
The other side can hear that my phone is ringing, but no notification/ caller id shown on my phone.
I observed that this is happening when LTE mode is on, other wise I can see incoming calls in 3g/2g modes. Any solutions?
I am using airtel-India
TIA.
 
info
i hope this will be fixed as soon as possible . at hetzner.com where i have my server .
Back bone malfunction FRA-HEL
Status: Investigate
Affected Systems: Network (Uplinks, Backbone, Datacenter, Network-FSN1, Switch-FSN1, Router-FSN1, Network-HEL1, Router-HEL1, Switch-HEL1, Network-NBG1, Router-NBG1, Switch-NBG1, vSwitch).

Status OTDR measurement: Completed - 07.08.2021 19:15 CEST
Fault location status: Completed - 07.08.2021 19:45 CEST
Civil Engineering Status: Active - 07.08.2021 20:15 CEST
Status Cable Work: Not yet started -
Fault end status: Unknown -
Last update: 2021-08-07 20:50 CEST
Start: 2021-08-07 14:48 CEST

currently no connection to ota server and forum 😢
 
Last edited:
Last edited:
  • Like
Reactions: bonswouar

bonswouar

Member
Mar 3, 2016
49
11
@Exodusnick I"m having some issues with localization. It felt like GSM NLP providers aren't always working very well, and I noticed recently using a cell discovering app (TowerCollector) that it has some issues getting full details about current towers.
According to app's developper, it could be fixed by "developers of your ROM": https://github.com/zamojski/TowerCollector/issues/109#issuecomment-909453346

Any idea how to fix that ?
Thank you !!
 
  • Like
Reactions: Exodusnick
@Exodusnick I"m having some issues with localization. It felt like GSM NLP providers aren't always working very well, and I noticed recently using a cell discovering app (TowerCollector) that it has some issues getting full details about current towers.
According to app's developper, it could be fixed by "developers of your ROM": https://github.com/zamojski/TowerCollector/issues/109#issuecomment-909453346

Any idea how to fix that ?
Thank you !!
Thanks for the info. Is it about the localization from the network or from the GPS ?
I think it has to do with the old GSM data.
With the new update which comes the days there will be a new
LocalGsmNlpBackend 1.5.2 version that may solve the problem.
 
Last edited:
Info : In the next days there will be a bigger update Here already the preliminary changelog
added in rom
- AuroraDroid 1.0.8
- AuroraServices 1.1.1
- AuroraStore 4.0.7
- LocalGsmNlpBackend 1.5.2
- PdfViewer 6
- additional_repos.xml extra FDroid repos
- Update GmsCore to 0.2.22
- Update FDroid to 1.13.1
LocalGsmNlpBackend: UnifiedNlp backend that uses local GSM data to resolve user location
* NominatimNlpBackend: UnifiedNlp (no GAPPS) backend that uses MapQuest's Nominatim service (based on OpenStreetMap) for geocoding
* additional_repos.xml: a configuration file to include the microG https://microg.org/fdroid.html , Bromite https://www.bromite.org/fdroid, and IzzyOnDroid https://apt.izzysoft.de/fdroid/repo FDroid repositories in the ROM (requires FDroid >= 1.5)
AuroraOSS packages (binaries sourced from here https://gitlab.com/AuroraOSS
* AuroraDroid: an alternate to the FDroid app store
* AuroraStore: an alternate to Google's Play Store
* AuroraServices: a system / root application that integrates with the Aurora line of products
* GrapheneOS packages (binaries sourced from here https://github.com/GrapheneOS/PdfViewer/releases
* PdfViewer: a Simple Android PDF viewer based on pdf.js and content providers
 
  • Like
Reactions: speedtouch2006

bonswouar

Member
Mar 3, 2016
49
11
Thanks for the info. Is it about the localization from the network or from the GPS ?
I think it has to do with the old GSM data.
With the new update which comes the days there will be a new
LocalGsmNlpBackend 1.5.2 version that may solve the problem.
The problem is not from the GPS but from the network: it seems that API 4.2 isn't working properly: MCC and MNC values are broken (it uses API 1.0 then and can't have proper values for signal strength and neighboring cells).
I doubt this is linked to LocalGsmNlpBackend as it's a low level Android API problem?

Info : In the next days there will be a bigger update Here already the preliminary changelog
added in rom
- AuroraDroid 1.0.8
- AuroraServices 1.1.1
- AuroraStore 4.0.7
- LocalGsmNlpBackend 1.5.2
- PdfViewer 6
- additional_repos.xml extra FDroid repos
- Update GmsCore to 0.2.22
- Update FDroid to 1.13.1
LocalGsmNlpBackend: UnifiedNlp backend that uses local GSM data to resolve user location
* NominatimNlpBackend: UnifiedNlp (no GAPPS) backend that uses MapQuest's Nominatim service (based on OpenStreetMap) for geocoding
* additional_repos.xml: a configuration file to include the microG https://microg.org/fdroid.html , Bromite https://www.bromite.org/fdroid, and IzzyOnDroid https://apt.izzysoft.de/fdroid/repo FDroid repositories in the ROM (requires FDroid >= 1.5)
AuroraOSS packages (binaries sourced from here https://gitlab.com/AuroraOSS
* AuroraDroid: an alternate to the FDroid app store
* AuroraStore: an alternate to Google's Play Store
* AuroraServices: a system / root application that integrates with the Aurora line of products
* GrapheneOS packages (binaries sourced from here https://github.com/GrapheneOS/PdfViewer/releases
* PdfViewer: a Simple Android PDF viewer based on pdf.js and content providers

Great news! Pretty good idea to include AuroraStore directly in the rom :)
 
Last edited:

bonswouar

Member
Mar 3, 2016
49
11
Means you have no mobile data do I understand correctly ?
Everything is working correctly regarding my network normal use, I didn't notice any problem with data and phone usage.
Not sure how it impacts anything else than location using network cells, but according to TowerCollector's developer when forcing to use Android API 4.2 to get cell information it returns
Code:
mMcc=null mMnc=null
mMcc=000 mMnc=null

And quote from him, it could also impact Nlp providers accuracy :
I think that can be related because the implementation of Android API is incorrect in your custom ROM and I think microG rely on that like any other app.
 
Info : In the next days there will be a bigger update Here already the preliminary changelog
added in rom
- AuroraDroid 1.0.8
- AuroraServices 1.1.1
- AuroraStore 4.0.7
- LocalGsmNlpBackend 1.5.2
- PdfViewer 6
- additional_repos.xml extra FDroid repos
- Update GmsCore to 0.2.22
- Update FDroid to 1.13.1
LocalGsmNlpBackend: UnifiedNlp backend that uses local GSM data to resolve user location
* NominatimNlpBackend: UnifiedNlp (no GAPPS) backend that uses MapQuest's Nominatim service (based on OpenStreetMap) for geocoding
* additional_repos.xml: a configuration file to include the microG https://microg.org/fdroid.html , Bromite https://www.bromite.org/fdroid, and IzzyOnDroid https://apt.izzysoft.de/fdroid/repo FDroid repositories in the ROM (requires FDroid >= 1.5)
AuroraOSS packages (binaries sourced from here https://gitlab.com/AuroraOSS
* AuroraDroid: an alternate to the FDroid app store
* AuroraStore: an alternate to Google's Play Store
* AuroraServices: a system / root application that integrates with the Aurora line of products
* GrapheneOS packages (binaries sourced from here https://github.com/GrapheneOS/PdfViewer/releases
* PdfViewer: a Simple Android PDF viewer based on pdf.js and content providers
Download Rom

OnePlus 5T(dumpling)
https://www.los-legacy.de/18.1/dumpling

OnePlus 5(cheeseburger)
https://www.los-legacy.de/18.1/cheeseburger

If there should be problems with the LocalGsmNlpBackend location simply clear the microg settings APK cache, data and restart .
 
Last edited:
  • Like
Reactions: speedtouch2006

bonswouar

Member
Mar 3, 2016
49
11
Yes this is due to the old LocalGsmNlpBackend and will be replaced by the new LocalGsmNlpBackend 1.5.2. Since everything works have tested it on my Samsung S7 with microg los 18.1
Still having the same issue when using Android API 4.2 instead of 1.0, it returns mMcc=null mMnc=null (from TowerCollector log file).
I suspect location providers from microG also can't use API 4.2, meaning they don't have information about neighboring cells and signal strength thus might have much lower accuracy.

Also an important thing I just remembered : I have to use SIM slot 2 instead of 1, because since I installed the rom data isn't working when using slot 1 ! Might be related ?
 
Still having the same issue when using Android API 4.2 instead of 1.0, it returns mMcc=null mMnc=null (from TowerCollector log file).
I suspect location providers from microG also can't use API 4.2, meaning they don't have information about neighboring cells and signal strength thus might have much lower accuracy.

Also an important thing I just remembered : I have to use SIM slot 2 instead of 1, because since I installed the rom data isn't working when using slot 1 ! Might be related ?
No that has nothing to do with it at all. You have to change that in the network settings which sim may use mobile data or not. I use both slots and have no problems with mobile data.
 

bonswouar

Member
Mar 3, 2016
49
11
No that has nothing to do with it at all. You have to change that in the network settings which sim may use mobile data or not. I use both slots and have no problems with mobile data.
I see no option for that (as I have only 1 sim card I guess I can't disable it). I don't find any way to activate it - it's already activated by default! (as you can see on the screenshots)
 

Attachments

  • Screenshot_20210908-094446_Settings.png
    Screenshot_20210908-094446_Settings.png
    84.2 KB · Views: 13
  • Screenshot_20210908-094522_Settings.png
    Screenshot_20210908-094522_Settings.png
    149.6 KB · Views: 14

Top Liked Posts