• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][LOLLIPOP 5.1][UNOFFICIAL] Cyanogenmod: cm-12.1 for SM-T705 16gb

Search This thread

mouldy.beer

Member
Mar 30, 2015
40
21
I can confirm as an official tester that it works fine

Sent from my SM-T705 using Tapatalk
Thanks bu44er. I had the official build installed but now I wiped everything and installed the latest unofficial build. Everything I need is working.
Excuse my ignorance but is it usual that bugs not present in unofficial builds appear in the official builds? Is it because the official nightlies are focused more on developing the system that usability? Just trying to understand the workings of Android development :)

Sent from my SM-T705 using Tapatalk
 
Basically Yeah. Official. Builds aim to have all features working, so that people can just use their Device. The test builds that Deadman has been posting are tests to improve one feature or multiple features. Deadman is one of the developers who contributes to the code for our device.

Don't get me wrong some features might not work as well as we'd like them to but trust me when I say this "Deadman is hardworking and he is passionate in what he does". I've had issues before with tests builds and he's fixed the issue ranging from minutes to hours, depending on what the issue was and how complex it was.

Sent from my SM-T705 using Tapatalk
 

scubajeff

Senior Member
Jul 16, 2009
61
35
Guangzhou
Here is a new build that should have the audio bug fixed

Requires lollipop modem (Easiest way is to flash the zip below)

Lollipop Modem:
http://androidrom.de/download/Addons/SM-T705_OJ1_MODEM.zip

Rom Download:
http://sean.sspencer10.com/cm-12.1-20151219-UNOFFICIAL-klimtlte.zip

The mic still NOT working during calls. The earpiece sometimes will echo what the mic picked up, and most of the time nothing go thru the mic. I applied this directly onto 1217 version, of course, wipe cache and dalvik cache before and after.

Sent from my SM-T705 using XDA Free mobile app

---------- Post added at 12:10 PM ---------- Previous post was at 12:08 PM ----------

And BTW, the nightly OTA update won't work with TWRP 2.8.7.2, saying that image is corrupted.

Sent from my SM-T705 using XDA Free mobile app
 
The mic still NOT working during calls. The earpiece sometimes will echo what the mic picked up, and most of the time nothing go thru the mic. I applied this directly onto 1217 version, of course, wipe cache and dalvik cache before and after.

Sent from my SM-T705 using XDA Free mobile app

---------- Post added at 12:10 PM ---------- Previous post was at 12:08 PM ----------

And BTW, the nightly OTA update won't work with TWRP 2.8.7.2, saying that image is corrupted.

Sent from my SM-T705 using XDA Free mobile app
I'd do a fresh install mate, wipe everything and then flash deadmans build. I've not had an issue with mic or earpiece.
 

scubajeff

Senior Member
Jul 16, 2009
61
35
Guangzhou
I'd do a fresh install mate, wipe everything and then flash deadmans build. I've not had an issue with mic or earpiece.

I just did a fresh install, even flashed the LL modem once more. No luck, the mic problem still exsit. Besides, seems like the phone will crash and power off at the very first call after fresh install. This is wired.

Sent from my SM-T705 using XDA Free mobile app

---------- Post added at 10:24 PM ---------- Previous post was at 10:19 PM ----------

Just checked with Recorder app, the mic is working properly. So not a H/W issue.

Sent from my SM-T705 using XDA Free mobile app
 

mac231us

Senior Member
Oct 26, 2010
2,409
515
I just did a fresh install, even flashed the LL modem once more. No luck, the mic problem still exsit. Besides, seems like the phone will crash and power off at the very first call after fresh install. This is wired.

Sent from my SM-T705 using XDA Free mobile app

---------- Post added at 10:24 PM ---------- Previous post was at 10:19 PM ----------

Just checked with Recorder app, the mic is working properly. So not a H/W issue.

Sent from my SM-T705 using XDA Free mobile app

issue with CM in general (but not all devices..do not think Ultra Z xperia sony had these issues or the old Note 2 or even Note 1)...on tab pro it appears that one had to modify the mixer to switch the mic to external mic (which was not best for folks at other end but got rid of the echo...if i recall correctly...simply reducing the gains did not work as then sounds would be too faint)...do not recall exactly now...may have the mixer.xml somewhere..do not want to give false hopes but something along lines of switching mic is the workaround imo
 

scubajeff

Senior Member
Jul 16, 2009
61
35
Guangzhou
issue with CM in general (but not all devices..do not think Ultra Z xperia sony had these issues or the old Note 2 or even Note 1)...on tab pro it appears that one had to modify the mixer to switch the mic to external mic (which was not best for folks at other end but got rid of the echo...if i recall correctly...simply reducing the gains did not work as then sounds would be too faint)...do not recall exactly now...may have the mixer.xml somewhere..do not want to give false hopes but something along lines of switching mic is the workaround imo

But those builds based on Kitkat radio works fine, either thru mic or speaker mode.

Sent from my SM-T705 using XDA Free mobile app
 

mac231us

Senior Member
Oct 26, 2010
2,409
515
But those builds based on Kitkat radio works fine, either thru mic or speaker mode.

Sent from my SM-T705 using XDA Free mobile app

on the tab pro Sm-T325 CM builds the speaker echo was an issue for persons at the other end of the call (KK AND LL both)

but i may have confused things here with the 325 and the 705

EDIT

and was referring to voice calling
 
Last edited:

IcedCube

Senior Member
Nov 9, 2010
356
118
Queensland
coburnsdomain.com
Could someone link me the last working build of the ROM? I just applied a "official" CM update (I think it was the 26th December klimtlte official one) via the auto updater tool and pretty much bricked my tablet (apart from TeamWin Recovery Mode). ttopia.co.uk just gives me 403 Forbidden now.
 

mouldy.beer

Member
Mar 30, 2015
40
21
Could someone link me the last working build of the ROM? I just applied a "official" CM update (I think it was the 26th December klimtlte official one) via the auto updater tool and pretty much bricked my tablet (apart from TeamWin Recovery Mode). ttopia.co.uk just gives me 403 Forbidden now.
This is the latest unofficial build. I have been using this for a couple of weeks and works fine.
Rom Download
http://sean.sspencer10.com/cm-12.1-20151217-UNOFFICIAL-klimtlte.zip

Sent from my SM-T705 using Tapatalk
 

IcedCube

Senior Member
Nov 9, 2010
356
118
Queensland
coburnsdomain.com
Thanks. I actually flashed deadman's last build (the one with reported calls working) and it booted fine. LTE radio initialized correctly, got 4G on Optus. Still has that little quirk where it'll lose data reception for a while, a quick toggle of 4G/3G in the settings will kick the modem back online after about 30 seconds or so. That's supposedly known since the Intel (?) 4G chip doesn't like doing the handover or something correctly.
 

mac231us

Senior Member
Oct 26, 2010
2,409
515
Thanks. I actually flashed deadman's last build (the one with reported calls working) and it booted fine. LTE radio initialized correctly, got 4G on Optus. Still has that little quirk where it'll lose data reception for a while, a quick toggle of 4G/3G in the settings will kick the modem back online after about 30 seconds or so. That's supposedly known since the Intel (?) 4G chip doesn't like doing the handover or something correctly.

Do you have that rom.. Could you perhaps post upload it to live drive etc if Deadman does not mind it..thanks

Sent from my SM-T705 using XDA Free mobile app
 

ratgutz

Member
Apr 5, 2007
35
8
Brisbane
www.aussienwn.com
Thanks. I actually flashed deadman's last build (the one with reported calls working) and it booted fine. LTE radio initialized correctly, got 4G on Optus. Still has that little quirk where it'll lose data reception for a while, a quick toggle of 4G/3G in the settings will kick the modem back online after about 30 seconds or so. That's supposedly known since the Intel (?) 4G chip doesn't like doing the handover or something correctly.
Hi.

I'm having trouble connecting to LTE (no option to connect via LTE) on optus using the latest modem for the t705y. Does anyone know if the differences on the 705(x)'s is the modem or something else m
 
  • Like
Reactions: maumarti2k

mac231us

Senior Member
Oct 26, 2010
2,409
515

ratgutz

Member
Apr 5, 2007
35
8
Brisbane
www.aussienwn.com
Hi.

I'm having trouble connecting to LTE (no option to connect via LTE) on optus using the latest modem for the t705y. Does anyone know if the differences on the 705(x)'s is the modem or something else m

would it be the modem is different (processor etc same) or is it just a firmware thing (have read about this in other devices such as the mediapad x2 although different manufacturer and device...there one can flash the international rom on the china device or it is vice versa...or both ways)

From the information in the link, it looks like its only the radio frequencies that are different. So, if you flash a mode for your model SM-T705x it is probably going to be more reliable with its connections and speed. For example, the SM-T705Y is the one that is sold in Australia and has more compatible bands for the Australian networks.

Unfortunately, mine does not have LTE at the moment and there is no option in the settings to choose LTE as the preferred connection.
 
  • Like
Reactions: mac231us

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    This is a build of Cyanogenmod 12.1 for the Tab S 8.4 LTE (SM-T705). This build is based on the last copy I had of Eousphoros' device tree source prior to them being deleted. All credit therefore goes to Eousphoros for the original port. I have only fixed a couple of build errors against the latest 12.1 source.

    Please note that although I've checked that the basics are working there will probably be a few bugs. I don't think the device tree I had saved was the latest from the last of Eousphoros' builds so there may even be regressions from his last build. On the plus side the build should incorporate the security fixes in CM 12.1 since then.

    I have limited spare time and I'm fairly new to building Android, so in all likelihood I won't be able to fix any issues you have quickly. I'll post a new build from time to time if people are interested, but don't expect daily / weekly builds.

    **** Update 06/09/15 - I've made a new build which hopefully fixes the microphone during calls. Link is updated below.

    **** Update 31/08/15 - It is my experience that the mobile data is a lot more stable if you have a KitKat radio installed and don't install the Lollipop libs. This is also backed up from comments in the thread I therefore recommend that if you plan on running this Rom you flash a KitKat radio. I use version T705XXU1ANF. I've put a link to this below (use the 'CP' slot in Odin).

    Installation

    1. Flash the zip file in recovery (I used TWRP)
    2. Flash Google apps
    3. If your coming from a stock Lollipop rom, rather than Kitkat, then you need to flash the lollipop-radio.zip. (this will give you the correct libs for the Lollipop baseband to get data working.) **** See note above. It is more stable to flash the KitKat modem.

    Downloads

    1. cm-12.1-20150904-UNOFFICIAL-klimtlte.zip https://www.dropbox.com/s/1ozly8yyupud727/cm-12.1-20150904-UNOFFICIAL-klimtlte.zip?dl=0
    2. lollipop-radio.zip https://www.dropbox.com/s/9ag8lyrjk6twlre/lollipop-radio.zip?dl=0
    3. modem.bin https://www.dropbox.com/s/fjhyr2tkgzzz10b/modem.bin?dl=0

    These are also mirrored at the link below (Thanks to bu44er)

    https://drive.google.com/open?id=0Bw9GrMgIwzUKTmdoTGNwdHZzV1k


    Old Versions

    1. cm-12.1-20150822-UNOFFICIAL-klimtlte.zip https://www.dropbox.com/s/0zs9xv7tqtoyyhu/cm-12.1-20150822-UNOFFICIAL-klimtlte.zip?dl=0

    Source


    1. Device Tree https://github.com/mtdoughty/android_device_samsung_klimtlte
    2. Kernel https://github.com/mtdoughty/android_kernel_samsung_klimtwifi
    3. Vendor Blobs https://github.com/mtdoughty/android_vendor_samsung_klimtlte
    9
    Status Update:
    So i just wanted to let you know what i am currently working on related to klimtlte, the main goal is to get it up to date with the other Tab S's

    Lollipop Modem File:
    http://sean.sspencer10.com/modem.bin

    Currently this is what i am working on:
    1. Using the new klimt-common and exynos5420-common repos (DONE)
    2. Updated the ril, ril interface, blobs to lollipop (DONE, but will need testing)
      ^That is using chagalllte's ril because it the same as klimtlte's
    3. Switched the gpu driver from the t6xx that kitkat uses to the new lollipop midgard (Brings it inline with the other tab s's and there is a lot of improvement from it) (DONE)
    4. Fix offline charging (Tablet is turned off and plugged in) (DONE)
    5. Moved to lollipop mali drivers (WIP)
    6. Switch to Selinux Enforcing (Not started but should be easy)
    7. Official CM Support (It will happen once all of the above are done and tested)
    6
    New Build
    cm-12.1-20151015-UNOFFICIAL-klimtlte.zip

    Available From
    http://www.ttopia.co.uk

    Enjoy

    Sent from my SM-T705 using Tapatalk
    5
    My battery life was really good, been watching HD video all day

    ---------- Post added at 06:11 AM ---------- Previous post was at 05:54 AM ----------

    Here is a link for anyone who would like the files. I've uploaded the installation files, radio files and the Google Apps Package I like using.

    My Google Drive Folder
    https://drive.google.com/open?id=0Bw9GrMgIwzUKTmdoTGNwdHZzV1k
    5
    New Version
    cm-12.1-20151014-UNOFFICIAL-KLIMTLTE.ZIP

    Available From
    http://www.ttopia.co.uk

    Sent from my SM-T705 using Tapatalk