• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][LOS][11.0][OFFICIAL][olive] crDroid v7.10 for Redmi 8

Search This thread

Mahi_777

Member
Apr 11, 2021
16
4
OnePlus 5
Xiaomi Redmi 8
Why this rom not run in my phone redmi 8 (olive) when i install this rom install easily nothing going to wrong but when i am reboot my phone in system phone goes to fastboot automatically why i am try this rom 5 times but this rom not running in my phone please help my
 
  • Like
Reactions: S143

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
Why this rom not run in my phone redmi 8 (olive) when i install this rom install easily nothing going to wrong but when i am reboot my phone in system phone goes to fastboot automatically why i am try this rom 5 times but this rom not running in my phone please help my
where did you download the ROM? from your phone or a PC? ive noticed sourceforge mirrors having a bit of issues lately with a bunch of corrupted zips.
more importantly, did you read the OP correctly? ive flashed this ROM thrice without any issues.
 

POQDavid

Senior Member
Aug 14, 2011
126
17
about.me
Xiaomi Redmi 8
glad you got that fixed, and sorry i wasnt of any help (also being late and all)
No actually I kept thinking about what you said and I was like maybe windows didn't figure out t`he change thanks

is the vbmeta required? IIRC im still using stock and ive successfully flashed like 5 ROMS already, i havent tried GSIs (not worth it IMHO).
I also had to use vbmeta hmm I got the global version of the phone
 
Last edited:

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
No actually I kept thinking about what you said and I was like maybe windows didn't figure out t`he change thanks


I also had to use vbmeta hmm I got the global version of the phone
friends whove tried win11 have all said its worse for PC oriented users. wonder how derpy win11 couldve been LOL

for comparisons, my phones stock firmware is still A9 global indo. ive had friends say they regretted upping to A10, and i havent seen a good enough consensus to up it as well from here.
 

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
Hi!
Many of my apps are crashing when I try to start them. Photos is crashing even without touching it. Have anyone experienced this? Could it be because I set the microSD card as internal storage?
Log: https://drive.google.com/file/d/1-OHyrsVr-sf8xlUkTII_SpGJFu3wncH5/view?usp=drivesdk
took a quick look at your logs and most of the issues are google photos related. did you install a bigger GAPPs pack? most custom ROMs do suggest we install the minimal version, then install whatever else we need instead of taking the bigger package. if you can access the phone, try disabling/deleting if possible.
a few users in previous pages also reported crashing when using bigger packs. some also reported nikgapps might not be a good idea

if you did any special tweaks to photos, also disable them. it looks like youre blocking it from running in the background, starting, syncing ETC. you should also send a bug report to them that somehow photos crashed your OS (CPU+memory leak)

as for an external, IIRC most ROMs do say we should use portable mode instead as there are a few bugs
 

banciii

Senior Member
Jul 26, 2012
968
363
Budapest
took a quick look at your logs and most of the issues are google photos related. did you install a bigger GAPPs pack? most custom ROMs do suggest we install the minimal version, then install whatever else we need instead of taking the bigger package. if you can access the phone, try disabling/deleting if possible.
a few users in previous pages also reported crashing when using bigger packs. some also reported nikgapps might not be a good idea

if you did any special tweaks to photos, also disable them. it looks like youre blocking it from running in the background, starting, syncing ETC. you should also send a bug report to them that somehow photos crashed your OS (CPU+memory leak)

as for an external, IIRC most ROMs do say we should use portable mode instead as there are a few bugs
thanks, I re-flashed again with the basic gapps and without SD card, now it looks fine, at least that part. now I realized I dont have mobile data at all. not in single sim mode, not in dual sim. checked the operator's APN settings which has been set fine. I don't understand :(
 
Last edited:

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
thanks, I re-flashed again with the basic gapps and without SD card, now it looks fine, at least that part. now I realized I dont have mobile data at all. not in single sim mode, not in dual sim. checked the operator's APN settings which has been set fine. I don't understand :(
i dont think ive had any issues of no network on this phone yet. have you tried the usual troubleshooting like airplane mode, turn off, cleaned out the SIMs, turn on? if the network is readable, internet should turn on by itself and shouldnt be affected by hardware.

when flashing this ROM, where did you come from?
 

banciii

Senior Member
Jul 26, 2012
968
363
Budapest
i dont think ive had any issues of no network on this phone yet. have you tried the usual troubleshooting like airplane mode, turn off, cleaned out the SIMs, turn on? if the network is readable, internet should turn on by itself and shouldnt be affected by hardware.

when flashing this ROM, where did you come from?
yes. I've tried all of them. they are brand new SIMs, just activated them about a week ago on the stock ROM, which was miui 12.0.3. also tried every APN troubleshooting tips from my operator, but still no mobile data connection :(

Edit: I made a clean flash again, started the setup wizard with 1 sim in the phone and tried to start with mobile data setup, which stucks at connecting. also tried with flame and opengapps.

Now 1 more thing came to my mind: when I was trying to boot into twrp and get things going, I flashed vbmeta from here. Could be this the reason?

Edit2: re-flashed stock ROM, mobile data works perfectly. Started to re-flash crDroid, but after this step:
  • Wipe dalvik cache, data, cache, system, vendor, internal storage
  • Reboot -> Recovery
even if I choose Recovery in the Reboot menu in TWRP, my device boots into fastboot and I can't boot into TWRP. IF I don't flash that custom vbmeta.img in fastboot. And I've seen this same report from other users here. Maybe it's a new MIUI 12 legacy which was not present when the OP was made?
 
Last edited:

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
yes. I've tried all of them. they are brand new SIMs, just activated them about a week ago on the stock ROM, which was miui 12.0.3. also tried every APN troubleshooting tips from my operator, but still no mobile data connection :(

Edit: I made a clean flash again, started the setup wizard with 1 sim in the phone and tried to start with mobile data setup, which stucks at connecting. also tried with flame and opengapps.

Now 1 more thing came to my mind: when I was trying to boot into twrp and get things going, I flashed vbmeta from here. Could be this the reason?

Edit2: re-flashed stock ROM, mobile data works perfectly. Started to re-flash crDroid, but after this step:
  • Wipe dalvik cache, data, cache, system, vendor, internal storage
  • Reboot -> Recovery
even if I choose Recovery in the Reboot menu in TWRP, my device boots into fastboot and I can't boot into TWRP. IF I don't flash that custom vbmeta.img in fastboot. And I've seen this same report from other users here. Maybe it's a new MIUI 12 legacy which was not present when the OP was made?
im probably the only non vbmeta user here. my base firmware is still A9. the SIM issues also weird since no one else reported it. GAPPs related issue is normal on customs.

back then when you had crashing issues you had both network ready right? did you flash the latest build? im actually still on 07-05 LOL, @mrjoker18 said there were missing base apps.

technically the vbmeta only affects the boot process, so yeah, your guess is a good as mine as to why data doesnt work now...
 

mrjoker18

Senior Member
Jun 8, 2021
59
2
im probably the only non vbmeta user here. my base firmware is still A9. the SIM issues also weird since no one else reported it. GAPPs related issue is normal on customs.

back then when you had crashing issues you had both network ready right? did you flash the latest build? im actually still on 07-05 LOL, @mrjoker18 said there were missing base apps.

technically the vbmeta only affects the boot process, so yeah, your guess is a good as mine as to why data doesnt work now...
i think 07-05 version is much more stable crdroid for me., coz camera browser and.music.app are both installed after booting ., so try to install it .,
 

mrjoker18

Senior Member
Jun 8, 2021
59
2
yes. I've tried all of them. they are brand new SIMs, just activated them about a week ago on the stock ROM, which was miui 12.0.3. also tried every APN troubleshooting tips from my operator, but still no mobile data connection :(

Edit: I made a clean flash again, started the setup wizard with 1 sim in the phone and tried to start with mobile data setup, which stucks at connecting. also tried with flame and opengapps.

Now 1 more thing came to my mind: when I was trying to boot into twrp and get things going, I flashed vbmeta from here. Could be this the reason?

Edit2: re-flashed stock ROM, mobile data works perfectly. Started to re-flash crDroid, but after this step:
  • Wipe dalvik cache, data, cache, system, vendor, internal storage
  • Reboot -> Recovery
even if I choose Recovery in the Reboot menu in TWRP, my device boots into fastboot and I can't boot into TWRP. IF I don't flash that custom vbmeta.img in fastboot. And I've seen this same report from other users here. Maybe it's a new MIUI 12 legacy which was not present when the OP was made?
dont.boot.to recovery again if you wipe.all everything.of your.current os.,
format data then boot.to recovery
then wipe.dalvic.cache.system and.vendor. DONT.BOOT.TO RECOVERY again bcoz.you will boot to fastboot.mode.,im getting.that problem also., just after wiping.,you can flash rom and.gapps after that format data.,
 

FunnySkeleton

Member
Jul 24, 2021
7
0
Xiaomi Redmi 8
BE3pE0l.png

*** Disclaimer I am not responsible for any damage you made to your device You have been warned


crDroid is designed to increase performance and reliability over stock Android for your device also attempting to bringing many of the best features existent today

Features:

https://github.com/crdroidandroid/crdroid_features/blob/11.0/README.mkdn

Flashing Instructions:


Pre-installation:

First time installation:
  • Reboot into recovery
  • Format data -> Yes
  • Reboot -> Recovery
  • Wipe dalvik cache, data, cache, system, vendor, internal storage
  • Reboot -> Recovery
  • Install ROM
  • Install GApps, Magisk if needed
  • Wipe dalvik cache
  • Reboot -> System

Update installation:
  • Reboot into recovery
  • Wipe dalvik cache and cache
  • Install ROM
  • If you used Magisk and/or a custom kernel, reinstall them
  • Reboot -> System


Sources:
ROM: https://github.com/crdroidandroid
Kernel: https://github.com/IAmDeadlylxrd/android_kernel_xiaomi_sdm439

Download:
ROM https://crdroid.net/olives
Changelog: https://raw.githubusercontent.com/crdroidandroid/android_vendor_crDroidOTA/11.0/changelog_olives.txt

Known issues:
  • Random reboot occurs with some other kernels which doesn't have fixes in kernel wlan driver
  • Carrier video calling and ViLTE


Visit official website @ crDroid.net
crDroid olives Telegram
crDroid Community Telegram
crDroid Updates Channel
Donate to help our team pay server costs
Hey ....
may be this guide is fully completed to flash any official and unofficial custom rom of android 11 to the Olive or other xiaomi device..

1. Download The custom rom to the external storage .

2. Download TWRP or any custom recovery , vbmeta.img, Android 11 Gapps { pico, nano, stock all are supported but i flashed pico to use in various roms all were working fine } .

3.Move vbmeta.img and twrp.img to ADB folder.

3.Make sure ADB is installed in your PC, and usb developing is Turn on in your phone and bootloader is unlocked.

4.Boot your phone into Bootloader.

5.Connected Your Phone To Adb using Usb.

6.Type Command:


fastboot flash recovery twrp.img

fastboot boot twrp.img

" device will boot into twrp to check it is properly installed .
now go to reboot in twrp and tap reboot to bootloader. "

connect your phone to adb and type command :

--disable-verity --disable-verification flash vbmeta vbmeta.img

fastboot boot twrp.img


7. Twrp recovery or any custom recovery will boot .... { make sure you have backup you all important data or media } go to format and type yes and format you phone .

8. Go to wipe > Advanced wipe > select Dalvik, Internal storage , Cache , system , vendor > WIPE .

9. Reboot your phone into recovery using twrp .

10. Move your custom rom and Gapps or Magisk ( if you need ) to the internal storage of your phone.

11.go to flash and select your custom rom and slide to flash.

12. wait untill completition flashing , then flash Gapps of your choice (considering flash magisk after first reboot of your custom rom using twrp ) .

13. now tap to REBOOT ..


HERE YOU GO !!!!
 

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
...
7. Twrp recovery or any custom recovery will boot .... { make sure you have backup you all important data or media } go to format and type yes and format you phone .

8. Go to wipe > Advanced wipe > select Dalvik, Internal storage , Cache , system , vendor > WIPE .
...
HERE YOU GO !!!!
you sure formatting data isnt required? that might lead to an encrypted internal (and a headache to decrypt).

also spamming in every thread isnt really a good idea...
 

fonzacus

Senior Member
Jun 23, 2016
156
21
30
30 Seconds From Mars
Xiaomi Redmi 8
plss dont.remove the camera app and.browser., that is the most important apps .,in crdroid 7.7 july 5th version,.the.camera and.music.app are both intact in rom but suddenly removed.it.for.no reason
i messed up on 07-05, and i just installed 07-14. everything is still here. maybe you have a GAPPs config file that accidentally removed them?
 

Top Liked Posts