• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][NZH54D][2021/08/05][Asus Nexus 7 2012 WiFi/3G][F2FS/EXT4]Android 7.x AOSP

Search This thread

marty_bebop

Member
Oct 23, 2016
31
13
Grouper July ROM MicroG version, Magisk 23.
Easy install, no problem (I think I could do it with my eyes shut).
I had to upgrade DuckDuckGo (from 5.85.3 to 5.91.0) as it quit on launch. No problem.
Many thanks.
 

KainRaziel

Member
Feb 23, 2013
11
5
First of all I wanted to thank anddisa for her work; i installed grouper microg version on my nexus 7, everything works perfectly.
As I am not an expert on microg, I wanted to know a few things; if i am offtopic, i apologize to mods and to anddisa.
1) I only installed the microg rom and the tablet booted up. Do I have to use it with my google account and, if so, how do I enter it? Or can I use it without?
2) how do i install the apps? (i read about aurora store, but do they have to be install manually?
I searched for a microg guide in the general threads, but couldn't find it.

Thanks again anddisa and I apologize again if I have broken any rules.
 

LesGirauds

Senior Member
Jul 27, 2013
303
140
France
Nexus 7
OnePlus X
@KainRaziel

1. No, you do not have to use your google account. You can if you want but there is little use or advantage to doing so, ime. You can enter your google account in 'MicroG Settings' (and you'd need to install that, it's part of the MicroG core services)

2. Their are a number of 'package manager' apps you can use to download apps, Aurora Store is one. F-Droid is another. Again, it's part of the MicroG core services.

So, to do the above, you'll need the MicroG core services files. The best way (imo) to get all of those is to download and flash a zip file (like you'd flash the gapps packages for the google services)

Have a read of this... https://microgdownload.com

...it will give you a link to download a microG services zip plus a little bit of an explanation about MicroG. It's all really quite straightforward and once you get the hang of it, no different to flashing a gapps zip. :)

Just another little note; there are other zip packages available for MicroG, depending on what level of services you want. Again, much like the different gapps zips. And, like gapps, the size of the zip might be an issue on your device. So choose smaller zip files to begin with.
 

KainRaziel

Member
Feb 23, 2013
11
5
LesGirauds, thank you very much for your availability and patience. I have installed the microg services you indicated, everything ok. Now I should just manually install the apk, for example, of the aurora store, or manually the apk of each application that I have to install, right?

For Anddisa: Installation with microg succeeded perfectly, really fast tablet. Thanks again.
 

LesGirauds

Senior Member
Jul 27, 2013
303
140
France
Nexus 7
OnePlus X
Yes, manually install the Aurora Store apk (and/or F-Droid) - if it's not already installed* - then use it to select and install the apps you want. Aurora will ask you to sign in, either anonymously or using your Google account. I don't know what using your google account gives you, I always use the anonymous sign in.

*some of the (larger) MicroG zips will include Aurora and/or F-Droid. Depends which one
 

KainRaziel

Member
Feb 23, 2013
11
5
I installed the microg components you indicated, I don't think I have aurora store because I don't see an icon, so I think I have to install it manually. I'll take the one posted in the aurora store thread here on xda. Thanks again for everything.
 

KainRaziel

Member
Feb 23, 2013
11
5
Last update: installed aurora store, everything works perfectly (I just had to activate "allow installation of unknown applications" in the tablet, I think I have to do it for all of them).
I noticed that after installing the microg components I have the playstore icon again. I'm not using it anymore.
Thanks again to Anddisa and LesGirauds for their help.
 

flintash

Member
Sep 17, 2016
9
1
I like to Thank AndDiSa first of all for the great job done. I was skeptical when I saw android 7 for Nexus 2012, but I had nothing to loose, those tablets were gathering dust in the drawer.But my god, is it that a resurrection?!
All is working great except the battery life when in "sleep". I read a lot of this thread, not all, weather I missed or it wasnt mention but I hoped that tablet lived longer than 2-3 days when in sleep. Because I dont use it daily, sometimes when I pick up the tablet , its dead because wasnt recently charged. I'm trying to investigate here myself with GSam battery app, and what is killing the battery is kernel, and I recon wlan_rx_wake. Because I'm not that sophisticated, I'm asking you lads, have you got any ideas how can I put Nexus into deep sleep?
I tried turning wifi off, and airplane mode, but it doesnt work, any ideas?
 

js-xda

Senior Member
Aug 20, 2018
212
99
I like to Thank AndDiSa first of all for the great job done. I was skeptical when I saw android 7 for Nexus 2012, but I had nothing to loose, those tablets were gathering dust in the drawer.But my god, is it that a resurrection?!
All is working great except the battery life when in "sleep". I read a lot of this thread, not all, weather I missed or it wasnt mention but I hoped that tablet lived longer than 2-3 days when in sleep. Because I dont use it daily, sometimes when I pick up the tablet , its dead because wasnt recently charged. I'm trying to investigate here myself with GSam battery app, and what is killing the battery is kernel, and I recon wlan_rx_wake. Because I'm not that sophisticated, I'm asking you lads, have you got any ideas how can I put Nexus into deep sleep?
I tried turning wifi off, and airplane mode, but it doesnt work, any ideas?
I stopped using actively the device (tilapia) but tested still the latest build (no Magisk, no GApps, WiFi on but not connected (see earlier post), no SIM in device) earlier this month and had no such issues (very little (few percent) battery drain over night). Maybe related to the GApps or Magisk?
 
  • Like
Reactions: AndDiSa

Gorilla Daddy

Member
Aug 6, 2018
42
6
Fantastic rom. I was excited to see Google Duo running on this old tablet! Is there some trick to getting the microphone-audio to work? The other side can't hear anything.

(Update: running the latest 7-14-2021 on grouper, no microphone sound recording working in any app. Is it my tablet hardware, or do I need to configure something?)

(Update2: I plugged in a headset, no audio recording from there either. Tried "Smart Recorder" which lets you adjust gain, no luck either)
 
Last edited:

AndDiSa

Senior Member
Dec 2, 2009
3,520
4,680
Heidelberg
@Gorilla Daddy I am not sure what might be the issue with your device, I just checked with the Nextcloud-Talk app and I was able to use the device with a headset to communicate with my partner on the other side.

Btw.: probably you are wondering why I am suddenly able to test / verify issues reported here as my device died around two years ago ... at this point I would like to send a big "thank you" to @js-xda who gifted me his Tilapia :)
 
Last edited:

mafarric0

Member
Aug 24, 2013
41
9
Tilapia with latest version and MicroG.

Works like a charm.

Also, I use F2FS on DATA and CACHE partitions.

@AndDiSa Thank you for keeping these great little devices alive for so many years!
 

AndDiSa

Senior Member
Dec 2, 2009
3,520
4,680
Heidelberg
New Versions 7.1.2 (2021-08) available

Hi guys, in the last days I played a bit with my "new" Tilapia device and I was able to prepare the new ROM versions having the security patches for August/2021 applied to them. Beside the security patches for August I did some further modifications / improvements:

  • The most important change is the default setting for the pmf (protected management frames). It was set to pmf=1 to provide better security (especially against the Kr00k security issue). Unfortunately not all routers are compatible with this setting so some people noticed that they had connection issues. Especially unexperienced people who wanted to try out the ROM complained about WiFi not working. Due to that the new default setting has changed, i.e. pmf=0 is default now. But this value will be used only on a fresh / clean install of the ROM, otherwise the settings provided by /data/misc/wifi/wpa_supplicant.conf will be used.
    Nevertheless I suggest you to modify /data/misc/wifi/wpa_supplicant.conf and set pfm=1 if your router is compatible to that setting as it provides a better security.
  • Some miror updates in some of the repositories being used for building the ROM were applied, e.g.
    • external/iptables
    • external/ppp
    • ...
  • a missed security patch in external/libhevc was applied
  • security patches for August 2021 were applied
The full list of changes you can find in my Github repos

The "standard" versions for Grouper / Tilapia are available for download:
aosp_grouper-7.1.2-ota-20210814.eng.ds.zip (MD5: 2817c388112830614b48fe129cbccf73)
aosp_tilapia-7.1.2-ota-20210814.eng.ds.zip (MD5: 07d6098119b4511f6fa56d1537f10a5f)

as well as the MicroG-Patched images:
aosp_grouper-7.1.2-mg-ota-20210814.eng.ds.zip (MD5: 8da739b71d8f60e645e01291ef628386)
aosp_tilapia-7.1.2-mg-ota-20210814.eng.ds.zip (MD5: f0f343f2a9a3c442cf0cb204caabd92f)

I quickly tested the ROM and didn't find issues, nevertheless I will wait for feedback from the community before I'll add them to the OP.

If you report a successful (or unsuccessful :)) installation, please note which version (Grouper / Tilapia, with or without MicroG-patch) you have installed and tested. Thank you very much!
Stay safe!
 

momentoid

Member
Feb 7, 2011
11
11
New Versions 7.1.2 (2021-08) available
Successfully installed August version of Grouper ROM, without MG patch, and May version of GApps. Did not mess with but confirmed pmf=1. Everything is good. Thanks @AndDiSa.

Big thanks to @js-xda for gifting your Tilapia to @AndDiSa.

Now that you can test, let me nitpick. In default Clock app, setting global time crashes.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Thank you @momentoid
    IT WORKS! =D

    • Nexus 7 2021 (grouper)
    • August ROM build (no MicroG)
    • May 13 Gapps

    Here are all my steps in full detail:
    1. Wipe everything available in TWRP, including dalvik cache, data, factory reset... every option available, just to make sure.
    2. Install the August ROM zip (aosp_grouper-7.1.2-ota-20210814.eng.ds.zip)
      1. Success message without errors
    3. Reboot into recovery
    4. Install GApps (open_gapps-arm-7.1-pico-20210513.zip)
      1. Success message without errors
    5. Wipe Cache & Dalvik Cache
    6. Reboot into system
    Thank you guys for helping me and thank you @AndDiSa for being so dedicated to this ROM.
    4
    Big thanks to all relevant devs for this fantastic rom, and to contributors of this thread!
    I found this thread quite by accident. Had given up on the functionality of my Nexus7 and had only retained it because I couldn't bear to dispose of the tablet AND the Otterbox Defender case that contained it.
    Yup. I'm THAT guy.
    Just as I decided to junk the old slab, I went on a quick hunt for worthwhile (or any) firmware to demonstrate to my son the life cycle of "all" android devices on a development level. There was no way I was wrong. This tablet shall surely prove my point, being old as it is... Nope. Top link, first search, this rom.
    I'm too elated to care you've personally discredited me in front of my offspring.

    I'm floored by how smoothly the ole 2012 can still run with this rom calling shots. So far, no burps, hiccups, etc. Your work is incredible.
    Many Nex7 have been brought back from the shadows by your hand.
    Again, my hat is off to all involved. Thank you.

    - mech
    2
    How far back did you go? Try with this gapps package: https://androidfilehost.com/?fid=2188818919693784514
    It worked, thank you so much!
    2
    Thanks! I have tried with the oldest version I could download but I get the same error...
    Hi, I have the same Nexus 3G model, just installed August ROM for Tilapia following @gmsalomao2 instructions, but with Gapps dd 2019/12/13 provided by @rahimali - everything works fine :) Thank you, guys!

    2
    Well, crashing Google Services generally is an indication that GApps are not installed / not installed correctly. Probably @momentoid can indicate which GApps he used lately ...
    Sorry for the delay, I just now saw this tagged message.

    I'm successfully using the May 13 version:
    open_gapps-arm-7.1-pico-20210513.zip

    FYI, the June 18 version is smaller by 20 MB but raises Error 70. The July version I downloaded was larger than the May 13th version which also gave me an Error 70.

    Hope this helps, @gmsalomao2.
  • 308
    This thread is about installing and using AOSP 7.x (Nougat) ROM for the ASUS Nexus 7 Grouper / Tilapia devices.

    Asus - Model names

    Grouper = Asus Nexus 7 2012 WiFi
    Tilapia = Asus Nexus 7 2012 3G



    Initial Setup Installation
    1. Update Recovery to TWRP 3.5.2-9 for Grouper resp. TWRP 3.5.2-9 for Tilapia
    2. Boot into Recovery
    3. Factory Reset (only needed if you are not already on Android 7.x AOSP)
    4. Install 7.1.2 Grouper OTA-Package (Build 20210814) (md5 :2817c388112830614b48fe129cbccf73)
      or
    5. Install 7.1.2 Tilapia OTA-Package (Build 20210814) (md5: 07d6098119b4511f6fa56d1537f10a5f)
    6. Reboot into recovery
    7. Install Open GApps (arm/7.1/pico)

    [*]To get root access, I suggest to use either Magisk (V21.4) and Magsik Manager (V8.0.7) the "old" version of Magisk, or the new unified Magisk (V22.1)

    Do not install Magisk on initial setup as it might lead to issues. Start the ROM without having root access the first time and install Magisk in a second step.

    If you are already on Android 7.x AOSP, it's sufficient to do the follwowing steps:

    Update Installation
    • Boot into Recovery
      • Install 7.1.2 Grouper OTA-Package (Build 20210814) (md5 :2817c388112830614b48fe129cbccf73)
        or
      • Install 7.1.2 Tilapia OTA-Package (Build 20210814) (md5: 07d6098119b4511f6fa56d1537f10a5f)
      • Reboot into recovery
      • Install Open GApps (arm/7.1/pico)
      • Wipe cache/dalvik-cache (optional, but suggested)
      • reboot

    Important: For more detailed installation instructions please refer to the next post
    Important: First boot after upgrading will take a bit longer (stays on ANDROID) because of art optimizations

    flash and use on your own risk!


    CREDITS,
    AOSP/Google, LineageOS, Ziyann for setting up the Grouper-AOSP repository and his Unlegacy Android project, daniel_hk for some hints how to get the 3.1 kernel running with N, timduru for his work on the Asus Transformer, Timur Mehrvarz for his work on the tegra kernel, Francisco Franco for his kernel work in general

    Bugs:
    • please report

    Latest Changes
    • 20210814 (AOSP 7.1.2)
      • default values for wpa_supplicant: pfm=1 -> pfm=0 for better router compatibility
      • missed patch in external/libhevc added
      • updated external/iptables version
      • updated external/ppp version
      • updated external/freetype version
      • updated system/netd version
      • updated external/icu version
      • updated with security patches from August 2021

    Latest version with MicroG-patch applied to them:
    aosp_grouper-7.1.2-mg-ota-20210814.eng.ds.zip (MD5: 8da739b71d8f60e645e01291ef628386)
    aosp_tilapia-7.1.2-mg-ota-20210814.eng.ds.zip (MD5: f0f343f2a9a3c442cf0cb204caabd92f)


    Changelog
    Please refer to the changes found in the github repos

    All ota packages can be found here:
    AndDiSa ROM files repository

    Sources

    https://github.com/AndDiSa

    If you would like to build from the sources, you can do so by cloning and build from repositories:
    but please take in mind that you need to have some free space (>= 100 GB) and some time ...


    XDA:DevDB Information
    Android 7.x AOSP, ROM for the Nexus 7

    Contributors
    AndDiSa
    Source Code: https://github.com/AndDiSa?tab=repositories

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.1.x
    Based On: AOSP

    Version Information
    Status:
    Stable

    Created 2016-09-23
    Last Updated 2021-03-05
    63
    Please note:
    • the system partition is already quite full which leads to the problem that gapps probably will not install correctly and that may lead to weired problems (apps closing / not showing up correctly / ...). I suggest to use the dynamic gapps package linked above. In addition I suggest you to erase the system partition completely before applying the OTA package
    • If you get "Error 7" when trying to flash the ROM directly after upgrading to TWRP 3.4.0, wipe the Boot, System and Cache partition and clean dalvik-cache, then re-boot to Recovery and try again (you will not loose any data as long as you do not wipe the Data partition).

    Some additional hints
    • If you are in a bootloop which shows to Google logo again and again, it's sufficient to hold vol- while booting. The next bootloop will boot into bootloader.
    • If you are in a bootloop which shows the ANDROID splash screen continuusly, connect your device to your PC and enter
      Code:
      adb reboot bootloader
      After a few seconds the device should show up the bootloader screen
    62
    Hi guys,

    first of all I would like to thank all of you for your support you offered to me in the last days and I really feel honoured that so many of your would like to support / help me so that I am able to continue the development for the Nexus 7.
    I've got many offers for a "new" Nexus device from all over the world which I really didn't expect. I was really torn between continuing and stepping out. I've thought very much about pros and cons and it wasn't an easy decision especially if you get so much positive feedback. Thank you again!

    Finally I've decided to stop development for the Nexus 7 (at least for the moment). There are several other projects (not all of them related to Android) I've in mind and probably this now was a broad hint to start with something different. I've uploaded the sources of the ROMs latest version (inc. security patches for June 2019) to Github and tested together with @fidoedidoe whether all needed repos and changes are consistent and that one can build the ROM from those repos without the need of doing additional modifications or patches. The build should run smoothly after synchronizing everything. I will also support and help everybody who would like to step in and continue the builds.
    I know there are several people interested in building the ROM from sources. Probably there is someone (or probably even a group) who would like to continue ...
    Cheers,
    AndDiSa
    55
    2019/02/05 - release for Grouper and Tilapia uploaded

    I've just uploded the latest version of the ROM for Grouper and Tilapia. As always the Android security issues listed in the latest Android Security Bulletin are patched in this ROM.

    Beside that once again I've worked much on the kernel side. Some features are added (multiple binder devices, alarm timer device, ...) and some bugs have been fixed.
    I am still working together with @OlliWi on the slow charging issue which occurs from time to time. Even if I was able to get charging currents up to 1500mA while the device was connected to a charger, we still have the impression that the cable / charger detection needs to be improved. We are on it ...

    Those of you who are familiar with the installation process of the ROM can download directly from here, otherwise please first read the instructions in the OP

    7.1.2 Grouper OTA-Package (Build 20190209) (md5: 885e601a06a2104628a1e450b73f3a18)
    7.1.2 Tilapia OTA-Package (Build 20190209) (md5: 8e4c0e1955ecc0bb65a51582bb01f779)

    And finally as always: flash on your own risk ... ;)
    52
    New year ... new security fixes (2019/01/05)

    Hi guys,

    I've just uploaded a new version of the ROM for our beloved Nexus 7 (Grouper / Tilapia) having the January 2019 security fixed applied to it.

    Beside that I found a bug causing bootloops on initial install / after wiping dalvik. This was caused by zygote not having enough memory available to create the boot.jar on the fly. To fix this issue, I am doing a dex-preopt for the boot image on compile time now which leads to a slightly larger image but improves initial boot time a bit, too.

    To get more memory free on the /system partition, I debloated the ROM a bit, e.g. removed the Browser2, LegacyCamera, Music and Calendar apps as some of them even didn't work fully. There are several alternatives available in several stores which you can install if you need them. Probably most of you do not even notice that these apps were removed.

    Most changes were applied to the kernel. I tested the changes in the last 4 weeks but as I have a Grouper device only and I cannot test each functionality I cannot exclude that something doesn't work as expected. So please file a bug report (best with logcat and a meaningful bug description) if you find some unexpected behaviour and I will have a look at it.

    The most important fix here is probably the improved charging behaviour (many thanks to @OlliWi who provided with fruitful analysis and hints and pushed me to have a deeper look at this issue).
    To get a faster charging of the device, do not boot with a USB cable connected as this prevents the device to charge with more than 500mA (or at least disconnect and re-connect the cable after the device booted).

    I've updated the links in the OP, so you can download the latest version from there.

    Happy new year to all of you!