• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][NZH54D][2021/10/05][Asus Nexus 7 2012 WiFi/3G][F2FS/EXT4]Android 7.x AOSP

Search This thread

aghy91r

New member
Dec 29, 2013
4
1
If you have a bit of electronic experience, I tied a Qi receiver into the battery leads in my device. Now I can wireless charge it at about 1.6 amps. Downside is device does not know it's charging. Upside is it charges very fast and no more worries about software and hardware issues charging wise.
You could've used the connectors on the side of the tablet to connect the Qi receiver to avoid overcharging situations. Because it it a Li-Polymer battery and it may explode with overcharging.
 

quique2

New member
Oct 31, 2010
4
1
do you currently have a ROM and version your able to use NETFLIX with the download feature? Thats what i'm currently looking to do as i use it for my kids in car entertainment. any info or pointing in the right direction would be great! i'm on lineage/cyanogenmod 14.1-20161130-unofficial-grouper. Haven't been able to figure a way to get netflix w/ DL feature to work. Confused w/ magisk etc

Sorry for the delay in reply. I had it working with this ROM, build 20170707 grouper (from earlier in this thread), and Netflix version 5.5.1 build 21226. I can't remember if I just downloaded the Netflix apk or if I got it from the store. I also haven't used it in the last 2 months so I don't know if Netflix has locked out older app versions but it was working just fine. I'm currently having some wifi issues so I can't test it unfortunately.
 

n3kf

Senior Member
Jul 13, 2015
232
94
You could've used the connectors on the side of the tablet to connect the Qi receiver to avoid overcharging situations. Because it it a Li-Polymer battery and it may explode with overcharging.

Tried that first. But the software/hardware still limits the charging. Batteries that are used in these devices have a battery protection circuit built into the pack to protect from over charging.
 

aghy91r

New member
Dec 29, 2013
4
1
Boot-loop while charging

I've flashed this ROM 3 times and every time the process went smooth, also with the Gapp mini. But I noticed that the tablet goes into bootloop several times (when it's connected to a charger) when I restart the device, then it boots into recovery mode, after disconnecting the charger and reboot the device it works perfectly. I've wiped the cache and dalvik/cache several times with no luck to fix that. Re-flashed the ROM again, same problem.

Nexus 7 2012 Grouper 32GB
Android 7.1.2 (Build 20171208)

This happened before and after flashing the SR1-SuperSU-v2.82 (systemless)
 
R

Roger O. Thronhill

Guest
Nexus 7 2012 Tilapia 32GB
Android 7.1.2 (Build 20171208)

After flash the tablet, when starts the configuration wizard, it crashes and enter in a loop requiring for the sim card.
 

pjcanales

Senior Member
Dec 18, 2010
455
83
Batesville
It's been a while since I been on here. Which version has the normal charging while on. Last I hear was that some of the latest had issue with charging while on that it would only be I believe half speed.

Sent from my [device_name] using XDA-Developers Legacy app
 

pjcanales

Senior Member
Dec 18, 2010
455
83
Batesville
As far as I understand "world" is a singular noun, and "fall" is a plural verb, so I see a mismatch here. Is this poetry or medieval English or dialect? :)
I'm guessing you don't watch the "walking dead" which it's reference to. Yet you do realize that not everything has to make sense since knowledge as we know could be different in another dimension. Beside why bother responding to a post completely off subject.

Sent from my [device_name] using XDA-Developers Legacy app
 
G

GuestD2048

Guest
Please release, January security patch update!

---------- Post added at 07:21 AM ---------- Previous post was at 07:19 AM ----------

Did you give up Oreo?
 

MacLeod100

Senior Member
Nov 28, 2013
158
45
Malmö
@AndDiSa Is it possible to add more custom options to the build ? Like move the clock to left side of statusbar, network meter , screenshot , etc and builtin messaging for tilapia ?
 

AdamisHun

New member
Aug 19, 2016
3
0
Mezőtúr
@AndDiSa Is it possible to add more custom options to the build ? Like move the clock to left side of statusbar, network meter , screenshot , etc and builtin messaging for tilapia ?

It is possible to make screenshot: long press vol- + power together! ;)
The left-sided clock is possible, too: go to Settings - nAOSProm options - Clock setting (at the bottom) - Alignment


YT2pXAUe5Aa6666rDsbmeZQGL9OLfde8IFi4jI3YHh3OakYs0xXpC-pFuHpJgi5N0IdtopG7sveNW9QnAWLSsKXPfT0H0iGb45EYvjGc9mVFQhd0Nun1CbNZ6NaTZyPUa2Kg2pDKdFzEj4PFxTbQBYneAxX148xw4WgMXHv2BVRCZp5V8cwcuM0t8bSoK1YqQd6gycWGbFYd0fZ9vwzn6mtgqL6d1c6Wo6VE5jXgORRGtITbLO4R04mwEBpeeupbxUqzH0gqWJdWB7qw-JoUTFgqUjjp5kHf6eEo6UXKsrbiJieofFLsJHeZAs8QuBDuRaNQABwk9k58nLyQ-kAyC0gJf7Ts2CCpRlawsukqGlRzzb-P-HCzbXVw9CNYZZoMFeIyKyvUi9uciSuF36-rwQcZ3eBy95VhrlDN3L-R-PUQMZ7pvpXHCq0Yeiu8pcAIOYlo_foHaFJhEMjju0W27KueIpPqbE0zrYj2OtnESWX3yCw59Xv60pCBz4XUuF-tryu_s4_f1-ntJAtdGFY4OL4lUGaLcxyuNYKi_zHl0M_Zx7QV1-dPPX4EhFqytUmqkl2KE1xX0_8zdkAad9qZ3cqdipwRlQm3e4K0gLtP0-pWIgwVudHuTkLmt3eMQc3fIE8BvjV29tQbUflwr8GNRz5WnSqwhJZa=w399-h637-no


bSoMNnwO3ZjhKRC0DyG2ZvC7V87zdsYreqHO-8d4DpIUw1RJQCtR7uMfJ0iyN_czDgRPpfKiBaFC_ptdkC4SE2LYx8bOtALSsWlCG_BsCiO7Xy0zyToORFvFnyXKafezeCx-cgtmq_6xtme3Ev88nOAbQtWiTkm4AggzbPHeeDJREXnGXtZla-_ZuSuqXYOsMZkU8Cm3-ncKD86O1oq5YjjyNrhmi7BxQNewIvj8PBf5xFxDhLbuieE4zp14Bnwf4F7plH1hwx96Dh9KOj-5y2r5RWESLKoZKRyPyiMI-HeFP_2P11Hjxwbfd95hJxBqyOAKTEmDWpVfdHrn8eY-TUgzVZU3o9FpZBg490SzugL8yP9_b2m6F6HTgBkp-nimBts3t5obosp04HkHngVlHR_mYUaO3NRuU0s7XZflfvSEffDJ3QLXsSV6C66_L3oVa1hhzeTvyGT83N_wNF4V8-uN8VphICYssTHsM5g3LX6UrwrHIsA_UngNbN_FgV_5MFUpHSA43oNXSIGym4jR9ROWm9MXUMuXHcxYQr9iQAVcpPZq5pw1J30IOnxLv3utOoTrdcjqY90twtmYHALrH6tiUWsEUQH5yLwBbO17bb314isPCLCkbzLQJlyZ6FmBCxTIrK1BoiePXIroJPVYA8ZE9Jy9Br1o=w399-h637-no
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    New Versions 7.1.2 (2021-11) are available

    Hi guys, a new release but only a few changes, i.e. the security paches for November 2021.
    The full list of changes, as always, you can find in my Github repos

    The "standard" versions for Grouper / Tilapia are available for download:
    aosp_grouper-7.1.2-ota-20211105.eng.ds.zip (MD5: d8dfedbca14005dce954931d1953e80a)
    aosp_tilapia-7.1.2-ota-20211105.eng.ds.zip (MD5: b5d1f12db835d236c0b736da3bcd79ed)

    as well as the MicroG-Patched images:
    aosp_grouper-7.1.2-mg-ota-20211105.eng.ds.zip (MD5: 4c0ef1ec4507940dda406d4fe83965b0)
    aosp_tilapia-7.1.2-mg-ota-20211105.eng.ds.zip (MD5: cb7d4c64a4c9d48b901f92027abc7c2e)

    I quickly tested the ROM and didn't find issues, nevertheless I will wait for feedback from the community before I'll add the new version to the OP.

    If you report a successful (or unsuccessful :)) installation, please note which version (Grouper / Tilapia, with or without MicroG-patch) you have installed and tested. Thank you very much!
    Stay safe!
    3
    @Luckz27 you need to store it as it is on /sdcard no need to modify the zip. During the installation the installer checks different directories for those gapps-config-* files.
    2
    Hi,
    How is the microG version installed? Just one file and all, or do I need extra steps? Like installing the AuroraStore?
    Quite simple. Just flash the microG version provided in post #2. Then head over to the microG download section and install the corresponding apps from there. From my point of view it makes sense to install all provided apps beside Fake Store (you can install Aurora Store directly from F-Droid, for example). Reboot your device afterwards, then open microG Settings app and set it up. That's it.

    EDIT: by adding the microG custom repo to your F-Droid sources, you can get automatic microG updates via F-Droid.
    2
    @ev-olution_net one additional question: in which country you are living? It came into my mind that in Germany all network operators have shut down their 3G networks (UMTS) in favour of 5G. So if 2G is working but 3G not it's probably due to the fact that there is no 3G available ...
    1
    Grouper MicroG installed and working. (y)

    Dirty flashed and re-rooted.
  • 316
    This thread is about installing and using AOSP 7.x (Nougat) ROM for the ASUS Nexus 7 Grouper / Tilapia devices.

    Asus - Model names

    Grouper = Asus Nexus 7 2012 WiFi
    Tilapia = Asus Nexus 7 2012 3G


    Initial Setup Installation
    1. Update Recovery to TWRP 3.5.2-9 for Grouper resp. TWRP 3.5.2-9 for Tilapia
    2. Boot into Recovery
    3. Factory Reset (only needed if you are not already on Android 7.x AOSP)
    4. Install 7.1.2 Grouper OTA-Package (Build 20211006) (md5 :b57ddee37bad03f59e2eff562076b027)
      or
    5. Install 7.1.2 Tilapia OTA-Package (Build 20211006) (md5: 65ea4ea189a41ec7792fb13a876157da)
    6. Reboot into recovery
    7. Install Open GApps (arm/7.1/pico)
      (if you have issues regarding the size of the GApps please refer to the next post)

    [*]To get root access, I suggest to use either Magisk (V21.4) and Magsik Manager (V8.0.7) the "old" version of Magisk, or the new unified Magisk (V23.0) which can be flashed by TWRP, too. Probably you'll need to rename Magisk-v23.0.apk to Magisk-v23.0.zip

    Do not install Magisk on initial setup as it might lead to issues. Start the ROM without having root access the first time and install Magisk in a second step.

    If you are already on Android 7.x AOSP, it's sufficient to do the follwowing steps:

    Update Installation
    • Boot into Recovery
      • Install 7.1.2 Grouper OTA-Package (Build 20211006) (md5 :b57ddee37bad03f59e2eff562076b027)
        or
      • Install 7.1.2 Tilapia OTA-Package (Build 20211006) (md5: 65ea4ea189a41ec7792fb13a876157da)
      • Reboot into recovery
      • Install Open GApps (arm/7.1/pico)
        (if you have issues regarding the size of the GApps please refer to the next post)
      • Wipe cache/dalvik-cache (optional, but suggested)
      • reboot

    Important: For more detailed installation instructions please refer to the next post
    Important: First boot after upgrading will take a bit longer (stays on ANDROID) because of art optimizations

    flash and use on your own risk!


    CREDITS,
    AOSP/Google, LineageOS, Ziyann for setting up the Grouper-AOSP repository and his Unlegacy Android project, daniel_hk for some hints how to get the 3.1 kernel running with N, timduru for his work on the Asus Transformer, Timur Mehrvarz for his work on the tegra kernel, Francisco Franco for his kernel work in general

    Bugs:
    • please report

    Latest Changes
    • 20211006(AOSP 7.1.2)
      • I applied the security fixes for Otctober 2021
      • I applied / backported a few CVE-kernel patches

    Latest version with MicroG-patch applied to them:
    aosp_grouper-7.1.2-mg-ota-20211006.eng.ds.zip (MD5: d5d788b3fa735c3e57d9f0fb562e15f6)
    aosp_tilapia-7.1.2-mg-ota-20211006.eng.ds.zip (MD5: 643f8fdf2195c2395f788611578c108e)


    Changelog
    Please refer to the changes found in the github repos

    All ota packages can be found here:
    AndDiSa ROM files repository

    Sources

    https://github.com/AndDiSa

    If you would like to build from the sources, you can do so by cloning and build from repositories:
    but please take in mind that you need to have some free space (>= 100 GB) and some time ...


    XDA:DevDB Information
    Android 7.x AOSP, ROM for the Nexus 7

    Contributors
    AndDiSa
    Source Code: https://github.com/AndDiSa?tab=repositories

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.1.x
    Based On: AOSP

    Version Information
    Status:
    Stable

    Created 2016-09-23
    Last Updated 2021-03-05
    68
    Please note:
    • the system partition is already quite full which leads to the problem that gapps probably will not install correctly and that may lead to weired problems (apps closing / not showing up correctly / ...). I suggest to use the dynamic gapps package linked above. In addition I suggest you to erase the system partition completely before applying the OTA package
    • If you get "Error 7" when trying to flash the ROM directly after upgrading to TWRP 3.5.2-9, wipe the Boot, System and Cache partition and clean dalvik-cache, then re-boot to Recovery and try again (you will not loose any data as long as you do not wipe the Data partition).
    • If you get "Error 70" when installing GApps copy the attached gapps-config files into the same directory where the gapps installation packages is copiedI.e. something like

      /sdcard/open_gapps-arm-7.1-pico-20210922.zip
      /sdcard/gapps-config-tilapia.txt
      /sdcard/gapps-config-grouper.txt

      and then try to start the installation again. Error 70 should be fixed.

    Some additional hints
    • If you are in a bootloop which shows to Google logo again and again, it's sufficient to hold vol- while booting. The next bootloop will boot into bootloader.
    • If you are in a bootloop which shows the ANDROID splash screen continuusly, connect your device to your PC and enter
      Code:
      adb reboot bootloader
      After a few seconds the device should show up the bootloader screen
    62
    Hi guys,

    first of all I would like to thank all of you for your support you offered to me in the last days and I really feel honoured that so many of your would like to support / help me so that I am able to continue the development for the Nexus 7.
    I've got many offers for a "new" Nexus device from all over the world which I really didn't expect. I was really torn between continuing and stepping out. I've thought very much about pros and cons and it wasn't an easy decision especially if you get so much positive feedback. Thank you again!

    Finally I've decided to stop development for the Nexus 7 (at least for the moment). There are several other projects (not all of them related to Android) I've in mind and probably this now was a broad hint to start with something different. I've uploaded the sources of the ROMs latest version (inc. security patches for June 2019) to Github and tested together with @fidoedidoe whether all needed repos and changes are consistent and that one can build the ROM from those repos without the need of doing additional modifications or patches. The build should run smoothly after synchronizing everything. I will also support and help everybody who would like to step in and continue the builds.
    I know there are several people interested in building the ROM from sources. Probably there is someone (or probably even a group) who would like to continue ...
    Cheers,
    AndDiSa
    55
    2019/02/05 - release for Grouper and Tilapia uploaded

    I've just uploded the latest version of the ROM for Grouper and Tilapia. As always the Android security issues listed in the latest Android Security Bulletin are patched in this ROM.

    Beside that once again I've worked much on the kernel side. Some features are added (multiple binder devices, alarm timer device, ...) and some bugs have been fixed.
    I am still working together with @OlliWi on the slow charging issue which occurs from time to time. Even if I was able to get charging currents up to 1500mA while the device was connected to a charger, we still have the impression that the cable / charger detection needs to be improved. We are on it ...

    Those of you who are familiar with the installation process of the ROM can download directly from here, otherwise please first read the instructions in the OP

    7.1.2 Grouper OTA-Package (Build 20190209) (md5: 885e601a06a2104628a1e450b73f3a18)
    7.1.2 Tilapia OTA-Package (Build 20190209) (md5: 8e4c0e1955ecc0bb65a51582bb01f779)

    And finally as always: flash on your own risk ... ;)
    52
    New year ... new security fixes (2019/01/05)

    Hi guys,

    I've just uploaded a new version of the ROM for our beloved Nexus 7 (Grouper / Tilapia) having the January 2019 security fixed applied to it.

    Beside that I found a bug causing bootloops on initial install / after wiping dalvik. This was caused by zygote not having enough memory available to create the boot.jar on the fly. To fix this issue, I am doing a dex-preopt for the boot image on compile time now which leads to a slightly larger image but improves initial boot time a bit, too.

    To get more memory free on the /system partition, I debloated the ROM a bit, e.g. removed the Browser2, LegacyCamera, Music and Calendar apps as some of them even didn't work fully. There are several alternatives available in several stores which you can install if you need them. Probably most of you do not even notice that these apps were removed.

    Most changes were applied to the kernel. I tested the changes in the last 4 weeks but as I have a Grouper device only and I cannot test each functionality I cannot exclude that something doesn't work as expected. So please file a bug report (best with logcat and a meaningful bug description) if you find some unexpected behaviour and I will have a look at it.

    The most important fix here is probably the improved charging behaviour (many thanks to @OlliWi who provided with fruitful analysis and hints and pushed me to have a deeper look at this issue).
    To get a faster charging of the device, do not boot with a USB cable connected as this prevents the device to charge with more than 500mA (or at least disconnect and re-connect the cable after the device booted).

    I've updated the links in the OP, so you can download the latest version from there.

    Happy new year to all of you!