• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][10.0][POTTER] Pixel Experience [AOSP]

Search This thread

vel0x

Member
Dec 9, 2011
10
4
Till now it is working, but I have a problem with my wifi. My wifi is setup as WPA2+WPA3. The phone detect this and I type in the password but it does not connect to the router. No error is disaplyed. When I change the router to "WPA2 only" it is working.
I'm seeing this as well on Pixel Experience 11 (3/12). Connecting to OWE Transition mode enabled open WiFis also fails without any errors. I'll try to get some logs.
 

skyper555

Member
Nov 4, 2009
20
2
I've been using the 03/12 version (non plus) since it came out and all was fine until maybe 3 days ago. Now I get a lot of pixel launcher crashes - mostly while using Android Auto or after using it. I haven't installed anything new for at least a week. Any ideas?

Strike the Android Auto - pixel launcher crashed again right after a full power off and startup. Phone might be overheating? Battery usage seems normal.

Edit: Trying my other phone with a clean install and same apps.
 
Last edited:

DEJAVU54

Member
Jul 10, 2020
22
0
Hello, I have been using the 10 (Plus) ROM for over a year now.

What I want to ask, is there any way to 'unroot' the phone, restore to the stock recovery and put the device status as official again?
 

skyper555

Member
Nov 4, 2009
20
2
I've been using the 03/12 version (non plus) since it came out and all was fine until maybe 3 days ago. Now I get a lot of pixel launcher crashes - mostly while using Android Auto or after using it. I haven't installed anything new for at least a week. Any ideas?

Strike the Android Auto - pixel launcher crashed again right after a full power off and startup. Phone might be overheating? Battery usage seems normal.

Edit: Trying my other phone with a clean install and same apps.

The second phone is now experiencing issues like the first one. Crashing, even right after a reboot. Seems this rom version lasts about 2-3 weeks and then develops problems. Very odd.

Just wanted to say I've flashed the 04/16/2021 plus version a few weeks ago and it's been running fine since. Thanks.
 
Last edited:

mcfisch

Senior Member
I'm impressed how fast the device is with Android 10 and 11. However, I have a major issue that keeps me from using it: on both, Android 10 and 11 (this ROM as well as PlusUI), I can't encrypt the phone.

When I set a PIN and then chose Settings -> Security -> Encrypt Phone I only see the green android briefly, then the phone reboots and lands in a bootloop. It doesn't even have started the encryption as everything is as it was before (partial encryption would mean it would need a factory reset).

I can than boot to TWRP and reflash the rom or repair the file system, both seem to work.

Is this because newer Android Versions no longer support FDE and the Phone tries to use the wrong method or so?

I've put a logcat here that shows what happened, just in case someone can figure it out:
 

spschneer

Senior Member
Dec 22, 2014
53
4
Another issue I've found with v11 is that the fingerprint sensor isn't working for unlocking. It is supported for gestures, though.
Mine's working fine for unlocking (as well as gestures). Did you re-save your fingerprint after install? I think it gets removed/destroyed with data wipe of reinstall. I did have to re-save mine to get it to work.

S
 

spschneer

Senior Member
Dec 22, 2014
53
4
It doesn't even offer to scan them. It only offers PIN, Pattern and Passcode.
Have you set your PIN yet? It prompts for that confirmation of identity before it will allow the Fingerprint to be recorded/modified. I'm not positive but I don't think it will do FP with just password set. IIRC, mine wanted both before it would talk FP...

I'm guessing you don't have an entry under Settings/Security for Fingerprint? If not, then I'm thinking something didn't properly install/configure to enable it. Beyond my knowledge to get it working again. Sorry...
 

tiazek

Senior Member
Apr 5, 2013
52
14
@spschneer @mcfisch Does anyone of you know if the android 11 version of this Rom is SELinux enforcing? (Sadly there's no official forum thread for the 11 version where we could read Rom details)
 

mcfisch

Senior Member
@spschneer @mcfisch Does anyone of you know if the android 11 version of this Rom is SELinux enforcing? (Sadly there's no official forum thread for the 11 version where we could read Rom details)
It is enforcing.
Have you set your PIN yet? It prompts for that confirmation of identity before it will allow the Fingerprint to be recorded/modified. I'm not positive but I don't think it will do FP with just password set. IIRC, mine wanted both before it would talk FP...

I'm guessing you don't have an entry under Settings/Security for Fingerprint? If not, then I'm thinking something didn't properly install/configure to enable it. Beyond my knowledge to get it working again. Sorry...
Yeah, I've wiped/formatted and reinstalled multiple times, set up a PIN etc, still no luck. The fingerprint option is missing, the encryption attempt leads to a softbrick.

I would like to use this phone to access internal company resources, but in order to do that I need both working, fingerprints and device encryption.

Edit: I checked the fingerprint sensor gestures and they actually don't work, which confirms the system doesn't recognize the sensor at all.
Also I verified that all of that does work with the stock ROM when flashing that.
 
Last edited:

spschneer

Senior Member
Dec 22, 2014
53
4
It is enforcing.

Yeah, I've wiped/formatted and reinstalled multiple times, set up a PIN etc, still no luck. The fingerprint option is missing, the encryption attempt leads to a softbrick.

I would like to use this phone to access internal company resources, but in order to do that I need both working, fingerprints and device encryption.

Edit: I checked the fingerprint sensor gestures and they actually don't work, which confirms the system doesn't recognize the sensor at all.
Also I verified that all of that does work with the stock ROM when flashing that.
Strange...I did double-check also, and my fingerprint sensor works for both unlock and gestures. I'm not encrypting so maybe there's something there? Otherwise, I don't know. Hopefully someone with knowledge of how the fp sensor works or integrates will jump in with some specific knowledge.
 

cjdijk

Member
Apr 25, 2021
20
8
Another issue I've found with v11 is that the fingerprint sensor isn't working for unlocking. It is supported for gestures, though.
I have exactly the same issue: fingerprint is not responding for unlocking, need to use the pincode to unlock. In other apps the fingerprintsensor works fine.

But have found a fix. If you want to reboot your phone, turn Power OFF then Power ON again, (do not use restart), and fingerprint sensor is now working for unlocking.
 
  • Like
Reactions: mcfisch

mcfisch

Senior Member
But have found a fix. If you want to reboot your phone, turn Power OFF then Power ON again, (do not use restart), and fingerprint sensor is now working for unlocking.
On my device it seems to behave similar as it does show "Not recognized" above the FP reader when I try to use it after powering up the device (and unlocking initially with the PIN). That's likely because I didn't have any FP's registered yet as the UI doesn't provide the option for that to me.
 

cjdijk

Member
Apr 25, 2021
20
8
On my device it seems to behave similar as it does show "Not recognized" above the FP reader when I try to use it after powering up the device (and unlocking initially with the PIN). That's likely because I didn't have any FP's registered yet as the UI doesn't provide the option for that to me.
I am afraid I can't help you with this, it seems you have a hardware problem. Or maybe it's your model number, I have an European model (XT-1685) with NFC and dual-sim. In my case, after a reboot, my fingerprint sensor cannot be used for unlocking, but after using the pincode to unlock, it works for other apps, for example my banking app (ING) for identification. After powering off and on, my fingerprintsensor works also for unlocking my phone. This continues working until reboot (after an Android update for example). I just need to power it of and on again, to get it working again. Hopefully my info can help someone else. Good luck solving your problem.
 
  • Like
Reactions: mcfisch

badtlc

Senior Member
Jan 28, 2013
266
18
KC
Trying to install PE 11.0 5/14 update from a clean install and on first boot it is getting stuck at the boot logo G and doesn't seem to proceed. The activity bar is moving left to right like it is doing something but I have waited 10 minutes and still not fully booting. Any suggestions?
 

badtlc

Senior Member
Jan 28, 2013
266
18
KC
Trying to install PE 11.0 5/14 update from a clean install and on first boot it is getting stuck at the boot logo G and doesn't seem to proceed. The activity bar is moving left to right like it is doing something but I have waited 10 minutes and still not fully booting. Any suggestions?

Got it. It was the format data to remove encryption part that i missed and screwed me up.
 

tiazek

Senior Member
Apr 5, 2013
52
14
Got it. It was the format data to remove encryption part that i missed and screwed me up.
Could you set up encryption back again? I get into a bootloop using PE 11.0 5/14 when attempting to encrypt the phone... AS far as I know the recovery image is in charge of performing this action (I may be wrong). Which recovery version do you use?
 

tiazek

Senior Member
Apr 5, 2013
52
14
I'm impressed how fast the device is with Android 10 and 11. However, I have a major issue that keeps me from using it: on both, Android 10 and 11 (this ROM as well as PlusUI), I can't encrypt the phone.

When I set a PIN and then chose Settings -> Security -> Encrypt Phone I only see the green android briefly, then the phone reboots and lands in a bootloop. It doesn't even have started the encryption as everything is as it was before (partial encryption would mean it would need a factory reset).

I can than boot to TWRP and reflash the rom or repair the file system, both seem to work.

Is this because newer Android Versions no longer support FDE and the Phone tries to use the wrong method or so?

I've put a logcat here that shows what happened, just in case someone can figure it out:

I've got the exact same problem on PE Plus 11 5/14, have you been able to figure it out?

For anyone else reading: Any tips on this? Have you had success encrypting the phone?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    oh... any chance to find this ROM (v10) ? looks like the 11 is half backed or my device is screwed (its long time since I ve used the FM radio ) thanks!
    I am using the plus version (PixelExperience_Plus_potter-11.0-20210910-0159-OFFICIAL.zip), download link is here https://download.pixelexperience.org/potter It says discontinued, but downloading still works.
  • 58

    GtwTyCR.png

    PixelExperience for Moto G5 Plus [potter]

    What is this?
    Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, bootanimation)

    Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

    Based on Android 10.0


    Whats working?
    Wifi
    RIL
    Mobile data
    GPS
    Camera
    Flashlight
    Camcorder
    Bluetooth
    FMRadio
    Fingerprint reader
    NFC
    Lights
    Sound / vibration
    Encryption
    Enforcing


    Known issues
    Tell me

    DON'T FLASH GAPPS, ALREADY INCLUDED
    Download from Website

    Donate
    Liked my work? Give me a beer

    Translation
    Help with project translation

    Stay tuned
    Our Telegram channel
    Our blog


    XDA:DevDB Information
    PixelExperience, ROM for the Moto G5 Plus

    Contributors
    ZJRDroid
    Source Code: https://github.com/pixelexperience

    ROM OS Version: Android 10

    Version Information
    Status: Stable
    Stable Release Date: 2019-11-01

    Created 2019-11-01
    Last Updated 2019-11-01
    9
    New build is up!
    changelog:

    • Merged november security patch
    • Added GoogleCamera 6.2 by default
    • Camera is a little more stable now
    • Temp added FlashlightApp
    • Added MotoActions original from potter
    • Merged latest source changes
    • Fixed Offline charging
    • New Wallpaper
    • New things ported from Pixel 3/4

    P.S: Clean flash is highly recommended


    Download
    4
    All builds can be found on Telegram:
    https://t.me/potterofficial (group)
    https://t.me/g5pluslinks (channel)
    3
    Issues in latest ROM 20200226 potter

    @ZJRDroid
    I am testing the Pixel Experience ROM on potter. I find these issues in ROM:
    1. Signal strength fluctuating too much in SIM 1. I am in strong network region.
    2. No VoLTE icon. No HD icon in call screen if it is an HD call.
    3. No charging percentage if charging when phone is off.(only showing a battery icon with question mark in it.)
    4. Sometimes the second sim slot cease to work after phone reboot.
    5. No different ringtones setting for both sim cards.

    If you need screenshots or something else to fix this, please let me know.

    You are doing awesome work. I would love to thank you by heart for the ROM you compiled for potter. Thank you so much :)
    2
    Hey guys, is this ROM working on the 32/2GB variant?

    Sent from my MG5+ using XDA Labs

    Yes, i'm using one right now