[ROM][OFFICIAL][10] LineageOS 17.1 Official

Search This thread

WaterMan!

Senior Member
Aug 12, 2009
275
50
I just installed this on my testing phone. Haven't really played around much, but one interesting thing to note is that there is apparently an LED that turns on when charging. Is this just disabled in stock, or what's going on here? Pretty wild. Any way to disable it or change the colour?
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
7,645
10,603
I just installed this on my testing phone. Haven't really played around much, but one interesting thing to note is that there is apparently an LED that turns on when charging. Is this just disabled in stock, or what's going on here? Pretty wild. Any way to disable it or change the colour?

In stock LED only indicates charging (unless rooted and using an app such as LiteFlow) but in LOS the LED should also work for notifications, although the color cannot be changed. There is a place where you can disable with it for charging. Search settings for battery light.
 
  • Like
Reactions: mrk2815

WaterMan!

Senior Member
Aug 12, 2009
275
50
In stock LED only indicates charging (unless rooted and using an app such as LiteFlow) but in LOS the LED should also work for notifications, although the color cannot be changed. There is a place where you can disable with it for charging. Search settings for battery light.

That's great, thank you! Crazy how it doesn't work on stock ROM at all.

Another question - I am reading up through the past posts about this "party mode" issue, and I do have it. What's the general consensus? How do I return the colors and so forth back to normal? Thanks for all the help!
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
7,645
10,603
That's great, thank you! Crazy how it doesn't work on stock ROM at all.

Another question - I am reading up through the past posts about this "party mode" issue, and I do have it. What's the general consensus? How do I return the colors and so forth back to normal? Thanks for all the help!

Change the color profile to any other setting then back to what you want and then never touch the live display setting or the live display quick tile.
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
7,645
10,603
Thank you, that much I gathered. The issue is that I cannot find the setting that changes color profile, what is it called?

LOL, I'm on stock now and forget what it is but IIRC it might be adjacent to the live display setting. Also, as it was previously discussed here the full path to the setting might be described somewhere in this thread. Additionally, in Android, searching settings for "colors" might find it.
 
Last edited:

onyxcode

Member
Mar 5, 2021
5
1
I just installed this on my testing phone. Haven't really played around much, but one interesting thing to note is that there is apparently an LED that turns on when charging. Is this just disabled in stock, or what's going on here? Pretty wild. Any way to disable it or change the colour?
I think so, when it turned on for the first time holy crap that thing was bright. I disabled it lol
 

Tod13

New member
Mar 10, 2021
4
1
Does anyone else have the problem where clicking on the Add Account to add a second account in the LineageOS Email app causes the app to crash?
 

Tod13

New member
Mar 10, 2021
4
1
I personally prefer third-party email clients like Zoho Mail. However, upon inspection, I am not having this issue in the latest version. Are you on the newest version? It came out on the 6th.

Thanks for the quick check. I'm running the 02-03 from MicroG. I think they'll get the 03-06 build out this weekend, so I'll test it again. I don't need much from an email app, and a lot of the third-party ones are overly complex for what I want. I'll probably test the SimpleEmail fork of FairCode if it remains an issue.
 

Tod13

New member
Mar 10, 2021
4
1
BTW, when I do the next phone, I'll be building and posting a install walkthrough (on Linux) and posting the APN settings for T-Mobile USA. (The ones in the ROM did not let my phone make calls.)
 

WaterMan!

Senior Member
Aug 12, 2009
275
50
Well, I really like it on my backup phone, so I may switch over my daily G7 to LOS17. A couple of questions:

1) Are there instructions for root with magisk? Seems weird it's not included in the ROM.

2)Can I still get updates if rooted?

Thanks in advance!
 

BTK19

Member
Jan 25, 2021
13
4
Earth
Nexus 6
Moto G4 Plus
Well, I really like it on my backup phone, so I may switch over my daily G7 to LOS17. A couple of questions:

1) Are there instructions for root with magisk? Seems weird it's not included in the ROM.

2)Can I still get updates if rooted?

Thanks in advance!

Flash the ROM and TWRP installer.
Choose Reboot -> Recovery
Install GApps & Magisk.
Reboot -> Bootloader
fastboot -w
Yes you can update if you're rooted
 

WaterMan!

Senior Member
Aug 12, 2009
275
50
Okay, so I got the devices rooted on Lineage OS 17.1 successfully, on an already installed and used ROM. I found information kind of all over the place so I will put it all together here. Anyway after you have installed LOS:

1) Download the magisk app, it is an APK. I got the apk file from Magisk itself HERE. You need to rename it to a .zip, then put the .zip on your device

2) Download the TWRP .img file. Place it in the same folder you'll be running commands from, or otherwise somewhere where it is easy to reference.I used twrp-3.5.1_10-0-ocean that I got HERE

3) Hook up your phone. ADB debugging enabled. Boot into the bootloader using the command "adb reboot bootloader". Verify your device shows up with the command "adb devices"

4) We will boot into TWRP, not flash it. The command is "fastboot boot twrp-file-name.img"

5) Keep the system read only when it prompts you. Don't know if it matters, thats how I did it. Now flash the magisk zip from step 1, and reboot. Ta-da!

I haven't got an OTA yet, but when a new one comes out, I'll see if root remains after an update.

PS: It does not pass safetynet.

EDIT: Yes, root survives updates!
 
Last edited:
  • Like
Reactions: mrk2815

thespacemonky

New member
May 6, 2016
3
0
Followed install directions but when I did the command to reboot so I could install GAPPS the os came up. In the instructions say you need to flash gapps before running os out of the question now caused it booted so when I go back to recovery lineage recovery comes up cant get back to twrp so can I sideload gapps from this recovery or do I need to start over. the os runs fine.
Update: factory reset, side loaded GAPPS in lineage recovery then reboot will see if that works with no errors
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Seems like my G7 power has graphical issues on LineageOS 18.1 (official release).
    I already had those Issues on 17.1 with multiple sim cards. One sim card alone worked out fine.

    Edit:
    A reset solved this issue for now.
    2
    Hi,

    I'm curious if there is any progress regarding this issue?
    I have g7 power 1955-5 (T-Mobile prepaid US) and have not been able to make VoLTE/VoWiFi work, neither with LOS 17.1 nor after upgrade to 18.1. IMS is not registered, carrier's instructions for BYOD do not help much...
    Would appreciate any help, it looks like the phone will turn into a useless brick without VoLTE support as soon as they switch to 4G completely...

    I'm now running stock on this device and testing LOS on a different device so I can't speak to this for current builds but for what it is worth:

    In stock I did not have the same problem where LTE did not persist during phone calls. In my case it's unclear if I did something wrong while flashing or if there is an issue with the ROM but for T-Mobile service I suspect the latter because there has not yet been a confirmation that voice over LTE is working on T-Mobile service om LOS on this device and there has been confirmation that it works in stock on the same devices (here and in other forums).
    1
    Okay, so I got the devices rooted on Lineage OS 17.1 successfully, on an already installed and used ROM. I found information kind of all over the place so I will put it all together here. Anyway after you have installed LOS:

    1) Download the magisk app, it is an APK. I got the apk file from Magisk itself HERE. You need to rename it to a .zip, then put the .zip on your device

    2) Download the TWRP .img file. Place it in the same folder you'll be running commands from, or otherwise somewhere where it is easy to reference.I used twrp-3.5.1_10-0-ocean that I got HERE

    3) Hook up your phone. ADB debugging enabled. Boot into the bootloader using the command "adb reboot bootloader". Verify your device shows up with the command "adb devices"

    4) We will boot into TWRP, not flash it. The command is "fastboot boot twrp-file-name.img"

    5) Keep the system read only when it prompts you. Don't know if it matters, thats how I did it. Now flash the magisk zip from step 1, and reboot. Ta-da!

    I haven't got an OTA yet, but when a new one comes out, I'll see if root remains after an update.

    PS: It does not pass safetynet.

    EDIT: Yes, root survives updates!
    1
    I noticed that lineagesos 18.1 has been available for download since April 1st and the last 17.1 version was released on March 27th. Does this mean 17.1 is no longer maintained? I normally prefer to hold off upgrading until the newer version is time-tested and deemed stable.

    Typically a device will not receive official builds from the previous android version if it has been added to the official build roster for the next android version. This makes sense because development by nature is forward-looking and testing in the previous android version would not inform bugs in the new android version. You would not be the only person who stays with the last official build of a previous android version while waiting to see what happens. Also sometimes developers may release on official builds of the previous version including security patches.

    that maybe hte case.but dont know. usually when there ar newer lineage releases the older ones will usually go on a weekely or semi weekly basis.

    IIRC the way it used to work is that devices on the roster for new android version got daily builds and devices on roster for previous android version got weekly builds the lists were mutually exclusive. Interestingly, now all builds are weekly. https://github.com/LineageOS/hudson/blob/master/lineage-build-targets.
    1
    Uh oh, I hope your phone's alright! Back to stock

    Yep. During what I thought would be a quick test of a build a few months ago the device was not connecting properly to cellular service. It saw the cellular service but it did not pick up any bars and could not make calls or connect to data unless forced to use WCDMA. While attempting to restore previous version and do another test something went wrong in TWRP and I was stuck so I figured that was a good time to go back to stock. In stock I found as mentioned above that VOLTE issue no longer occurred, in fact a few things were better in stock and I might as well share some details.

    VOLTE: the path I took through this from first installation of LOS and since then introduced the possibility that I messed something up as SyberHexen had hypothesized, but here and in other forms I found multiple reports of issues with VOLTE in LOS on T-Mobile and no confirmations that that combination worked as it does in stock. If and when I returned to LOS on this device I'll watch this stuff closely..

    Messy fade in/out when switching call between handset mode and speaker mode and occasional failure to exit speaker mode. This has never happened in stock even with the same phone recording software installed.

    The rules of the ballgame have somewhat changed with the move to android 11 so I would not call these bugs but they are worth noting because some issues to travel along the android versions.

    Also, it seems that the underlying issues with saving photos to external storage have been rectified and that functionality has been restored to the camera which can now properly access photos saved their. I noticed this well testing LOS 17 on a different device.

    Anyhow, as this is my daily device and there was an instant gain in the return to stock I stayed there, and probably will stay a little more while testing LOS in devices that don't matter to me so much as this one with its capacious battery.
  • 2
    Hi,

    I'm curious if there is any progress regarding this issue?
    I have g7 power 1955-5 (T-Mobile prepaid US) and have not been able to make VoLTE/VoWiFi work, neither with LOS 17.1 nor after upgrade to 18.1. IMS is not registered, carrier's instructions for BYOD do not help much...
    Would appreciate any help, it looks like the phone will turn into a useless brick without VoLTE support as soon as they switch to 4G completely...

    I'm now running stock on this device and testing LOS on a different device so I can't speak to this for current builds but for what it is worth:

    In stock I did not have the same problem where LTE did not persist during phone calls. In my case it's unclear if I did something wrong while flashing or if there is an issue with the ROM but for T-Mobile service I suspect the latter because there has not yet been a confirmation that voice over LTE is working on T-Mobile service om LOS on this device and there has been confirmation that it works in stock on the same devices (here and in other forums).
    2
    Seems like my G7 power has graphical issues on LineageOS 18.1 (official release).
    I already had those Issues on 17.1 with multiple sim cards. One sim card alone worked out fine.

    Edit:
    A reset solved this issue for now.
    2
    question for those of you who flash roms from one rom to the next.what's the best approach to avoid the encryption issues with internal storage with these android 10 based roms and encryption mess .

    I think your best bet is to make a backup of the internal storage and then use TWRP to format all partitions first and finally format data. To avoid any issue you must remove any lockscreen setup before flashing a new ROM, otherwise you'll have issues.

    So far I haven't had any problems installing these ROMs (I've tested every official one and some unofficial ones).
    1
    Thanks for that reassurance.

    I'll be a few days behind you. My G7 Power is on a truck. I had been shopping for new device and wanted Moto G7 Power but did not see it in LOS. Then I saw your post. Within minutes I ordered the one I had been eyeing.

    As to this thread, typically an LOS official ROM thread will have certain standard language and statements in the original posts. I have no complaint, I'm obviously delighted that you shared the information and you provide links to the official instructions, but be prepared to manage the inclusion of additional information in this thread or hand the thread off to a maintainer to make it the official official thread, or we follow to a new official thread LOS Moto G7 of power.

    In any event... Thanks again!

    I'm glad I could reach you on time! :) I'll keep that in mind about the thread - thanks for the heads-up.


    Getting the following error when trying to flash <lineage-17.1-20200912-nightly-ocean-signed.zip>

    Error applying update: 18 (ErrorCode::
    kDownloadPayloadPubKeyVerificationError)

    I would recommend that you try the installation again, taking care to follow the pre-installation instructions here. Additionally, I recommend that you wipe everything (system, data, internal storage, and cache) before attempting to install LOS.
    1
    Uh oh, I hope your phone's alright! Back to stock

    Yep. During what I thought would be a quick test of a build a few months ago the device was not connecting properly to cellular service. It saw the cellular service but it did not pick up any bars and could not make calls or connect to data unless forced to use WCDMA. While attempting to restore previous version and do another test something went wrong in TWRP and I was stuck so I figured that was a good time to go back to stock. In stock I found as mentioned above that VOLTE issue no longer occurred, in fact a few things were better in stock and I might as well share some details.

    VOLTE: the path I took through this from first installation of LOS and since then introduced the possibility that I messed something up as SyberHexen had hypothesized, but here and in other forms I found multiple reports of issues with VOLTE in LOS on T-Mobile and no confirmations that that combination worked as it does in stock. If and when I returned to LOS on this device I'll watch this stuff closely..

    Messy fade in/out when switching call between handset mode and speaker mode and occasional failure to exit speaker mode. This has never happened in stock even with the same phone recording software installed.

    The rules of the ballgame have somewhat changed with the move to android 11 so I would not call these bugs but they are worth noting because some issues to travel along the android versions.

    Also, it seems that the underlying issues with saving photos to external storage have been rectified and that functionality has been restored to the camera which can now properly access photos saved their. I noticed this well testing LOS 17 on a different device.

    Anyhow, as this is my daily device and there was an instant gain in the return to stock I stayed there, and probably will stay a little more while testing LOS in devices that don't matter to me so much as this one with its capacious battery.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone