• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][11.0]dot-OS v5.0-POCO X3[surya/karna][18.04.2021]

Search This thread

userBach

Member
Jan 17, 2020
8
3
Somehow my google location history was not working, timeline in google Map recorded nothing. This has happened since dot 5.1 i guess. Tried add the device, allow permissions, unrestricted data & battery, etc.
 

s3xymo

Member
Aug 2, 2021
21
6
Has anyone encountered a bug where whenever shutting down, the phone slightly freezes and reboots itself? I've had this problem on ArrowOS and have only encountered it on DotOS these past few days. Really annoying.
 

Metall Boy

Senior Member
Aug 30, 2012
225
48
OnePlus 7 Pro
HI, I found a bug. Sometimes the screen doesn't turn on when pressing the power button or double tap to wake... After a few tries it sometimes turns on and works fine but other times it asks for my SIM pin number but I can't type it because it shows like this (see picture)
 

Attachments

  • Screenshot_20211027-093305.jpg
    Screenshot_20211027-093305.jpg
    2.4 MB · Views: 72
  • Like
Reactions: Mawoka

Viora_boy

New member
Oct 12, 2021
2
0
I am having the same battery problem on my poco x3 pro (vayu).
Is there a custom kernel that I can install on this device to solve this problem?
 

qu38mm

Senior Member
I am having the same battery problem on my poco x3 pro (vayu).
Is there a custom kernel that I can install on this device to solve this problem?
I don't know. I'm just going to flash the previous version again.

Edit: on ArrowOS 12. Battery isn't as good as the previous dotOS but better than 5.2. Hopefully they fix the battery life cause I love this rom.
 
Last edited:

lopilpo

New member
Dec 7, 2011
1
0
Tried to flash the latest DotOS 5.2.1 with the latest global 12.5.3 and eu 12.5.4 vendor. Also tried differently versions of twrp. Ended up in it getting stuck at the boot amination.
Is there something wrong with the latest DotOS 5.2.1 zip?

Using Poco X3 NFC (Surya)
 

s3xymo

Member
Aug 2, 2021
21
6
Tried to flash the latest DotOS 5.2.1 with the latest global 12.5.3 and eu 12.5.4 vendor. Also tried differently versions of twrp. Ended up in it getting stuck at the boot amination.
Is there something wrong with the latest DotOS 5.2.1 zip?

Using Poco X3 NFC (Surya)
If you can go to TWRP, did you format data?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    dotOS_banner-5.0.png


    " #DroidOnTime "



    ROM Version: 5.0

    Device: Poco X3

    Maintainer: thepsambit & CHRISL7

    Build Status: OFFICIAL



    banner_discl.png




    Code:
     * Your warranty is now void.
    
     * We are not responsible for anything that may happen to your phone by installing any custom ROMs and/or kernels. 
    
     * You do it at your own risk and take the responsibility upon yourself and you are not to blame us or XDA and its respected developers.



    "This is a user-friendly thread, all your suggestions are important to us and will be taken into consideration.."



    banner_about.png




    dotOS is an Android ROM which focuses on performance and stability. We focus on making our rom look and feel great without struggling on Performance and Battery! So that one can get most out of his/her device.....



    banner_inst.png




    CLEAN FLASH :

    Download the latest build and GApps

    Reboot to recovery

    Make nandroid backup (Not Necessary)

    Wipe System, Data, Cache, Dalvik

    Flash the latest build and GApps

    Reboot




    DIRTY FLASH :

    Download the latest build

    Reboot to recovery

    Flash the latest build

    Wipe Cache

    Reboot




    Note: GApps only has to be flashed once whereas Magisk/Su is to be flashed every time you Dirty Flash the OTA Update.



    banner_downlods.png




    SourceForge





    banner_features.png




    Code:
    [LIST]
    
    New and refreshed UI
    
    New Customization app (previous named as DotExtras)
    
    Accent Overlay & RGB Picker
    
    Edge Lightning
    
    Battery Styles
    
    Battery Percentage Styles
    
    Clock Customization
    
    Traffic Indicator
    
    Battery Light Customizations
    
    QS Tiles title toggle
    
    QS Tiles style toggle (AOSP & accent)
    
    QS Rows & Columns Customization
    
    New FOD Icon & Animation picker with previews
    
    FOD recognition color picker
    
    Screen-Off FOD
    
    Automatically temporary disable night light while using FOD (toggle)
    
    New Theme Manager
    
    Overlays based Accent Picker
    
    Material Palette Accent Picker
    
    Smart Accent Picker (find automatically proper shade of accent for the other theme; if you apply custom accent for dark theme, press Smart Accent Picker and it will find a good shade to use for light theme and vice-versa)
    
    Fonts, Icon Packs and Icon Shapes picker
    
    Other Extra Features
    
    Hold power to torch
    
    Double tap on statusbar and lockscreen to sleep
    
    Double tap while sleeping to open doze (ambient display)
    
    Quick Screenshot (3 fingers gesture)
    
    Volume Panel position switch (right or left)
    
    Navigation bar pill size customization (hide, stock, medium, large)
    
    Pocket Mode - avoid scree touches while the phone is in your pocket
    
    Use Biometrics on first boot (unavailable for encrypted users)
    
    Lockscreen Media toggle
    
    Built-in Launcher Grid control
    
    MicroG support
    
    [CENTER]
    
    [/LIST]

    banner_credits.png


    DotOSteam

    AOSP

    Pixel Experience

    Dirty Unicorns

    And all other open source Devs/Teams.



    banner_team.png




    Mohan CM - Founder/Core Developer

    Sam Grande - UI Developer/Project Co-ordinator

    Iacob Ionut - UI, UX Developer/ Core Developer

    Sipun Kumar - Developer/Maintainer


    Shreehari Vaasistha L - Developer/Maintainer [/SIZE]



    Special thanks:

    Aswin - Graphics Designer

    ShreeJoy - Web Backend Developer

    Manish Bajpai - Web Frontend Developer






    Important Links



    Liked The ROM? Want to Help Us? Then gift us some credits



    banner_sources.png






    dot OS source


    dotOS-Device Sources



    telegram.png


    Telegram Group

    Telegram Channel



    web.png


    Website




    REPORTING BUGS!

    As soon as the problem occurs, take a logcat!

    for more READ THIS

    and do not forget to send it to us 😜

    header_logo_50.png

    XDA DevDB Information

    dotOS, ROM for Poco X3



    Contributors: Psambitk1 & CHRISL7

    Source Code: https://github.com/DotOS

    Kernel Source:: https://github.com/GZR-Kernels/Optimus_Drunk_Surya



    ROM OS Version: 11.x Android R

    ROM Kernel: 4.14.x

    ROM Firmware Required: Must be On latest Firmware

    Based On: AOSP



    Version Information

    Status: OFFICIAL

    Current Stable Version: v5.0.1

    Stable Release Date: 24-02-2021​
    2
    Just sharing the proccess I did to get it working:
    - Flash stock 12.0.8 trough MiFlash on PC;
    - Install OrangeFox Recovery;
    - Reboot to recovery;
    - Wipe Data - yes;
    - Wipe Caches;
    - Reboot to recovery;

    OPTIONAL:
    (in this part, I had a really big problem, cause my computer wasn't recognizing FTP anymore. Everytime I rebooted to recovery, it showed the device connected, but I could not do anything like copy or create anything)
    Here is how I solved this part:
    - Rebooted to system;
    - MIUI boot screen showered up, so I quickly rebooted to recovery;
    - Now my computer recognized my device properly;
    END OF OPTIONAL

    - Flash ROM (mine was with gapps);
    - Reboot to system;

    OBS:
    (in this part, my phone kept rebooting to recovery all the time)
    Here is how I solved:
    - Once in recovery, wipe Data again;
    - Reboot to System;
    - Done!

    (Sorry for my bad english, I'm learning by myself)
    (I hope I can help at least one person with difficulties)
    2
    Help. Stuck on recovery when try to flash DoT OS 5.1
    Already follow said step by step but I got recovery bootloop
    2
    For those who after upgrading to 5.1.3 having wifi problem, cannot boot, storage encrypted, etc. Rest assure, follow this step:
    1) Download this latest R Firmware and this DFE place it in ext sdcard or OTG
    2) Boot to recovery (i'm using OFOX), if asking for password, enter your device pin/password otherwise just leave it blank and enter
    3) Backup your things on internal sdcard and FORMAT your data partition. NOT WIPE. after that, reboot to recovery again
    4) Flash this in order { R Firmware -> DFE -> ROM -> Magisk (optional) -> Reboot to System }

    This step worked flawlessly in my case.

    Still this update feels unstable, random lag sometimes appear , KCAL not working, and the scrolling experience feel laggy, i'm personaly reccomend to not update to this version.
    2
    Hi, can you share link to this camera? Do i need root for this? I dont want safety net fails. Btw i swirched to arrow's latest build (OSS + A11), can't seem to flash this rom, any ideas why? xD
    1. Here is the link :
    2. For root i flashed anxcamera through Magisk which needs root acces (i havn't tried flashing it through recovery)
    3. i use PE+ and SafetyNet passes, so there is no problem with this.
    4. Try to flash stock MIUI ROM then flash the rom because PE+ it's not OSS based.