• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][11.0][X00P] Pixel Experience [2020/04/08]]

Search This thread


Senior Member
Dec 12, 2015
im on stock oreo and flash andriod pie with success but when it boots its just stuck on checking for updates screen.ive got a very strong net but cannot proceed.badly need help guys

Top Liked Posts

  • There are no posts matching your filters.
  • 6


    PixelExperience for Asus Max M1

    What is this?
    Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, bootanimation)

    Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

    Based on Android 10

    Whats working?
    Mobile data
    Fingerprint reader
    Sound / vibration

    Known issues
    MSM8917 variants

    Telegram Group

    Download from Pixel Experience website

    Help with project translation

    Stay tuned
    Our Telegram channel
    Our blog

    XDA:DevDB Information
    pixel-experience, ROM for the Asus ZenFone Max M1

    Source Code: https://github.com/pixelexperience-devices/device_asus_X00P

    ROM OS Version: Android 11
    ROM Kernel: Linux 3.x
    ROM Firmware Required: Pie firmware.
    Based On: AOSP

    Version Information
    Current Stable Version: 1.0
    Stable Release Date: 2020-04-15

    Created 2020-04-09
    Last Updated 2020-10-12
    I had successfully unlocked the bootloader and installed TWRP. After flashing the latest build the device is encrypted and asks for a password every time I reboot the device & when I open the TWRP it also asks for a password to decrypt. So is there any way to remove the encryption?
    Format data or use unofficial twrp
    I got a new X00PD (ZB555) and I wanted to try putting this rom on it out of the box. I have done:

    1) Unlocked bootloader via Asus apk
    2) Booted into fastboot and flashed unofficial TWRP
    3) Rebooted into TWRP.
    4) Flashed twrp in twrp (I wasn't sure if this was needed or not)
    5) Rebooted into recovery
    6) Wiped dalvik, system, cache, data
    7) Flashed Pixel Experience. TWRP says it was successful.

    Here is where I have a problem. On reboot its a boot loop.

    I've tried flashing this rom now 4 times, keeps giving me a boot loop. I just booted into fastboot and reflashed TWRP and then tried to flash the rom from there, still boot loop.

    I have questions:

    1) Did I do things right?

    2) Could the message on TWRP's site have something to do with this "This device uses dm-verity! This means that swiping to allow system modifications will prevent you from being able to boot if you are using the stock kernel."? I never got a request to allow system modification.

    3) Yikes, what do I do now?
    Have you msn8917 or msm8937 variant
    Have the same problem with boot loops on MSM8917 device.
    Did you find any way to fix it?

    Nope and no help on any of the threads I posted in here but Reddit was at least a little more helpful. I was able to downgrade the android 10 beta stock rom back to android 9 stable and then root it and run Magisk with help from there.

    It seems this forum is not setup to help people, more to just promote dev work. However, if you also want stock pie rom rooted, let me know and I will help you.