[ROM][OFFICIAL][11] LineageOS 18.1 for Samsung Galaxy Note 3 (hlte*)

Search This thread

haggertk

Senior Member
2okPze5.png



LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

Device source code:
Kernel source code:

Build Compatibility:
The noted models are the only ones supported. If you have a model that isn't listed and ask politely then I might work to add compatibility.
BuildModel
hlteSM-N9005, SM-N900P
hltechnSM-N9008V
hltekorSM-N900K, SM-N900L, SM-N900S
hltetmoSM-N900R4, SM-N900T, SM-N900V, SM-N900W8

Downloads:
Installation Instructions:
Reporting Bugs:
Compatibility Notes:
  • External SD cards don't support POSIX (ext*, f2fs) or NTFS filesystems anymore. If this affects you then just bite the bullet, copy any data off you really want to save, and reformat as exfat.
  • The latest TWRP does work, but if someone has issues then perhaps try using the actual supported recovery.
  • If you are encrypted, even with insecure boot, you absolutely must format userdata on upgrade, as noted in upgrade instructions in wiki.
    • If you are not encrypted then disable lockscreen before upgrading and it *should* work without wiping userdata.
    • If you didn't disable lockscreen before upgrading then delete the lockscreen files and it *should* work. Use the power of search, I'm not going to help out with this one -- it's an unsupported path.
    • If you get terribly stuck then wipe userdata as our official upgrade guide notes.
Donations:
  • I absolutely don't personally accept them. If you really feel that this work deserves it, then find a local food bank or animal shelter/rescue and throw some money their way. You can also throw some the way of LineageOS, but we're actually doing pretty well right now.
 

kisilmike

Member
Jan 14, 2012
21
3
I have install this new 18.1 + MindTheGapps + magisk (before that i used 17.1) and after 2 days using i want to say that os works normal and suitable for everyday use. Camera, bt, calls, battery life - all is that works like 17.1. All call logs, sms, 120 apps was success restored by google backup. But some bugs detected:

  • some apps cant get login via google account. When i select my account nothing is happen.
  • other man after install 18.1 got internal storage wrong free space - only 2gb free and total space is ~22 but correct is 32. Once i got similar problem: it was 20gb free, but new app from play market cant be installed because no free space. After reboot that was fixed. I have dump if someone needs.
  • in system settings when i choice sound for notifications there is no sound on selection.
  • sometimes ui got freezes but very rarely, probably 2 times a day
no other problems detected.
 
Last edited:
  • Like
Reactions: vasyekv

r0mushii

Senior Member
some apps cant get login via google account. When i select my account nothing is happen.
this is a gapps-related issue, use a different gapps package
works fine here on microg or opengapps beta
in system settings when i choice sound for notifications there is no sound on selection.
lineage has it's own sounds(soundpicker) app for you to select its default ringtones. if your gapps package has google sounds bundled in, that may be the cause as it always has issues on 32bit systems and will replace lineage's own soundpicker
sometimes ui got freezes but very rarely, probably 2 times a day
did you clean flash? are you previously from official 17.1 build?
 

kisilmike

Member
Jan 14, 2012
21
3
this is a gapps-related issue, use a different gapps package
works fine here on microg or opengapps beta

lineage has it's own sounds(soundpicker) app for you to select its default ringtones. if your gapps package has google sounds bundled in, that may be the cause as it always has issues on 32bit systems and will replace lineage's own soundpicker

did you clean flash? are you previously from official 17.1 build?
thank you for answer.
"in system settings when i choice sound for notifications there is no sound on selection. "
- now its work correct. May be reboot fixed it.
did you clean flash? are you previously from official 17.1 build?
yes, it was official 17.1 with latest updates but new 18.1 i have install on blank phone with all wipes available: internal memory, caches, ... . I Said wrong, it wasn't a freeze: just when i go to settings to modify somethings some times ui stopped for response and just kill window and getting new solve that. but it doesn't matter, because it happened only 3-4 times, maybe there was a synchronization or some.

But the problem with the internal memory size is quite real for my friend, he could not fix it and getting back for 17.1 for a while.
 

rayman95

Senior Member
Jan 14, 2009
6,101
3,766
63
monaco
on clean flash, had a strange issue...got my music folder on ext sd replaced by a file with 0 byte, same if I look on computer, but can still read music....but after 2 days, the folder with music come back....don't know why but everything is ok now.o_O
 

r0mushii

Senior Member
Running well so far.
Only issue or a feature request would be miracast support.
I can't say this for sure cause I don't know for sure but I think miracast support is left out because it's proprietary.
it's because miracast has been nuked by google since android 8.x (blame chromecast). most roms still have it but it's not a bulletproof fix and more of a hack and less likely that lineage will add these in the future(people complained about this since los15)
 

Scorpionea

Senior Member
Dec 13, 2013
3,845
2,077
You tell me
Amazing work yet again by all mighty haggertk

Will most definitely install and test new official build pretty soon. Btw one question I have for all, did anyone ever noticed sudden drop in speed via WiFi? Ever since I got new router and default WIFI is 5g and not 2.4 my note 3 (n9005) constantly lose how should I say speed.

Example im watching YouTube in 1080 or 720 and after maybe 1 to 2 hours and it stops buffering and just spinning circle is shown then I need to lower it to 360p to resume. Then I go to download file or browser and it's soon slow. Sometimes reboot fix it sometime don't. I've flashed few latest modems for our device but still the same.

Edit: when I'm on 2,4ghz wifi all is good and even going back to 5ghz after been connected to 2.4 works fine but looses is strength later on.
 
Last edited:

Lahpyrcopa

Member
Jan 27, 2021
43
6
With my SIM card in my phone I notice that texts don't seem to be received unless the screen is on and if the screen is off they are delayed. I don't know if this is a bug or just my phone.
 

kisilmike

Member
Jan 14, 2012
21
3
Amazing work yet again by all mighty haggertk

Will most definitely install and test new official build pretty soon. Btw one question I have for all, did anyone ever noticed sudden drop in speed via WiFi? Ever since I got new router and default WIFI is 5g and not 2.4 my note 3 (n9005) constantly lose how should I say speed.

Example im watching YouTube in 1080 or 720 and after maybe 1 to 2 hours and it stops buffering and just spinning circle is shown then I need to lower it to 360p to resume. Then I go to download file or browser and it's soon slow. Sometimes reboot fix it sometime don't. I've flashed few latest modems for our device but still the same.

Edit: when I'm on 2,4ghz wifi all is good and even going back to 5ghz after been connected to 2.4 works fine but looses is strength later on.
My wifi 5ghz always on and sometimes i transmit big data form/to PC, for example 5GB photo or more and speed is always 7-20 megabyte/s, no any disconnects or low speed detected. It is on 17.1 and 18.1 too.

I suspect that the problem is in the router, some routers are overheating or their memory is full. Try restarting your router when you got low speed
 
  • Like
Reactions: Scorpionea

Lahpyrcopa

Member
Jan 27, 2021
43
6
My wifi 5ghz always on and sometimes i transmit big data form/to PC, for example 5GB photo or more and speed is always 7-20 megabyte/s, no any disconnects or low speed detected. It is on 17.1 and 18.1 too.

I suspect that the problem is in the router, some routers are overheating or their memory is full. Try restarting your router when you got low speed
You could also disable unnecessary settings in the router that just slow it down.
 

kisilmike

Member
Jan 14, 2012
21
3
I have a problem with screen orientation. Previously, at 17 everything worked well, but last 3 updates came and next time sometimes the screen began to display the wrong orientation. Then I setup 18 in the hope of solve the problem and first 4 days everything worked well. But today it suddenly stopped working. Rebooting didn't help. I have attached 2 screenshots from other app. Acceleromer always show action but phone is not moving. Magnetic is changes depending on device position correctly.
 

Attachments

  • photo_2021-04-28_08-50-15.jpg
    photo_2021-04-28_08-50-15.jpg
    56.9 KB · Views: 89
  • photo_2021-04-28_08-41-15v3.jpg
    photo_2021-04-28_08-41-15v3.jpg
    209.2 KB · Views: 88
Last edited:

Scorpionea

Senior Member
Dec 13, 2013
3,845
2,077
You tell me
My wifi 5ghz always on and sometimes i transmit big data form/to PC, for example 5GB photo or more and speed is always 7-20 megabyte/s, no any disconnects or low speed detected. It is on 17.1 and 18.1 too.

I suspect that the problem is in the router, some routers are overheating or their memory is full. Try restarting your router when you got low speed
Thx for replay

My router is fine,all other phones works just fine on 5ghz. Since im the only one who have ever reported something like this on 17.1 or 18.1 thread it must be router that has difficult time with my note 3. I could disable 5ghz and stick with 2.4ghz as for a phone its no big problem.

btw can u tell my your bootloader and modem version? cheera
 

kisilmike

Member
Jan 14, 2012
21
3
Thx for replay

My router is fine,all other phones works just fine on 5ghz. Since im the only one who have ever reported something like this on 17.1 or 18.1 thread it must be router that has difficult time with my note 3. I could disable 5ghz and stick with 2.4ghz as for a phone its no big problem.

btw can u tell my your bootloader and modem version? cheera

there is routers with dual band transmitter simultaneously: 2.4 and 5 it is very comfortably.

bootloader N9005XXUGBOK6
radio N9005XXUGPQB1
latest TWRP
 
  • Like
Reactions: Scorpionea

r0mushii

Senior Member
Does QC working on hlte?
in short: yes

in long: all aosp-based roms can charge up to 1800mA max (compared to 1200mA on stock iirc). you can check the input current using battery monitoring apps like amplify or batteryguru
if it doesn't go 1800 max, check your wall adapter(charger) if it's capable of at least 5V-2A output and/or your cable/charging port if it's damaged or not(or in the case of the cable, if it can deliver that amount of current or not)

p.s. i've also read your reply on the abandoned havoc thread so i decided to explain it here instead
 

Top Liked Posts

  • 1
    does this may work on "International 3G" ha3g version or it is impossible ?
    never. ha3g threads are over here
  • 4
    Interesting you say that as i had some crackling on the old baseband i was running although i've never really looked into it...

    I've just tested on baseband: N9005XXUGBOJ1 with no issues to report :)
    Well, thanks!
    That's great sharing this with us, very weird of baseband to cause that sound crackling. I'm going to upgrade my baseband to see if it is going to solve this bug.
    EDIT: Flashed Nordic Countries baseband solved the issue! Thanks man!
    I'm currently using RL1 bootloader (from latest EGY firmware) and QB1 baseband (from latest Nordic Countries firmware).
    They're the recommended ones from baseband and bootloader topic on general forum because they are the most
    updated ones till now. (FOR "N9005" MODEL ONLY, ALSO KNOWN AS "hlte")

    PS: for anyone who want to flash the bootloader and baseband I mentioned above, I've uploaded them again on the
    general forum thread for bootloader and baseband discussion in a reply, as all links in the post are dead.
    (FOR "N9005" MODEL ONLY, ALSO KNOWN AS "hlte")
    You can find them here: https://forum.xda-developers.com/t/...g-firmware-for-sm-n9005.3582504/post-85128029
    2
    Hi. I am stunned to learn that SM-N9005 is supported by Lineage OS 18.1. I have not touched my N9005 for years and was thinking of getting rid of it. I have not tinkered with custom OSes in recent years, but if Lineage OS 18.1 works on it, then it may be worth reviving.

    Now, probably the answer is no, but this ROM does not support S-Pen... correct? I would just like to draw some sketches on this device.

    If the answer is indeed no, could someone recommend a ROM that supports S-Pen?

    Thanks!
    Well, the pen itself works but the main concern is samsung apps related to spen cannot be installed on lineage.
    any third party apps should work, though.
    1
    you have to update to last modem and bootloader....
    May I suggest to add a hint to the first post (@haggertk) at the Installation Instructions: section, that you have to use a specific BL/CP (though people tend to not read or follow any instructions ;))
    1
    you have to update to last modem and bootloader....
    Thanks for the quick reply.

    After checking the bootloader and modem version it appears i've never updated the firmware since purchasing the device back in 2014.

    I was unable to find pre-compiled packages on the forum so i decided to extract the files from a Sam Mobile image.

    My old versions:
    Bootloader: N9005XXUEND3 - Mon, 14 Apr 2014)
    Modem: N9005XXUENC2 - Mon, 14 Apr 2014)

    Latest version from Sam Mobile:
    Bootloader: N9005XXSGBRI2 - Fri, 07 Sep 2018
    Modem: N9005XXUGBOJ1 - Fri, 07 Sep 2018

    Once i extracted the bootloader + modem files i created a couple of archives called bootloader.tar.md5 + modem.tar.md5

    bootloader.tar.md5
    - aboot.mbn
    - rpm.mbn
    - sbl1.mbn
    - sdi.mbn
    - tz.mbn

    modem.tar.md5
    - modem.bin
    - NON-HLOS.bin

    I then proceeded to flash using Odin v3.10 and everything updated successfully.

    After rebooting the phone, i'm pleased to confirm the video recorder is now working correctly :)

    Thank you so much, i really appreciate the support.

    LineageOS 18.1 on a 7 year old phone rocks!!!
    1
    Can anyone confirm sound crackling bug on Nordic countries baseband?
    I'm currently on EGY baseband and bootloader. I don't think it's related to baseband but I heard someone on General forum saying that flashing Nordic countires baseband solved sound issues on lineage roms.
    Steps to reproduce this bug is playing music on background using default music app, then going to settings-sounds, and adjusting notification volume to play a notification sound where then a sound crackling occurs.
    If someone with Nordic countries baseband (or any other baseband) can try this and respond wether bug is happening or not with it, I'd be very thankful. I'm currently have a very little time free and I don't want to mess with the phone without knowing for sure it would fix the bug.
  • 16
    2okPze5.png



    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Device source code:
    Kernel source code:

    Build Compatibility:
    The noted models are the only ones supported. If you have a model that isn't listed and ask politely then I might work to add compatibility.
    BuildModel
    hlteSM-N9005, SM-N900P
    hltechnSM-N9008V
    hltekorSM-N900K, SM-N900L, SM-N900S
    hltetmoSM-N900R4, SM-N900T, SM-N900V, SM-N900W8

    Downloads:
    Installation Instructions:
    Reporting Bugs:
    Compatibility Notes:
    • External SD cards don't support POSIX (ext*, f2fs) or NTFS filesystems anymore. If this affects you then just bite the bullet, copy any data off you really want to save, and reformat as exfat.
    • The latest TWRP does work, but if someone has issues then perhaps try using the actual supported recovery.
    • If you are encrypted, even with insecure boot, you absolutely must format userdata on upgrade, as noted in upgrade instructions in wiki.
      • If you are not encrypted then disable lockscreen before upgrading and it *should* work without wiping userdata.
      • If you didn't disable lockscreen before upgrading then delete the lockscreen files and it *should* work. Use the power of search, I'm not going to help out with this one -- it's an unsupported path.
      • If you get terribly stuck then wipe userdata as our official upgrade guide notes.
    Donations:
    • I absolutely don't personally accept them. If you really feel that this work deserves it, then find a local food bank or animal shelter/rescue and throw some money their way. You can also throw some the way of LineageOS, but we're actually doing pretty well right now.
    4
    Interesting you say that as i had some crackling on the old baseband i was running although i've never really looked into it...

    I've just tested on baseband: N9005XXUGBOJ1 with no issues to report :)
    Well, thanks!
    That's great sharing this with us, very weird of baseband to cause that sound crackling. I'm going to upgrade my baseband to see if it is going to solve this bug.
    EDIT: Flashed Nordic Countries baseband solved the issue! Thanks man!
    I'm currently using RL1 bootloader (from latest EGY firmware) and QB1 baseband (from latest Nordic Countries firmware).
    They're the recommended ones from baseband and bootloader topic on general forum because they are the most
    updated ones till now. (FOR "N9005" MODEL ONLY, ALSO KNOWN AS "hlte")

    PS: for anyone who want to flash the bootloader and baseband I mentioned above, I've uploaded them again on the
    general forum thread for bootloader and baseband discussion in a reply, as all links in the post are dead.
    (FOR "N9005" MODEL ONLY, ALSO KNOWN AS "hlte")
    You can find them here: https://forum.xda-developers.com/t/...g-firmware-for-sm-n9005.3582504/post-85128029
    3
    Anyone else facing when there's music playing and a notification sound comes, comes some noise from the speaker?
    3
    installed and have to say WOW this rom seems not only stable but smoother than los 17.1 for me everything works well my only complaint is for spen still not blocking touch inputs when use and have less priority than finger touch, but aside that I think Is perfect for daily use.
    device n900w8, install with twrp, los 18.1 mindthegapps and magisk
    2
    Does QC working on hlte?
    in short: yes

    in long: all aosp-based roms can charge up to 1800mA max (compared to 1200mA on stock iirc). you can check the input current using battery monitoring apps like amplify or batteryguru
    if it doesn't go 1800 max, check your wall adapter(charger) if it's capable of at least 5V-2A output and/or your cable/charging port if it's damaged or not(or in the case of the cable, if it can deliver that amount of current or not)

    p.s. i've also read your reply on the abandoned havoc thread so i decided to explain it here instead