• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][11] LineageOS 18.1 for Samsung Galaxy Note 3 (hlte*)

Search This thread

asassello

Senior Member
Nov 18, 2008
54
11
Samsung Galaxy Note 3
Hi.
Could you please tell me what's the last version of compilation?
I have that one (after update from 26 Jun 2021):
lineage_hlte-userdebug 11 RQ3A.210605.005 d117211f4f

I suspect that maybe it's not updating properly? Last version has this bug with clock icon in status bar fixed. And my icon is still not corrected even after update (updater says that I'm up to date).

Edit:
Answering myself. It's just the number of the compilation 210605, but version is ok
 
Last edited:

slipstreamer88

Senior Member
Dec 20, 2018
50
31
My config is hltetmo, LOS 18.1 20210617 build, mindtheGapps, and Magisk 23(using only the systemless host module)

My temperature and humidity sensor don't work when using this Galaxy Sensor app. Is there any workaround or solution for this?
 

Attachments

  • Screenshot_20210627-014821_Galaxy_Sensors.png
    Screenshot_20210627-014821_Galaxy_Sensors.png
    80.4 KB · Views: 22

Hassan 4

Senior Member
Apr 6, 2013
353
142
My config is hltetmo, LOS 18.1 20210617 build, mindtheGapps, and Magisk 23(using only the systemless host module)

My temperature and humidity sensor don't work when using this Galaxy Sensor app. Is there any workaround or solution for this?
Happens to me also, a simple reboot makes them work again. It happens every week or two.
 

Reutertu3

Member
Apr 16, 2016
7
0
Updating to the latest release (2021-06-26) resulted in a bootloop, which was fixable by re-flashing GApps. Not sure if it's a MindTheGApps related issue.
 

Fredfj

Member
Oct 2, 2019
7
0
Can't use NFC.
I installed LineageOS 18.1 some days ago on my Samsung note 3 LTE N9005. After that I can't use NFC anymore. Is there a solution to solve this?
NFC is needed in some apps to scan my drive licence or passport.
 
Last edited:

stevelazer

Member
Jun 27, 2019
6
1
I just love this rom! Smooth, quick, refined, intuitive.

It's my all time favorite and I'm bummed out that I can't continue to use it. After test driving it for a month or so, I have experienced random reboots every day or two, often at the worst time - in the middle of a phone call, composing a long text message which then vaporizes, looking up information needed quickly. I have not installed Magisk or rooted the phone. It was a fresh install onto a wiped phone.

I've read about others having similar random reboot problems, and there doesn't appear to be a fix. A real shame...
Success! Random reboot problem solved. I initially used TWRP recovery to install this rom and gapps, which appears to have caused the intermittent random reboot issue. Reinstalled with Lineage recovery, rom is solid, smooth and never reboots. Many thanks for this fantastic rom! My sm-n900p had never run better and is now a real pleasure to use.
 

drdxda

Member
Aug 22, 2020
7
0
Cannot send SMS

I am able to receive messages but cannot send any. Checked everyhing with the carrier settings. Happened also on earlier Lineage versions. Everytime I try to send a message, I get "Error 0"
 

ModiGrey

New member
Nov 12, 2018
1
1
Sprint Samsung Galaxy Note 3
Hi, today I flashed the latest nightly build of this great ROM on my note 3 (SM-N900P), and everything seems to work amazing, except, when I try to download any app from the Play Store it says that I need to free up space on my storage, but my storage is 85% empty which means there is 27gb free space.

I used nano opengapps. Did anyone have this problem? I need your help as I can't download any apps on my phone using the play store.

EDIT: Also the lineage os camera app and music app are not working.

EDIT 2: Clean Installed the new lineage-18.1-20210717 with latest opengapps and everything worked perfectly.
 
Last edited:
  • Like
Reactions: curiousrom

drdxda

Member
Aug 22, 2020
7
0
When the phone is in use, battery life is good, but last night before I went to sleep I had almost 40%, when I woke up phone was turned off. I plugged in to a charger, Display was showing 0% remaining battery.
I am using a 10W charger (5V, 2A). I am having this issue since~beginning of July.
 

Attachments

  • Screenshot_20210716-082913_Settings.png
    Screenshot_20210716-082913_Settings.png
    141.1 KB · Views: 30
  • Screenshot_20210716-082827_Settings.png
    Screenshot_20210716-082827_Settings.png
    130.5 KB · Views: 32

JRSmit

New member
Jun 19, 2021
3
2
Thanks for the quick response. Strange bug, it was crashing the UI as I mentioned even after installing the latest nightly, but once I reordered the buttons the bug disappeared. This may be useful to someone at some point.

Thanks for the heads up on the OBB problem. It seems it this security feature that has been causing me my headaches with the few applications that aren't able to install.
I have installed the newly released openGapps and my obb problems have gone away. Seems that mindthegapps didn't get the android 11 security right.

On the other issue as mentioned by others here it seems to be a regression of the no-security used bug. For me a decent workaround is just using swipe to unlock.
 
  • Like
Reactions: kisilmike

stevelazer

Member
Jun 27, 2019
6
1
Something has changed for the worse in a recent update of this rom. Phone now heats up even during light use and battery life has become terrible. Stats show Android System using 43% of battery. Happening on two different phones running 18.1. Just typing this has caused a 3% reduction. Has anyone else noticed this change in heat and battery life?
 
  • Like
Reactions: Seraphim401

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Why is WiFi Direct disabled in Android 11?
    Is this a problem with the ROM or can something be done to fix it?
    It is not disabled, it is just new Android 11 permissions. You have to turn on location to use WiFi direct.
    1
    Just want to say THANK YOU that you still maintain this device :) Keep rockin'!
  • 22
    2okPze5.png



    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Device source code:
    Kernel source code:

    Build Compatibility:
    The noted models are the only ones supported. If you have a model that isn't listed and ask politely then I might work to add compatibility.
    BuildModel
    hlteSM-N9005, SM-N900P
    hltechnSM-N9008V
    hltekorSM-N900K, SM-N900L, SM-N900S
    hltetmoSM-N900R4, SM-N900T, SM-N900V, SM-N900W8

    Downloads:
    Installation Instructions:
    Reporting Bugs:
    Compatibility Notes:
    • External SD cards don't support POSIX (ext*, f2fs) or NTFS filesystems anymore. If this affects you then just bite the bullet, copy any data off you really want to save, and reformat as exfat.
    • The latest TWRP does work, but if someone has issues then perhaps try using the actual supported recovery.
    • If you are encrypted, even with insecure boot, you absolutely must format userdata on upgrade, as noted in upgrade instructions in wiki.
      • If you are not encrypted then disable lockscreen before upgrading and it *should* work without wiping userdata.
      • If you didn't disable lockscreen before upgrading then delete the lockscreen files and it *should* work. Use the power of search, I'm not going to help out with this one -- it's an unsupported path.
      • If you get terribly stuck then wipe userdata as our official upgrade guide notes.
    Donations:
    • I absolutely don't personally accept them. If you really feel that this work deserves it, then find a local food bank or animal shelter/rescue and throw some money their way. You can also throw some the way of LineageOS, but we're actually doing pretty well right now.
    5
    Interesting you say that as i had some crackling on the old baseband i was running although i've never really looked into it...

    I've just tested on baseband: N9005XXUGBOJ1 with no issues to report :)
    Well, thanks!
    That's great sharing this with us, very weird of baseband to cause that sound crackling. I'm going to upgrade my baseband to see if it is going to solve this bug.
    EDIT: Flashed Nordic Countries baseband solved the issue! Thanks man!
    I'm currently using RL1 bootloader (from latest EGY firmware) and QB1 baseband (from latest Nordic Countries firmware).
    They're the recommended ones from baseband and bootloader topic on general forum because they are the most
    updated ones till now. (FOR "N9005" MODEL ONLY, ALSO KNOWN AS "hlte")

    PS: for anyone who want to flash the bootloader and baseband I mentioned above, I've uploaded them again on the
    general forum thread for bootloader and baseband discussion in a reply, as all links in the post are dead.
    (FOR "N9005" MODEL ONLY, ALSO KNOWN AS "hlte")
    You can find them here: https://forum.xda-developers.com/t/...g-firmware-for-sm-n9005.3582504/post-85128029
    4
    installed and have to say WOW this rom seems not only stable but smoother than los 17.1 for me everything works well my only complaint is for spen still not blocking touch inputs when use and have less priority than finger touch, but aside that I think Is perfect for daily use.
    device n900w8, install with twrp, los 18.1 mindthegapps and magisk
    3
    Hello guys. This is my first time dealing with modifying my phone and I don't have any past experiences. I even made this account just to post this reply. So, please bear with me :(

    I've been following the instructions here https://wiki.lineageos.org/devices/hlte/install and had problems with flashing the recovery with heimdall, it kept giving me this error:
    Code:
    ERROR: Failed to confirm end of file transfer sequence!
    ERROR: RECOVERY upload failed!
    I googled it and found that other users have had the same error https://github.com/Benjamin-Dobell/Heimdall/issues/191# but found no solution. I tried a different USB port and cable, still didn't work.

    I assumed that this is some heimdall issue and tried flashing directly with adb by following these steps https://www.xda-developers.com/how-to-install-twrp/ but this time I got "waiting for any device" although my phone appears when typing the command "adb devices"
    Googling told me that this is some sort of a driver issue. Maybe has something to do with zadig.exe (that came with heimdall) and the whole driver replacing process?

    Now I'm stuck between these two problems, and I don't know what to do. Is there other ways to flash the recovery? Or what can I do to fix the problem with drivers?
    Any help would be much appreciated.
    Use odin to flash twrp.tar available from their official website, then download lineage zip from lineage website and place on sd card and download mindthegapps "search for lineage gapps you'll find links on their wiki", and finally boot to recovery to install lineage and gapps packages.
    3
    Does QC working on hlte?
    in short: yes

    in long: all aosp-based roms can charge up to 1800mA max (compared to 1200mA on stock iirc). you can check the input current using battery monitoring apps like amplify or batteryguru
    if it doesn't go 1800 max, check your wall adapter(charger) if it's capable of at least 5V-2A output and/or your cable/charging port if it's damaged or not(or in the case of the cable, if it can deliver that amount of current or not)

    p.s. i've also read your reply on the abandoned havoc thread so i decided to explain it here instead