• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.
  • If you are experiencing issues logging in, we moved to a new and more secure software and older account passwords were not able to be migrated. We recommend trying to reset your password, then contacting us if there are issues.

[ROM]-[OFFICIAL]-[17-08-2020] HAVOC-OS-v3.8 TEN [10.0]-[SANDERS]

User Sid

New member
Sep 17, 2016
60
15
0
24
New Delhi
Just facing one issue Bluetooth Connectivity is little bit less My Bluetooth headset supports range up to 10m but in this Rom it is up to 5m only and after that, I lost my connection. Otherwise, The Rom is Awesome, Smooth and working flawlessly.
Please increase Bluetooth connectivity in future updates.
Thank you
 

Vaibhav_Khulbe

New member
Nov 18, 2016
21
3
0
Ghaziabad
I'm not able to do these in the latest build:

1. Not able to enable gesture navigation. Gives an alert saying "Pixel Launcher has crashed".
2. Not able to hide the navigation bar. I want to use fingerprint navigation.
3. Unable to install apps like Snapchat, Twitter. It downloads completely but is stuck on "Installing..." Sometimes it doesn't even downloads.

How can I fix these issues?
 

tierniss

New member
Mar 2, 2018
94
27
0
La Plata
I'm not able to do these in the latest build:

1. Not able to enable gesture navigation. Gives an alert saying "Pixel Launcher has crashed".
2. Not able to hide the navigation bar. I want to use fingerprint navigation.
3. Unable to install apps like Snapchat, Twitter. It downloads completely but is stuck on "Installing..." Sometimes it doesn't even downloads.

How can I fix these issues?
Referencing to issue #1 and #3, upload a logcat please
 
Did you do a clean install ?
In order to hide navbar, enable gestures navigation and in its settimgs choose minimal sensitivity and the navbar disappears (worked for me).
Hope this helps.
About the other issues, did you root your phone with Magisk ?
If so, try Magisk Hide for those.
Good luck !

---------- Post added at 04:23 PM ---------- Previous post was at 04:18 PM ----------

Please Master Ronax, FP unlock after first boot... Please !!!:D
 

trevor_akshay

New member
Oct 10, 2019
105
80
0
Trichy
github.com
I'm not able to do these in the latest build:

1. Not able to enable gesture navigation. Gives an alert saying "Pixel Launcher has crashed".
2. Not able to hide the navigation bar. I want to use fingerprint navigation.
3. Unable to install apps like Snapchat, Twitter. It downloads completely but is stuck on "Installing..." Sometimes it doesn't even downloads.

How can I fix these issues?
Regarding your issues here are the fix

1 .do a clean flash it will fix it

2.you need to be rooted to do this ..once rooted either go to build prop in system and paste this line "qemu.hw.mainkeys = 1"
Or
You need magisk ..download immersive gesture navigation from magisk repo and your good to go

3.for this its pretty easy just clear data and cache of play store and clear cache of google play services .reboot this will fix it..i believe dirty flashing leads to this bug..

Good luck
 
@ronaxdevil

Hello Master, is bugged, is not working the direct button, which shows the recent, this is present in the last build of 2019 -12-09

Enviado de meu sanders usando o Tapatalk
Hi Master Jadilson12 . I know your great work with Roms for our device, it's great that you are a brazilian like me.
I just want to let you know that i did not face this bug. I will not recomend anything to you since i'm a just a noob and you are a Master ;
Maybe doing a clean flash again ?
 

Vaibhav_Khulbe

New member
Nov 18, 2016
21
3
0
Ghaziabad
Did you do a clean install ?
In order to hide navbar, enable gestures navigation and in its settimgs choose minimal sensitivity and the navbar disappears (worked for me).
Hope this helps.
About the other issues, did you root your phone with Magisk ?
If so, try Magisk Hide for those.
Good luck !

---------- Post added at 04:23 PM ---------- Previous post was at 04:18 PM ----------

Please Master Ronax, FP unlock after first boot... Please !!!:D
[SOLVED] Hi Padre,

I can't select gesture navigation, whenever I do that, it says "Pixel Launcher keeps stopping" and I have to go back to other options. I will try other solutions as suggested here.


Thanks!

---------- Post added at 01:47 PM ---------- Previous post was at 01:18 PM ----------

Regarding your issues here are the fix

1 .do a clean flash it will fix it

2.you need to be rooted to do this ..once rooted either go to build prop in system and paste this line "qemu.hw.mainkeys = 1"
Or
You need magisk ..download immersive gesture navigation from magisk repo and your good to go

3.for this its pretty easy just clear data and cache of play store and clear cache of google play services .reboot this will fix it..i believe dirty flashing leads to this bug..

Good luck
How to do a clean install of Havoc OS? I did the steps listed here under "Steps to install".
 
Last edited:

Vaibhav_Khulbe

New member
Nov 18, 2016
21
3
0
Ghaziabad
Regarding your issues here are the fix

1 .do a clean flash it will fix it

2.you need to be rooted to do this ..once rooted either go to build prop in system and paste this line "qemu.hw.mainkeys = 1"
Or
You need magisk ..download immersive gesture navigation from magisk repo and your good to go

3.for this its pretty easy just clear data and cache of play store and clear cache of google play services .reboot this will fix it..i believe dirty flashing leads to this bug..

Good luck
Above issues are fixed but the app installation one still remains. I reinstalled latest Havoc rom and chose to backup my app via tha initial Google setup. It installs all the apps but now two apps aren't installed - Spotify and Snapchat. For Spotify it remains on "Waiting for download" and for Snapchat it downloads til 95% then stops. I have done that clear data and cache of Google Play and Play Services and rebooted it. Also, did a clean flash (by factory reset).

Thanks.
 

trevor_akshay

New member
Oct 10, 2019
105
80
0
Trichy
github.com
Above issues are fixed but the app installation one still remains. I reinstalled latest Havoc rom and chose to backup my app via tha initial Google setup. It installs all the apps but now two apps aren't installed - Spotify and Snapchat. For Spotify it remains on "Waiting for download" and for Snapchat it downloads til 95% then stops. I have done that clear data and cache of Google Play and Play Services and rebooted it. Also, did a clean flash (by factory reset).

Thanks.
Use Bitgapps which is much suited for havocos if already using bitgapps then download those app from apkmirror and wait for ronax dude or someone else to provide the fix
 
  • Like
Reactions: Vaibhav_Khulbe

g0ms!

New member
Jan 19, 2019
8
0
0
Hi I just clean installed the ROM & am unable to remove "Device HD capable" and remove some redundant apps which are not working in India. Is this by default,or some error in installing.

---------- Post added at 04:34 PM ---------- Previous post was at 04:31 PM ----------

FACE UNLOCK IN 9/12/2019 version????
its disabled by Google
 
Last edited:

Sam1112

New member
Dec 3, 2019
11
0
0
Hi I just clean installed the ROM & am unable to remove "Device HD capable" and remove some redundant apps which are not working in India. Is this by default,or some error in installing.

---------- Post added at 04:34 PM ---------- Previous post was at 04:31 PM ----------


its disabled by Google
Ik bro but I believe that the devs can do it. Good luck devs!!!
 

@sur

New member
Nov 29, 2019
8
0
0
Magisk ERROR :1

Using Havoc since a week, Its GOOD, but

unable to flash Magisk.

Tried Magisk 20.0 and 20.1 Versions.

Tried TWRP 3.2.1-r16 and r20.

Saying " Cannot mount /Vendor "

ERROR : 1

---------- Post added at 06:39 AM ---------- Previous post was at 06:35 AM ----------

Using Havoc since a week, Its GOOD, but

unable to flash Magisk.

Tried Magisk 20.0 and 20.1 Versions.

Tried TWRP 3.2.1-r16 and r20.

Saying " Cannot mount /Vendor "

ERROR : 1
here is the log ;

************************
* Magisk v20.1 Installer
************************
- Mounting system
- Mounting vendor
mount: can't find /vendor in /etc/fstab
! Cannot mount /vendor
- Unmounting partitions
Updater process ended with ERROR: 1
I:Install took 1 second(s).
Error installing zip file '/sdcard/Magisk-v20.1.zip'
Updating partition details...
I:Data backup size is 50MB, free: 52647MB.
I:Unable to mount '/external_sd'
I:Actual block device: '', current file system: 'auto'
I:Unable to mount '/usb-otg'
I:Actual block device: '', current file system: 'auto'
...done
 

trevor_akshay

New member
Oct 10, 2019
105
80
0
Trichy
github.com
Using Havoc since a week, Its GOOD, but

unable to flash Magisk.

Tried Magisk 20.0 and 20.1 Versions.

Tried TWRP 3.2.1-r16 and r20.

Saying " Cannot mount /Vendor "

ERROR : 1

---------- Post added at 06:39 AM ---------- Previous post was at 06:35 AM ----------



here is the log ;

************************
* Magisk v20.1 Installer
************************
- Mounting system
- Mounting vendor
mount: can't find /vendor in /etc/fstab
! Cannot mount /vendor
- Unmounting partitions
Updater process ended with ERROR: 1
I:Install took 1 second(s).
Error installing zip file '/sdcard/Magisk-v20.1.zip'
Updating partition details...
I:Data backup size is 50MB, free: 52647MB.
I:Unable to mount '/external_sd'
I:Actual block device: '', current file system: 'auto'
I:Unable to mount '/usb-otg'
I:Actual block device: '', current file system: 'auto'
...done
Use batik recovery latest version this wil fix the issue
Good luck

---------- Post added at 02:28 PM ---------- Previous post was at 02:27 PM ----------

Ik bro but I believe that the devs can do it. Good luck devs!!!
Bro hd capable cant be removed..it means android supports volte
 

Sam1112

New member
Dec 3, 2019
11
0
0
Use batik recovery latest version this wil fix the issue
Good luck

---------- Post added at 02:28 PM ---------- Previous post was at 02:27 PM ----------


Bro hd capable cant be removed..it means android supports volte
I think you understood it wrong, I was talking about your comment on face unlock:good:
 

@sur

New member
Nov 29, 2019
8
0
0
System app remover

Tried Few System App Removers without any luck,

Those apps are working on Stock ROM, Arrow etc.

Whats Your Suggestion for System app removal ??

and Digital TV app crashing, Will it work on XT1804 INDIA ??
 

trevor_akshay

New member
Oct 10, 2019
105
80
0
Trichy
github.com
Tried Few System App Removers without any luck,

Those apps are working on Stock ROM, Arrow etc.

Whats Your Suggestion for System app removal ??

and Digital TV app crashing, Will it work on XT1804 INDIA ??
System app remover wont work as android 10 is system as root..but there r two methods

1.use magisk module debloater and terminal to debloat

2 use file manager and delete the apps from system to remove them manually

Using method 2 is quite risky look after that

Good luck