[ROM][Official][5.0.2] CyanogenMod 12

AntaresOne

Recognized Developer
Sep 30, 2013
2,205
17,619
0
27
Chieti, Italy
www.antaresone.eu


CyanogenMod is a free, community built, aftermarket firmware distribution of Android 5.0.2 (Lollipop), which is designed to increase performance and reliability over stock Android for your device.​

Code:
#include <std_disclaimer.h>

/*
 * Your warranty is now void.
 *
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
 *
 */
CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). CyanogenMod does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for CyanogenMod is available in the CyanogenMod Github repo. And if you would like to contribute to CyanogenMod, please visit our Gerrit Code Review. Your changelog is whatever was merged into gerrit.

Official CyanogenMod Wiki:http://wiki.cyanogenmod.org/w/Main_Page


Important information:
This thread is for CyanogenMod 12.0 builds for jfltexx (GT-I9505). The following will not be supported here:
  • Custom kernels
  • Mods
  • Xposed

We don't support Xposed and any logcat which includes a Xposed module will be ignored. You're kindly invited to not report bugs if you:
  • Flashed a custom kernel
  • Installed or did mods from untrusted sources
  • Modified system files


Installation

First time flashing CyanogenMod 12.0 on your device, or coming from another ROM?
  • Download the zip(s)
  • Install a compatible Recovery
  • Perform a nandroid backup of your current ROM (Optional)
  • Wipe data/factory reset
  • Flash CyanogenMod
  • Optional: Install the Google Apps addon package
  • Reboot


Useful links
Unofficial jfltexx changelog
CyanogenMod Wiki jfltexx
Jira issue tracker - don't report bugs for nightly builds!


Other issues?
Before posting in this thread, make sure of a few things:

  • You used the search function of the forums.
  • If you are the only one having a problem. Boot into recovery, wipe data/factory reset, reflash the rom/gapps and nothing else. Boot up and see if the problem persists.
  • Make sure your post is relevant to this thread.
  • Logs! You can use this: https://play.google.com/store/apps/details?id=com.tortel.syslog


Downloads

CyanogenMod:
http://download.cyanogenmod.org/?device=jfltexx
We have de-unified the Galaxy S4 line. Too many issues with having them all in one and a maintainer's nightmare. Look for jfltexx builds now as opposed to the jflte builds you previously used.

Google Apps:
https://basketbuild.com/filedl/gapps?dl=gapps-lp-20150222-signed.zip

The CyanogenMod team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!


XDA:DevDB Information
Official CyanogenMod 12.0 builds for the Qualcomm Intl Galaxy S4, ROM for the Samsung Galaxy S 4

Contributors
AntaresOne
Source Code: https://github.com/CyanogenMod/android_kernel_samsung_jf/tree/cm-12.0

ROM OS Version: 5.0.x Lollipop
ROM Kernel: Linux 3.4.x

Version Information
Status: Stable
Stable Release Date: 2015-04-20

Created 2015-01-11
Last Updated 2015-06-04
 

themetatron

Senior Member
Oct 29, 2009
317
42
58
39
SLOcala, FL
Tried clean flash of jfltexx cm12 to 9505G. Using twrp 2.8.3.0 for jgedlte, ext4. Getting "E: error executing binary updater in zip" then "E: unable to mount /system." CM11 was able to flash jfltexx to jgedlte, guess this isn't true for CM12?
 
  • Like
Reactions: CaptShaft

Soufiansky

Senior Member
Dec 12, 2014
4,050
1,626
0
Thank you so much @AntaresOne , i'm sooo happy really , you deserve this after all you hard work on your rom ( without forgetting the team and alucard ;) )


Sent from my GT-I9505 using XDA Free mobile app
 

robygt

Senior Member
May 27, 2012
1,040
1,232
153
43
Lecco
Ciao, I've flashed the cm12 nightly but twrp says that my device is jfltecan, I was on cm12 optimized, have I to modify build.prop and then re flash?
Edit: solved changing recovery.
Inviato dal mio Nexus 4 utilizzando Tapatalk
 
Last edited: