[ROM][OFFICIAL][7.1/8.1][A6020] AOKP-ROM - Lenovo Vibe K5/K5 Plus | OMS/Substratum

Search This thread


Senior Member
Sep 18, 2017
The Middle of Nowhere
Okay, I need some help. When I tried to install the ROM using TWRP, it got error 7, so I thought about going back to the stock ROM I was sure it would install. The only problem is: after the wipe I just can't boot into TWRP in ANY WAY. Not even using adb commands.
It's just stuck in the lenovo boot screen.
When I try the buttons it just stays there. When I plug into the computer and type "adb devices" it just shows nothing or "unauthorized".
Only when I power down, put it into the PC's USB to charge and then turn it on it appears on "adb devices" as "device".
But when I type "adb reboot bootloader" (or recovery) it justs restarts on the same screen and vanishes from adb.
If I just wait a little, it resets and goes "unauthorized".

I've searched EVERYWHERE on the internet how to fix this thing. I know I've wiped the system, cache, dalvik, data, etc, but I made a backup with TWRP on my SD Card BEFORE doing it, if I can access it I can backup or just install the stock ROM.
I also didn't do anything to TWRP itself, so there must be a way to boot into it.
I can’t even fastboot it again since the device isn’t recognized.
I’ve tried updating drivers on my Windows 10 but that doesn’t seem to be the issue here.
Please, if anyone can offer some help, I've exhausted my knowledge here. Without being able to use adb I'm stuck.
My K5 is A6020l36, btw.

Sent from my Lenovo Vibe K5 using XDA Labs
  • Like
Reactions: walterfuster


Senior Member
May 10, 2016
Hi, walterfuster and thanks for the info. Have you installed "BusyBox"? And if yes, which one?

With the default pre installed magisk busybox you are done to lkt works. Osmosis busybox module is needed for accessing to profiles selecting menu from terminal, wich no sense cause there's no another profile available for us other than the balanced one, yet.

Oh if you want tagg me, you have to add @ just before my nick name.

like this: @walterfuster
Last edited:
  • Like
Reactions: frogst


Senior Member
Sep 19, 2012
When switching data SIM, I encountered a weird bug today on "Call with" preference...

Sent from my Vibe K5 Plus using XDA Labs


Senior Member
Sep 19, 2012


  • Screenshot_20190306-092903_Parametres.png
    114.5 KB · Views: 270
  • parameters.png
    114.5 KB · Views: 276
Last edited:


Senior Member
Nov 3, 2012

Clean install all wiped and formatted.
Time to time does not see sim card after reboot.
After boot no sim pin menu, after some time it appears, or sometimes not.
Sometimes I enter pin and menu show - no network only emergency calls.

Problem begin just after installation, with first boot. So I don't think this is physical problem.

Perhaps LTE mode is to blame?
Or some strange behavior where pin menu only appears when network is seen?

This only happens if wi-fi turnedon on the moment of smartphone boot.

So if I turn off wi-fi and then reboot sim will be seen and pin will be asked.

Second issue, after first boot I have no welcome dialog.
Last edited:


Senior Member
Oct 20, 2011
Been using this rom for quite some time with no issues except one plus it's rather nasty too.
Most times receiving a call ,screen remains off and device keeps on ringing and then reboots by itself.
The call does not get registered in call log ,so can't even tell who it was.
So, may it be that this is a known bug or how can i reproduce the error with maybe a logcat ?
I'm thinking most probably, one or two of my apps having conflicts.
Ideas pls...

P.s. Same thing on Lineage Oreo but not on dotOs3.1

Tnx in advance
Last edited:


Senior Member
Mar 18, 2014
please help
was trying to go from android 9 to this rom but after flashing my phone is stuck at bootloop and i am unable to access recovery.

Top Liked Posts

  • There are no posts matching your filters.
  • 72

    Android. Infused with magical unicorn bytes
    The unicorn eats nougat and oreo and farts rainbows :D

    Here is AOKP 7.1/8.1 for the Lenovo Vibe K5/K5 Plus

    - TWRP 3.0.3+ build: Recovery TWRP 3.0.3-n1 for K5
    - You can now use the Official TWRP builds

    How to install:
    From stock
    1. Copy the ROM zip on your phone
    2. Reboot in TWRP Recovery mode
    3. Backup your phone!
    4. Format/Wipe system, cache, dalvik, data
    5. Flash/Install ROM
    6. Flash Install Gapps (OpenGapps ARM64 Mini or smaller is recommanded)
    7. Reboot

    Upgrade from previous build
    1. Copy the ROM zip on your phone
    2. Reboot in TWRP Recovery mode
    3. Format/Wipe only cache, dalvik
    4. Flash/Install ROM
    5. Reboot

    Official Nightly builds Downloads:

    Old Beta builds Downloads:

    XDA:DevDB Information
    [ROM][OFFICIAL][7.1/8.1][A6020] AOKP-ROM - Lenovo Vibe K5/K5 Plus | OMS/Substratum, ROM for the Android General

    Shreps, scritch007
    Source Code: https://github.com/AOKP/device_lenovo_A6020

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: TWRP 3 Recovery
    Based On: AOKP

    Version Information
    Status: Nightly

    Created 2016-11-15
    Last Updated 2018-07-25

    AOKP Gerrit: http://gerrit.aokp.co/#/q/status:merged

    This ROM now implements OMS.

    What is OMS ?
    OMS: (Overlay Manager Service) was designed by google. It's a layer/theme service which is used by Substratum: https://play.google.com/store/apps/details?id=projekt.substratum&hl=fr

    So basically, if you install Substratum, you will be able to apply any theme on the ROM UI because OMS has been implemented.

    For the record, on PAC MM or AOKP MM, they were using CyanogenMod Theme Engine for theming the UI, but since CMTE has not been implemented for Nougat, many choose to use OMS & Substratum instead.

    Screenshot_20161115-114050.png Screenshot_20161115-114031.png

    device-2017-01-03-142534.jpg device-2017-01-03-142552.png device-2017-01-03-142603.png
    AOKP Oreo (8.1) is now official for this device.

    Big thanks again to @Harry8242 and his great development and contribution !

    Hello guys,

    Here we go for Official Nightly builds made by AOKP Buildbot : https://basketbuild.com/devs/aokp/A6020

    Enjoy !
    Finaly I could install this ROM. This is what I found for now. Maybe some of them was already listed, but anyway, there are:

    1. Shotcuts on lock screen desapear from nothing, the top ones or the righ bottom;
    2. Alarm icon and some others desappears after reboot, and after re-enable them appears a blank space at right of battery icon;
    3. Notification led don't turns green when fully charged;
    4. Notification led don't stay lit, it always pulse even if I disable this on settings. I uncheck this, go back, and if I return to this setting, it is re-enabled itself. I have to add personalized led notification to each app I want to keep always lit;
    5. I don't have a warning telling an alarm is next, like PAC-ROM;
    6. "Don't disturb" (or "Do not perturb") keep some sounds even it is enable only priority alarms. As well, the icon for schedule time for "do not perturb" is different for manual "do not perturb" (from the status bar pull down menu): the scheduled is a "plus" sign, the other is a "minus". Can anyone tell the difference or how to have always "minus" scheduled, please?
    7. Some calls still alive after some seconds even when I terminate them;
    8. I use a PIN for lock my phone. If I configure a direct call to lock screen, it dials the number directly, don't asking for PIN. Any other shortcut ask for PIN;
    9. I can't find the icon to change the screen off timer on status bar pull down menu. I have to go to settings to change this timer;
    10. How I can 'centralize' the listings? They always appears at bottom of screen;
    11. Date and time aren't correct after a reboot. I have to keep automatic date and time from network in settings;
    12. After a reboot, battery mode is always at 'balanced', even if I configure to 'performance'.

    Other issues:
    1. I haved to use TWRP R2 instead R4, because R4 shows two 'data' partitions. With this, R4 always returns erros about can't mount or format data;
    2. System is very low in free space, so I used TWRP R2 to backup the whole ROM, and just after I restored it, like sayed before. I gain about 1,2Gb of free space, and can move some user apps to system partition;
    3. There are translation errors, at least for brazilian portuguese: a lot of words are still in English.

    Even with these, the ROM is the best I used until now. Is really fast, camera works fine, and there a lot of options to personalize. Very, very thanks for the ROM.

    I'm using 12-12-2016 build on a L36 variant.

    Thx for this great and detailed feedback.
    I made a new build today, with somes fixes, let me know how it's going:
    * Fixed system and other partitions size, so you should be able to flash micro or mini Gapps for example now.
    * Added the LiveDisplay in the kernel
    * Divided light sensor returned value by 10 this is much much closer to what we get from the Moto G4 Plus sensor
    * xxhdpi density (tks to Dinokin)
    * Tethering should be fixed