• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][7.1] CyanogenMod 14.1 Nightlies for i9300

Status
Not open for further replies.
Search This thread

notstpaul

Senior Member
May 2, 2016
69
43
Redmi Note 9 Pro
OK guys
I've had my sIII for literally 5 years.
It has never seen a better, faster unofficial build than 4.4.4 cyanogenmod. When I say better, I mean, battery life, stability.

Over the years I've tried android 5,6,7 cyan builds but they've never been a fast or responsive.

----cyanogenmods downloads archive for siii is dead as we know.

I'm trying to get hold of the 4.4.2 official cyan build. Is there anywhere we can still get them please?
I've got a couple of old builds from cm11 time. But I don't remember which would be 4.4.2...
 

Attachments

  • Screenshot_2017-08-24-18-52-26.jpg
    Screenshot_2017-08-24-18-52-26.jpg
    203.5 KB · Views: 497

Hamx5

Senior Member
Aug 28, 2015
126
40
OK guys
I've had my sIII for literally 5 years.
It has never seen a better, faster unofficial build than 4.4.4 cyanogenmod. When I say better, I mean, battery life, stability.

Over the years I've tried android 5,6,7 cyan builds but they've never been a fast or responsive.

Totally agree!!!!

My daily driver is Lineage OS 11 which is a custom cyanogenmod 11 build that contains fixes and latest android security patches.

My old galaxy S3 GREAT with that build.

EDIT: If someone is interested: https://forum.xda-developers.com/galaxy-s3/development/cyanogenmod-12-1-t3345690/page1
 
Last edited:

SkEvol

Member
Sep 7, 2012
44
6
Totally agree!!!!

My daily driver is Lineage OS 11 which is a custom cyanogenmod 11 build that contains fixes and latest android security patches.

My old galaxy S3 GREAT with that build.

EDIT: If someone is interested: https://forum.xda-developers.com/galaxy-s3/development/cyanogenmod-12-1-t3345690/page1

That sounds pretty encouraging!
I'll try it out of my current one goes tits up!
Thx!

---------- Post added at 07:10 PM ---------- Previous post was at 07:07 PM ----------

Totally agree!!!!

My daily driver is Lineage OS 11 which is a custom cyanogenmod 11 build that contains fixes and latest android security patches.

My old galaxy S3 GREAT with that build.

EDIT: If someone is interested: https://forum.xda-developers.com/galaxy-s3/development/cyanogenmod-12-1-t3345690/page1

I've got a couple of old builds from cm11 time. But I don't remember which would be 4.4.2...

That's great to know!
I managed to find an old 4.4 version on my old hard drive. It's very close to being that version you've got there with M2 in its name. (I think I have the M4 version of that). I've loaded mine on today and it seems ok so far but thanks for the reply.

Hopefully I won't need to call on you! :)
 

SkEvol

Member
Sep 7, 2012
44
6
I've got a couple of old builds from cm11 time. But I don't remember which would be 4.4.2...

I'm having a massive ball-ache of a time getting my i9300 to act stable. Spent about 5 hours today loading on different combinations of cm, lineageOS, and various OpenGapps zips and I have failed even after 5 hours.

All I'm doing is what I've ever done before:
Using ClockworkModRecovery:
1) wipe dalvik
2) wipe cache
3) wipe data/factory reset (don't quote me on this one/ - I can't remember the exact term. -basically it's the complete nuker which bins the current installed OS)
4) Finally, install a custom room (CM,lineage)

However. After first run, I get a horrific 'system UIDs ' error with the option 'im feeling lucky'. -its the only option it gives you. It suggests that you wipe your 'data partition '. (Which I take it to.mean 'wipe cache') to stop the error occuring again.

I clear that error, then I get recurring 'proces has stopped ~ com.google.play or something along those lines.

-i find it strange, because as far as I'm aware, the CM11 (in fact doesn't this to for all CM builds?) includes no Google apps at all. So where is my OS finding any reference to Google Play from? (unless I misunderstand it and CM has some very small amount of Play services built into it from the get go).

With that recurring message, its very crippled and I can hardly navigate anywhere to even approach trying to fix something.

I'm not sure why I get this system UIDs message to be honest, it never used to happen. And my reinstall method is the same as it ever was. I would have thought that the 3 steps I took above (1,2,3) would be enough to nuke any trace of Google anything. A web search suggested I try an app called ROM TOOLFIX from the play store. Or course, I couldn't access the play store as i hadnt installed gapps yet!

So I downloaded an apk on my laptop, attempted to copy it to my i9300 over usb, but because the install was so broken, it wouldn't show up in my windows explorer. Next step, I tried sending it to my Gmail and Google drive. But the fail to start on the phone as well because the play service is so.broken!

I then tried to copy it to my usb stick, plug that onto.my phone, use FILES app (CM) to find the file and install it but hey presto FILES is limited to internal storage only and couldn't access my extra microSD card!! (or usb stick)

All kinds of hell going on here!!

so.in the end I was pretty eff'd and I had to give up.

It's boiling my p*ss to put it lightly!

I would very very much appreciate access to.any CM builds you have available at this point!! Thanks for reading!

:-O
 
  • Like
Reactions: Hamx5

Simon_29

Senior Member
May 22, 2015
243
121
Hamm
I'm having a massive ball-ache of a time getting my i9300 to act stable. Spent about 5 hours today loading on different combinations of cm, lineageOS, and various OpenGapps zips and I have failed even after 5 hours.

All I'm doing is what I've ever done before:
Using ClockworkModRecovery:
1) wipe dalvik
2) wipe cache
3) wipe data/factory reset (don't quote me on this one/ - I can't remember the exact term. -basically it's the complete nuker which bins the current installed OS)
4) Finally, install a custom room (CM,lineage)

However. After first run, I get a horrific 'system UIDs ' error with the option 'im feeling lucky'. -its the only option it gives you. It suggests that you wipe your 'data partition '. (Which I take it to.mean 'wipe cache') to stop the error occuring again.

I clear that error, then I get recurring 'proces has stopped ~ com.google.play or something along those lines.

-i find it strange, because as far as I'm aware, the CM11 (in fact doesn't this to for all CM builds?) includes no Google apps at all. So where is my OS finding any reference to Google Play from? (unless I misunderstand it and CM has some very small amount of Play services built into it from the get go).

With that recurring message, its very crippled and I can hardly navigate anywhere to even approach trying to fix something.

I'm not sure why I get this system UIDs message to be honest, it never used to happen. And my reinstall method is the same as it ever was. I would have thought that the 3 steps I took above (1,2,3) would be enough to nuke any trace of Google anything. A web search suggested I try an app called ROM TOOLFIX from the play store. Or course, I couldn't access the play store as i hadnt installed gapps yet!

So I downloaded an apk on my laptop, attempted to copy it to my i9300 over usb, but because the install was so broken, it wouldn't show up in my windows explorer. Next step, I tried sending it to my Gmail and Google drive. But the fail to start on the phone as well because the play service is so.broken!

I then tried to copy it to my usb stick, plug that onto.my phone, use FILES app (CM) to find the file and install it but hey presto FILES is limited to internal storage only and couldn't access my extra microSD card!! (or usb stick)

All kinds of hell going on here!!

so.in the end I was pretty eff'd and I had to give up.

It's boiling my p*ss to put it lightly!

I would very very much appreciate access to.any CM builds you have available at this point!! Thanks for reading!

:-O
Like eriol1 said use twrp recovery. For gapps (google apps) go to opengapps.org and select the right version. After installing twrp do a factory reset and install the lineage rom and then the gapps. For root you need a extra zip.
 

AdnanShah

New member
Mar 18, 2018
4
0
Stuck in bootloop

my phone stucked in boot loop when ever i install(flash) any custom rom on my Samsung GT-i9300 using TWRP recovery. I also do factory reset (wipe cache etc) before and after installation and read alot of ways/pages here on XDA developers but didn't solve the issue. Please help me.
 

Hamx5

Senior Member
Aug 28, 2015
126
40
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 314
    250px-CyanogenMod_logo.svg.png

    CyanogenMod is a free, community built, aftermarket firmware distribution of Android 7.1 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

    Code:
    #include "std_disclaimer.h"
    /*
     * Your warranty is not void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     */

    CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community. All the source code for CyanogenMod is available in the CyanogenMod Github repo. And if you would like to contribute to CyanogenMod, please visit Gerrit Code Review.

    Wiki
    Official CyanogenMod Wiki: https://wiki.cyanogenmod.org/w/i9300_Info

    Installation
    (NOTE: if you experience robotic voice during calls: see the FAQ for a fix)
    First time CyanogenMod 14.1 installation on your Galaxy S III:
    • Read the official Wiki page
    • Flash a custom recovery via Heimdall or Odin
    • Push GApps (arm) and the CM 14.1 zip to your device
    • Boot into Recovery
    • Perform factory reset
    • Flash the CM 14.1 zip from SD card
    • Flash GApps from SD card
    • Reboot
    Upgrading from earlier version of CyanogenMod (even from 13.0) :
    • Update your recovery - CM Recovery will be done automatically, TWRP can be downloaded from here (NOTE: you need 3.0.2-2 to automatically install updates in CM14.1)
    • Push the new CM 14.1 zip to your SD card
    • Boot into Recovery
    • Flash the CM 14.1 zip from SD card
    • Flash the most recent GApps for 7.1 if you are upgrading from earlier android version
    • Reboot

    Downloads
    -----------------------------------------------------------------------------

    Reporting bugs
    • DO NOT report bugs if you're running a custom kernel
    • DO NOT report bugs if you've modifies system files
    • DO NOT report bugs if you've installed xposed and/or other mods
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues or bugs reported in the lastest 5 pages of this thread. Any bug not reported in the bug report format below may be ignored.

    Code:
    Phone Informations
    * CM version
    * Gapps version
    What you did:
    * Wipe data: y/n
    * Upgrade from previous official cm build: y/n
    * Restore with titanium backup: y/n
    You're using (if yes write which one) :
    * Task killer
    * Phone cleaner / Battery enhancer apps
    * Non-stock kernel
    * Modified kernel settings
    * Other mods
    Bug info:
    * Last version it worked on
    * Repro steps

    F.A.Q.
    (see next post)

    The CyanogenMod team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    XDA:DevDB Information
    Official CyanogenMod 14.1 Nightlies, ROM for the Samsung Galaxy S III I9300

    Contributors
    forkbomb444, Nameless, Haxynox, JustArchi
    Source Code: https://github.com/CyanogenMod

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.0.x

    Version Information
    Status: Nightly

    Created 2015-12-17
    Last Updated 2016-12-25
    115
    FAQ

    Robotic voice during calls?
    Make sure you're on the I9300XXUGMK6 modem. Instructions are here

    Root?
    CM ships with root, enable developer options and look in Settings -> Developer options -> root access

    Google camera crashes?
    Use Google Camera from the play store, not from gapps

    There's a non-device related bug? - such as SystemUI crashes triggered by performing a certain action, stray settings entries, theme crashes, translation, etc.
    I just work on the device support - not something I'll fix.

    Something that worked in the last nightly doesn't work in the new nightly? - bootloops? Something new is broken? It can all go here.
    Quick, to the bug tracker!

    Some other issue?
    You can't just say 'x is broken!' and expect me to magically find the bug and fix it.
    Here's what I need:
    1. Steps to reproduce - I don't care if "it's simple". I want to know exactly what you were doing at the time of the bug. How'd it happen? Does it only happen on Tuesdays when watching a specific YouTube video? Include it *all*
    2. What happened - in what way is this *not* the expected behaviour? Don't just say "it didn't play/upload/whatever". Did the entire phone crash? Did it show an error? Did it just show an endless progress indicator? Again, I need specifics here.
    3. Logcat/last_kmsg - Include the whole thing please, and if your phone's been running for a while, give me a rough region of time when the issue happened. Use last_kmsg if your device reboots unexpectedly, otherwise use a logcat. (See below for info on how to get them)

    How to logcat?
    See here (read up to the end of the "logcat" section).
    Upload it to a pastebin, include the link in your bug report.

    or if you're on your phone and can't get to a computer:

    I'd like to provide logs for problems I'm reporting, but I can't sit by my computer all the time ...

    If you install a terminal (this one works nicely) and type this:
    Code:
    su
    then, accept the superuser prompt, and type
    Code:
    logcat -d > /sdcard/logcat.txt
    it should save a logcat at /sdcard/logcat.txt. You can change the filename, and it will overwrite whatever exists already at /sdcard/logcat.txt

    How to get last_kmsg?
    Copy /proc/last_kmsg and upload the file contents to a pastebin, include the link to that in your bug report
    72
    Flickering should be fixed in the next nightly.
    71
    Hi!

    CM 14.1 is coming!

    Upgrading to CM14.1
    1. Backup
    2. Update TWRP to version 3.0.2-2 - download it here
    3. Flash new CM
    4. Flash new GApps

    You will need the updated TWRP to automatically take *any* updates (i.e. by using the "update" button in the ROM) starting from the next build - you can safely install the next update with your current TWRP.

    If you don't update TWRP, you'll have to manually install all updates.
    69
    Hey,

    I intend to keep working on i9300 for Lineage. There's not much else to say at the moment, but keep an eye on the website for more updates.