[ROM][OFFICIAL][A11] dotOS 5.1.2 [Vanilla/GApps]

Search This thread


Apr 21, 2019
I don't recommend using DotOS 5.1.3 on a Mi 10T. I tried this rom doing a clean flash, and I wasn't able to properly configure Google setup. Thankfully if you don't connect to a Wifi, you can skip that part. Even then, the rom was constantly rebooting itself. It usually happened while also setting up stuff on "settings". It was also extremely sloppy when it comes to performance, having a lot of stuttering on the main menu (with just the Google apps installed).

Worst thing is, after deciding to change roms, TWRP was unable to mount storage. I have no idea if DotOS somehow ****ed this thing too, or maybe I did something, but this is the first time I ever had that problem occur to me, and I have been using custom roms for 4 years now. Thankfully I was able to solved it, and now I'm running PixelPlusUI, which for now is WAY better.

If you really want to use DotOS, you should wait until 5.2, or maybe use one of the old versions.
  • Like
Reactions: Mikami15

Top Liked Posts

  • There are no posts matching your filters.
  • 9


    " #DroidOnTime "

    ROM Version: 5.1.2
    Device: apollo
    Maintainer: ejbtrd
    Build Status: OFFICIAL


    * Your warranty is now void.
    * We are not responsible for anything that may happen to your phone by installing any custom ROMs and/or kernels.
    * You do it at your own risk and take the responsibility upon yourself and you are not to blame us or XDA and its respected developers.

    "This is a user-friendly thread, all your suggestions are important to us and will be taken into consideration.."


    dotOS is an Android ROM that focuses on performance, stability, and User Experience. We focus on making our rom look and feel great without struggling on Performance and Battery! So that one can get the most out of your device.....


    CLEAN FLASH/First Time Installation :
    Download the latest build
    Reboot to recovery
    Flash latest build
    Flash mentioned firmware
    Format data
    Reboot to System

    Download the latest build
    Reboot to recovery
    Flash latest build
    Wipe cache and dalvik cache
    Reboot to System

    Note: GApps only has to be flashed once whereas Magisk/Su is to be flashed every time you Dirty Flash the OTA Update.


    GApps build
    Vanilla build

    Firmware - 12.1.3 Global


    Complete Changelogs: https://changelogs.droidontime.com/


    Lineage OS
    Pixel Experience
    Dirty Unicorns

    And all other open-source Devs/Teams.


    Mohan CM - Founder/Core Developer
    Iacob Ionut - UI, UX Developer/ Core Developer
    Sipun Kumar - Developer/Maintainer

    Special thanks:
    Manish Bajpai
    - Web Developer

    Important Links

    If you liked our Project, please consider supporting us. - Donate - https://www.paypal.me/MOHANCM

    dot OS source

    dotOS-Device Sources

    Telegram Group
    Telegram Channel



    Downloads page


    As soon as the problem occurs, take a LOGCAT!

    for more READ THIS

    and do not forget to send it to us 😜


    Contributors: ejbtrd, Ramisky, Dobsgw, SebaUbuntu and all our testers
    Source Code: https://github.com/DotOS
    Kernel Source: - https://github.com/dotOS-Devices/kernel_xiaomi_sm8250
    ROM OS Version: 11.x Android R

    Version Information
    Current Stable Version: v5.1.2
    Stable Release Date: 08-08-2021
    Update: 27/05/2021
    Rom changelog:
    - 5.1 update! Check out https://changelogs.droidontime.com/

    Device changelog:
    - Initial public OFFICIAL build
    - OSS kernel
    - OSS vendor

    Update: 12/04/2021
    Device changelog:
    - Initial unofficial build
    - Prebuilt kernel
    - OSS vendor
    I saw some screenshots of this and it looks interesting.
    I think I will try it.

    Good job (y)
    Great job!!!
    hey, i tried to flash the rom, but sadly it just stucks on the boot animation...

    im on a freshly unlocked and twrp installed mi 10t.
    format data after flash