Development [ROM][OFFICIAL][alioth][13] LineageOS 20 for POCO F3/Mi 11X/Redmi K40

Search This thread


Senior Member
Jun 4, 2013
Yes, I have the MIUI compass app and also calibrated it but it doesn't help.
Just to clarify. You installed 20 and it came with MIUI compass installed? If you installed it after then I have no idea if it will help at all. I was hoping for a built-in compass app.

Also, are you running the recommended firmware?


Senior Member
Apr 13, 2006
I also have situations where the vibration/haptic feedback doesn't work. F.e. when using the fingerprint sensor in an app. Also when playing Pokemon Go.

It works in:
Fingerprint unlocking the phone
Whatsapp calls/messages

It doesn't work in:
Fingerprint unlocking apps (banking etc)
Pokemon Go game
Last edited:


Senior Member
Apr 13, 2006
No it doesn't work for me either. I guess for no-one.

On the topic of the haptic feedback. I fixed Pokemon Go vibration with

Settings - Sound & Vibration - Vibration & Haptics - Interactive haptics / Touch Feedback
Now I have small haptic feedback throughout interfering with my Android phone though. Guess that also doesn't do good for the battery.... sigh

Still no feedback when logging into my bank app


Senior Member
Apr 13, 2006
Another small nuisance is that the shortcuts I made to some settings-screens (Battery, for example) no longer work. I can create a new one (Nova) and it works for a while, but doesn't work any longer after a reboot. Might be Android 13 related, so not necessarily Lineage

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Jio 5G not supported!
    checked NR availability by dailing *#*#4636#*#*
    it says NR availibility unknown...
    I did have jio 5G in stock ROM MIUI 14
    Device: MI 11X
    Have you tried to change preferred network type in settings? This happened to me after the instal, the preferred netwotk type was set to: LTE, TD-SCDMA , CDMA,... I changed it to : WORLD and the 5G appeared immediately.
    Have you tried to change preferred network type in settings? This happened to me after the instal, the preferred netwotk type was set to: LTE, TD-SCDMA , CDMA,... I changed it to : WORLD and the 5G appeared immediately.
    You mean 'Global' and not World?
    You mean 'Global' and not World?
    Yes, you're right. My phone is in Spanish, i have "Mundial" as an option in preferred network type, so I thought that World would be the english word for that.
    Hello there,

    I flash my phone to this firmware POCO F3 EEA - V14.0.7.0.TKHEUXM
    Then tried to "fastboot boot twrp-3.7.0_12-0-alioth.img" and it rebooted to the TWRP
    But it failed to mount the partitions:
    '/system_root' (Invalid argument)
    '/vendor' (Invalid argument)

    Could anyone give me a tip?

    EDIT: I have missed this part:
    fastboot flash boot boot.img
    Hey guys,
    First of all, thank you all so much for the work you're all putting in this community.

    I'm encountering the SIM card reboot bug with my new (second hand) F3. After a while, the network disconnects, then the phone restarts, doesn't show any network setting and I need to reboot again for everything to work.

    So from what I've read on this forum, the solution is to flash the right firmware before flashing LOS? I'm not new to flashing ROMs, but I don't really understand the concept of flashing a firmware beforehand.
    So I need to check if my phone is a Global or EEA version using my IMEI, then flash the right firmware, then reflash LOS (no way of fixing this without losing my data, right?)

    So can someone confirm that this famous bug is fixed by doing this, and that it's the correct way of doing it?
    Uploading the right firmware is key. Simply uploading a firmware will not remove your data from the phone. It's worth doing it with these instructions
    I personally having downloaded a newer version of Global. The lineageos website recommends V14.0.4.0.TKHMIXM. In my case, the network continued to disappear and reboots occurred. However, after uploading V14.0.7.0.TKHMIXM, everything works very well. No reboots and network outages. You'll have to see what works for you.
  • 57

    LineageOS is a free, community built, aftermarket firmware distribution of android, which is designed to increase performance and reliability over stock android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:
    • Camera (and flashlight)
    • Mobile Data (4G/5G)
    • WiFi
    • Bluetooth
    • Telephony (VoLTE/VoWifi)
    • Audio (Record and Playback)
    • Video Playback
    • Sensors
    • GPS
    • NFC (Except aliothin)
    • Nothing (?)



    • Must follow installation wiki for this device.
    • GApps can only be flashed on clean installs.
    • Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.
    • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported.
    • Flashing LineageOS through custom recovery is not supported and not advised.
      • For recovery you must flash vendor_boot.img and boot.img
    Bug reports:
    • DO NOT report bugs if you're running a custom kernel, recovery or Xposed or Magisk mods.
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.).
    • Report bugs here:

    Credits & collaborations:
    All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    XDA is preferred for main discussion. But if you need any unofficial support then check this group. We strongly discourage direct contact with any devs through social media.

    Credits :



    DONATIONS : Paypal


    By default LineageOS doesn't pass SafetyNet, why?, Check here

    You can use this unofficial method to pass SafetyNet (Not for rooted users):
    LineageOS 20.0 based on android 13 is out. Enjoy 🎉
    LineageOS 19.1 official build is out

    Make sure follow steps before upgrading to lineage-19.1

    - Follow this fresh install
    - Follow this for upgrade

    - Install Android 12 Gapps after installing rom (if you use)
    - Update firmware to required firmware version MIUI 13.x.x builds (Based on Android 12).
    V13.0.5.0.SKHCNXM 12.0 China
    V13.0.4.0.SKHEUXM 12.0 Europe
    V13.0.4.0.SKHINXM 12.0 India
    V13.0.2.0.SKHMIXM 12.0 Global

    - What does this do?

    - Spoof build as a user build (lineage builds are userdebug).
    - Spoof bootloader unlock status.
    - Spoof device as mi 8

    Download from attachments:


    - Spoofing does not stays in ota updates.
    - This method is only for non-rooted users.
    - Use to uninstall.