Development [ROM][OFFICIAL][alioth/aliothin][11] LineageOS 18.1

Search This thread


Mar 30, 2011
I found Lineage 18.1 20220507, but trying to apply it over Miui 12.5.6 + nikgapps causes one weird bug where the in call ui does not appear. Using MicroG 18.1 20220506 does not causes the same issue, but I need the playstore and can't use MicroG. Any ideas?

Top Liked Posts

  • There are no posts matching your filters.
  • 79

    LineageOS is a free, community-built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restores the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me ;)
    Instructions :
    Check #2 post before installation


    Reporting Bugs :
    • DO NOT report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    Kernel Source :

    Remember to provide as much info as possible. The more info you provide, the more likely it that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download URL:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Credits :



    Important notes:

    • * Required * firmware version must be based on MIUI 12.5.x builds.
    • GApps can only be flashed on clean installs.
    • Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.
    Flashing LineageOS through TWRP is NOT SUPPORTED and NOT ADVISED, do with your own risk. Please use LineageOS Recovery instead.

    Right now, Lineage Recovery is really only intended to be used on devices with Seamless Updates (aka A/B partitions) and, in that role, it is only intended to be embedded within the OS's normal Boot image. While flashing TWRP, it replaces boot image's ramdisk (possible security risks, coz it runs SeLinux permissive on recovery). That's why it's not recommend to use with A/B devices.