Development [ROM][OFFICIAL][alioth/aliothin][12.1] LineageOS 19.1

Search This thread

barturblits

Senior Member
Jul 4, 2014
331
79
I never did this, and its also the first time that I read about this.

For my part I upgraded from 18.1 and never flashed this. Everything, also OTA updates are working for me without any issues.
It was added after 19.1 was released.

I suspect the vendor_boot is part of the LOS19.1 rom/zip but also a hard dependency for the 19.1 recovery to boot. So the chicken or the egg problem. For upgrading we are using a 18.1 recovery so that's why we probably don't need it. I am gonna check the payload.bin of the latest LOS19.1 and see if the vendor_boot is in there.

Update: I checked the payload.bin and my suspicions were correct, it has the vendor_boot in it. It has the same hash as the downloadable vendor_boot from the wiki.
 
Last edited:

Boracho

Member
Mar 25, 2022
33
15
For the people still under 18.1 my personal experience after upgrading:

Im using 19.1 since a few days now and everything is running fine for my use cases. Battery usage is same or even "feels" a bit better than 18.1 (dont have statistics).

Under 18.1 with corresponding Android 11 firmwares (I tried them all) I had the problem here in mexico (f3 bought and made in indonesia) with flaky mobile network connections in some regions or parts of cities. The network connection was sometimes breaking away, or, I only had 4G for the first few seconds after I got signal. At first I was thinking this is an frequency related problem, since I bought the phone in asia, but the new global firmware or/and 19.1 seemed to solve the problem. My connection is much more stable now.
 
  • Like
Reactions: duttyend
I've been using the 19.1 ROM from several days and no problem so far from the perfomance perspective.
The only "issue" I see is that slow charge is displayed when I'm pretty sure it actually works as if it was fast. Any suggestion on how to fix this wrong indication?
Thanks
 

avguser23

Senior Member
May 31, 2019
65
16
I'm getting it on Lineage for microg, maybe it's an issue for installations without gapps. Have you managed to solve it? It doesn't happen just right after boot, I've also had it appear randomly when I'm using the phone.

I blocked its connection and it stopped crashing for few days, but today it crashed again untin if forced stopped it.
 

orlapa

Member
Jan 30, 2013
41
4
Xiaomi Redmi Note 7
Any who have tested this rom found issues with android auto using MindThe Gapps?. On 18.1 it fails, so I installed open gapps and it was solved.
On another hand, screen cast failed also, so I would like know if somebody has tested this feature.
Thanks in advance
 

booci

Senior Member
Jan 28, 2009
116
71
Buzau
I have only one question: is it normal that after every reboot this setting turns on again?

View attachment 5615291

It's not a big deal, I'm just asking to know if it's the intended behavior. Also I have removed the line to push 60.ih8sn.sh, not sure if that's the reason.
It is a bug in lineageos. Same behavior (after restart it turns back on) before ih8sn installation.
 
  • Like
Reactions: Emeraldawn

booci

Senior Member
Jan 28, 2009
116
71
Buzau
There is a new firmware for EU region: V13.0.6.0.SKHEUXM. After flashing, it broke my internet connection and I had to return to V13.0.4.0.SKHEUXM.
 
  • Like
Reactions: Emeraldawn

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    After being forced to use MIUI for 7 days until I could be released from Xiaomi's jail, I've finally installed this ROM. I'm a big fan of LineageOS, and have been using it for several years. I'm really pleased to have it running on my POCO F3. Everything seems to be working as expected. It has been a very smooth experience, from installing it to actually getting it running.

    Thanks to everyone who makes this wonderful experience possible!
    5
    If theres anyone here using any of these models with lineageos, then please let me know which firmware version is working fine for you.

    - POCO F3 Global : V13.0.3.0.SKHMIXM
    - Mi 11X India : V13.0.6.0.SKHINXM
    - POCO F3 Turkey : V13.0.1.0.SKHTRXM
    - POCO F3 Taiwan : V13.0.1.0.SKHTWXM
    - POCO F3 Indonesia : V13.0.2.0.SKHIDXM
    - POCO F3 Russia : V13.0.2.0.SKHRUXM
    - POCO F3 EEA : V13.0.6.0.SKHEUXM
    - Redmi K40 China : V13.0.5.0.SKHCNXM


    Note : Broken firmware usually have audio/touch issues
    I have updated the list. If anyone faces issues with above firmware version while using lineageos, then please let me know.
    4
    It was merged and will be included in the next build :)
    4
    Make sure you are running correct firmware - MIUI 13.x.x builds (Based on Android 12).
    - For Redmi K40 China V13.0.5.0.SKHCNXM 12.0 China
    - For MI 11X India V13.0.6.0.SKHINXM 12.0 India
    - For POCO F3 V13.0.3.0.SKHMIXM 12.0 Global
    - Others regions use MIUI 13.x.x.x 12.0 with july security patch (eg: Europe, Indonesia, Russia, etc..)

    Note: Newer/older firmware than this may or may not cause any issues, but it is not recommended.
    sound is not working with V13.0.7.0.SKHEUXM version
  • 30
    lineageos-png.5317459
    LineageOS is a free, community built, aftermarket firmware distribution of Android 12L (Sv2), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:

    yG18r6g.png


    Working:
    • Camera (and flashlight)
    • WiFi
    • Bluetooth
    • Telephony (Calls)
    • Audio (Record and Playback)
    • Video Playback
    • Sensors
    • GPS
    • VoLTE/VoWifi
    Bugs:
    • Nothing (?)

    Downloads:
    Supported models
    • M2012K11AC - Redmi K40 China
    • M2012K11AI - Mi 11X India
    • M2012K11AG - POCO F3

    Wiki:
    Installation :

    Updating firmware :

    Note:
    • Required firmware version must be same as here
    • GApps can only be flashed on clean installs.
    • Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.
    • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported.
    • Flashing lineageos through custom recovery is not supported and not advised. Use LineageOS Recovery instead. Right now, Lineage Recovery is really only intended to be used on devices with Seamless Updates (aka A/B partitions) and, in that role, it is only intended to be embedded within the OS's normal Boot image. While flashing TWRP, it replaces boot image's ramdisk (possible security risks), also using TWRP might break ota updates and cause other issues with LineageOS like bootloops.
    Bug reports:
    • DO NOT report bugs if you're running a custom kernel or you installed Xposed or mods.
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.).
    • Report bugs here: https://wiki.lineageos.org/how-to/bugreport#reporting-a-bug
    Credits & collaborations:
    All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    Credits :

    @SebaUbuntu

    @Sahil_Sonar


    DONATIONS : Paypal
    15
    LineageOS 19.1 official build is out

    Make sure follow steps before upgrading to lineage-19.1

    - Follow this fresh install https://wiki.lineageos.org/devices/alioth/install
    - Follow this for upgrade https://wiki.lineageos.org/devices/alioth/upgrade

    - Install Android 12 Gapps after installing rom (if you use)
    - Update firmware to required firmware version MIUI 13.x.x builds (Based on Android 12).
    V13.0.5.0.SKHCNXM 12.0 China
    V13.0.4.0.SKHEUXM 12.0 Europe
    V13.0.4.0.SKHINXM 12.0 India
    V13.0.2.0.SKHMIXM 12.0 Global
    11

    SafetyNet


    By default LineageOS don't pass safetynet, why?- its explained here https://lineageos.org/Safetynet

    Unofficial method to pass safetynet: ih8sn
    9
    #ih8sn

    - What does this do?

    - Spoof build as a user build (lineage builds are userdebug).
    - Spoof bootloader unlock status.
    - Spoof build fingerprint as an old device (mi 8 in our case). Why ? Else its pain to pass without root.

    - Requirements:
    - 🧠
    - 📱
    - 💻
    - Latest platform-tools from https://developer.android.com/studio/releases/platform-tools or android studio.

    - With adbroot
    1. Extract the ih8sn-aarch64.zip in a folder with 'adb' access or in platform-tools folder.
    2. Turn on USB debugging and Rooted debugging in Settings> System> Developer options.
    3. Connect phone to PC
    4. Open powershell/terminal in your location and run push script. (.sh/.ps1)
    ./push.ps1 (Windows)
    ./push.sh (Linux)
    5. Reboot

    - With recovery
    1. Boot into recovery
    2. Apply update > Apply from ADB
    3. In terminal : adb sideload ih8sn-aarch64.zip
    4. Click yes for verification failed
    5. Reboot

    Download:

    Note:
    - Adding 60-ih8sn.sh file will keep the spoofing stay in ota updates.
    - I haven't properly tested recovery support.
    - Re-flash same ih8sn.zip/push-script to uninstall.

    Source: https://github.com/althafvly/ih8sn/commits/alioth
    7
    Updated build is UP (Check OP for link)

    - Based on android-12.1.0_r2
    - Some features are up (like expandable volume panel)
    - Fixed recovery assert issue
    - https://download.lineageos.org/alioth/changes/