[ROM][OFFICIAL][anne][9] LineageOS 16.0

Search This thread

Hakxer

Member
May 11, 2021
13
0
Running stock EMUI 9.1:
- Required: root & TWRP installed (3.2.1-0 Gaguga Edition)
- Download Script
- Flash it in TWRP
- Enter Stock Recovery
- Do Factory reset
- Reboot
listen, well usb-otg via this 3.2.1-0 GAGUGA Edition
it doesn't work. it just won't mount. I don't have, like, a micro-sd slot.


I have this TWRP worked fine , there was an option to flash TWRP in erecovery , but I have not tried it . maybe someone will like the theme in it .
But as i understand it , what i need at the end of the day is to
How to boot into patched Recovery:
- Restart your phone, when appears the yellow warning on the screen, press and hold Volume Up for ~ 2 sec,
release the button and immediately press and hold again for ~ 2 sec. Repeat it 6-7 times, the device will reboot into Stock Recovery (you can perform Wipe cache or Factory reset).

If I use another TWRP or this one, will I be able to enter the above described method of recovery? Maybe this TWRP is based on the Gaguga Edition? :) screenshots if anything in Russian - by default in English
 

Attachments

  • DI_TWRP_3.2.1_P20_LITE_WHITE.img
    24.4 MB · Views: 12
  • TWRP_ADDON.zip
    86.6 MB · Views: 7
  • 4.png
    4.png
    153 KB · Views: 17
  • 3.png
    3.png
    104.6 KB · Views: 16
  • 20249778.png
    20249778.png
    37.9 KB · Views: 17
  • 20249773.jpg
    20249773.jpg
    11.2 KB · Views: 17
Last edited:

Hakxer

Member
May 11, 2021
13
0
Then use this TWRP , it works with OTG , 100%.
So my advice - don't look for new know-how ...
Bro, thank you!
I started right away with this TWRP
DI_TWRP_3.2.1_P20_LITE_WHITE.img
and it worked. the script was successful too.
after the final wipe I installed MagiskManager-v8.0.6.apk again
poured through TWRP magisk_patched-ane-v21.img.
Immediately those times could see through TWRP that data/data
normal names,or rather decrypted!
HOORAY!

"
кстати, если можно, порекомендую этот
переводчик , я через с него с вами обащался! :)


By the way, if I may recommend this one
interpreter, I used it to communicate with you! :)
 
Last edited:

-Alf-

Senior Member
Sep 28, 2017
1,040
287
Huawei P9
Huawei P9 Lite
Last edited:
  • Like
Reactions: Fjord1 and Incomtus

Frax3r

Member
May 18, 2016
15
6
Huawei P20 Lite
What problems could i get from installing this rom to emui 9.1.0.379?
Wifi doesnt connect. Theres also the webview problem regardless of which build you came from, other than those I can't remember anything else. If you are wondering how you can downgrade search on androidhost for our device, theres a straight .200 dload file for dual sim but if you are single sim you can either rebrand or use .132 dload and let it update once, iirc it should update to .200 first. If you want a newer version .278 is reported working.
 
Last edited:

Frax3r

Member
May 18, 2016
15
6
Huawei P20 Lite
Could anyone running this rom atm show some screenshots, tell about how stable its been for him, problems etc? :)
I used this for a while back when it was first released and it was pretty solid experience. Coming from a10 and a11 gsi's it'll feel like nostalgic but not in a bad way. Force stop and uninstall buttons, package installer screen etc. for example feels old, dated. In recent gsis we get UI improvements for granted but I'd like you to remember aosp 9 gsi from phh. Lineage does a great job at hiding the ugliness. Recently I've had enough of gsi performance/battery life and decided to give this another shot. Ran for a week and it was pretty stable without any problems whatsoever. Battery usage is a little higher than emui, when you get all your apps installed, since there are no overkill app-"suspension" features but it won't make too much of a difference in terms of screen on time. At least it didn't for me. Aside from webview, only 2 things were missing, volte/vowifi and gesture navigation. Volte is, in theory, fixable (?) with hwims and gestures are fixable with 3rd party apps. I used fluid to get around gestures but didn't much cared for volte. Tbh this rom better than most gsis out there. Try it and see for it yourself, you won't regret your time spent on installing. You'd ask "if it's so great why don't you run it anymore", my answer is dev is active even if you don't see him on xda. I don't want to spoil anything so heads up :)
 
  • Like
Reactions: DeSAiRePLYX

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Could anyone running this rom atm show some screenshots, tell about how stable its been for him, problems etc? :)
    I used this for a while back when it was first released and it was pretty solid experience. Coming from a10 and a11 gsi's it'll feel like nostalgic but not in a bad way. Force stop and uninstall buttons, package installer screen etc. for example feels old, dated. In recent gsis we get UI improvements for granted but I'd like you to remember aosp 9 gsi from phh. Lineage does a great job at hiding the ugliness. Recently I've had enough of gsi performance/battery life and decided to give this another shot. Ran for a week and it was pretty stable without any problems whatsoever. Battery usage is a little higher than emui, when you get all your apps installed, since there are no overkill app-"suspension" features but it won't make too much of a difference in terms of screen on time. At least it didn't for me. Aside from webview, only 2 things were missing, volte/vowifi and gesture navigation. Volte is, in theory, fixable (?) with hwims and gestures are fixable with 3rd party apps. I used fluid to get around gestures but didn't much cared for volte. Tbh this rom better than most gsis out there. Try it and see for it yourself, you won't regret your time spent on installing. You'd ask "if it's so great why don't you run it anymore", my answer is dev is active even if you don't see him on xda. I don't want to spoil anything so heads up :)
    1
    Someone can share a 9.1.0.200 dload please? I don't find on the web seems like all links are dead
    Here you go https://androidhost.ru/1Lzq
  • 7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the Huawei P20 Lite

    Contributors
    DarkJoker360
    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status: Stable

    Created 2020-08-21
    Last Updated 2020-09-03
    2
    official build download link is dead
    Maybe because https://metimetech.com/lineageos-re...ls-are-no-longer-compatible-with-popular-rom/

    You can try Lineage-16.0-20210215-nightly-anne-signed Link
    Working NFC, GPS, native call recording, offline charging etc.
    Note: EMUI 9.1 is required.

    Edit: internet browser doesn't work (due to missing webview) . Solution : simply install Google Chrome app
    1
    Cool, where's the device trees?
    github.com/hi6250-dev

    Hi! Is factory reset with stock recovery still needed?
    Edit : yes is needed

    BUG : webview is missing , solved by installing it with apk , device is not certified by google play
    It is not missing, it is in system/product due to lineage changes and it is crashing just because it is there right now, I am working on it.
    1
    P20 Lite is now officially supported. Wait next week for first official builds.
    1
    Someone can share a 9.1.0.200 dload please? I don't find on the web seems like all links are dead
    Here you go https://androidhost.ru/1Lzq