[ROM][OFFICIAL][anne][9] LineageOS 16.0

Search This thread


Senior Member
Jul 13, 2012
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 8

    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
     restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the Huawei P20 Lite

    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status: Stable

    Created 2020-08-21
    Last Updated 2020-09-03
    You are a lifesaver! Thank you kindly.

    On a totally different note : Someone please remind me to never get a huawei device ever again, they are way more trouble than they are worth to unlock lol
    official build download link is dead
    Maybe because https://metimetech.com/lineageos-re...ls-are-no-longer-compatible-with-popular-rom/

    You can try Lineage-16.0-20210215-nightly-anne-signed Link
    Working NFC, GPS, native call recording, offline charging etc.
    Note: EMUI 9.1 is required.

    Edit: internet browser doesn't work (due to missing webview) . Solution : simply install Google Chrome app
    Makes sense lol.
    Well either way, hitting a bit of an issue from the starting point :

    >fastboot flash erecovery_ramdisk TWRP-oreo-smart.img
    Sending 'erecovery_ramdisk' (24790 KB)             OKAY [  0.677s]
    Writing 'erecovery_ramdisk'                        FAILED (remote: 'Command not allowed')
    fastboot: error: Command failed

    All I can flash is the regular recovery_ramdisk partition, which would overwrite the stock recovery :|

    EDIT : Trying to relock and unlock the bootloader to get around that, since that seems to be the issue here.
    First flash TWRP , run command
    fastboot flash recovery_ramdisk (TWRP's_name).img
    Since A8 and above you can not install TWRP over eRecovery from fastboot, only from TWRP:
    - Copy TWRP file to the SD card, and also copy to card Stock Recovery_ramdisk, download here:
    Boot in TWRP, select storage - SD Card, select "Install image", find TWRP file and mark eRecovery, swipe. Go back, find recovery_ramdisk-9.1 file , mark Recovery, swipe. Reboot system.
    Cool, where's the device trees?

    Hi! Is factory reset with stock recovery still needed?
    Edit : yes is needed

    BUG : webview is missing , solved by installing it with apk , device is not certified by google play
    It is not missing, it is in system/product due to lineage changes and it is crashing just because it is there right now, I am working on it.