Development [ROM][OFFICIAL][barbet] LineageOS 19

Search This thread

thx1200

Inactive Recognized Developer
I saw Lineage 19.1 drop. Two questions.

First, when I upgrade, regarding this: "NOTE: If you previously had any Google Apps add-on package installed on your device, you must install an updated package before the first boot of Android! If you did not have Google Apps installed, you must wipe the Data partition (or perform a factory reset) to install them."

By first boot, do you mean before first boot after upgrade to 19.1 or do you mean first boot after Lineage 18.1 was installed ever? I guess my question is, do I have to add gapps if I already have gapps installed? Sorry if this is a basic question, but I'm confused. I do have gapps installed on 18.1. My guess is I need to load the (newest) package again after 19.1, but wanted to confirm.

Second, are there going to be any more 18.1 updates? I don't know if I'm quite ready for the Android 12 experience, I'm pretty happy as-is with my phone. But I also don't want to stop receiving security updates if 18.1 is dead now.
 

aleasto

Senior Member
Jul 15, 2012
1,066
2,681
Milan
i9100
Samsung Galaxy S5
I saw Lineage 19.1 drop. Two questions.

First, when I upgrade, regarding this: "NOTE: If you previously had any Google Apps add-on package installed on your device, you must install an updated package before the first boot of Android! If you did not have Google Apps installed, you must wipe the Data partition (or perform a factory reset) to install them."

By first boot, do you mean before first boot after upgrade to 19.1 or do you mean first boot after Lineage 18.1 was installed ever? I guess my question is, do I have to add gapps if I already have gapps installed? Sorry if this is a basic question, but I'm confused. I do have gapps installed on 18.1. My guess is I need to load the (newest) package again after 19.1, but wanted to confirm.
After flashing 19, before booting. Mind that you still must reboot to recovery between the two sideloads.
Second, are there going to be any more 18.1 updates? I don't know if I'm quite ready for the Android 12 experience, I'm pretty happy as-is with my phone. But I also don't want to stop receiving security updates if 18.1 is dead now.
No more updates.
 
  • Like
Reactions: thx1200

TheSayaMan

Senior Member
Sep 12, 2016
318
155
I saw Lineage 19.1 drop. Two questions.

First, when I upgrade, regarding this: "NOTE: If you previously had any Google Apps add-on package installed on your device, you must install an updated package before the first boot of Android! If you did not have Google Apps installed, you must wipe the Data partition (or perform a factory reset) to install them."

By first boot, do you mean before first boot after upgrade to 19.1 or do you mean first boot after Lineage 18.1 was installed ever? I guess my question is, do I have to add gapps if I already have gapps installed? Sorry if this is a basic question, but I'm confused. I do have gapps installed on 18.1. My guess is I need to load the (newest) package again after 19.1, but wanted to confirm.

Second, are there going to be any more 18.1 updates? I don't know if I'm quite ready for the Android 12 experience, I'm pretty happy as-is with my phone. But I also don't want to stop receiving security updates if 18.1 is dead now.
I had my own 18.1 build but closed the thread several days ago. Turned out to be a dead thread after awhile, it was showing no interest and I certainly wouldn't build it again if there was little interest in it. It takes a long time to build this. The source is still available for it, which means someone can make regular updates for it but if there isn't a update to the repo then it wouldn't make any sense to do so.
 

Zedicus

Member
Apr 25, 2013
42
6
When my lockscreen is in landscape mode it is almost impossible to swipe up far enough to get to the pin input screen.

In the stock sms app, any word followed by a period shows up with a red underline, like it is misspelled.

Do nightly builds not show up in the system updates?
 

satya-1998

Senior Member
Aug 24, 2012
1,028
430
I am facing the same issue as Zedicus. The spell checker is flagging words the precede periods/full-stops with a red underline. This does not happen with exclamation or question marks.
It is a minor annoyance, but does someone know how to get rid of it?

btw I see this not only in the stock SMS app but also WhatsApp etc
 

Rigulel

New member
Mar 21, 2017
4
0
@aleasto The left bottom speaker is never used. Instead, the rom uses the top speaker.

I updated to 12 when I noticed the issue but it's still there.

Can someone check on their device so I know it's not just me? It's easy to miss this because the speakers still sound good.
 

aleasto

Senior Member
Jul 15, 2012
1,066
2,681
Milan
i9100
Samsung Galaxy S5
@aleasto The left bottom speaker is never used. Instead, the rom uses the top speaker.

I updated to 12 when I noticed the issue but it's still there.

Can someone check on their device so I know it's not just me? It's easy to miss this because the speakers still sound good.
Only the bottom right grill is a speaker. The bottom left grill is a microphone!
 
  • Like
Reactions: Rigulel

thx1200

Inactive Recognized Developer
I upgraded from 18.1 to 19.1. Working well, but for some reason Magisk got wiped out and I need to reinstall it. It seems the simple zip installation method is deprecated now. I need the boot.img to patch it manually. How do I get the boot.img for this ROM? https://topjohnwu.github.io/Magisk/install.html

UPDATE: nevermind, found this. It required some older packages, but still works. https://github.com/vm03/payload_dumper
 
Last edited:

aleasto

Senior Member
Jul 15, 2012
1,066
2,681
Milan
i9100
Samsung Galaxy S5
I upgraded from 18.1 to 19.1. Working well, but for some reason Magisk got wiped out and I need to reinstall it. It seems the simple zip installation method is deprecated now. I need the boot.img to patch it manually. How do I get the boot.img for this ROM? https://topjohnwu.github.io/Magisk/install.html

UPDATE: nevermind, found this. It required some older packages, but still works. https://github.com/vm03/payload_dumper
Just sideload it in recovery, otherwise you have to redo the process every update.
 

boscorama

Senior Member
May 27, 2012
191
105
Strange question: Anyone else had issues making calls since AT&T retired their 3G network recently? I have data and SMS but no voice calls (immediate disconnect on dial). (I'm actually on RedPocket.) Depending on where I am the phone says 'LTE' or '5G' with good strength, so it seems to have acquired a signal.

I wonder if I need to change something in LOS ... or if I possibly need a new SIM?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @aleasto The left bottom speaker is never used. Instead, the rom uses the top speaker.

    I updated to 12 when I noticed the issue but it's still there.

    Can someone check on their device so I know it's not just me? It's easy to miss this because the speakers still sound good.
    Only the bottom right grill is a speaker. The bottom left grill is a microphone!
  • 14
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. LineageOS does still include various proprietary hardware-specific code.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Informations :
    • This ROM uses source built kernel, kernel modules, boot kernel modules (vendor_boot) and vendor image.
    • This ROM bundles the latest firmware so you don't have to worry about updating firmware.
    • To use the eSIM you need to have GApps
    Instructions :
    Downloads :
    Reporting Bugs
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/*
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved.

    Known Issues
    • Google Play Store provides a very out of date version of Google Camera. You can use GoogleCamera.apk extracted from stock here
    Contributors
    mikeioannina
    aleasto
    The LineageOS team

    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 12L
    6
    Official builds set to start on Thursday at https://download.lineageos.org/barbet
    6
    Two update questions:

    - I just got notice for OTA update. For the OTA updates, do we need to disable/uninstall Magisk before applying the update?

    - Is there a way to do a Nandroid (or similar) backup in recovery before applying an update so we can roll back if it goes wrong?
    If you installed Magisk by sideloading in recovery it will persist the update. Otherwise you'll need to reinstall it after the update if you want to keep root.
    3
    Source code temporarily on my github before it can be moved to the LineageOS organization
    3
    Thanks for putting this together so quickly! I've been running for a couple of days now with MindTheGapps and haven't noticed any significant issues. I'm now pretty darn satisfied with my new 5a (Even though it's a friggin chonk). I'm on Visible and I was able to just pop my SIM card in and everything worked. Wifi calling, texting, 5G connection, etc - all good.

    Only weird thing I've noticed is that after setting up fingerprints for device locksreen security I'm not able to then use fingerprint security within my other apps. For example - Chase app tells me "You haven't set up fingerprint sign in on this device", PayPal app says "We're having trouble confirming your fingerprint right now" and Bitwarden app doesn't present an option to enable "Unlock with Biometrics". So I'm using currrently using PINs for these apps which is a fine compromise for me - would be curious to know whether others have experienced this.

    There have been some changes to SafetyNet in the past couple of days that tripped ctsProfile on my Pixel 4a running official LineageOS but I was able to pass SafetyNet check in this ROM by installing kdrag0n's Universal SafetyNet Fix v2.0.0 and using MagiskHide Props Config to set device fingerprint to Pixel 5.
    I doubt you need to set device fingerprint to Pixel 5 for safetynet.

    Will fix fingerprint in apps in the next build now fixed