[ROM][OFFICIAL][cedric][11] LineageOS 18.1

Search This thread

macGam

Member
Jun 8, 2019
9
1
You can use Denylist to hide root from the banking app
Indeed but that was still not enough. Finaly, it's working. Passed all the SafetyNet tests in MicroG and my banking app is now working like a charm. Here are (more or less) the steps for those interested:
  1. Install Magisk 24.3
  2. Add module microG Installer Revived (2.6.2-0 by @nift4) and reboot. ⚠the microG app in fdroid didn't worked for me.
  3. Add module Zygisk - LSPosed and reboot
  4. Add module Shamiko (0.4.4) and reboot
  5. Add module Universal SafetyNet Fix and reboot
  6. Add module MagiskHide Props Config and reboot
  7. Add the banking app to the exclusion list in Magisk BUT don't enforce the exclusion list.
  8. From LSPosed (installed thanks to module Zygisk - LSPosed), install module FakeGapps (thanks @nift4) and reboot
  9. Activate the previous module and activate it for FakeStore (recommended), subsystem (recommended), microG Services Core (recommended) AND you banking app.
  10. From a terminal, enter `su props -c` and follow the procedure described in #18 and reboot (this is done thanks to the MagiskHide module
Now microG should successfully pass the safetyNet certification test.
 

hellwhynot

Member
Feb 28, 2017
23
3
I'm having an issue with Spotify not working properly (empty library, no playback) with at least the last two builds (20220428 and 20220505). Reinstalled the app, rebooted, et cetera, but nothing helped. Flashing 20220407 fixed it immediately, fortunately.
Did not test if it also affects builds 20220414 and 20220421.

I should add that I have another LOS 18.1 device on which the same builds of Spotify do work with the last two LOS builds.
 
Last edited:

hellwhynot

Member
Feb 28, 2017
23
3
Tried 20220512, did another clean Spotify reinstall and still the same issue: empty library and no playback on the local device. Anybody who can confirm this, suggestions as how to fix? TIA!
 
D

Deleted member 12131809

Guest
Thank a lot for this ROM, works flawlessly for me.

Much obliged.
 

abcxdaabc

Member
Oct 29, 2021
6
1
Tried 20220512, did another clean Spotify reinstall and still the same issue: empty library and no playback on the local device. Anybody who can confirm this, suggestions as how to fix? TIA!

Don't have any personal experience with spotify, but it's seems like it's an ongoing issue.

Try removing the sd card/unmount your sd card and restarting, then reinstall spotify.

See:

 

hellwhynot

Member
Feb 28, 2017
23
3
Tried 20220512, did another clean Spotify reinstall and still the same issue: empty library and no playback on the local device. Anybody who can confirm this, suggestions as how to fix? TIA!
Don't have any personal experience with spotify, but it's seems like it's an ongoing issue.

Try removing the sd card/unmount your sd card and restarting, then reinstall spotify.

See:

I already found a lot of threads about the issue but had not noticed this one. Thanks!
As for the proposed 'solution' in these threads, removing the sd card is not an option for me. I really need the extra space! I guess for now I'll just wait and see.
 

abcxdaabc

Member
Oct 29, 2021
6
1
I already found a lot of threads about the issue but had not noticed this one. Thanks!
As for the proposed 'solution' in these threads, removing the sd card is not an option for me. I really need the extra space! I guess for now I'll just wait and see.
Try it and then put it back in after reinstalling?

Nevermind.

The app storage system will not use any storage card added to the phone. It WILL use what appears as sd card storage, provided it's part of the phones permanent built in memory and not an actual removable card.


Is the card internal storage or portable?


 
Last edited:

hellwhynot

Member
Feb 28, 2017
23
3
Nevermind.




Is the card internal storage or portable?
It's portable and I like to keep it that way. Let's say using an external sd card for 'internal storage' did not always work for me... Thanks again though for pointing this out! I have posted in the thread you mentioned before, and hopefully it helps Spotify sorting out this issue.
 

mksu9

Member
May 23, 2022
6
0
Can I flash this ROM with old TWRP 3.2.0-0 and lineage-15.0-20171125_073252-UNOFFICIAL-cedric .
 

TheFixItMan

Senior Member
Jul 8, 2012
7,851
4,039
London
Can I flash this ROM with old TWRP 3.2.0-0 and lineage-15.0-20171125_073252-UNOFFICIAL-cedric .
Use latest official twrp to avoid issues and backup everything

You need to be on latest retail stock firmware or at least flash the latest modem part of the firmware (doesn't matter what custom rom you are using and you don't need to actually flash stock rom - just need to have the latest modem as your base)

Format system data and cache before flashing a new rom
 

mksu9

Member
May 23, 2022
6
0
Microphone doesn't work in conversations.im audiocalls. Regular Audio recorder works normally. Conversations is allowed to use microphone "while in use" and mic icon in app window is turned on. Any ideas where to look?

Edit:
-tried reinstall app, clear data, reboot and no change

I also installed [ROM][I9190/I9192/I9195][Unofficial][11.0.0] LineageOS 18.1 for S4 Mini and microphone works normal way in conversations app.

Edit2:
I downgraded to LineageOS 14.1 temporarily and now the mic is working again.
 
Last edited:

matiusuario

Member
Nov 18, 2020
18
14
Microphone doesn't work in conversations.im audiocalls. Regular Audio recorder works normally. Conversations is allowed to use microphone "while in use" and mic icon in app window is turned on. Any ideas where to look?

Edit:
-tried reinstall app, clear data, reboot and no change

I also installed [ROM][I9190/I9192/I9195][Unofficial][11.0.0] LineageOS 18.1 for S4 Mini and microphone works normal way in conversations app.

Edit2:
I downgraded to LineageOS 14.1 temporarily and now the mic is working again.
I recommend you to install the TWRP flashable version of stock ROM before switching between a7/a8 ROMs to a9/a10/a11 and viceversa (Stock Nougat for a7/a8 and Oreo for a9+). So you don't loose fingerprint nor face microphone issues. It's easier and quicker than fastboot flashing individual parts of stock.
 

mksu9

Member
May 23, 2022
6
0
TWRP flashable version of stock ROM

I can't even remember what I flashed before first time I installed custom rom to this phone, because it was years ago, so I might have a frankensystem now. At least I know it's not a hardware issue since it's working now. I will try a whole stock image next.
 

DefenderII

Member
Jan 19, 2022
6
1
I had a problem with syncing my google contacts. if anyone else does, here is what i did to make it work. I hope this helps others:

1: download gapps; I used Open Gapps
2: open the archive and extract:

  • googlecontactssync-all.tar.lz from the Core folder
  • calsync-all.tar.lz from the GApps folder (maybe the folder names and paths will change with other gapps? The archives names shouldn't though, so maybe you could search for the names and extract them)
3: extract the respective APKs. If you can't open ".tar.lz" archives because reasons, convert them or find a tool that will open them. I converted them to .zip archives with https://convertio.co/it/tar.lz-tar/ and win10 file explorer to extract them to the folder of your choice
4: put the the google calendar apk on your phone folder "download" (or any other folder, i used this one) and run it. => calendar syncs (it takes some time but it syncs!!!)
5: for the google contacts use de adb program on your pc and then via cmd (here you find how if you don't have adb)
open cmd platform-tool and type:

  • adb root
  • adb remount
  • adb shell
  • adb shell mkdir -p /system/app/GoogleContactsSyncAdapter
or if you are in the app folder:

mkdir -p GoogleContactsSyncAdapter



close the cmd window and open a new cmd platform-tool and type:

  • adb push "location of your apk file/GoogleContactsSyncAdapter.apk" "/system/app/GoogleContactsSyncAdapter"
  • check if the file was pushed:
    • adb root
    • adb remount
    • cd system
    • cd app
    • cd GoogleContactsSyncAdapter
    • ls (now you shoud see the apk file)
    • chmod 644 "/system/app/GoogleContactsSyncAdapter/GoogleContactsSyncAdapter.apk"
    • ls -l to check the new rights (this should be rw-r-r)
    • adb reboot or simply reboot
this should be done after each update

Manage file permissions on Unix-like systems (iu.edu)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    *
    */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Instructions:
    • Download the latest build, recovery image and GApps (if you need them)
    • Flash the downloaded recovery image via fastboot
    • Boot to recovery
    • Format system and perform a factory reset
    • Reboot to recovery
    • Flash the latest build
    • Flash GApps and any other necessary add-ons

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • NFC
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE/VoWiFi
    • USB tethering/audio
    • SELinux: Enforcing

    Known issues:
    • You tell me

    Downloads:

    Reporting Bugs
    • All bugs should be reported here: Issue Tracker
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Thanks to:
    @GivFNZ for testing my builds
    @wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
    LineageOS team

    Changelogs:

    Code:
    2021-04-08:
    Initial build.


    Source code:
    5
    just to verify.
    i have to put this on a sd card and install them on the phone with TWRP?
    No, sorry for not explaining.
    You download the ZIP on your PC, extract it (or extract NON-HLOS.bin from the ZIP).
    Then you reboot your phone to the bootloader, connect it to the PC and flash the file to the modem partition:
    Bash:
    fastboot flash modem NON-HLOS.bin
    3
    No, that didn't help. I tried that already. Tried again now, flashed newest recovery image and tried again - didn't work. Updated to latest version with adb sideload.

    Thanks for your efforts by the way :)
    It should be fixed in the next build - you'll still have to sideload that one, but future builds should update OTA fine
    3
    Okaaay ... this seems to be more compliacted than expected. How did you guys upgrade to Oreo FW? Where did you get it from?

    Thanks
    update firmware from pc in fastboot mode volume down (-) connect to pc

    Firmware LATAM XT1670 (amxla) Mini
    Firmware RETAIL XT167x (retail) Mini
    2
    Okaaay ... this seems to be more compliacted than expected. How did you guys upgrade to Oreo FW? Where did you get it from?

    Thanks

    Click the spoiler for commands to flash in fastboot
    Code:
    fastboot oem fb_mode_set
    fastboot flash partition gpt.bin
    fastboot flash bootloader bootloader.img
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    fastboot flash dsp adspso.bin
    fastboot flash oem oem.img
    fastboot flash system system.img_sparsechunk.0
    fastboot flash system system.img_sparsechunk.1
    fastboot flash system system.img_sparsechunk.2
    fastboot flash system system.img_sparsechunk.3
    fastboot flash system system.img_sparsechunk.4
    fastboot flash system system.img_sparsechunk.5
    fastboot flash system system.img_sparsechunk.6
    fastboot flash system system.img_sparsechunk.7
    fastboot flash system system.img_sparsechunk.8
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1 
    fastboot erase modemst2 
    fastboot flash fsg fsg.mbn
    fastboot erase cache 
    fastboot erase userdata 
    fastboot oem fb_mode_clear
    fastboot reboot