[ROM][OFFICIAL][cedric][11] LineageOS 18.1

Search This thread

facua92

Member
Mar 16, 2018
27
2
Moto G5
Hi, i've been using this rom for several months without issues, but with the last updates the camcorder with front camera is crashing. This only happens when trying to use video recording with frontal camera. In photo mode it works just fine. Back camera works fine on both modes. My model is xt1670
 
  • Like
Reactions: Tiki Thorsen

oldfone

Senior Member
Nov 12, 2020
54
5
Moto E 2015
Moto G5
OK, thanks for the info. It sounds like I should just bite the bullet, forget about backup/restore and just do a clean install of 18.1, recovery and all. Everything else seems like a disproportionately large amount of work. Probably just exporting settings from a couple of apps and then importing them after the install will be enough. Contacts and photos are already synced to a local Nextcloud instance.
Just wanted to report that I eventually got round to doing this after Xmas and everything went very smoothly. I have been enjoying LOS 18.1 now for several weeks. The phone occasionally seems very slightly less responsive than with 17.1, but that's maybe to be expected and doesn't really bother me. Thanks for all the work that has gone into official support for cedric!
 

JarlPenguin

Recognized Developer
Oct 16, 2018
1,019
935
Earth
github.com
Moto G5S
Moto G7
Hi, i've been using this rom for several months without issues, but with the last updates the camcorder with front camera is crashing. This only happens when trying to use video recording with frontal camera. In photo mode it works just fine. Back camera works fine on both modes. My model is xt1670
Is this still happening on the latest build?
 
  • Like
Reactions: facua92

clowesc

New member
Nov 23, 2021
3
0
Hi, 18.1 is working great but high ram games are crashing. Is the bottleneck of the 2 gigs of ram insurmountable? I saw the android 11 is using over 700mb of those 2 gigs
aanything to be done?
 
Last edited:

4Rom

Member
Dec 23, 2021
11
1
the installation worked fine, and very pleased i have a newer android on this, for me, perfect phone..
there are some little things.
even though i select that the powerbutton must NOT activate the camera app, it just does.
but that, i can life with that.

annoying is the wifi connection.
when i still have 50 to 80 % wifi connection, some apps give me a "no connection to internet" and i have to stop and restart wifi again.
exaple a news app, you see it takes time to load the photos that belong to the topics.
a banking app can't load the data.

maybe someone would know what to do?
now using: lineage_cedric-userdebug 11 RQ3A.21 1001.001 10038822
 

oldfone

Senior Member
Nov 12, 2020
54
5
Moto E 2015
Moto G5
After installing 18.1 when I have rebooted my phone, several apps, but always the same ones, have disappeared from the dock and home screen. That was a bit anoying, but not a major problem. Now, after updating to the 20220127 nightly, not only have the apps vanished from the dock and home screen but also from the draw and thus seem to have been uninstalled. On top of that, many more apps have been affected. I can't see a pattern. Most of the apps from the Play Store seem to be still there and most from F-Droid have gone. However, at least two apps from F-Droid are still there. My SD card is configured as internal storage. Anyone seen this before and/or knows what's going on?
 

oldfone

Senior Member
Nov 12, 2020
54
5
Moto E 2015
Moto G5
After installing 18.1 when I have rebooted my phone, several apps, but always the same ones, have disappeared from the dock and home screen. That was a bit anoying, but not a major problem. Now, after updating to the 20220127 nightly, not only have the apps vanished from the dock and home screen but also from the draw and thus seem to have been uninstalled. On top of that, many more apps have been affected. I can't see a pattern. Most of the apps from the Play Store seem to be still there and most from F-Droid have gone. However, at least two apps from F-Droid are still there. My SD card is configured as internal storage. Anyone seen this before and/or knows what's going on?
I just noticed that the SD card was shown as being corrupted. I have rebooted and the missing apps are back in the draw. However, problem with the apps missing from the dock and home screen persists.
 

Nemgathos

Member
Dec 10, 2018
22
1
Some people I called from my Moto G5 phone running LineageOS 18.1 complained about the microphone volume being very low. Did anyone of you experience similar issues? What can I do about this? Do I have to edit some XML files in the /system folder? How can I access this folder in order to edit these files?

Strangely enough, recording my voice when creating voice messages works perfectly fine. The volume then isn’t too low. It is just right.
 

JarlPenguin

Recognized Developer
Oct 16, 2018
1,019
935
Earth
github.com
Moto G5S
Moto G7
Yes, still happening on 20 of Jan build.. When you try to put the front camera in video rec mode it just crashes and closes
Would you mind trying a factory reset?
I just noticed that the SD card was shown as being corrupted. I have rebooted and the missing apps are back in the draw. However, problem with the apps missing from the dock and home screen persists.
You're going to most likely need to replace your SD card.
annoying is the wifi connection.
when i still have 50 to 80 % wifi connection, some apps give me a "no connection to internet" and i have to stop and restart wifi again.
At the moment we have no solution for this problem.
 

oldfone

Senior Member
Nov 12, 2020
54
5
Moto E 2015
Moto G5
You're going to most likely need to replace your SD card.
Maybe. However, just certain apps reproducibly disappearing from the dock after a reboot seems like a very specific (and, in a way, harmless) problem to be being caused by a flaky SD card. Certainly with PC and servers, hardware issues with storage media and problems with file systems tend, in my experience, to be a bit more catastrophic.
 

multimill

Member
Jun 8, 2014
47
3
Münster
Hello,

I tried updating with the OTA update. But the installation fails with Error that I need an Android 8.1 based firmware. Is there any guide + download where I can just upgrade my firmware instead of installing the whole stock rom?

Thanks!
 

h1h0silver

Member
Mar 14, 2014
12
4
Hello,

I tried updating with the OTA update. But the installation fails with Error that I need an Android 8.1 based firmware. Is there any guide + download where I can just upgrade my firmware instead of installing the whole stock rom?

Thanks!
same for me... OTA update to 20220210 fails and complains about android 8.1. Update failed and I am back to Feb 3, 2022 version. Using TWRP 3.5.2_9-0. Update
 

Attachments

  • PXL_20220210_183930146.jpg
    PXL_20220210_183930146.jpg
    296.3 KB · Views: 40
  • PXL_20220210_183857762.jpg
    PXL_20220210_183857762.jpg
    206.2 KB · Views: 38

ei146

Member
Feb 17, 2015
21
1
Samsung Galaxy S6 Edge
Moto G5
You're going to most likely need to replace your SD card.
Well, I noticed the same issues that oldphone described, e.g. certain apps (always the same) keep dissapearing from the dock and home screen after a reboot. I also use the SD card as internal storage. As I thought the card has an issue I replaced it with a factory new one. But the problem is still there.
 

JarlPenguin

Recognized Developer
Oct 16, 2018
1,019
935
Earth
github.com
Moto G5S
Moto G7
Hello,

I tried updating with the OTA update. But the installation fails with Error that I need an Android 8.1 based firmware. Is there any guide + download where I can just upgrade my firmware instead of installing the whole stock rom?

Thanks!
same for me... OTA update to 20220210 fails and complains about android 8.1. Update failed and I am back to Feb 3, 2022 version. Using TWRP 3.5.2_9-0. Update
+1
Same here for me...Was on Official LOS Recovery, same Android 8.1 message. Then switched to TWRP 3.5.2_9-0 the same issue ...
I think its a ROM issue....
Same here. It's definitely related to the ROM's last version. See Changelog for lineage-18.1-20220210-nightly-cedric-signed.zip:
Line 6: cedric: Assert on Oreo firmware
The issue will be fixed in the next build, and this build will be taken down. Sorry for the inconveniences caused by this.
Well, I noticed the same issues that oldphone described, e.g. certain apps (always the same) keep dissapearing from the dock and home screen after a reboot. I also use the SD card as internal storage. As I thought the card has an issue I replaced it with a factory new one. But the problem is still there.
That's definitely strange, I'll ask my testers to replicate it and hopefully I'll be able to fix it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    *
    */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Instructions:
    • Download the latest build, recovery image and GApps (if you need them)
    • Flash the downloaded recovery image via fastboot
    • Boot to recovery
    • Format system and perform a factory reset
    • Reboot to recovery
    • Flash the latest build
    • Flash GApps and any other necessary add-ons

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • NFC
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE/VoWiFi
    • USB tethering/audio
    • SELinux: Enforcing

    Known issues:
    • You tell me

    Downloads:

    Reporting Bugs
    • All bugs should be reported here: Issue Tracker
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Thanks to:
    @GivFNZ for testing my builds
    @wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
    LineageOS team

    Changelogs:

    Code:
    2021-04-08:
    Initial build.


    Source code:
    5
    just to verify.
    i have to put this on a sd card and install them on the phone with TWRP?
    No, sorry for not explaining.
    You download the ZIP on your PC, extract it (or extract NON-HLOS.bin from the ZIP).
    Then you reboot your phone to the bootloader, connect it to the PC and flash the file to the modem partition:
    Bash:
    fastboot flash modem NON-HLOS.bin
    3
    No, that didn't help. I tried that already. Tried again now, flashed newest recovery image and tried again - didn't work. Updated to latest version with adb sideload.

    Thanks for your efforts by the way :)
    It should be fixed in the next build - you'll still have to sideload that one, but future builds should update OTA fine
    3
    Okaaay ... this seems to be more compliacted than expected. How did you guys upgrade to Oreo FW? Where did you get it from?

    Thanks
    update firmware from pc in fastboot mode volume down (-) connect to pc

    Firmware LATAM XT1670 (amxla) Mini
    Firmware RETAIL XT167x (retail) Mini
    2
    Okaaay ... this seems to be more compliacted than expected. How did you guys upgrade to Oreo FW? Where did you get it from?

    Thanks

    Click the spoiler for commands to flash in fastboot
    Code:
    fastboot oem fb_mode_set
    fastboot flash partition gpt.bin
    fastboot flash bootloader bootloader.img
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    fastboot flash dsp adspso.bin
    fastboot flash oem oem.img
    fastboot flash system system.img_sparsechunk.0
    fastboot flash system system.img_sparsechunk.1
    fastboot flash system system.img_sparsechunk.2
    fastboot flash system system.img_sparsechunk.3
    fastboot flash system system.img_sparsechunk.4
    fastboot flash system system.img_sparsechunk.5
    fastboot flash system system.img_sparsechunk.6
    fastboot flash system system.img_sparsechunk.7
    fastboot flash system system.img_sparsechunk.8
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1 
    fastboot erase modemst2 
    fastboot flash fsg fsg.mbn
    fastboot erase cache 
    fastboot erase userdata 
    fastboot oem fb_mode_clear
    fastboot reboot