• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] [OFFICIAL] crDroidAndroid for Redmi 9 / Poco M2 (lancelot, galahad, shiva)

Search This thread
@Evan_Ferrao For some reason, when I flash my fdroid privileged extension, it can't install automatically on my system.

And also, nextcloud issues as well for auto upload. I selected my aegis backup folder in my local instance and it didn't appear the folder for some reason, so it can't upload automatically.


All of the apps are on F-droid.


New member
Nov 24, 2021
ROM has been excellent so far. It was also the only ROM that had good enough instructions for me as a noob to install without complications.

Runs smooth and works even better than the stock MIUI ROM imo. I've been using it for over a month now. It has not crashed or had any bugs yet.

Edit: please make the Night Light independent of GPS-Services. Or make it so it doesn't need constant GPS access. Maybe I should voice this on the crdroid github though.
Last edited:
  • Like
Reactions: Wyverneagle


New member
Jan 24, 2021
What I've done:

-unlock bootloader
-downgrade to 11.0.4 eea with xiaomi flashtool v2
-installed twrp 3.4.28-0108 with flashtool v2
-installed crdroid from here

everything works, but got following error in madlog:
ccci_fsd - failed to read Form FS Device (-1) !! errno = 4
After that the Device reboots

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    It's been my rom for the last 3 months. Stable and few problems.
    Thanks so much.
    It's been my rom for the last 3 months. Stable and few problems.
    Thanks so much.
    Faster than MIUI Indonesia rom?
    Faster than MIUI Indonesia rom?
    I don't know. Similar to the european rom and free from so many useless apps.
    Does anyone know why these messages spam the log?

    I SystemUpdate: [Execution,ExecutionManager] Action pending executed for 0.01 seconds.
    W SystemUpdate: [Execution,ExecutionManager] Unable to create the action. Restart the execution from the scratch.
    W SystemUpdate: java.lang.IllegalStateException
    W SystemUpdate:  at vcf.k(:[email protected]@21.48.15 (150400-414534850):0)
    W SystemUpdate:  at bfzx.f(:[email protected]@21.48.15 (150400-414534850):0)
    W SystemUpdate:  at bfyq.a(:[email protected]@21.48.15 (150400-414534850):10)
    W SystemUpdate:  at com.google.android.gms.update.execution.InstallationIntentOperation.onHandleIntent(:[email protected]@21.48.15 (150400-414534850):12)
    W SystemUpdate:  at com.google.android.chimera.IntentOperation.onHandleIntent(:[email protected]@21.48.15 (150400-414534850):2)
    W SystemUpdate:  at syl.onHandleIntent(:[email protected]@21.48.15 (150400-414534850):4)
    W SystemUpdate:  at eln.run(:[email protected]@21.48.15 (150400-414534850):4)
    W SystemUpdate:  at elm.run(:[email protected]@21.48.15 (150400-414534850):11)
    W SystemUpdate:  at byvi.run(:[email protected]@21.48.15 (150400-414534850):2)
    W SystemUpdate:  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
    W SystemUpdate:  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
    W SystemUpdate:  at java.lang.Thread.run(Thread.java:923)

    It looks like the device has issues with sleeping. The only way to make it stop is to kill Google Play services, i.e. to stop the com.google.android.gms app. The device was working well for almost a month, but recently it got this nasty issue. Does anyone experience this and maybe know how to fix it?
  • 13

    *** Disclaimer
    I am not responsible for any damage you made to your device
    You have been warned

    crDroid is designed to increase performance and reliability over stock Android for your device also attempting to bringing many of the best features existent today


    Read (THIS) If You Have Issues With Dialer App

    Flashing Instructions:

    [*]IMEI-BACKUP-SCRIPT (Download from here)
    [*]FIRMWARE (Download from here)


    First time installation:
    • step 0: Make Sure You Have IMEI Backup, Take From link above
    • step 1 : Assuming You Have Your Bootloader Unlocked Already, Go to fastboot mode, Flash recovery(shrp in this case)
    • step 2: Reboot To Recovery, Format Dalvik, Art Cache And Cache, Click on format data --> type yes
    • step 3: Flash Your Device FW(skip if on MIUI Android 11), then Flash crDroidAndroid Zip
    • step 4: Flash The Suggested Gapps Package(optional)
    • step 5: If you want magisk, flash after you've setup the phone from the setup wizard

    Update installation:
    • step 1: If You're On Non-OSS rom, Or OSS-Q rom, Follow "First Time Installation" Guide
    • step 2: First Unroot Your Device!(**IMPORTANT**), Now Assuming Youre on OSS-R Rom, or an Old Crdroid Build, Reboot To Recovery, Format Dalvik, Art Cache And Cache
    • step 3: Flash crDroidAndroid Zip
    • step 4: Flash The Suggested Gapps Package(optional)
    • step 5: If you want magisk, flash after you've setup the phone from the setup wizard

    ROM: https://github.com/crdroidandroid
    Kernel: kernel url

    ROM Download-Link
    Changelog: Changelog

    Visit official website @ crDroid.net
    Support Group(Telegram)
    crDroid Community Telegram
    crDroid Updates Channel
    Donate to help our team pay server costs
    Somebody asked before but no answer. How is the situation with low in call volume, is it present like in all custom roms for this phone?
    hello, yeah it is present in this custom rom... its a problem with all custom roms for redmi 9... i switched back to miui because of this issue
    Fist of all I don't use GAPPS, only microG installed via Magisk. Everything seems to be working just fine except two things.

    1. It looks like something is wrong with sensors. Compass shows wrong directions (I use the Trial Sense app, form F-Droid) and also the position (x-y) of the phone seems to be switched (it can be visualized better in the Bubble lvl in the app) -- it wrongly recognizes horizontal/vertical angle, apparently it thinks the right-left plane of the phone is the top-bottom one. When I hit the compass icon in the phone's nav bar, it hangs the whole phone after 10-20 seconds. There's no way to switch the icon back to the off state, and I have to reboot the phone.

    2. The volume buttons on my earphones don't work. The only button that seems to work is the power one. The phone's hardware buttons seem to work without issues. I tried two different earphones (connected via minijack and also the usb-c port), and I got the same result, which is I can't change volume via the buttons. Pressing vol+ or vol- on the earphones seems to be issuing a tap action on the screen, so for instance I can tap on a Firefox icon using either one of the volume buttons.

    Does anyone experience such behavior?
    The problem of the calls is in telephone calls or also in calls of watsap or messenger?
    @Evan_Ferrao Also, is there a microg package for the build? I know there's signature spoofing on the rom, but it causes a bootloop (nanodroid) on my end.
    I installed microG from Magisk. It was working well.