• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] Official Cyanogenmod 11 4.4.4 for the Moto G 4G (Peregrine)

Status
Not open for further replies.
Search This thread

Somcom3X

Inactive Recognized Developer
Aug 19, 2012
2,959
3,209
Metro Detroit
CyanogenMod is a free, community built, aftermarket firmware distribution of Android 4.4 (KitKat), which is designed to increase performance and reliability over stock Android for your device.

Code:
#include 
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */

CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community

All the source code for CyanogenMod is available in the CyanogenMod Github repo. And if you would like to contribute to CyanogenMod, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Downloads:

CM server

Installation:

Unlock the bootloader
Flash a recovery
Reboot into recovery
Flash rom.

Reporting bugs:

Reporting Bugs

You are allowed to report bugs only in this thread. Before reporting a bug, please make sure you are running as stock as possible. This means no custom kernel, no custom framework modification, etc. If you are using any of the above modifications, please flash the rom again to get rid of the modifications before reporting.

Report bugs on Jira at jira.cyanogenmod.org
Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. The following is a useful format to follow. Note: If you can provide the latest night/build that the bug didn't exist, it would greatly help in tracking down what caused it.

Code:
What is your:

Phone model:
CM Download url:
Gapps version:
Radio (baseband):
CM version:


Did you:

Install xposed framework?
Restore apps in titanium backup?
Flash another kernel?
Are you using a supported recovery?
start Art Runtime?
search the thread for similar issues before posting?
I don't reply to tech support by pm or emails/hangouts messages.
If you have xposed installed, please bother to post.

The CyanogenMod team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

XDA:DevDB Information
Offiical cm for peregrine, ROM for the Moto G

Contributors
Somcom3X, ShabbyPenguin
ROM OS Version: 4.4.x KitKat
ROM Kernel: Linux 3.4.x
ROM Firmware Required: Unlocked Bootloader with recovery

Version Information
Status: Nightly

Created 2014-08-28
Last Updated 2014-10-30
 

Somcom3X

Inactive Recognized Developer
Aug 19, 2012
2,959
3,209
Metro Detroit
Reserved

I'm your maintainer.

Current bugs:

Low ram bug (Essentially after 24hours an unknown process will take up a good amount of your ram and eat it until you factory reset/flash clean.)

Moto g will not connect to certain router securities.

Gps (device only) requires a signal lock from stock to function correctly.
 
Last edited:

Polloos

Senior Member
Sep 19, 2013
126
146
Barcelona
Awesome! In this ROM work all GPS modes (in any custom rom don't work for me), the Wifi works fine. This ROM is very smooth and faster, good work!

Only have 1 bug, the low ram...


I have 39 model with only xposed and gravitybox.
 
  • Like
Reactions: camargomaia

DeLaLuz22

Senior Member
Sep 1, 2013
62
46
32
Mexico City
Thank you!!! Can you say if this rom will work well with my xt1040, the south american version of the the moto g 4g?

Hi! New Moto G 4G owner here. I can confirm this ROM works very well with my XT1040.

Great job from all the people behind this. I'll give it a day and see how it works.
 
Last edited:

Somcom3X

Inactive Recognized Developer
Aug 19, 2012
2,959
3,209
Metro Detroit
Mind expanding on these two? What is the low ram bug? And how do you get a lock from stock for the gps fix?

Sorry for noobishness
Ram basically gets eaten up by an "unknown" process and the only way to fix is to reinstall the ROM.
You need to have GPS running on stock before you reboot to recovery.

Sent from my XT1045
 

1graser

Member
Jul 15, 2008
8
2
Hello!

Thank you for this great work. :good:

I am glad to see, that there is cm11 also for my moto g 4g ...

The following problems occured at my installation (xt1039) and I hope you can give me a hint...

WLAN:
The already known WLAN-bug prevents a WLAN connection.
Is there a workaround or do you have more information in which security context the problem appears?

EXT. SD-CARD:
The SD-Card (Sandisk, 32 Gb, Class 10) is not available in cm11.
Using the stock rom, the sd card was available and usable.
Do you have an idea how to fix this?

Thank you and best regards,
1graser
 

Oddfeld

Member
Feb 2, 2014
28
11
Edinburgh
OK, tried the first nightly. I'm still having problems with horrible wifi when connected to my cable router (VirginMedia SuperHub). I get a craptastic connection that works for a bit then drops out. Here's a logcat filtered on 'wifi'.

It seems to give multiple lines of "W/XTWiFiOS(1809): No entry in secure settings for enhanced location services: false" then lose my SSID and disconnect. I think maybe it's fine for a few minutes then it's trying to use my WLAN for location pinpointing and failing.


What is your--
Phone model: xt1039
CM Download url: http://download.cyanogenmod.org/get/jenkins/81401/cm-11-20140827-NIGHTLY-peregrine.zip
Gapps version:BaNkS's standard 4.4.4 GApps from here
Radio (baseband):MSM8926P_101.90.49.01R
CM version: 11


Did you:
Install xposed framework? no
Restore apps in titanium backup? no
Flash another kernel? no
Are you using a supported recovery? yes
start Art Runtime? no
search the thread for similar issues before posting? yes, it's a known issue.
 
  • Like
Reactions: schakusa

eteles

Senior Member
Aug 20, 2012
668
149
Bug report: device won't respond to Bluetooth player commands (next or previous or play/pause music) when browsing the internet with Chrome and listening to music at the same time on Bluetooth...
Tested with Poweramp and Apolo... Sometimes Poweramp even closes when playing music in backgroung (no FC error, just stops playing music).
With stock browser it works normally...

It worked fine with unofficial build from 08/05...

My device is the XT1040...
 
Last edited:

1graser

Member
Jul 15, 2008
8
2
EXT. SD-CARD:
The SD-Card (Sandisk, 32 Gb, Class 10) is not available in cm11.
Using the stock rom, the sd card was available and usable.
Do you have an idea how to fix this?

I changed the SD-Card and I am now using a Samsung, 32 Gb, Class 10.
This works without problems...
Now the SD-Card is also available in the CWM-Recovery.
Seems to be the strange behaviour that some cards do not work together with custom roms and recovery...
 

eteles

Senior Member
Aug 20, 2012
668
149
I changed the SD-Card and I am now using a Samsung, 32 Gb, Class 10.
This works without problems...
Now the SD-Card is also available in the CWM-Recovery.
Seems to be the strange behaviour that some cards do not work together with custom roms and recovery...
I use a genuine SanDisk 32GB class 10 card here... It works on all ROMs and recoveries with external SD support...
 

drakohla

Senior Member
May 24, 2010
120
57
Have the same on unofficial Build from 08/05.
Sometimes various apps were closed without FC message when using them, happens mostly to Chrome, Poweramp, sometimes Youtube.
On Chrome very often it tries to open the keyboard (Switftkey) when tapping the search bar but then Chrome got closed and I'm landing in an emtpy Homecreen (which also seemed to be closed) an then the icons came back one by one.

Maybe this has to do with low memory? Or misconfigured apps..I don't know how to track this down.
In Youtube the volume Buttons don't work, and the app closes itself very often when rotating the phone to go into full-screen mode.

Need to double test this with a clean install.
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 65
    CyanogenMod is a free, community built, aftermarket firmware distribution of Android 4.4 (KitKat), which is designed to increase performance and reliability over stock Android for your device.

    Code:
    #include 
    /*
     * Your warranty is now void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     */

    CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community

    All the source code for CyanogenMod is available in the CyanogenMod Github repo. And if you would like to contribute to CyanogenMod, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Downloads:

    CM server

    Installation:

    Unlock the bootloader
    Flash a recovery
    Reboot into recovery
    Flash rom.

    Reporting bugs:

    Reporting Bugs

    You are allowed to report bugs only in this thread. Before reporting a bug, please make sure you are running as stock as possible. This means no custom kernel, no custom framework modification, etc. If you are using any of the above modifications, please flash the rom again to get rid of the modifications before reporting.

    Report bugs on Jira at jira.cyanogenmod.org
    Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. The following is a useful format to follow. Note: If you can provide the latest night/build that the bug didn't exist, it would greatly help in tracking down what caused it.

    Code:
    What is your:
    
    Phone model:
    CM Download url:
    Gapps version:
    Radio (baseband):
    CM version:
    
    
    Did you:
    
    Install xposed framework?
    Restore apps in titanium backup?
    Flash another kernel?
    Are you using a supported recovery?
    start Art Runtime?
    search the thread for similar issues before posting?
    I don't reply to tech support by pm or emails/hangouts messages.
    If you have xposed installed, please bother to post.

    The CyanogenMod team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    XDA:DevDB Information
    Offiical cm for peregrine, ROM for the Moto G

    Contributors
    Somcom3X, ShabbyPenguin
    ROM OS Version: 4.4.x KitKat
    ROM Kernel: Linux 3.4.x
    ROM Firmware Required: Unlocked Bootloader with recovery

    Version Information
    Status: Nightly

    Created 2014-08-28
    Last Updated 2014-10-30
    27
    Reserved

    I'm your maintainer.

    Current bugs:

    Low ram bug (Essentially after 24hours an unknown process will take up a good amount of your ram and eat it until you factory reset/flash clean.)

    Moto g will not connect to certain router securities.

    Gps (device only) requires a signal lock from stock to function correctly.
    21
    Good news:
    Today I got wifi working. Borrowed some changes from invisiblek for the driver. Audio shouldn't be too too long and i'll release a build to you guys.

    Bad news:
    I am stressed for time around this time of the year. I'll only have weekends to look at anything android-related, hopefully.
    20
    Reserved

    Credits to:
    @shabbypenguin - can't say how much this guy deserves.

    intervigil- Helping me get CM support

    dhacker- The original framework of the moto's
    20
    Are you dependant on them at the current stage of development, or have you been trying to make progress without them?

    Through various workarounds, I finally got it working well
    MD5: 1fd51cbd4d2345c0aa79a6d45b473433

    After cm-12.0 port is finished, I will work on bringing carbon back up to speed.
    Also, when flashing cm-12.0 there may be an error in recovery that has something to do ith the /mount being busy. It's normal till I update twrp, unfortunately I have to download omni's source to do so.