[ROM][OFFICIAL][d85x, f400, ls990, vs985] LineageOS 18.1

Search This thread

yvesjordan06

Member
Aug 20, 2018
11
29
Yaoundé
Thank you for the ROM

Doesn't boot on LG LS900 (Sprint)
Shows boot animation then reboots

When trying to flash MindTheGapps, il fails saying "Can not mount mnt/system !"
 
Last edited:

HardStyl3r

Senior Member
  • Aug 12, 2015
    985
    3,169
    Poland, Łódź
    Maybe, you should buy a new batterie? This effect occurs while booting the first time with worn out batteries.
    I still haven't heard from my testers. I am assuming nothing could go wrong but Sprint variant is known for being tricky. I with somebody else with ls990 could test it. It holds up the entire 18.1 bringup.
     
    • Like
    Reactions: Ph3ar.

    Max Frost

    Senior Member
    Oct 25, 2015
    229
    115
    @HardStyl3r , Here's the scoop . The rom boots fine on the LS990 . The problem I ran into is I can't get the MindTheGapps to flash at all. I downloaded them twice , tried on twrp 3.4 and 3,5 but they give an error 1 and simply won't flash for me. I went ahead and booted the rom up. It booted smooth and fast. I then downloaded Mindthegapps from last month and tried those. They also wouldn't flash. I can view the zips so I don't think they are corrupt. I then flashed the open gapps 11 test from last month and they flash fine. Rom also boots up fine with them. I've never had an issue flashing gapps in years of testing so I dunno what's wrong. I can say the rom boots up on open gapps just fine and it doesn't take long. There was NO reboot issue for me. Sorry about the wait @HardStyl3r . I must have missed these post and only saw your PM tonight.

    @yvesjordan06 Did you clean flash or dirty ? The MindTheGapps did flash for you ? Try a clean flash of the rom without the gapps and see if you can boot. Like I said above t's booting up fast on my LS990 .
     
    Last edited:
    • Like
    Reactions: Ph3ar.

    Max Frost

    Senior Member
    Oct 25, 2015
    229
    115
    Thank you for the ROM

    Doesn't boot on LG LS900 (Sprint)
    Shows boot animation then reboots

    When trying to flash MindTheGapps, il fails saying "Can not mount mnt/system !"
    Just realized you couldn't flash those gapps either. If your dirty flashing on 17.1 gapps it might not ever boot. I don't have the link to the Open Gapps 11 Test that was posted last month but if you can find those they do work good. Maybe @HardStyl3r still has the link ?
     
    • Like
    Reactions: Ph3ar.

    Max Frost

    Senior Member
    Oct 25, 2015
    229
    115
    Also discovered magisk 20.4 won't flash either . Gives the same exact error as MindTheGapps . I was however able to flash Magisk 22 without issue and successfully rooted. I'm curious if anyone with the other g3 variants have tried MindTheGapps and or Magisk 20.4 ? Did they flash ok or give Error 1 , cannot mount system ? Thanks for any replies .
     
    • Like
    Reactions: Ph3ar.

    Huffos_net

    New member
    Feb 12, 2021
    2
    1
    Good morning, unfortunately I had to go back to 17.1, my LG G3 D855 with LinegaeOs 18.1, started restarting repeatedly and especially when I tried to open the tiktok application and the aliexpress application. I believe it is because of the Gapps. I will wait for LineageOs 18.1 to mature a little more.
     

    TwizzyDizzy

    New member
    Feb 7, 2015
    1
    0
    Hi there, @HardStyl3r !

    thanks for putting in your time to give us 18.1! As for now, I can report flawless operation of 18.1 without Gapps on d855.

    Slow / non-existant GPS lock but this seems to be a general issue with that device and does not seem to be related to 18.1.

    Cheers & Thanks
    Thomas
     

    Ph3ar.

    Senior Member
    Apr 16, 2016
    287
    147
    MindTheGapps-11.0.0-arm-20210328_143701 gives ERROR:1 during TWRP flash.

    Use BiTGApps-arm-11.0.0-R19_signed.zip instead: https://drive.google.com/file/d/1fHKK-vqLLePk2GZyjsFknBYkwoHD1kSu/view?usp=sharing
    Yeah , I had the same problem. The question is why . I assumed it was just a bad script or something with the MindGapps until I flashed it on a galaxy S4 and it flashed and installed without issue.. Something about our twrp/device is having a hiccup when it comes to that zip .
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 2
      Thanks for this awesome ROM - Android 11 on d851 in 2021 is amazing.

      Working good so far, except built-in LineageOS terminal reboots phone when I try to start it. Termux works fine so not major issue for me.
      Built-in terminal support is partially unsupported and drop change is WIP. Don't use it.
      2
      Is there any known bug regarding WPA3? Because I can´t establish a connection with my d855 device (lineage-18.1-20210501-nightly). WPA2 is working though.

      Also knock knock functionality is not working.
      You have to enable DoubleTap2Wake in Settings > Display.
      1
      4/23 ota update installed without a problem.
      4/30 ota update, ditto.
      1
      Hi, thank you for this information, actually I do not understand why the best variant is not supported, but anyway, do you know which is the most valuable ROM for dual sim?
      The answer is simple, I don't have g3ds variant and it wasn't me who brought it up in the first place. There are very few g3ds users that it's really hard to debug. It also wouldn't make it to LineageOS official.
      And to answer the question, stock rom is probably the best.
      1
      ugh I accidently lost my twrp recovery to the lineageos recovery and lost root...can someone link me to to the twrp zip file mentioned that I could flash using the lineageos recovery?

      *edit - i found the zip and i got twrp back! also figured out how to flash magisk again!!! yay!!!!!!!!!!!!!
    • 13
      V1KTmBM.png



      Code:
      /*
      * Your warranty is now void.
      *
      * I am not responsible for bricked devices, dead SD cards,
      * thermonuclear war, or you getting fired because the alarm app failed. Please
      * do some research if you have any concerns about features included in this ROM
      * before flashing it! YOU are choosing to make these modifications, and if
      * you point the finger at me for messing up your device, I will laugh at you.
      */

      sFC1ljz.png

      LineageOS 18.1 is a free, community built, aftermarket firmware distribution of Android 11 (R), which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      The source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review. You can also view the Changelog for a full list of changes & features

      Lin·e·age
      /ˈlinēij/
      noun
      1. lineal descent from an ancestor; ancestry or pedigree.
      2. a sequence of species each of which is considered to have evolved from its predecessor.

      F2KbTDc.png

      If you encounter any issues with sensors or anything related to hardware, please flash stock rom and then a custom one.
      Check the G3 issue tracker and LineageOS issue tracker before installation.
      Clean flash is recommended, here's the procedure:
      • wipe Dalvik cache, /system, /data and /cache.
      • flash latest ROM zip
      • optional: flash Google apps ARM

      TK3TVvO.png

      Download LineageOS 18.1
      TWRP
      Open GApps ARM BETA BUILDS
      Rooting your phone by Linus Tech Tips
      Stock ROM by @MESA
      3__HacerPermisivo.zip - this switches your selinux to permissive
      bootimage_adb_unsecure by @AdrianDC - debugging, disables adb auth
      Mr_Bump.zip by @dadi11 - fix for Secure booting error (boot certification verify)

      Nh9aiVb.png

      Join G3 development channel on Telegram to get more info about my projects.

      Onx1GCn.png

      @dadi11
      @walter79
      @aleasto

      DPxaQu8.png

      github.com/LineageOS
      github.com/itsHardStyl3r
      device and kernel sources
      local_manifests
      Important: information about open sources from HardStyl3r
      7
      A new update (for a short while) before we'll have official builds. Once the builds are available to download, I'll convert this thread to Official and close 17.1.
      Enjoy.
      5
      New update. Changelog is in the #2 post.
      If no bugs are reported, I'll push the changes to gerrit and hopefully, we'll get official LineageOS 18.1.
      3
      @HardStyl3r , I flashed the new 18.1 build along with the open test gapps on my LS990 . I have to say it's running great so far. Things I've checked and work fine are data, wifi , telephony, camera( both camera and video) and GPS. All work good without any lag or issue. I also rooted with magisk . Had no problems whatsoever with TWRP either. I went through the whole setup process of entering account and restoring all apps from the cloud. GPS locks in super fast and finds lots of satellites . I tried the first 18.1 build you put out and while most stuff worked I can tell this build is smoother and improved. Thanks for all your efforts .

      Warning to all TWRP users ::: . During setup on 18.1 you' must be careful not to check the box offering to update Lineage Recovery . If your on TWRP and you check this box you''ll lose your TWRP .
      3
      Auto update didn't find new version. Attempted a dirty flash of rom only, which resulted in boot loop. Did full wipe, flash rom, bitgaps and magisk and is working very nicely. Thanks HardStyler.

      Auto update will not work until the rom eventually goes official.
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone