• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][discovery][10] LineageOS 17.1

Search This thread

maximdq

Member
Aug 28, 2011
37
5
I have 4 problems, 1 from the beginning and I do not see a solution anywhere, it is when I have WhatsApp calls or video calls, the microphone stops working for audios.
2 the front camera is blurry and does not focus well
3 the front flash does not work and the application closes.
4. the wifi cuts out and reconnects
any solution? I put all the patches here, and the wifi doesn't work.
regards


unfortunately I had to go back to the stock version of sony as I could not find a solution to the problems detailed above.
 

AndreiOR

New member
Jan 23, 2020
2
0
Colima
I've read everything (at least that's what I think) and can't find a solution.
Lineage: Installed
Gapp: Installed
Everything seems ok but when I get to the "Android Configuration" to finally add wallpapers, apps and so from my account backup in drive, it just crashes. I get the "Import data from...", set my account then crashes and a message says "Android Configuration continues to fail" or "Android UI continues to fail".
Done every thing I found in other forums, wipe cache, forced app to stop, reboot and even installed everything from stratch 3 times. I've noticed this happens ONLY after Gapps is installed, so guess that's it.
By the way, gapp version is "pico", tryed "mini", "aroma" and "tvstock" but was a total failure.

Please tell me what dumb EFFING thing I'm doing.
 

AndreiOR

New member
Jan 23, 2020
2
0
Colima
Ok so, I've tried Lineage for like a week or so now, FINALLY everything went well, I just installed BITGapps and no rebooting or problems with google apps... except for one, Spotify. The thing just keeps erasing my account and songs with it, it just works fine and then NOTHING, open the app and asks for account again and again, wich just can be resolved if I uninstall/install the app again. I don't know if it's related to Lineage or my SD memory card but didn't happened before with stock ROM.
Finally, a simple question, every single Sony improve or whatever has been removed? Remember touching the bottom corner of the screen and shrink to a smaller version so I could reach everything but now is gone :(

Anyway, thanks in advance :fingers-crossed:
 

andreaserry

New member
Aug 10, 2018
4
0
Hi, I need a hand with ota updates. I have already tried several times, to download an update and install it from twrp, but the phone goes in the lineageos boot loop. And every time I have to reinstall everything all over again. What am I doing wrong?
 

andreaserry

New member
Aug 10, 2018
4
0
I've read everything (at least that's what I think) and can't find a solution.
Lineage: Installed
Gapp: Installed
Everything seems ok but when I get to the "Android Configuration" to finally add wallpapers, apps and so from my account backup in drive, it just crashes. I get the "Import data from...", set my account then crashes and a message says "Android Configuration continues to fail" or "Android UI continues to fail".
Done every thing I found in other forums, wipe cache, forced app to stop, reboot and even installed everything from stratch 3 times. I've noticed this happens ONLY after Gapps is installed, so guess that's it.
By the way, gapp version is "pico", tryed "mini", "aroma" and "tvstock" but was a total failure.

Please tell me what dumb EFFING thing I'm doing.
If isn't a problem for you, wipe sistem, then install Los, reboot then gapps
 

maxis123

Senior Member
Jan 2, 2011
56
3
Sony XA2 Ultra
got issue/question..
Usually I use Lineage16 and there I can disable or even completely delete Trebutchet, in 17 I can't do it, so my question is is there any way to completeley disable trebutchet in here?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][discovery][10] LineageOS 17.1, ROM for the Sony XA2 Ultra

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2019-10-23
    Last Updated 2020-04-01
    5
    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261769960 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    or
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?
    3
    OK so far the only issue I've seen is not being able to set the dark mode to black, it just reverts back to normal dark mode, other than that no issues here! Great work man!

    Update: If I try connecting to a public WiFi that requires a login, when I click "sign in to network" that function just crashes, however regular WiFi at home works great.
    Also, expanded desktop crashes the settings app when you try going into it
    I'll be able to send you a logcat when I get home(about 8hrs from now)

    Don't bother sending a logcat for expanded desktop.
    3
    Sorry for bothering, I'm just not really sure.
    If I flashed recent Sony full stock 50.2 firmware with Newflasher, does it mean I am on both slots with it? :confused:

    It depends how you flashed it. You can do `strings /dev/block/bootdevice/by-name/modem_* | grep Daily` in TWRP. If you see both dates starting with 2019 then you probably have some kind of 50.2 on both slots.