• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][discovery][11] LineageOS 18.1

Search This thread

thedieselspaceship

Senior Member
Dec 6, 2011
113
9
Hello LuK1337,

First of all many thanks for the excellent work.
I have installed the latest nightly LOS build on the device of mine and I have sound problems when I insert standard "Sony" headphones with microphone that comes with the smartphone: the sound is stuttering and if I try to make a call to someone I cannot hear anything or scraps of conversation. Could you please take a look at the attached log file?

Thanks a lot.
I have uploaded the logs to ix.io as I do not see the attached file:


and yes. I have updated firmware using XperiaFirm and Newflasher tools on the both "a" and "b" slots.
Here another log whilst trying to play mp3 file:
 
Last edited:

Vlackrs

Senior Member
Nov 23, 2011
250
23
Strong
Sony XA2 Ultra
How i can Upgrading the Recovery Image what command is? I don't want to get stuck at boot every update.

Or how do i fix it? trying flashing with twrp lol, dont know what option.

edit. bitgapps is the one that is bootlooping my phone, nikgapps dont have this problem.
 
Last edited:

AndreyAleks

Member
Sep 14, 2019
43
7
lineage-18.1-20210513-nightly-discovery-signed.zip has a bug, dont even boot, stuck in sony logo.

bitsgapp last one.
I had this. Try to do the following [if you are in the boot stuck in sony logo].
1. Press Vol_up + Power and when phone vibrate 1 time release Power, but keep pressing Vol_up and connect USB cable to PC at this moment. The phone will start in fastboot mode (blue light).
2. Check which slot is active now by command: `fastboot getvar current-slot`
3. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if it's `_a`
4. Reboot (you are rolled back to pre-update system).
5. Open updater, and install the update again, DO NOT REBOOT!!!
6. Open Magisk and tap 'Install' in the Magisk card (not App card).
7. Select 'Install to Inactive Slot (After OTA)', Let's Go ->
8. Reboot

ps For the future, make LineageOS updates by steps 5-8.
 

muzontnt

Senior Member
Jul 23, 2011
164
123
NSK-CITY
LuK1337, please change the logo SONY (white background) on the boot screen on black background. When restart smartphone, the white background dazzles eyes 👀
db18e25f9e18294e608ff51ba091f2b1.jpg
 
Last edited:

AveryEmerous_64

New member
Aug 27, 2019
3
0
Hey, guys. I've been having issues with SIM network connectivity. The SIM card cannot find any access point while working just fine on my other phone. It detects the operator though.
I've flashed over the firmware for my country's biggest telecom provider while following the first reply to this thread and still no budge. Even flashed over the attached modem zip.
This happens even if I just use LineageOS and nothing else but the given zips.
Everything else works fine.

Disregard this. It's meant for the XA2, not the XA2 Ultra.
 
Last edited:

AndreyAleks

Member
Sep 14, 2019
43
7
Hey, guys. I've been having issues with SIM network connectivity. The SIM card cannot find any access point while working just fine on my other phone. It detects the operator though.
I've flashed over the firmware for my country's biggest telecom provider while following the first reply to this thread and still no budge. Even flashed over the attached modem zip.
This happens even if I just use LineageOS and nothing else but the given zips.
Everything else works fine.

Disregard this. It's meant for the XA2, not the XA2 Ultra.
I had the similar 2 month ago. And I wrote about it on first page of this thread - the firmware update described on #2 is obsolete. But I don't know how it should be. As a workaround, try to flash the whole stock - all files except simlock.ta and persist_X-FLASH-ALL-18AE.sin (+ persist_X-FLASH-ALL-18AE_0x00.hash). After that, you can install LineageOS.
 

maxis123

Senior Member
Jan 2, 2011
56
3
Sony XA2 Ultra
got issue/question..
Usually I use Lineage16 and there I can disable or even completely delete Trebutchet, in 18 I can't do it, so my question is is there any way to completeley disable trebutchet in here?
 

Yndi

Senior Member
Nov 12, 2011
246
64
Hi,
thank you @LuK1337 for supporting this phone.
I recently put this ROM on a phone and have two questions: Is it correct that the SD card is formated in FAT32? I want to use it for apps and besides the camera it does not seem to work. 'Here We Go' cannot put it's maps there, which worked in the original Pie ROM.
Also the camera: Does it use some special format? It says .jpg and the Gallery shows images properly but I can't edit it or see the pictures in other apps. It looks like they are damaged.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    1
    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261769960 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    or
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?
    1
    so i installed it, but it shows me LOS 17.1 and not 18.1.. whats the point?? :)
    1
    Wonderful work thanks
    i upgrade from 17.1 to 18.1
    first flash twrp in fastboot wiping data + cash

    fastboot flash oem_a SW_binaries_for_Xperia_Android_11_4.14_v4b_nile.img
    fastboot flash oem_b SW_binaries_for_Xperia_Android_11_4.14_v4b_nile.img

    in twrp flash rom then gapps reboot
    then flash Magisk canary update direct install done

    for download Magisk canary
    You don't need to flash oem image.
    1
    Any way to fix the bootloop after every update?
    Not using Nikgapps would likely help.