[ROM][OFFICIAL][enchilada][10] LineageOS 17.1

Search This thread

Christophfy

Member
Sep 21, 2018
7
1
Bottom of section "Drawing" -> "Display cutout"
Between "Smallest width" and the header of section "Hardware accelerated rendering"
This is not what i wanted.
Stock option makes something that looks like the left picture.
The app gives back the black top panel with notifications like on the right one.
1610739081251.png
 

MaxRabbit

Senior Member
Oct 21, 2010
778
227
Austin
I haven't seen any complaints from anyone in this thread about the LED notifications not working - am I the only one for whom the LED doesn't light up on LOS 17.1?

Actually, now I notice that if I set the LED to "always on," it will appear for a few ms before turning off, and it never comes back on.
 

rayray07

Senior Member
Aug 20, 2018
162
15
Hey guys thinking of installing this until the lineage os 18 build comes out, one thing i'd like to ask is how is the battery lfie on this rom and which gapps is the best to go with (as of now im thinking of gapps pico, but you can let me know if you have other recommendations)
Thanks
 

dumbl3

Senior Member
Apr 19, 2012
354
94
Do you still dont understand that "hide" makes the notch disappear at all without showing notifications there?
Did you ever try it? On my OP6 it does exactly that.
If you actually did, please post pictures of the selection and the top part of your screen and explain, why it doesn't meet your expectation -- ATM I strongly doubt you did anything.
This is old news. The hide option has not been available since update to android 10. Since 10 you can still hide the notch but only by moving the whole display below the notch. Notch hiding like we had in android 9 by black out can only be achieved with apps or some under the hood modification (with root). Both options are buggy in my experience so I have chosen to live with the notch and got used to it..
 

hayvan96

Senior Member
Mar 23, 2018
296
220
Hi, I need your help
Magisk offered a new update (I have no module, except magisk hide) and since then I'm blocked at fastboot. I've flashed uninstaller with twrp, but obviously, I need to flash also boot.img back

I'm running throught the backups made by Magisk, but is there a way to find the original boot.img I should flash for LOS17.1?

thank you
 

hayvan96

Senior Member
Mar 23, 2018
296
220
The Magisk uninstaller should have taken care of that already. If not, just reflash LOS.
Well, this is what I did:
* in all the /data/magisk* backup folders, I took the boot.img.gz from the latest LOS update, and flashed the image as boot image. This has allowed me to boot again
* Magisk seemed broken so I flashed latest LOS, changed slot, flashed gapps and Magisk, and it's fixed :)
 

hayvan96

Senior Member
Mar 23, 2018
296
220
@hayvan96
Which magisk version and which LOS build did you use?
I'm at the hospital and haven't updated my phone since september and wanted to flash today but don't want to mess around fixing stuff.
It happened when updating magisk from 21.3 to 21.4
But reinstalling LOS and gapps and magisk -- no problem. It could be that the 21.4 upgrade failed on my device, explaining the bootloop.
Since then, I've updated LOS again (to have January security patch), and all went nicely.
 
  • Like
Reactions: keelsonkeelson

ImjuzCY

Senior Member
Jun 14, 2012
531
139
Kuala Lumpur
Does the QuickSwitch Magisk module work with gesture navigation on LineageOS? I know on AOSP Android 10 it doesn't work, but on OOS they made it work, so I wonder if it work on LineageOS.
 

Ufos92

Senior Member
May 5, 2015
54
13
Hi, I need your help
Magisk offered a new update (I have no module, except magisk hide) and since then I'm blocked at fastboot. I've flashed uninstaller with twrp, but obviously, I need to flash also boot.img back

I'm running throught the backups made by Magisk, but is there a way to find the original boot.img I should flash for LOS17.1?

thank you
Lesson #36 of custom ROMs. When you're far behind on updates, stop updating magisk as well.

Sry, you got screwed bro.
I have an ultimate unbrick guide in this thread somewhere. No data loss.

In essence: backup data through twrp, reflash everything, restore data on top, hope it works.
Backup through migrate and clean flash.
 

hayvan96

Senior Member
Mar 23, 2018
296
220
Lesson #36 of custom ROMs. When you're far behind on updates, stop updating magisk as well.

Sry, you got screwed bro.
I have an ultimate unbrick guide in this thread somewhere. No data loss.

In essence: backup data through twrp, reflash everything, restore data on top, hope it works.
Backup through migrate and clean flash.
Thank you, but problem is already solved without any data loss, see #895 above
 

Gotolei

Senior Member
Is anyone noticed on latest build color profiles not working properly,i mean whenever i switch to wide or rgb nothing hapennes.it stayes the same all time.so i am on latest build,flashed yesterday by instructions in wiki page.Last time i was on Lineage back in august.Rom is really awesome,super fast,fluid etc.
This is still a problem on current builds (livedisplay color profile settings not actually applying, and the option itself immediately reverting once you exit the settings screen). If anything, the most recent one is even more needlessly vibrant. Has anybody looked into this?
 
  • Like
Reactions: dickta

darksx

Senior Member
Dec 19, 2014
237
87
This is still a problem on current builds (livedisplay color profile settings not actually applying, and the option itself immediately reverting once you exit the settings screen). If anything, the most recent one is even more needlessly vibrant. Has anybody looked into this?
At least i'm not the only one,i can't tell anything further because i'm on Oxygen OS.But from time to time i usually switch to Lineage.Cheers
 
  • Like
Reactions: dickta

ImjuzCY

Senior Member
Jun 14, 2012
531
139
Kuala Lumpur
OOS supports 4K 60fps video capture, but LOS seem to max out at 30fps for 4K video. I tried on OpenCamera and MJL Gcam port.

OpemCamera won't let you choose 4K if 60fps (or above) is selected, Gcam can let you choose 4K 60fps but the captured video is only 30fps.

@LuK1337 I know you're looking into LOS 18.1, but I think this is worth some attention too.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 74
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][enchilada][10] LineageOS 17.1, ROM for the OnePlus 6

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2019-09-12
    Last Updated 2020-04-01
    24
    And one more bug: the system alarm isn't working. Almost overslept this morning ?
    The more sleep the better.
    23
    I wonder what is fixed in the sept 25 build
    Me too.
    21
    Btw I uploaded new build, don't expect any device specific fixes tho.
    19
    I uploaded a single Q based build before disappearing again, have fun.

    Here are some minimalistic instructions:
    $ fastboot boot twrp-3.3.1-16-enchilada-Pie-mauronofrio.img
    $ adb shell twrp sideload
    $ adb sideload OnePlus6Oxygen_22_OTA_042_all_1912142031_0fb330.zip
    $ adb reboot bootloader
    $ fastboot boot twrp-3.3.1-16-enchilada-Q-mauronofrio.img
    $ adb shell twrp sideload
    $ adb sideload OnePlus6Oxygen_22_OTA_042_all_1912142031_0fb330.zip
    $ adb reboot bootloader
    $ fastboot boot twrp-3.3.1-16-enchilada-Q-mauronofrio.img
    $ adb shell twrp sideload
    $ adb sideload <lineage>
    $ adb reboot bootloader
    $ fastboot boot twrp-3.3.1-16-enchilada-Q-mauronofrio.img
    $ adb shell twrp sideload
    $ adb sideload <gapps>
    $ adb reboot