[ROM][OFFICIAL][enchilada][11] LineageOS 18.1

Search This thread

darksx

Senior Member
Dec 19, 2014
225
83
Will it be safe to let the phone install OTA update in settings or is it advisable to do it manually? Please reply.
If you followed official instructions and you are using Lineage recovery you can you OTA without problems,and if you using twrp then you must update manually
 
  • Like
Reactions: sid4306

ozrex

Member
Aug 7, 2008
5
2
Is anyone using Android Auto? It seems like USB audio routing is not working as the audio is still played through my phone when I connect it to the car. There's no other output device to select.
Tried it with another phone and it worked fine.
I had this, from memory, I had to go to Settings -> Apps -> See All Apps -> Android Auto -> Permissions and enable them, specifically I think the Microphone permission is the one that fixed it.
 
  • Like
Reactions: nozz93

ashutosh_13

New member
Dec 26, 2008
3
0
When I take a picture (GCam or LOS Stock) sometimes I can not find that picture at the gallery anymore.

I tried updating LOS but the problem persists.

Using the firmware version 10.3.9 and MindTheGapps.
Yes this is a known issue with andriod 11.These pictures are visible in file manager.Do see it in gallery app i changed the name of the files in batch mode.After that i see them..Simple copy paste of files to some other folder also did the trick
 
Nov 14, 2015
5
0
Hello!
I want to flash firmware 10.3.9 on my OP6 as described here prior to upgrading from 17.1 to 18.1. But I'm running into a problem:

Code:
➜ extracted_20210517_205615: adb --version
Android Debug Bridge version 1.0.41
Version 31.0.2-7242960
Installed as /home/user/adb-fastboot/adb

➜  extracted_20210517_205615: sudo $(which fastboot) --version
fastboot version 31.0.2-7242960
Installed as /home/user/adb-fastboot/fastboot

➜  extracted_20210517_205615: adb devices
List of devices attached
b16f6d7a        device

➜  extracted_20210517_205615: adb reboot bootloader

➜  extracted_20210517_205615: sudo $(which fastboot) devices
b16f6d7a        fastboot

➜  extracted_20210517_205615: ll abl.img
-rwxr-xr-x 1 user user 204K May 17 20:56 abl.img

➜  extracted_20210517_205615: sudo $(which fastboot) flash --slot=all abl abl.img
fastboot: error: Could not check if partition abl has slot all # <------------- that's the problem

Any ideas how to solve this?
 

tiga016

Senior Member
May 20, 2015
226
38
Yes this is a known issue with andriod 11.These pictures are visible in file manager.Do see it in gallery app i changed the name of the files in batch mode.After that i see them..Simple copy paste of files to some other folder also did the trick
Try using Simple Gallery app.
 

keelsonkeelson

Senior Member
Aug 5, 2012
114
34
Nvidia Shield Tablet
OnePlus 6
Hello!
I want to flash firmware 10.3.9 on my OP6 as described here prior to upgrading from 17.1 to 18.1. But I'm running into a problem:

Code:
➜ extracted_20210517_205615: adb --version
Android Debug Bridge version 1.0.41
Version 31.0.2-7242960
Installed as /home/user/adb-fastboot/adb

➜  extracted_20210517_205615: sudo $(which fastboot) --version
fastboot version 31.0.2-7242960
Installed as /home/user/adb-fastboot/fastboot

➜  extracted_20210517_205615: adb devices
List of devices attached
b16f6d7a        device

➜  extracted_20210517_205615: adb reboot bootloader

➜  extracted_20210517_205615: sudo $(which fastboot) devices
b16f6d7a        fastboot

➜  extracted_20210517_205615: ll abl.img
-rwxr-xr-x 1 user user 204K May 17 20:56 abl.img

➜  extracted_20210517_205615: sudo $(which fastboot) flash --slot=all abl abl.img
fastboot: error: Could not check if partition abl has slot all # <------------- that's the problem

Any ideas how to solve this?
Use fastboot from lineageos recovery, not fastboot from bootloader. It's in the instructions, read them again. Ran into the same issue...
 
Nov 14, 2015
5
0
Use fastboot from lineageos recovery, not fastboot from bootloader. It's in the instructions, read them again. Ran into the same issue...
There is no "Enter Fastboot" option under "Advanced", though :/
los_rec.png


Solved:

I just upgraded LOS first to 18.1. There I also had the fastboot option in Recovery Mode and then I updated the firmware.
 
Last edited:

aHcVolle

Senior Member
Nov 3, 2010
427
247
Stuttgart
I'm still having connection issues after updating to the 10.3.11 firmware. One day it's working fine, the next day all connections (cellular + Wi-Fi) regularly lose connection (WiFi disconnects, cellular shows no signal) for a few seconds.
Got the same problem on 10.3.9 (had installed 10.3.10 earlier). haven't found a fix yet, even resetting with the msmtool...
 
Jan 8, 2014
22
5
Is it possible to change the Power Menu layout?
With 18.1 the Power Menu entries are no longer below each other and shown in full, but in a single row at the top of the screen.
If there are more than three entries, all other entries are hidden behind a three dots menu, although there's more than enough space on the screen.

Would it be possible to order the entries from top to down or in rows filling up available space instead of that rather impractical three dots menu?
 

lidor546

Member
Jan 23, 2013
36
0
Hi everyone
I have some questions about the ROM
I am with lineage 17.1 with magiak
how do I update?
Did the 18.1 better than the 17.1?
Thanks allot 🙃😄😁
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I'm still having connection issues after updating to the 10.3.11 firmware. One day it's working fine, the next day all connections (cellular + Wi-Fi) regularly lose connection (WiFi disconnects, cellular shows no signal) for a few seconds.
    1
    It works fine for me. Yo

    It works fine for me on the latest build. Make sure you're on 10.3.9 firmware. 10.3.10 has wifi issues.
    What about 10.3.11?
    1
    Did you instal hide probs module an are you passing safetynet ?
    Thanks for the help,I fix it😁😁
    1
    Fixed the issue by replacing the charging cable .. it was cable fault ... I Think so .. 😬..

    The next thing is I need to install magisk .. but I'm already running on this rom.. is it possible to flash magisk again..??? If yes what's the right procedure to do ???
    Well just reboot to lineage recovery and apply update from adb and sideload magisk,and when you reboot to system just install magisk as apk
    1
    Hi friends,how is the battery life of this rom.Can i use banking apps with this?please reply
    A bit more than 6h of screen at home with wifi, a bit less out.
    I'm using banking apps, three of them, without problems with Magisk Hide.
  • 22
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • WFD
    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    9
    ofcause i want los 18.1 by luk1337.
    me too
    3
    If anybody is curious, Ive been crawling through the code commits. Unfortunately, it looks like both Enchilada and Fajita will have to wait for some time due to issues that were encountered when booting. At least for Fajita. It will be some time until we get our first official build.

    UPDATE 1: Both Enchilada and Fajita have been reverted from the hudson branch, which indicates official commit status has been reversed. Our savior Luk has got hands full with work on these issues I imagine, so wait times will extend. Hang tight lads! We will land on Hudson soon, I hope.

    UPDATE 2: That was quick! Seems like Luk figured out the issue for Fajita and has opened a commit to merge fajita to 18.1 official again. Fajita and enchilada are merged to the Hudson branch once again. This is good news, and I am hoping that the enchilada build will be posted and merged on schedule.
    2
    Clean flash, latest OOS, TWRP, LOS 18 in both slots, and Nikgapps and Magisk Modded. It boots, but NFC it´s no working. All the rest in my initial setup works ok. I didn´t try camera at moment.
    With Magisk Canary it doesn´t boot, goes to fastboot mode.
    At first it doesn´t pass Safetynet test. With Magisk Props module it´s ok. (Correction: Magisk props works with Manager Canary app over Magisk Modded, but root it´s lost)
    Thanks dev for your work!