[ROM][OFFICIAL][enchilada][11] LineageOS 18.1

Search This thread

gamertag128

Member
Nov 15, 2021
41
28
Hey guys,

Since OnePlus has finally dropped support for the OP6 I wanted to see if installing LineageOS is still as easy as with my OnePlus One years ago.

The first post isn't quite clear to me. Can anyone point me to a instruction that includes all the steps?

Thanks!

I was in the same situation and used this tutorial with the 20220104 build, because some people had problems with the 20220111 build (updated on it afterwards with no issues). Instead of the microG builds, I downloaded the it directly from the LineageOS website 😄 If you want to use it as an instruction, I would recommend to watch it first and then go thru step by step, because he made some mistakes, which he corrects afterwards. As for the GApps I used "MindtheGApps" as recommend.
 

antonyjr

Member
Jan 16, 2022
33
6
Hey guys,

Since OnePlus has finally dropped support for the OP6 I wanted to see if installing LineageOS is still as easy as with my OnePlus One years ago.

The first post isn't quite clear to me. Can anyone point me to a instruction that includes all the steps?

Thanks!
Follow the official guide. But Please don't flash the Jan 11th nightly build. It's buggy and cause to stuck on bootanimation. Go with 220104 build. That is working really good for me. Or wait for another build this week.
 
  • Like
Reactions: esbeeb and Bart-NL

Spaceoid

Senior Member
Mar 29, 2013
297
98
Dortmund
How long does it take for your phone to connect to your home wifi after you get home? For me, it sometimes takes a minute and I wonder why. Is that to be expected? :) (No big problem though, obviously. Just curious.)
 

antonyjr

Member
Jan 16, 2022
33
6
How long does it take for your phone to connect to your home wifi after you get home? For me, it sometimes takes a minute and I wonder why. Is that to be expected? :) (No big problem though, obviously. Just curious.)
For me in stock rom, the IMEI and baseband would magically disappear and re-appear again after some time or never appear and crash and reboot. With Lineage OS I only seen this very very rarely or never. I think this might be hardware issue. But using Lineage OS for like 3-4 days now, I have seen this issue occur very rarely in my phone(But it did occur to me twice in 3 days, but reboot would fix it or it would repair itself after seconds. But no crashes ever in LineageOS). So for you if in your stock everything works great but you only encounter this in Lineage OS then you can just use Stock or try to fix it or just use LineageOS with these little quirks.

Maybe oneplus screwed up some firmware. We will never know until they release the source which will never happen xD.
 

antonyjr

Member
Jan 16, 2022
33
6
sometimes screen flickering :( is this firmware issue?
I really don't know, It could be hardware issue. These phones are notorious for that. or Maybe Oneplus is deliberately doing something to throttle something like Apple to make use buy new phones. Because IMO OP6 is really good in terms of performance. Why drop support for software when these phones are good in terms of performance.

Have you tried to connect a new display(yes you need to open up your phone to do that) and check if the flickering exists even in the new display? If it exists then the problem might be firmware/os or the motherboard itself. Because things like these which occurs randomly are very very hard to debug.

But I'm no expert in electronics or circuits.

I will stop here since the discussion is going off-topic and I'm really stupid with respect to electronics, so all I said is just my 2 cents not to be taken as verdict. Thanks.
 

antonyjr

Member
Jan 16, 2022
33
6
But I have been using LineageOS nightly 220104 build and it works very good. Never going back to stock. No issues with IMEI or baseband anymore. Wifi and Data working flawless. But sometimes I can see the network just disappear but it will reappear in less than 10 seconds (This occurs very rarely though, I can't pinpoint the issue yet, it might be a corrupt EFS partition which I have backup so let me see, only time will tell).

But when I use internet constantly there is no interruption, in Stock I used to reboot randomly and interrupted network connection with both Wifi and data. The oneplus forums is suggesting it is a hardware issue. But how does LineageOS works flawlessly if it's hardware issue? I have no clue. Maybe it is caused by overheat and LOS seems to keep my phone cool all the time unlike the Stock.
 

Spaceoid

Senior Member
Mar 29, 2013
297
98
Dortmund
Can someone else confirm that his phone takes 10-20 seconds to connect to wifi?
My old Sony took like 3 secs. According to OP forums, this might be an OOS 'issue' (if you want to call it like that), though.
 

Spaceoid

Senior Member
Mar 29, 2013
297
98
Dortmund
I reset my wifi and bluetooth settings (via the settings) and also rebooted my router. Now the connection is made every time in 3 secs, too. So it was either a settings or router issue. Sorry for the confusion.

Edit: After 20 mins, connecting to wifi now takes 20 secs again.
 
Last edited:

madman

Senior Member
Apr 21, 2011
1,637
461
Planet Earth
OnePlus 5
OnePlus 6
I reset my wifi and bluetooth settings (via the settings) and also rebooted my router. Now the connection is made every time in 3 secs, too. So it was either a settings or router issue. Sorry for the confusion.

Edit: After 20 mins, connecting to wifi now takes 20 secs again.
20 secs seem reasonably fast to me but if you really need it as fast as you can maybe try toggling this setting in developer options.
"WiFi Scan Throttling".

As the name suggests, android generally throttles how fast it should scan for networks to save power but I guess you can make that tradeoff?
 

Spaceoid

Senior Member
Mar 29, 2013
297
98
Dortmund
20 secs seem reasonably fast to me but if you really need it as fast as you can maybe try toggling this setting in developer options.
"WiFi Scan Throttling".

As the name suggests, android generally throttles how fast it should scan for networks to save power but I guess you can make that tradeoff?
Ty for that input! I already tried that option, no change.
And no, I do not 'need' it that fast... The backstory is, at work we operate at 5 GHz, too, and recently my phone lay very close to a 5 GHz antenna with very high output. So now I am wondering if the wifi delay is a software issue or a hardware fault caused at work.

Edit: "Slow" wifi connection (up to 20 sec) only happens with 5 GHz, 2,4 GHz seem to go faster. Might be a remnant of previous 5 GHz problems in OOS...?
 
Last edited:

Bart-NL

Member
Apr 5, 2011
31
8

I was in the same situation and used this tutorial with the 20220104 build, because some people had problems with the 20220111 build (updated on it afterwards with no issues). Instead of the microG builds, I downloaded the it directly from the LineageOS website 😄 If you want to use it as an instruction, I would recommend to watch it first and then go thru step by step, because he made some mistakes, which he corrects afterwards. As for the GApps I used "MindtheGApps" as recommend.
Thanks... I'll try it with a regular ROM since I don't mind some Google stuff..

Currently I'm still messing around with drivers while in Fastboot mode.. Can't get them installed...
 
  • Like
Reactions: gamertag128

gamertag128

Member
Nov 15, 2021
41
28
Thanks... I'll try it with a regular ROM since I don't mind some Google stuff..

Currently I'm still messing around with drivers while in Fastboot mode.. Can't get them installed...
It can be a bit of a struggle to get it done, but as of now, I can say it was fully worth it. It took me about a day to get adapted and I'm just happy to be able to receive further updates 😄
 

antonyjr

Member
Jan 16, 2022
33
6
I'm getting qualcom crash dump frequently and randomly. But reboot just fixes it. What is happening? is it software issue or hardware?

I'm going to get a logcat to see if I could pinpoint the moment it crashes.

Using Lineage OS (Built from source and self-signed), the bootloader is re-locked with lineage os and working fine. OnePlus 6 Enchilada. I think I had no crashes with official lineage os build 220104 with the bootloader unlocked.
 

Spaceoid

Senior Member
Mar 29, 2013
297
98
Dortmund
Same here. I haven't figured it out why yet.

Just to gather some data (and because I have some free time right now) I chose to sweep to the 5 GHz channels manually in my router settings and take the time it takes to connect the phone to wifi.
Interestingly, lower channels (e.g. 36 and 40) get connected near-instantly (takes like 3 seconds), while higher channels (e.g. 60 or 116) take up to 10-15 seconds.
At this point I am not sure anymore if this is something like a small bug or just normal behaviour, as it is so constant and reproducable. Also, ofc. I can totally live with that behaviour.

Edit: Still, my old Sony connects to all possible channels within 2-3 seconds, so there is a difference.
 
Last edited:
  • Like
Reactions: gamertag128

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

    MindTheGapps-11.0.0-arm64-20220217_100228.zip

    The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
    a terrible mistake i tried again with Mindth gapps 11 no error everything is great ! Thank a lot
    1
    Did you reboot to recovery after LOS installation and before Gapps installation? Also, did you choose the Gapps for the right Android version? Someone in the LOS-19-thread had issues bc of that.
    1
    I tried many times with nikk gapps,opengapps,mindth gapps Mindth gapps I use version MindTheGapps-10.0.0-arm64-20220224_161733.zip all installed via lineageos recovery following the
    step-by-step instructions in the wiki,after copying partition~Reboot to recovery format...~install los os~reboot recovery~install gapps.
    I followed the wiki rom before and it worked great and never had an error.
    I get the error message E: ca'nt mount...and failed I can't remember the error because the image couldn't be captured.I'm currently on Oxygenos 11.1.1
    Thank a lot for reply me
    If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

    MindTheGapps-11.0.0-arm64-20220217_100228.zip

    The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
    1
    If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

    MindTheGapps-11.0.0-arm64-20220217_100228.zip

    The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
    I will try again tonight with Mindth gapps 11 Take a picture of the installation process if there is an error
  • 36
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    8
    Guys I was checking out the gerrit and found something to be excited about.


    If I interpret it right, we should be included in the initial batch of devices being promoted to 19.1 🥳 and Luk1337 is probably staying our Maintainer.
    6
    Dear Forum, i plan to switch my OP6 back to LOS as well.
    Back, because once i bought it some years ago, i was running LOS on it, but then switched to OOS, due to some struggles (and it was the first phone since the good old Motorola Milestone, where CyanogenOS gave me Froyo for the first time :D ).
    I don't need root or anything extraordinary, just LOS and Google apps. my Question: will the build in updater work and preser Gapps during updates? In the past due to A/B Layout, i always had to go to recovery, flash update and gapps, reboot into Recovery, flash gapps again, to no loose them.
    And on my OP3 the builtin Updater is not working, i always have to flash manually through TWRP ;(
    Thanks in advance!
    GAPPS are preserved. If you dont need anything fancy, then also just use LineageOS recovery. This will most probably also fix your update isues on OP3.
    Also had a OP3 before and LOS recovery worked flawless.

    Slightly "offtopic":
    I was kind of afraid that our OP6 support was dropped, because nothing happened on the LineageOS Gerrit regarding our device. But Lukasz jsut pushed a whole lot of commits. So Android 12 seems inbound! (Whenever LOS team decides to release)
    4
    I always update via OTA. I always have to patch a new boot.img with Magisk and install via fastboot, but Gapps are kept.
    No need for fastboot. Go into the Magisk app before installing the OTA, click on Uninstall Magisk, then Restore Images. Now install the OTA via the built in updater. Once the OTA update is installed, do not reboot. Go back into the Magisk app. Click on Install Magisk, select Install to Inactive Slot (After OTA), and only then reboot.

    Full instructions can be found here: https://topjohnwu.github.io/Magisk/ota.html