[ROM][OFFICIAL][enchilada][11] LineageOS 18.1

Search This thread

madman

Senior Member
Apr 21, 2011
1,630
457
Planet Earth
OnePlus 5
OnePlus 6
@LuK1337 It is possible to get something similar to this commit for OP6?

It will be a pretty great QoL improvement as there have been many times I connect phone for charging and it was not Dash Charging and only way for me to check was to check in app like Ampere or wait a while to realize its charging very slow. The above commit from cheeseburger/dumpling is very handy as it shows on lock screen.
 

Jdouchebag

New member
Jan 25, 2022
1
0
I switched to lineage after the end of support.
Everything was working fine, apart from the calls, I hear the interlocutors very well but for them there are cuts in my voice.
I went back to OOS and everything was back to normal.
I'm very disappointed, does anyone have an idea how to solve this?
 

esbeeb

Member
Jan 25, 2022
6
2
Huawei Nexus 6P
This isn't a conventional solution, but for what it's worth... myself, I virtually never make POTS voice phone calls any longer, only voice calls within Signal or WhatsApp. If I'm stuck with no wifi/data, only cellular coverage, then I prefer SMS.

The only few voice calls I make every year, are a few to government agencies (taxes, healthcare, etc). Those calls are important! SMS definitely needs to work, to receive various login codes (2FA, or when a new app is installed, and they want to verify the cellular number).
 

gamertag128

Member
Nov 15, 2021
38
25
It could be a carrier problem. I use the Google Phone App, VoWiFi & VoLTE disabled, carrier: Telefonica (Germany) without Band 20 (because I have the CN-Version of the Phone). Made some calls, which where a few hours each and except of the typical call drop every 2 hours, had no issues.
 
Last edited:

Spaceoid

Senior Member
Mar 29, 2013
296
98
Dortmund
Does your phone, while charging, sometimes show "Charging slowly" instead of just "Charging"? Maybe it's a faulty charging cable on my side.
 

ricky0007

Member
Jun 23, 2010
8
0
Honor 6X
Hi

I installed the lineageos recovery, I would like to go back to twrp but impossible to install it => neither in fastboot mode nor with the slideload of the lineageos recovery! error message!

If anyone has any idea thank you
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Now it is official 🥳View attachment 5598481

    and when I was digging in the Gerrit, I found something interesting. I'm not sure, if it is allowed on lineage, or if we will be supported but here we go: Face Unlock?

    hardware/oplus repo is for OnePlus/Realme Android 12+ devices, so this is not going to be used on legacy OnePlus such as this one.
    Also, this change was related to OnePlus 10, and turned out to not be necessary anyway because it's not using HIDL for face HAL.
    2
    Now it is official 🥳
    Screenshot_20220426-032550_Chrome~2.png


    and when I was digging in the Gerrit, I found something interesting. I'm not sure, if it is allowed on lineage, or if we will be supported but here we go: Face Unlock?

    2
    If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

    MindTheGapps-11.0.0-arm64-20220217_100228.zip

    The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
    a terrible mistake i tried again with Mindth gapps 11 no error everything is great ! Thank a lot
    1
    With my Oneplus 6, LOS 18.1 I tried to restore root and ran into bootloop. The phone would show the LOS logo for a while and then reboot.

    As I did not have a backup (don't ask!), I was fiddeling around with different options. Something was wrong with /data or/and /system. Finally the following procedure helped to restore system and data:

    1. adb boot twrp-3.5.2_9-0-enchilada (3.6 did not work for me)
    2. TRWP: Enter Password to decrypt Data
    3. Backup All Partitions with TWRP (actually only Data was relevant, I activated Enable compression)
    4. Copy Backup Files from TWRP Dir to PC
    5. adb pull /sdcard sdcard (to backup internal storage)
    6. Wipe Data, System, Dalvik, format System and Data.
    7. adb boot twrp-3.5.2_9-0-enchilada (to remount System)
    8. Wipe Cache/ Dalvik
    9. copy LOS and TWRP Image from PC to internal storage
    10 Install LOS Image
    11. TWRP advanced: Install Recovery RamDisk using TWRP Image
    12. Reboot to system (make sure to use the updated slot)
    13. Basic setup of LOS (disable screen lock!)
    14. reboot to recovery
    15. Copy Backup Files (see 4.) from PC to TWRP dir on internal storage
    16. adb push sdcard / (this will recover internal storage from Path on PC to internal storage root. Same file as in 5. Make sure you don't push to some subdir)
    17. Restore Data partition from Backup File
    18. Copy and Flash Magisk-v24.1.apk
    19. Copy and Flash MindTheGapps-11.0.0-arm64-20220217_100228 (!) - I think this was actually fixing boot loop
    20. Wipe Cache/ Dalvik
    21. Reboot to system (on first boot things looked really messy
    22. Reboot to system - et voila, apps, settings, data are back at work.

    Had to reinstalls Signal and BikeCiticens from PlayStore. Unfortunately no backup from Signal. Magisk still does not work with root, even though it was ok on step 13. Will do a fresh TWRP Backup and retry.
    Your post just was a real life saver: slightly different ROM (Jaguar) but the exact same situation - incl. the "don't ask!" part :eek:
    Thanks for your detailed description
    1
    I've been out of the loop for a while and I'm still on lineageOS 17.1 and would like to upgrade to lineageOS 19. What's the easiest way to do this? I would also like to have magisk and root.
    Seriously, just a few posts above yours...
  • 36
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    8
    Guys I was checking out the gerrit and found something to be excited about.


    If I interpret it right, we should be included in the initial batch of devices being promoted to 19.1 🥳 and Luk1337 is probably staying our Maintainer.
    6
    Dear Forum, i plan to switch my OP6 back to LOS as well.
    Back, because once i bought it some years ago, i was running LOS on it, but then switched to OOS, due to some struggles (and it was the first phone since the good old Motorola Milestone, where CyanogenOS gave me Froyo for the first time :D ).
    I don't need root or anything extraordinary, just LOS and Google apps. my Question: will the build in updater work and preser Gapps during updates? In the past due to A/B Layout, i always had to go to recovery, flash update and gapps, reboot into Recovery, flash gapps again, to no loose them.
    And on my OP3 the builtin Updater is not working, i always have to flash manually through TWRP ;(
    Thanks in advance!
    GAPPS are preserved. If you dont need anything fancy, then also just use LineageOS recovery. This will most probably also fix your update isues on OP3.
    Also had a OP3 before and LOS recovery worked flawless.

    Slightly "offtopic":
    I was kind of afraid that our OP6 support was dropped, because nothing happened on the LineageOS Gerrit regarding our device. But Lukasz jsut pushed a whole lot of commits. So Android 12 seems inbound! (Whenever LOS team decides to release)
    4
    I always update via OTA. I always have to patch a new boot.img with Magisk and install via fastboot, but Gapps are kept.
    No need for fastboot. Go into the Magisk app before installing the OTA, click on Uninstall Magisk, then Restore Images. Now install the OTA via the built in updater. Once the OTA update is installed, do not reboot. Go back into the Magisk app. Click on Install Magisk, select Install to Inactive Slot (After OTA), and only then reboot.

    Full instructions can be found here: https://topjohnwu.github.io/Magisk/ota.html