[ROM][OFFICIAL][enchilada][11] LineageOS 18.1

Search This thread

LuK1337

Recognized Developer
Jan 18, 2013
8,711
17,511
Samsung Galaxy S III I9300
Moto G 2014
Now it is official 🥳View attachment 5598481

and when I was digging in the Gerrit, I found something interesting. I'm not sure, if it is allowed on lineage, or if we will be supported but here we go: Face Unlock?

hardware/oplus repo is for OnePlus/Realme Android 12+ devices, so this is not going to be used on legacy OnePlus such as this one.
Also, this change was related to OnePlus 10, and turned out to not be necessary anyway because it's not using HIDL for face HAL.
 

Dreyn

Member
Dec 24, 2010
8
0
OnePlus 6
I've been out of the loop for a while and I'm still on lineageOS 17.1 and would like to upgrade to lineageOS 19. What's the easiest way to do this? I would also like to have magisk and root.
LOS 19 has just been announced, but no builds are publicly available for now AFAIK
When they arrive, you should be OK by following the instructions from the official LOS wiki (https://wiki.lineageos.org/devices/enchilada/)
 

diemadedrei

Senior Member
Mar 13, 2012
680
253
OnePlus 6
Google Pixel 6 Pro
  • Love
Reactions: sid4306

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
Sounds good, but apparently not true in all cases: I'm currently running on latest Stock OOS 11.1.x with maoronofrio's TWRP 3.4.0-1 as recovery.
Trying to boot into LOS recovery (V 18.1-20220412) sends the device to the black "1+ Fasboot Mode" screen where it sits forever.
I'll try the remainder of the installation instructions based on my existing TWRP recovery. Fingers crossed it'll work...
from OOS 11.1 to los os bootlop you were right
 
Last edited:

esbeeb

Member
Jan 25, 2022
9
5
Huawei Nexus 6P
I can acknowledge that the Apr. 21st update installed without any obvious problems. My Android Security update was bumped to April 5, 2022.

Thank you, LineageOS devs! :)
 

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
please help me
i can't install google gapps for lineage version-18.1-20220421-nightly-enchilada-signed i tried going back to stock rom with version 11.2.2 and 11.1.1 then reinstall los os but still no gapps after install even though i did it right according to wiki
 
Last edited:

Spaceoid

Senior Member
Mar 29, 2013
364
133
Dortmund
Did you reboot to recovery after LOS installation and before Gapps installation? Also, did you choose the Gapps for the right Android version? Someone in the LOS-19-thread had issues bc of that.
 
  • Like
Reactions: kecodoc

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
Did you reboot to recovery after LOS installation and before Gapps installation? Also, did you choose the Gapps for the right Android version? Someone in the LOS-19-thread had issues bc of that.
I tried many times with nikk gapps,opengapps,mindth gapps Mindth gapps I use version MindTheGapps-10.0.0-arm64-20220224_161733.zip all installed via lineageos recovery following the
step-by-step instructions in the wiki,after copying partition~Reboot to recovery format...~install los os~reboot recovery~install gapps.
I followed the wiki rom before and it worked great and never had an error.
I get the error message E: ca'nt mount...and failed I can't remember the error because the image couldn't be captured.I'm currently on Oxygenos 11.1.1
Thank a lot for reply me
 
Last edited:

Spaceoid

Senior Member
Mar 29, 2013
364
133
Dortmund
I tried many times with nikk gapps,opengapps,mindth gapps Mindth gapps I use version MindTheGapps-10.0.0-arm64-20220224_161733.zip all installed via lineageos recovery following the
step-by-step instructions in the wiki,after copying partition~Reboot to recovery format...~install los os~reboot recovery~install gapps.
I followed the wiki rom before and it worked great and never had an error.
I get the error message E: ca'nt mount...and failed I can't remember the error because the image couldn't be captured.I'm currently on Oxygenos 11.1.1
Thank a lot for reply me
If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

MindTheGapps-11.0.0-arm64-20220217_100228.zip

The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
 
  • Like
Reactions: kecodoc

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

MindTheGapps-11.0.0-arm64-20220217_100228.zip

The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
I will try again tonight with Mindth gapps 11 Take a picture of the installation process if there is an error
 
  • Like
Reactions: Spaceoid

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
If I am not mistaken, then for LOS18 you need to use the MindTheGapps version

MindTheGapps-11.0.0-arm64-20220217_100228.zip

The one you used, according to your post, is meant for Android 10 and therefore LOS17. That is the way I understand it.
a terrible mistake i tried again with Mindth gapps 11 no error everything is great ! Thank a lot
 

fred_gaou

Senior Member
Jul 25, 2014
384
159
Here and there
OnePlus 6
Does anyone keep updating lineage 18.1 ? Only v19 is available on their site.

Can someone test Remote debugging WebViews on this ROM ? I need to know if the issue I have is related to my ROM or Android 11 or LOS code.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    8
    Guys I was checking out the gerrit and found something to be excited about.


    If I interpret it right, we should be included in the initial batch of devices being promoted to 19.1 🥳 and Luk1337 is probably staying our Maintainer.
    6
    Dear Forum, i plan to switch my OP6 back to LOS as well.
    Back, because once i bought it some years ago, i was running LOS on it, but then switched to OOS, due to some struggles (and it was the first phone since the good old Motorola Milestone, where CyanogenOS gave me Froyo for the first time :D ).
    I don't need root or anything extraordinary, just LOS and Google apps. my Question: will the build in updater work and preser Gapps during updates? In the past due to A/B Layout, i always had to go to recovery, flash update and gapps, reboot into Recovery, flash gapps again, to no loose them.
    And on my OP3 the builtin Updater is not working, i always have to flash manually through TWRP ;(
    Thanks in advance!
    GAPPS are preserved. If you dont need anything fancy, then also just use LineageOS recovery. This will most probably also fix your update isues on OP3.
    Also had a OP3 before and LOS recovery worked flawless.

    Slightly "offtopic":
    I was kind of afraid that our OP6 support was dropped, because nothing happened on the LineageOS Gerrit regarding our device. But Lukasz jsut pushed a whole lot of commits. So Android 12 seems inbound! (Whenever LOS team decides to release)
    4
    I always update via OTA. I always have to patch a new boot.img with Magisk and install via fastboot, but Gapps are kept.
    No need for fastboot. Go into the Magisk app before installing the OTA, click on Uninstall Magisk, then Restore Images. Now install the OTA via the built in updater. Once the OTA update is installed, do not reboot. Go back into the Magisk app. Click on Install Magisk, select Install to Inactive Slot (After OTA), and only then reboot.

    Full instructions can be found here: https://topjohnwu.github.io/Magisk/ota.html