[ROM][OFFICIAL][enchilada][12] LineageOS 19

Search This thread

Zeti2000

Member
Aug 13, 2022
9
0
But I have another problem! My hotspot is not working… how I can fix this problem? Other devices can’t find my phone, hotspot nor usb sharing internet. Before I installed LOS, it was working just fine on Android. Is there a fix for it?
 

Spaceoid

Senior Member
Mar 29, 2013
364
133
Dortmund
Today I again received two SMS for which I did not reveive any notification. I just saw them upon opening my (stock) SMS app. So my workaround posted above seems not to work completely. Maybe I'll try a different SMS app.

Edit: I did some further research. Apparently the workaround I posted a little further above IS in fact working, it just has to be re-applied after every LOS update. So, for now it seems to be up to the user to either whitelist the stock SMS app from doze after every update via ADB, or to switch the standard SMS app completely.
Edit2: It seems that whitelisting the stock SMS app in fact DOES survive updates. My SMS app STIILL got shut down by doze mode, though. Which probably leaves switching to a non-stock SMS app the only solution for reliable SMS reception at the moment.
 
Last edited:
  • Like
Reactions: sid4306

lupastro82

Senior Member
Jul 16, 2018
76
8
Will be my preferred CR if support faceunlock.
Atm i still continue to use los or AOSP fork.

Is sadness 🥲😅
 

falcodx

Member
Apr 8, 2013
36
4
OnePlus 6
Hi all, since yesterday I'm experiencing a wierd behavior of media Playback (audio or video): Infrequently it stucks, freezes or stutters, depends on how long it lasts.
It happens on any platform and hardware like YouTube, audiobook app, Bluetooth headphones, phone speaker, etc . No difference.
Telephone call tests seems normal so far
Someone experienced something like this before?
Even after trying upgrading to latest nightly did not fix this..
 

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
I'm on version 19-20220802-NIGHTLY-enchilada and can't update after downloading the new version I got an error that the update system was stopped and exited like the picture I sent.
What do I need to do to update to the new version without causing errors?
Thank you very much
after i restarted my phone everything was updated.
 

Attachments

  • Screenshot_20220819-080604_Trebuchet.png
    Screenshot_20220819-080604_Trebuchet.png
    1.4 MB · Views: 45

simsim8791

New member
Aug 19, 2022
1
0
hello

how is the autonomy with this ROM ?
with the last version of the offical one plus i'm arround 1 day with low usage and it's hard to do intense usage without a power bank to be safe for a day

thanks
 

lm089

Senior Member
Highly depends on how you use the phone, and on the current state of the battery. For me on a usual workday with not too much playing around, no videos, just wifi connection, some emails, messages and phone call the phone consumes between 1.5 and 2% per hour (according to GSam). On other days it can get up to 2.5% / hr. As far as I remember figures were similar with the latest stock ROM version, maybe slightly higher.
I often use the phone for GPS tracking on bike trails. Power consumption is much higher then, but I still can easily complete an 10 hr trail (with breaks, I'm not Lance Armstrong :D) without recharging.
If you're heavy player or video watcher, and constant user of mobile data figures will be much higher of course
 

kecodoc

Senior Member
Apr 29, 2011
583
68
HaiPhong
OnePlus 6
Please help
i'm rooted and ok google function on my device is not working is there anything i can do to fix it? I can't find an option to hold down the home key to turn on the assistant please help thank a lot !
 

esbeeb

Member
Jan 25, 2022
9
5
Huawei Nexus 6P
I just did an upgrade to the latest weekly enchilada (to get the August Security updates especially), and all seemed to go smoothly. (The wireless hotspot feature also means a lot to me, working smoothly... and I'm using it successfully to make this post).

Much appreciated for your kind work, @LuK1337 !
 
  • Like
Reactions: Spaceoid

Zeti2000

Member
Aug 13, 2022
9
0
I upgraded also to the latest update but still the hotspot is not working for me.
 
Last edited:

wordlesswind

Member
May 19, 2016
8
2
It may really be tough to address something when I get feedback 2 weeks later. Join the IRC channel if you care about getting it fixed.
It seems Libera.Chat has stricter requirements for access from the Chinese mainland (must have SASL), but I don't have an nickname, and requiring SASL also means I can't get into the server to register.
 

Zeti2000

Member
Aug 13, 2022
9
0
That's not "hotspot", but "USB tethering".
Check
a) Settings -> Network and Internet -> Hotspot and tethring -> USB tethering
b) the popup when plugging in the USB cable
c) the USB cable itself
Umm… I’v done that every time but my pc can’t connect to internet via USB. I also understand the differences between hotspot and USB tethering. Neither one of those are working.
 

Top Liked Posts

  • 2
    I have used my OP6 on AT&T off and on over the years and never had any problem, I never heard anything about AT&T blacklisting this phone until I saw your post but I see people were posting about it. My OP6 is on AT&T towers through Pure Talk right now and the sms, mms and data, VoLTE work fine. I have always used Straight Talk or Pure Talk, etc.. never gone directly through AT&T but only their towers through secondary carriers like these. Pretty strange AT&T won't support it but it works just fine on their towers through a MVNO :p

    As insignia96 said on reddit: "The way they are scamming unsuspecting consumers into buying new phones with these patently false claims about them "not supporting HD Voice" should be a crime. It's 100% false and they know it."
    So, all I did was chat with someone at AT&T, told them I needed my data turned on and the did something on their end...... It works fine now 🤷
    1
    Has anyone figured out how to get this phone to work on AT&T? I can get/make calls and texts but the data doesn't work. I know AT&T sucks and they blacklisted this phone but I figured that someone would've found a workaround by now, no?
    I have used my OP6 on AT&T off and on over the years and never had any problem, I never heard anything about AT&T blacklisting this phone until I saw your post but I see people were posting about it. My OP6 is on AT&T towers through Pure Talk right now and the sms, mms and data, VoLTE work fine. I have always used Straight Talk or Pure Talk, etc.. never gone directly through AT&T but only their towers through secondary carriers like these. Pretty strange AT&T won't support it but it works just fine on their towers through a MVNO :p

    As insignia96 said on reddit: "The way they are scamming unsuspecting consumers into buying new phones with these patently false claims about them "not supporting HD Voice" should be a crime. It's 100% false and they know it."
  • 2
    I have used my OP6 on AT&T off and on over the years and never had any problem, I never heard anything about AT&T blacklisting this phone until I saw your post but I see people were posting about it. My OP6 is on AT&T towers through Pure Talk right now and the sms, mms and data, VoLTE work fine. I have always used Straight Talk or Pure Talk, etc.. never gone directly through AT&T but only their towers through secondary carriers like these. Pretty strange AT&T won't support it but it works just fine on their towers through a MVNO :p

    As insignia96 said on reddit: "The way they are scamming unsuspecting consumers into buying new phones with these patently false claims about them "not supporting HD Voice" should be a crime. It's 100% false and they know it."
    So, all I did was chat with someone at AT&T, told them I needed my data turned on and the did something on their end...... It works fine now 🤷
    2
    I just updated my enchiada to the 20221115 build yesterday (especially to get my security string bumped to 2022-11-05). No obvious issues seen yet.
    1
    Trying to install for 3 times (error, MSM tool, update to oos11, lineage recovery, ROM), did follow the instrutions line by line, always failed to install. I quit... (did also tryed with other ROMs)
    What type of error did you get ?
    Have you tried with ROM and GAPPS previously stored in TWRP, instead of sideload method?
    1
    I am trying to get VoLTE working on my OnePlus 6, do you have any suggestion?
    The smartphone is rooted using Magisk.

    I tried to load my carrier profiles from other Snapdragon 845 devices using QPST Advanced PDC Tool, but nothing gets loaded after the app refresh. I am trying to understand this topic in depth if needed but I was not able to find detailed information for the low level details.

    Here https://github.com/MaurizioCasciano/Snapdragon-845-VoLTE there is my git repository to keep track of this work/study and the extracted MBN configurations from other devices using the same soc.

    Any additional detail or link is highly appreciated.

    Thanks for this ROM that is way better than the original firmware.
    This is how I did it a long time ago. Deleting the mentioned config was essential as far as I remember, as it somehow defaulted back to it all the time. But don't quote me on that. It's almost a year :D
    1
    You could try siddk's version which is marked, as Twrp-3.7.0_12. I recently updated from my existing twrp-3.6.2_11 without any problems, so far.
  • 46
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    6
    Just did a dirty flash from LOS 18.1 and everything works fine.

    I had to reinstall some Google apps (YouTube, Gmail, Keep, GCam, Photos), as they stopped working after the upgrade (maybe because I accidentally clicked No on the Signature verification failed screen while flashing Gapps and didn't notice, then the OS didn't boot. whoops. So I went back into the recovery and flashed Gapps again. Sure enough, the install went through. So be careful and make sure to click the correct button, lol)

    Everything else seems to work perfectly!

    Thanks again LuK for your work!

    In case anyone with Gapps and Magisk wants to try a dirty flash from 18.1, here are the steps I did:
    (you're on your own if things break! better to do a clean flash! magisk isn't officially supported!)

    1. Restored images in Magisk
    2. Removed PIN and fingerprints
    (Not sure if these first two steps are needed, but did them just in case)
    3. adb reboot sideload
    4. adb sideload lineage-19.1-20220426-nightly-enchilada-signed.zip
    5. Advanced->Reboot to Recovery
    6. Apply Update->Apply from ADB
    7. adb sideload MindTheGapps-12.1.0-arm64-20220416_174313.zip
    8. adb sideload Magisk-v24.3.apk
    9. Back->Reboot system now
    6
    I know this will be slightly off-topic, so sorry in advance; and also, since the development as of know 'only' is done in the common Gerrit for all devices that share our SoC, it might not yet be guaranteed that we'll receive LOS20 in the end; BUT

    In the common Gerrit of all the OnePlus devices that feature the Snapdragon 845, development on LOS20 has begun! Let the hype train start once more! And, in any case, endless gratitude for the brave developers that work on LOS in their valuable freetime...

    Edit 18.09.: Now there's movement also in the Gerrit for our specific device!
    5
    I'm using a single SIM and I see the same thing often. I guess it depends on the amount of icons you have in the status bar. I observed this since the first build
    Change the smallest width to 411 in developer options.
    Before OOS 11 it was set to 411 by default but that changed with OOS11.
    5

    I guess that makes it official. Soon we should be promoted to LineageOS 20 🎉
    Thanks to Luk1337 & Edwin Moquete for their efforts, to support our devices.

    PS. from User to User: If you have the opportunity, feel free to tip them something. I guess it's the best recognition we have, to support their great work.