[ROM][OFFICIAL][enchilada][9] LineageOS 16.0

Search This thread

dumbl3

Senior Member
Apr 19, 2012
353
90
Ty for your answer.
This GCam works fine; idk why selfie os 4mpx but the rest is okay.
Problem with AdAway is that app can't mount system r/w...un using LOS supersu addon.

Why don't you use Magisk. Then you can enable systemless host file in Adaway . Magisk is the better solution anyway, I think LOS even dropped support of the SuperSU addon in favor for Magisk
 
  • Like
Reactions: RobertOrd97

hayvan96

Senior Member
  • Mar 23, 2018
    244
    191
    Why don't you use Magisk. Then you can enable systemless host file in Adaway . Magisk is the better solution anyway, I think LOS even dropped support of the SuperSU addon in favor for Magisk
    No they dropped addonssu in the upcoming 17.1 release because of Android 10, but they're not supporting any specific way of rooting. So it was dropped because of a technical issue, not in favour of Magisk or any other alternative.
    That being said I do use Magisk :)
     

    lepidas

    Senior Member
    Sep 3, 2011
    324
    101
    Athens
    Hi to all!
    I managed to flash this rom, in the system settings it shows phone is encrypted but my question is where is the "To start android enter your pin" when I boot the phone;
    Is it normal this;
    Currently I use a pocophone with LOS and I see this screen before android starts.


    Thank you in advance for any replies
     

    cca310

    Member
    Dec 3, 2016
    39
    3
    I've been using the ROM for a while now. over a year now.

    I installed 03/10/2020 update and when I booted a whole bunch of google services were crashing. I rebooted my phone and now I'm stuck on the boot animation. I let it sit for 10 minutes and it rebooted to the recovery with an error message.
    The message says "Can't load Android system. Your data may continue to get this message, you may ne factory data reset and erase all use da device."
    Obviously this message makes no sense, I think it's getting cutoff so it's missing some words.

    Any ideas on what to try to get this to boot? And is anyone else having any issues similar to this?
     

    nasos79

    Member
    Aug 22, 2010
    15
    1
    Vadstena, Sweden
    Hello everyone.

    I have a pretty strange problem and I wonder if I can get some help from you in here.

    I have an OP6 that runs on Lineage OS 16.0. I also have an OPO, running on the same ROM. I am mentioning this because it is relevant.
    I have used nordVPN with both phones on Lineage 16.0 and it worked absolutely fantastic, until about 2 or maybe 3 weeks ago, when it suddenly became impossible to use VPN.

    The symptoms are:
    Very long lag when trying to open web pages, with any browser (have tried Firefox focus, duckduckgo and chrome. Once the connection is established though, the loading speed is almost ok. But it can take up to 15-20 seconds for the page to even start loading.
    Even longer lags when doing speedtest, with the app. It has even taken 3 minutes trying to connect to the server. Once the connection is made, the speeds are very high, from a 100/10 connection I get like 90/9 while through VPN (98/9,7 without VPN). However, it has even registered speeds as low as 0,6 dl while on VPN.
    Often the connection is totally dead with VPN on, I mean I have to disconnect and reconnect to even get a reaction.

    So, I pretty much don't have internet when I use nordVPN, because most apps don't even see a connection. Spotify for example doesn't even bother waiting longer than the lag (I guess), after a few seconds it gives up and the "no internet connection" text shows up down there.

    I contacted nordVPN support. I spent about 3 hours on their chat, trying all the troubleshooting tricks with them, which I already had tried anyway, because there is a very comprehensive troubleshooting guide on their site. It didn't help.
    Then their advanced technical support contacted me with instructions to use obfuscated servers (didn't solve the problem). I was then encouraged to try and connect to their servers through strongSwan, another vpn client, in order to see if the problem was with their app. The problem persisted though, even with strongSwan, which led both them and me to the conclusion that the problem is on my side.

    Now, the reason why I suspect Lineage is that the problem began on both phones at the same time, and it was after an update. I'd like to mention that I have tried both on my WiFi and on my mobile data, which I guess proves that the problem isn't with my connection either.

    So, I was wondering, can it be something that went wrong with an update? Something that can be fixed at a future update?

    My last resort now is to try a different ROM, which I am not very happy about, because I am very satisfied with Lineage.

    Thank you very much in advance for your time.

    Best regards,

    Nasos
     

    Sepero

    Senior Member
    Dec 11, 2012
    102
    45
    [Running Vanilla LOS, no gapps]

    I'm having really really bad problems with screen touches. Sometimes I have to press the back/home/recents buttons several times to get it to register touch. Other times, I intend to scroll the screen and it will instead register as touch on something.

    I don't have these issues at all on stock OOS

    Anyone else having problems with screen tap/touches?
     

    Sepero

    Senior Member
    Dec 11, 2012
    102
    45
    I made a newbie mistake today and restored a TWRP backup from an earlier security patch. Now, my interal storage is inaccessible and the filenames are gibberish, as expected.

    Is there ANY way possible to recover my internal storage? I never backed it up to another location, and I would really like to get it back.

    I had this problem before. I was able to solve it by flashing back the previously installed system and TWRP. Also try previous TWRP versions.
     

    Sepero

    Senior Member
    Dec 11, 2012
    102
    45
    [Running Vanilla LOS, no gapps]

    I'm having really really bad problems with screen touches. Sometimes I have to press the back/home/recents buttons several times to get it to register touch. Other times, I intend to scroll the screen and it will instead register as touch on something.

    I don't have these issues at all on stock OOS

    Anyone else having problems with screen tap/touches?
    Reply to my own post.

    It seems I accidentally stumbled across a bug in LOS. I believe this has to do with changing the navigation button settings. I was messing with them a lot, trying out all the different variations (left/right/center/others).

    I wiped and reinstalled the system, and it doesn't have touch screen problems anymore.

    I apologize in advance if my bug report isn't good. Thank you for LOS
     

    MaxRabbit

    Senior Member
    Oct 21, 2010
    778
    227
    Austin
    https://forum.xda-developers.com/oneplus-6/development/rom-lineageos-17-0-t3967251/page29
    If anyone like me doesn't regularly check the subforum... Los 17 is available

    ---------- Post added at 08:18 AM ---------- Previous post was at 08:03 AM ----------


    Does this work for you? I have more if it won't do https://www.dropbox.com/s/le9vvhzaf7w2atb/lineage-16.0-20190812-nightly-enchilada-signed.zip?dl=0

    @diemadedrei or anyone else, do you still have a copy of lineage-16.0-20190812-nightly-enchilada-signed.zip that you can share?
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 110
      2okPze5.png


      LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

      Instructions :
      • Download the latest build and gapps
      • Boot to recovery
      • Flash the latest build
      • Boot to recovery again
      • Flash gapps
      • Reboot
      Downloads :
      Reporting Bugs
      • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
      • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
      • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
      • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
      Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

      Code:
      What is your--
      LineageOS version:
      LineageOS Download url:
      Gapps version:
       
      Did you--
      wipe:
       restore with titanium backup:
      reboot after having the issue:
       
      Are you using--
      a task killer:
      a non-stock kernel:
      other modifications:
       
      Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

      XDA:DevDB Information
      [ROM][OFFICIAL][enchilada][9] LineageOS 16.0, ROM for the OnePlus 6

      Contributors
      LuK1337, luca020400
      Source Code: https://github.com/LineageOS

      ROM OS Version: Windows 8 Mobile

      Version Information
      Status: Testing

      Created 2018-09-08
      Last Updated 2019-06-15
      40
      NOTE: Before flashing these builds you have to flash latest Oxygen OS or Hydrogen OS in TWRP twice ( so that both A and B slots are flashed ); Oreo firmware is not supported and will not work on these builds.
      27
      Voila enchilada is official, commits merged.
      Expect a build by tomorrow
      16
      >Last build ~6h ago
      >Have you abandoned the project?
      Yeah obviously, can't you tell we did so?
      12
      I think OTA updates are a challenge for a/b devices like this one. Looking at the procedure how they are flashed manually, I am looking forward to see a way how OTAs achieve the same!

      OTA will be as simple as flashing from the built-in Updater
      Gapps ( or any other package that provides support for addon.d ) will be backed up automatically.
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone