[ROM][OFFICIAL][fajita][11] LineageOS 18.1

Search This thread

MIhaegn

New member
Oct 15, 2019
4
0
Bug:
Contacts delete bug happened again.
Recently I updated my Rom to 4.11 version. When it succeeded I boot in and imported the contacts.
Last night my phone ran out of battery and shut down. I charged it and reboot this morning. I found my contacts all missing.

It happened when I flashed the Rom the last time.
It seems that the first reboot will delete the contacts after update or Rom flash.
 

sohailmm

Member
Nov 7, 2013
43
12
Coming from stock, I have used this ROM for a month now, so till now it works very well, Smooth and fast. There is only one thing i noticed during navigation with GPS on , the mobile gets very hot and the battery runs out quite fast. Otherwise its super sleak

For lineage 18.1 official. I assume its the most recent update form LuK1337 in this thread. If not how can we upgrade to the official one without losing anything. ?
 
Last edited:
  • Like
Reactions: jhedfors

jhedfors

Senior Member
Oct 16, 2009
1,419
700
St Paul, AZ
@snaggen I am guessing there was some problem with the build, as it has now been removed. I was having trouble installing it, and went to reinstall unofficial and the file got corrupted somehow, and I had only backed up data. Fortunately I was able to download the unofficial version again to get back up and running.

@LuK1337, you won't by chance be making a migration build are you? Otherwise, a full wipe it is! Thanks for all your work on this!
 

snaggen

Member
Jan 20, 2011
15
6
Does anyone know what happend to 18.1? Luk reverted this last night:


This commit explains a bit more:

Flattened apexes don't boot up on GSI alike targets. If we somehow manage to drop flattened apexes flag then we can add these back to 18.1.

So, basically the Official 18.1 didn't boot.

It would be interesting to hear some explanation why they need this in the Official build but not the Unofficial, and what to expect forward.
 
  • Like
Reactions: mistersixt

jhedfors

Senior Member
Oct 16, 2009
1,419
700
St Paul, AZ
While I like my 6T with its 128GB storage, this is my first phone without an external SD card. I am finding that that extra storage is of limited use if I have to format data when swapping ROMs - which is necessary when encrypted.

Question:
If I remove encryption with the zip in this post, will taking an OTA update re-encrypt my device?
 
  • Like
Reactions: beamscotty

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Recent update broke the phone ):

    No logs or description? I used the latest update, no problems for me.
    3
    I've installed the latest version, and I'm having trouble with audio through Bluetooth. The sound comes from the phone speaker even when connected to the Bluetooth.
    Same issue here.
    Go to Settings -> Connected Devices -> that little cog wheel next to your Bluetooth device, and then turn off HD audio.
    SBC HD is being turned on by default in this week's fajita build, but not all Bluetooth devices can handle it. If the BT device doesn't work well with it, the audio will end up playing through your phone instead. Some changes have been merged in since to make SBC HD an optional codec instead of being mandatory, so it won't be automatically enabled by default for new devices, but you'll need to wait for next week for those builds.
    3
    I go into bootloader mode and connect from my Linux Mint machine via fastboot. I am not sure what version of fastboot, I will try to check later. I thought that setting did not affect a/b devices as the boot was always overwritten, however I did just install TWRP before trying this update.
    If needed: fw-fajita-10.3.11.tar.gz
    Extract and follow the instructions (see txt file).
    2
    So I followed this, installing LOS to both slots as suggested.
    When trying the original "all" variation, I get many similar errors like:
    $ sudo fastboot flash --slot=all xbl xbl.img
    error: Could not check if partition xbl has slot.

    When trying to flash to specific slot, I got many similar errors like:
    $ sudo fastboot flash --slot=a xbl xbl.img
    Warning: xbl does not support slots, and slot a was requested.
    target reported max download size of 805306368 bytes
    sending 'xbl' (3212 KB)...
    OKAY [ 0.111s]
    writing 'xbl'...
    FAILED (remote: Flashing is not allowed for Critical Partitions
    )
    Did you perform pre-install instructions ?

    In some cases slot b can be unpopulated or contain much older firmware than slot a, leading to various issues including a potential hard-brick. We can ensure none of that will happen by copying the contents of slot a to slot b. This step is NOT optional.
    To do this, sideload the copy-partitions-20210323_1922.zip package by doing the following:

    1. Download the copy-partitions-20210323_1922.zip file from here.
    2. Sideload the copy-partitions-20210323_1922.zip package.
    2
    Yeah, as I had restored my data after updating, I needed to re-add (or re-authenticate) my cards. Got an error that they could not be used in stores.
    If you're passing SafetyNet then just wipe google play services data and reboot. I noticed that they no longer have a button that lets you recheck whether your phone is *safe* again.
  • 9
    @LuK1337 Tahnks for all your hard work.
    Will our beloved 6T also get official 18.1 support?
    Eventually.
    8
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • WFD
    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    5
    Why do the builds say nightly and not stable on the download page? I thought the ROM was "official" and stable now?
    lmao.
    4
    Thanks for your reply! I have a noob question, I can find several guides and instructions on how to install Magisk using TWRP recovery. However, I cannot seem to find any guides on how to install Magisk using Lineage OS recovery.

    Probably because most people on this device are using TWRP, myself included.

    You should be able to use the steps for installing Magisk from 8T Guide. (Should be the key word, as I'm using TWRP, this is untested on this device personally. It is how I would do it though if I needed to try it.)

    It's basically just

    In LOS recovery choose:

    - Apply update
    - Apply from ADB

    Now in the terminal on the PC:
    - sudo adb sideload Magisk-v22.1.zip. (remove sudo if you aren't using Linux)

    If you get a warning about them not being signed, choose flash anyways. We should be ready to reboot to the system now.

    The section there about passing safety net will work as well. Just remember the safety net test in Magisk doesn't currently work.
    3
    Just gone official

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone