• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][fajita][11] LineageOS 18.1

Search This thread


Sep 2, 2016
I followed official LOS wiki method of LOS 18.1 installation

I flash los 18.1 (22/07 build)
And install nikgapps custom pkg
I am on los recovery and now today (29/07 new build arrive in OTA Updater Section)
So now how to update new LOS build without losing data


Sep 2, 2016
Just follow the prompts in the updater.
I download via ota Updater but after download complete

That stuck finishing at 0%


Senior Member
Oct 16, 2009
St Paul, AZ
Moto G6
OnePlus 6T
I just installed the 7/29 update. The touch response is really off for me where initial touches register as "select" rather than "click". I have to touch a second time often.

Anyone else experiencing this? Suggestion how to fix?
I rolled back (switched slots) to 7/22 version, and am no longer experiencing the touch issue above. Anyone else experiencing this issue with the 7/29 update?
Last edited:


Senior Member
Jan 27, 2019
Last edited:
  • Like
Reactions: mprost and jhedfors


Senior Member
Jan 27, 2019


  • Screenshot_20210802-090556_Settings.png
    152.6 KB · Views: 90
Last edited:


Jan 19, 2016
Moto G5 Plus
Google Pixel 3
I converted my tmob to international.... I am assuming that it won't be an issue? (Looking for confirmation 😁)
I'm in the same boat with a tmob converted to international. I ran the last OTA (10.3.11) without any issue, but haven't done this one yet. Assuming it should be fine, but I'm going to have some backups at the ready :/
  • Like
Reactions: jhedfors


Senior Member
Jun 25, 2010
Installed this ROM today and I'm wondering if there is a way to improve the camera quality? I installed the Gcam port and the results are pretty bad, worse than my Nexus 6P with custom ROM and Gcam port.
When I used OOS I used a Gcam port and the pictures quality was excellent.
Is there a way I can fix it or has it something to do with OnePlus camera drivers that we no have on this ROM?

Thanks in advance! :)

Top Liked Posts

  • 1
    Hmm, even with latest ROM, the colours are still saturated (srgb, after locking the device, it returns to saturated) :/
    A well known issue on OP6/6T... not easy to fix.
  • 3
    Guys can someone let me know, How to make sure that my upgrade from old to new vendor firmware and kernel image is successful?
    Check your baseband version.
    .15-00007-SDM845_GEN_PACK-1.417328.2.422944.1 for fw 11.
    We can now update to A11 vendor.

    I have updated successfully but, first update to the 2nd September build.


    Thanks @LuK1337
    I had converted it to international prior.
    Important point - I thought that might be the case. Same here
    As @Eric_Lev mentioned, update to the newest build first before updating to Android 11 vendor + fw. Without the kernel changes from the newest build, your phone will end up booting into crashdump mode on Android 11 fw, whether you try booting android or recovery.

    I'd suppose if you already did this and your phone enters crashdump upon trying to boot android or recovery, you could still download and boot the latest lineage recovery using the wiki instructions?
  • 10

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    @LuK1337 Tahnks for all your hard work.
    Will our beloved 6T also get official 18.1 support?
    So I went and read through the RTT docs. One way to make sure RTT is disabled is to remove it from the carrier configuration, lol. So I went and did just that:

    UPDATE: So, I found a better way to do this that doesn't break everything else. You can go to /data/user_de/0/com.android.phone/files and edit the carrierconfig file there. It should be something like carrierconfig-com.android.carrierconfig-89148000001882338238-1839.xml. Note that the first number is the SIM ID, so it will be different for each phone. Change the following line:

    <boolean name="rtt_supported_bool" value="true"/>
    <boolean name="rtt_supported_bool" value="false"/>

    And reboot! After that, RTT shouldn't be a bother anymore. This is a bit of a hack, but it works! XD
    Why do the builds say nightly and not stable on the download page? I thought the ROM was "official" and stable now?
    Thanks for your reply! I have a noob question, I can find several guides and instructions on how to install Magisk using TWRP recovery. However, I cannot seem to find any guides on how to install Magisk using Lineage OS recovery.

    Probably because most people on this device are using TWRP, myself included.

    You should be able to use the steps for installing Magisk from 8T Guide. (Should be the key word, as I'm using TWRP, this is untested on this device personally. It is how I would do it though if I needed to try it.)

    It's basically just

    In LOS recovery choose:

    - Apply update
    - Apply from ADB

    Now in the terminal on the PC:
    - sudo adb sideload Magisk-v22.1.zip. (remove sudo if you aren't using Linux)

    If you get a warning about them not being signed, choose flash anyways. We should be ready to reboot to the system now.

    The section there about passing safety net will work as well. Just remember the safety net test in Magisk doesn't currently work.