[ROM][OFFICIAL][ginkgo][10] LineageOS 17.1 for Redmi Note 8 / 8T

Search This thread

VickRedmi

Member
May 30, 2020
25
0
You need only Magisk Hide Props to pass CTS and use Magisk Hide for certain app's (bank etc) - there is no need to mess with Riru and so on...

Thank you very much.

I tried your solution, but I still have the same issue. eBay App and Bank App, say to me: "the app can't run without Google Play Service, not compatible with your device"

How can I solve the problem?

Thank you
 

sarapnst

Member
Jan 28, 2021
20
3
Ok @sarapnst @myixl0823 and the others with not working front cam.
I got my hands on another unit of Ginkgo and flashed the LOS again, build from 8.02.
First I updated the phone on MIUI (12.0.2). I opened the front cam there to launch it once and check it.
Then I did everything according to official LOS instructions, the only difference is that this time I used twrp-3.5.0_9-0 instead of Lineage Recovery and I didn't wipe /system, only formatted data.

Front cam works.

It's hard to guess what can be the reason. It could be some different piece of hardware in different units, but I got the Redmi Note 8 from the same country, same shop, same color, within 1 month. Could also be something related to specific build/firmware version/whatever.

I'm too busy and it would be great if you tried with the old method to see if it's a hardware diff.. I'll probably try in the future
 

VickRedmi

Member
May 30, 2020
25
0
Use Magisk Hide for eBay App and Bank App + any Google app (including Pay)
If needed, there is an option to hide (rename) the manager from the settings, then reboot

Hello!
i try your solution but eBay App and Bank App still don't work and return to me the same message:

"the app can't run without Google Play Service, not compatible with your device"

I try everythings : Magisk Hide Props, Magisk Hide with or without MicroG but nothing.

Am I doing something wrong?
 

_pX_

Senior Member
Feb 17, 2010
102
11
After a week of using this ROM:

PROS:
- great battery life and the only A10 ROM where CallerID works well with VoLTE and VoWiFi on polish P4 cellular provider and I can use HD for calling (I tried quite a few A10 ROMs for Willow and CallerID is broken in every one)

CONS:
- BT is completely unstable (stops working while being connected)
- dialer and phone has lags when answering and sometimes when calling
- need use Magisk for passing CTS and some apps (GPay)

To pity I need to switch to another ROM.
 

VickRedmi

Member
May 30, 2020
25
0
Sorry I use Opengapps, not sure how MicroG works with Google Play Services

Thank you! I have install Open G-App (Pico) + Magisk Hide and now ebay App, Bank App and the other "playservice needed app" are working.

The only problem is the presence of Google in my phone. I have install LOS for completly de-googling my RN8, but now I have again to do with google.

Currently Open G-App is a solution, but i would to now if there is a fix for the Apps without install Play Service (original or open source)

Is there a way or no Google no party?
 

VickRedmi

Member
May 30, 2020
25
0
I think this is the purpose of MicroG, but I never used it ...
You probably have to give microG some permissions ?

I know there is a pre-built version of Lineage with microg, you can have a look

Very interesting. I have download the ROM for didactic purpose.
I don't know at this time of the excellent LOS 17.1 OFFICIAL make sense for me to switch to an UNOFFICIAL ROM. I Will try in the future, maybe.
anyway, if I have understand everything, there is no way apart install MicroG or OpenGapp, to have a fully compatible de-googled device with the app that need PlayService, right?

If it is so, I prefer lost few app (in my case only bank app and ebay app) instead ha Google in my phone!

A part from everything, if anyone have other ideas for this topic, let we know!
 

Istju

Member
Aug 6, 2011
41
9
Győr
Thank you! I have install Open G-App (Pico) + Magisk Hide and now ebay App, Bank App and the other "playservice needed app" are working.

The only problem is the presence of Google in my phone. I have install LOS for completly de-googling my RN8, but now I have again to do with google.

Currently Open G-App is a solution, but i would to now if there is a fix for the Apps without install Play Service (original or open source)

Is there a way or no Google no party?
I tried everything. Micro-g, nanodroid, universal safetinetfix, fake store, patched play store, micro-g for LOS. I resolved the play services error. But unfortunately, due to some "payload verification" error, SAFETYNET did not go.
If you can get a solution for a google free phone, let me know. For now, unfortunately, I had to go back to opengapps.
 
  • Like
Reactions: pnin and VickRedmi

VickRedmi

Member
May 30, 2020
25
0
I tried everything. Micro-g, nanodroid, universal safetinetfix, fake store, patched play store, micro-g for LOS. I resolved the play services error. But unfortunately, due to some "payload verification" error, SAFETYNET did not go.
If you can get a solution for a google free phone, let me know. For now, unfortunately, I had to go back to opengapps.

Hello!

In this days I tried LOS with MicroG. Bank App work great but eBay doesn't work. Also I found the ROM unstable. I go back to the official LOS without any presence of Google and I look for modified version of the apps that require Play Service in third part APK store.

In my case they are: Ebay App, Bank App and a game. I found Bank app and the game and they work great without google! (i think they bypass any check during startup). the only app that remains non-functional is ebay. But I'll keep looking for a modified version.
However, it is not a sacrifice for me renounce to eBay App in exchange of free google phone.

Apart from my experience, will still remain for didactic purpose aimed at the more exeperienced users, the same question:

is there a way to have a fully worked google-free phone without have any (official or not) Play Service?

Many thanks!
 

myixl0823

Member
Feb 11, 2021
20
3
I've been using LOS 17.1 2021-02-01 nightly for a week now..and although people here said front cam doesn't work and there's no quick charge, random reboots on switching off wifi and other stuff, I flashed the rom and everything seems to work just fine for me till now...

Here's what I did:

- used OrangeFox recovery (you can use any other recovery too I don't think it'll change anything)
- wiped dalvik/art cache, cache, system, data
- flashed this firmware
- flashed rom zip
- flashed magisk
- format data (format, not wipe)
in TWRP > wipe > format(don't go to advanced) > type yes
in OrangeFox > menu > manage partitions > data > format data > type yes
- for TWRP users I think you also have to flash dm-verity (sorry I forgot, so not sure..been using OrangeFox for too long :D )
- [OPTIONAL] if you don't want encryption, flash disable-forceencrypt [personally not recommended..encryption is always better.. but you choose :) ]
- reboot system
- to pass CTS use MagiskHide Props Config.
- done

Hope it helps someone. :)

UPDATE: updated (dirty flashed) to 2021-02-08 and the updated firmware. Everything still works.
My redmi note 8 is bought three weeks ago in China, can't make the front camera work even step-to-step as you say. the switch icon is disappear.
 

myixl0823

Member
Feb 11, 2021
20
3
Ok @sarapnst @myixl0823 and the others with not working front cam.
I got my hands on another unit of Ginkgo and flashed the LOS again, build from 8.02.
First I updated the phone on MIUI (12.0.2). I opened the front cam there to launch it once and check it.
Then I did everything according to official LOS instructions, the only difference is that this time I used twrp-3.5.0_9-0 instead of Lineage Recovery and I didn't wipe /system, only formatted data.

Front cam works.

It's hard to guess what can be the reason. It could be some different piece of hardware in different units, but I got the Redmi Note 8 from the same country, same shop, same color, within 1 month. Could also be something related to specific build/firmware version/whatever.
Thanks, but the front camera isn't work too.
 
  • Like
Reactions: sarapnst

sarapnst

Member
Jan 28, 2021
20
3
After a week of using this ROM:

PROS:
- great battery life and the only A10 ROM where CallerID works well with VoLTE and VoWiFi on polish P4 cellular provider and I can use HD for calling (I tried quite a few A10 ROMs for Willow and CallerID is broken in every one)

CONS:
- BT is completely unstable (stops working while being connected)
- dialer and phone has lags when answering and sometimes when calling
- need use Magisk for passing CTS and some apps (GPay)

To pity I need to switch to another ROM.

For me the BT problem was there in the stock ROM too, maybe it has something to do with BT AVRCP version in the developer options, and it could be a firmware problem.

Fixing or including (in known issues) the front camera detection problem in some devices (including mine) would be a good thing btw. Hey devs?
 
  • Like
Reactions: myixl0823

beechwood45

New member
Aug 27, 2020
2
0
Can anyone help with a minor issue?

I have just flashed this rom on my Note 8 (Global version) and whilst everything works as expected, no problems, the performance seems laggy compared to the PE+ rom that I previously had on this phone. When I tap to open an email there is a noticeable delay before the email is displayed. When I tap an item in the settings app there is a small delay before it is displayed. I didn't have any of these lags with PE+, it was always super-snappy and responsive.

Is this a feature of the rom or an issue with my installation?

I didn't flash any firmware before installation, just followed the instructions on the offical LOS/Gingko page. This is what I did:

formatted data.
sideloaded lineage-17.1-20210208-nightly-ginkgo-signed
sideloaded open_gapps-arm64-10.0-nano-20210211
rebooted system
rebooted recovery
flashed magisk v21.4
rebooted system
installed magisk hide props config module and changed fingerprint to pass safetynet

No other magisk modules installed.

Should I have flashed updated firmware before installing LOS?
Would this affect performance?
 

spider1163

Senior Member
I don't experience these lags.
You can try to Flash updated firmware, but I don't think it will correct this problem if it is software.

I personally disable animations to speed up the display :
  • Head over to Developer Options.
  • Scroll down until you find Window Animation Scale, Transition Animation Scale, and Animator Duration Scale.
  • Here, you can play with all three options, and see which one brings the best results for you. Each animation scale can go from Off to 10x.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Front camera is not working :(
    ...
    It looks this issue isn't important enough, because the majority of users hasn't this problem.
    Xiaomi changed the frontcam sensor with 11-2020 batch.
    It is now OV13B10 (Omnivision). The old one is OV13855. (you can check this with "device info HW" app)
    Custom A10 rom's doesn't connect to this new camera, because the HW vendor image isn't updated in these rom's, so there isn't a driver for it.

    I found some A11 rom's does work with OV13B10 ,so I think LOS 18.1 will too.
    1
    Front camera is not working :(

    See this issue
    https://gitlab.com/LineageOS/issues/android/-/issues/2990#note_550573240

    In addition to these messages in this thread about the front cam issue:
    BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
    Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

    Yes, I bought the redmi note 8 two weeks ago and my front camera not work too after flashing LOS or Havoc.

    I got my hands on another unit of Ginkgo and flashed the LOS again, build from 8.02.
    First I updated the phone on MIUI (12.0.2). I opened the front cam there to launch it once and check it.
    Then I did everything according to official LOS instructions, the only difference is that this time I used twrp-3.5.0_9-0 instead of Lineage Recovery and I didn't wipe /system, only formatted data.

    Front cam works.
    1
    Hello!

    My SDcard from a few days disappears from file management app.
    I need to reboot the devices to see the memory again.
    is it my problem? (the card starts to be broken) or is it a LOS' bug?

    Have a nice day
    Happens for me too from time to time and on several roms (more on A11 then on A10). So this doesn't indicate your sdcard is going to break. Hint: after reboot let it settle for a few seconds and/or if you see the indicator for sdcard in the statusbar appearing shortly everything should went fine. Cheers
  • 10
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the Redmi Note 8

    Contributors
    DarkJoker360, erfanoabdi
    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status: Nightly

    Created 2020-09-28
    Last Updated 2020-09-28
    3
    if it helps with anything:

    BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
    Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

    What is your--
    LineageOS version: 17.1
    LineageOS Download url: https://mirrorbits.lineageos.org/fu...neage-17.1-20210125-nightly-ginkgo-signed.zip (also updated to 20210201 but doesn't matter)
    Gapps version: open_gapps-arm64-10.0-nano-20210127 (also tried installing without gapps, no diff)

    Did you--
    wipe: yes, step by step using the guide
    restore with titanium backup: no
    reboot after having the issue: did many times

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk but doesn't matter

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    before flashing,
    updated to the latest MIUI Global 12.0.3 Stable (QCOMIXM)
    kernel version 4.24.227-perf+
    Model: M1908C3JG, the 4GB 128GB model

    Stock camera: doesn't show the camera switch button, logcat: https://file.io/NGERieHfjn63
    Google camera (installed from Play Store): stops/crashes on switching, logcat: https://file.io/6yFQ7KyVRmpX
    OpenCamera: no front camera
    Most apps: crash

    Bump!
    I have the same issue. Phone mfg batch 2020.11
    On the original MIUI 12.0.1.0 (QCOEUXM) ROM, the kernel (QKQ1.200114.002) reports the front camera linux module as being an OmniVIsion OV13B10 (ov13b10_ginkgo) in Device Info HW App. Also "Supported" is listed as 20 (maybe the number of bundled camera kernel driver modules).

    On LOS17.1 the entry is missing, and "Supported" is 17

    Maybe the missing kernel driver can be included in the LOS17.1 kenel tree.
    2
    You have China version? My phone PCOCNXM - China version and fastcharge doesn't work!
    I have the China version too. Fast charge works only in recovery (orangefox). I've had this problem for months now.
    2
    Is there a way to disable the charging led?

    When I trigger a search for updates it lists the weeklies since I flashed LOS 2 weeks ago but it also says "no new updates". Is this normal? The automatic check is set to Weekly, but never does a thing, and since this is my first time installing a ROM I wonder if maybe I should wait an "official" update (maybe monthly?).
    Settings > "battery light" (type this in the search box).
    2
    Hello. found a bug. 4K video recording is not possible. gcam and the camera does not want to drain. crashes. please correct this critical issue.
    "Critical"? 😅
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone