[ROM][OFFICIAL][ginkgo][10] LineageOS 17.1 for Redmi Note 8 / 8T

Search This thread

jotaru

Member
Mar 18, 2021
5
0
From February when I have install on wife's Note 8 (ginkgo) LineageOS it reboots when she comes from outside usually in elevator. At first I thought it connected to low temperatures outside (or possible change of pressure %) ). Then I thought it ties with WiFi connectivity ( like in other messages here about reboots and some issues on gitlab 3148 2983 2910 2844). But when I have pulled logs from /sys/fs/pstore/console-ramoops it appears that problem is with interaction between LineageOS and modem FW. Sorry that logs somewhat dirty looking (i don't know reason for this :rolleyes: ). I have combined output of 2 logs together from yesterday's and today's reboot. If it will be next reboot i will collect output from logs.

log1:
[ 1970.985366] [FTS_TS/I]nts_pM_resume:pm resTme Y 1976.047407] iClss: Received eafly ir!sh kndicatyon from FW [ 19^W2.612726] Fatal errïr oN modem! [ 1972.612848] mo`ei suBsqstem failure reason2 wl1rfmif,c:3331:RX_KNIT^@FAILED^@due |o NULL RF Cal!0ChecC wéth RF^@team!. Y 1972.6!3205] RaIdump(ramd}mp_ma^Crodum`_mod$i): no^@consqmerr. Aborthng.* Y 1972.32556^V] Ker.el^@pqnic - not sqncing^Z subsys-restart: ResEttiæg the SoG ) modem frasHe$.
log2:
[ =240>8^W379·] [FTS_TS/ ]fts_pí_^Resume:pm be3uma [ 8245.441203] Fatal error mn }ndee! [ 9245.440335U m^?dem sufSy3tem faélURa r%asoJ: wd1Rfm^Hf.c:3331:RX_INIT FAILEL^@due to NULL^HRF Cal^A ChEck with RF team!* [ 9245.440635] Ramtump^Hramlump^WmicrodUmp_mmdem): N^? cïnsumers. Abortine.® [ 9245.^U44^S7;] Kernad pajia ) not s9ncing subqx3-restart: R%{Ettinw thm^@SoC - mOdem crAbhel.
decoding attempt:
Fatal error on modem! modem susbsystem failure reason w?1?rm?f.c:RX_INIT FAILED due to NULL RF Cal? check with RF team! Ramdump ... Aborting. Kernel panic - not s?ncing subsys-restart: Ressetting the SoC - modem crashed

Thank You for Your work and great ROM!
Files was not attached, so try to attach it here.
 

Attachments

  • ramoops_logs.zip
    632.2 KB · Views: 3

jotaru

Member
Mar 18, 2021
5
0
If it will help here some info about current phone config:
Code:
What is your--
LineageOS version:lineage-17.1-20210215-nightly-ginkgo-signed.zip
LineageOS Download url: https://mirrorbits.lineageos.org/full/ginkgo/20210215/lineage-17.1-20210215-nightly-ginkgo-signed.zip (now not available)
Gapps version: open_gapps-arm64-10.0-nano-20210116.zip (it is possible that they updated now)

Did you--
wipe: yes
restore with titanium backup: no
reboot after having the issue: of course (rebooting is the issue)

Are you using--
a task killer: no
a non-stock kernel: no
other modifications: no

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
- problems appears when phone is not at home (wifi-off data-on <--- (reboot(s) is somewhere here) ---> data-off wifi-on)
- reboot appears even in wifi-on data-on and wifi-off data-off configurations.
- 2 sim cards 1st GSM 2nd LTE (when cards exchanged in slots or GSM card is taken out phone also reboots)
- problem exist on versions of LineageOS from lineage-17.1-20210111-nightly-ginkgo to lineage-17.1-20210215-nightly-ginkgo
- phone had latest firmware to date of unlocking and flashing (Baseband ver: MPSS.AT.4.3.1-00270-NICOBAR_GEN_PACK-1.317803.1.340483.2)
- phone seems is Chinese version but MIUI was in English

I could flash a newer firmware (if I figure out which is better global (stable) or Chinese (weekly)) or newer LineageOS (but in changelog for recent 3 versions were nothing about modem fixes)
 

SwipeToWipe

New member
Jan 1, 2020
2
1
Stock MIUI kernel has "battery idle mode" (power straight from charger) option available in ACCA (Advanced Charging Controller App).


Only few models in the world have this option, and we are lucky enough to have it. This is really something groundbreaking and could mean wonders for extending battery life.

I have tried flashing kernel (boot.img with and without dtbo.img) from stock MIUI 12 but it won't boot.

How to get kernel from stock to run in custom ROM?
 
  • Like
Reactions: pnin

NeoPreacher

Senior Member
  • Dec 4, 2012
    728
    417
    Bielefeld
    Stock MIUI kernel has "battery idle mode" (power straight from charger) option available in ACCA (Advanced Charging Controller App).


    Only few models in the world have this option, and we are lucky enough to have it. This is really something groundbreaking and could mean wonders for extending battery life.

    I have tried flashing kernel (boot.img with and without dtbo.img) from stock MIUI 12 but it won't boot.

    How to get kernel from stock to run in custom ROM?
    Why necessarily stock kernel? There are a few I used in ginkgo roms that support "battery idle mode" (including my actual config).
     

    SwipeToWipe

    New member
    Jan 1, 2020
    2
    1
    Why necessarily stock kernel? There are a few I used in ginkgo roms that support "battery idle mode" (including my actual config).
    I didn't know there are any others, I couldn't find anything here on XDA that is in standalone .zip ready to flash. I've read a lot and tried different things but still not enough experience and understanding of switching between kernels. I don't understand why original files from MIUI won't work here with LineageOS.

    Can you show me where to look and what to search for? What setup do you use that has working battery idle mode?
     

    NeoPreacher

    Senior Member
  • Dec 4, 2012
    728
    417
    Bielefeld
    I didn't know there are any others, I couldn't find anything here on XDA that is in standalone .zip ready to flash. I've read a lot and tried different things but still not enough experience and understanding of switching between kernels. I don't understand why original files from MIUI won't work here with LineageOS.

    Can you show me where to look and what to search for? What setup do you use that has working battery idle mode?
    The road leads to telegram. Here's a good start click. Cheers
     

    redandvidya

    Member
    Mar 28, 2021
    9
    2
    The Philippines
    Hello! I reported a possible bug that has to do with all audio sounding crackly and terrible with this phone. I am on the latest build, March 15 2021, and I did exactly as all the instructions said. And it sounds like ****! :( I was hoping someone could find out what's causing this and fix it? Thanks!

     

    rossholmes

    Senior Member
    Sep 18, 2011
    62
    28
    London
    I've been operating on this ROM (microG) version for a week or so now. I can report that's a really nice and smooth system - the only thing for what I needed to do a bigger research it was the location as it wasn't capturing my position correctly. However on microG telegram group there are some nice guides, ideas on solving such issue, or any other one.

    It's a great feeling to have a phone without Google Play Services or other unnecessary battery draining background monster.
     
    • Like
    Reactions: pnin

    dario-20

    Member
    Dec 19, 2019
    46
    6
    Poznań
    I've been operating on this ROM (microG) version for a week or so now. I can report that's a really nice and smooth system - the only thing for what I needed to do a bigger research it was the location as it wasn't capturing my position correctly. However on microG telegram group there are some nice guides, ideas on solving such issue, or any other one.

    It's a great feeling to have a phone without Google Play Services or other unnecessary battery draining background monster.
     

    Jhoner

    Member
    May 22, 2016
    16
    2
    I love this rom, it is very minimalist and without any bloatware, but even so I have realized that output audio in lineageos 17.1 is too low compared to miui12. Could you please boost the output audio in a next build?
     

    cali.s

    Senior Member
    Nov 3, 2009
    119
    24
    after the last update and magisk 22 phone responds very sluggish not operable, after removing magisk ok, does magisk work with this version for someone?
    also with magisk 21.4
     
    Last edited:

    veracid

    Member
    Sep 24, 2016
    12
    1
    Anyone have problem with every call app? At First call i can't hear voice, than immediaty recall and sound woks fine...
    Screenshot_20210413-120124_Market_Feedback_Agent.png
     
    Last edited:
    • Like
    Reactions: jaysongaray

    jotaru

    Member
    Mar 18, 2021
    5
    0
    I could flash a newer firmware (if I figure out which is better global (stable) or Chinese (weekly)) or newer LineageOS (but in changelog for recent 3 versions were nothing about modem fixes)
    Apparently problem was with modem device. But flashing of stable global firmware didn't help much.
    What help that is changing region from "Automatic" to some sensible to my location in the menu *#*#4636#*#*. Now phone work without reboots for almost 400 hours.
     

    jotaru

    Member
    Mar 18, 2021
    5
    0
    For what was happening under the hood here is reconstructed messages before modem crash:
    [FTS_TS/I]fts_pm_resume:pm resume Fatal error on modem! modem susbsystem failure reason wl1rfmif.c:3331:RX_INIT FAILED due to NULL RF Cal! Check with RF team! Ramdump(ramdump_microdump_modem): No consumers. Aborting.. Kernel panic - not syncing subsys-restart: Ressetting the SoC - modem crashed.
    The mentioned file wl1rfmif.c is from firmware for device. It is mentioned in unpacked image/modem.b16. It is possible that modem in Automatic setting conflict with some frequencies for LTE in my country.
     

    teosound

    Member
    Jun 14, 2014
    10
    2
    Hello, does someone use the sd card as adoptable storage?
    Tt doesn't work for me. When it's time to migrate data, everything goes right, but then i can't find my files on /storage/emulated/0/. All the directories are there but no files, and it seems it can't write on the adoptable storage... i tried different sd card and i had the same problem.
    Thanks to everyone will help!
     
    Last edited:

    photocut

    New member
    Mar 20, 2021
    1
    1
    Front camera is not working :(

    See this issue
    https://gitlab.com/LineageOS/issues/android/-/issues/2990#note_550573240

    In addition to these messages in this thread about the front cam issue:
    BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
    Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

    Yes, I bought the redmi note 8 two weeks ago and my front camera not work too after flashing LOS or Havoc.

    I got my hands on another unit of Ginkgo and flashed the LOS again, build from 8.02.
    First I updated the phone on MIUI (12.0.2). I opened the front cam there to launch it once and check it.
    Then I did everything according to official LOS instructions, the only difference is that this time I used twrp-3.5.0_9-0 instead of Lineage Recovery and I didn't wipe /system, only formatted data.

    Front cam works.
     
    Last edited:
    • Like
    Reactions: sarapnst

    Elinx

    Senior Member
    Jan 5, 2015
    96
    34
    Front camera is not working :(
    ...
    It looks this issue isn't important enough, because the majority of users hasn't this problem.
    Xiaomi changed the frontcam sensor with 11-2020 batch.
    It is now OV13B10 (Omnivision). The old one is OV13855. (you can check this with "device info HW" app)
    Custom A10 rom's doesn't connect to this new camera, because the HW vendor image isn't updated in these rom's, so there isn't a driver for it.

    I found some A11 rom's does work with OV13B10 ,so I think LOS 18.1 will too.
     
    Last edited:
    • Like
    Reactions: sarapnst and AA0_o

    VickRedmi

    Member
    May 30, 2020
    25
    0
    Hello!

    My SDcard from a few days disappears from file management app.
    I need to reboot the devices to see the memory again.
    is it my problem? (the card starts to be broken) or is it a LOS' bug?

    Have a nice day
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 2
      Front camera is not working :(
      ...
      It looks this issue isn't important enough, because the majority of users hasn't this problem.
      Xiaomi changed the frontcam sensor with 11-2020 batch.
      It is now OV13B10 (Omnivision). The old one is OV13855. (you can check this with "device info HW" app)
      Custom A10 rom's doesn't connect to this new camera, because the HW vendor image isn't updated in these rom's, so there isn't a driver for it.

      I found some A11 rom's does work with OV13B10 ,so I think LOS 18.1 will too.
      1
      Front camera is not working :(

      See this issue
      https://gitlab.com/LineageOS/issues/android/-/issues/2990#note_550573240

      In addition to these messages in this thread about the front cam issue:
      BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
      Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

      Yes, I bought the redmi note 8 two weeks ago and my front camera not work too after flashing LOS or Havoc.

      I got my hands on another unit of Ginkgo and flashed the LOS again, build from 8.02.
      First I updated the phone on MIUI (12.0.2). I opened the front cam there to launch it once and check it.
      Then I did everything according to official LOS instructions, the only difference is that this time I used twrp-3.5.0_9-0 instead of Lineage Recovery and I didn't wipe /system, only formatted data.

      Front cam works.
      1
      Hello!

      My SDcard from a few days disappears from file management app.
      I need to reboot the devices to see the memory again.
      is it my problem? (the card starts to be broken) or is it a LOS' bug?

      Have a nice day
      Happens for me too from time to time and on several roms (more on A11 then on A10). So this doesn't indicate your sdcard is going to break. Hint: after reboot let it settle for a few seconds and/or if you see the indicator for sdcard in the statusbar appearing shortly everything should went fine. Cheers
    • 10
      2okPze5.png


      LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

      What's not working :
      • You tell me
      Instructions :
      • Download the latest build and gapps
      • Reboot to recovery
      • Flash the latest build and gapps
      • Reboot
      Downloads :
      Reporting Bugs
      • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
      • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
      • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
      • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
      Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

      Code:
      What is your--
      LineageOS version:
      LineageOS Download url:
      Gapps version:
       
      Did you--
      wipe:
       restore with titanium backup:
      reboot after having the issue:
       
      Are you using--
      a task killer:
      a non-stock kernel:
      other modifications:
       
      Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

      XDA:DevDB Information
      LineageOS, ROM for the Redmi Note 8

      Contributors
      DarkJoker360, erfanoabdi
      Source Code: https://github.com/LineageOS

      ROM OS Version: Android 10
      ROM Kernel: Linux 4.x
      Based On: LineageOS

      Version Information
      Status: Nightly

      Created 2020-09-28
      Last Updated 2020-09-28
      3
      if it helps with anything:

      BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
      Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

      What is your--
      LineageOS version: 17.1
      LineageOS Download url: https://mirrorbits.lineageos.org/fu...neage-17.1-20210125-nightly-ginkgo-signed.zip (also updated to 20210201 but doesn't matter)
      Gapps version: open_gapps-arm64-10.0-nano-20210127 (also tried installing without gapps, no diff)

      Did you--
      wipe: yes, step by step using the guide
      restore with titanium backup: no
      reboot after having the issue: did many times

      Are you using--
      a task killer: no
      a non-stock kernel: no
      other modifications: magisk but doesn't matter

      Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
      before flashing,
      updated to the latest MIUI Global 12.0.3 Stable (QCOMIXM)
      kernel version 4.24.227-perf+
      Model: M1908C3JG, the 4GB 128GB model

      Stock camera: doesn't show the camera switch button, logcat: https://file.io/NGERieHfjn63
      Google camera (installed from Play Store): stops/crashes on switching, logcat: https://file.io/6yFQ7KyVRmpX
      OpenCamera: no front camera
      Most apps: crash

      Bump!
      I have the same issue. Phone mfg batch 2020.11
      On the original MIUI 12.0.1.0 (QCOEUXM) ROM, the kernel (QKQ1.200114.002) reports the front camera linux module as being an OmniVIsion OV13B10 (ov13b10_ginkgo) in Device Info HW App. Also "Supported" is listed as 20 (maybe the number of bundled camera kernel driver modules).

      On LOS17.1 the entry is missing, and "Supported" is 17

      Maybe the missing kernel driver can be included in the LOS17.1 kenel tree.
      2
      You have China version? My phone PCOCNXM - China version and fastcharge doesn't work!
      I have the China version too. Fast charge works only in recovery (orangefox). I've had this problem for months now.
      2
      Is there a way to disable the charging led?

      When I trigger a search for updates it lists the weeklies since I flashed LOS 2 weeks ago but it also says "no new updates". Is this normal? The automatic check is set to Weekly, but never does a thing, and since this is my first time installing a ROM I wonder if maybe I should wait an "official" update (maybe monthly?).
      Settings > "battery light" (type this in the search box).
      2
      Hello. found a bug. 4K video recording is not possible. gcam and the camera does not want to drain. crashes. please correct this critical issue.
      "Critical"? 😅
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone