[ROM][OFFICIAL][ginkgo][10] LineageOS 17.1 for Redmi Note 8 / 8T

Search This thread

DominguesJ

New member
Jan 20, 2017
1
0
Hi !
Thanks for all your work on this ROM.
Since I've started using LOS I've noticed a lower volume on my speaker but I've used an app to increase volume and work around that problem but since the last update I now have a very low volume on the earpiece speaker.

Can someone help me with this?
 

sjohannes

New member
May 18, 2014
3
0
Hi,
The ROM work perfectly but the battery drains way to fast. On normal usage "listening podcast, checking mails, WhatsApp" the battery is low after 3/4 of a day. When I use maps in the car, the battery drains even faster that it's possible to load via USB.

I did a clean install without root, with opengapps Pico and no restoring via titanium.
 
Sep 14, 2021
20
5
39
italy
thanks for your reply. one more question. did you set up all new before flashing, wipe factory reset and so on, or is it possible to boot into recovery and flash the old firmware "over the new firmware", then reboot and LOS works fine?
I flashed only the firmware and everything worked (then I went to another ROM because I prefer TWRP recovery, however I tested everything was working...)
 

mdude22

Senior Member
Sep 25, 2014
86
8
My xiaomi 8 won't boot into lineageOS unless i have my sim in it.
I tried a different simcard but same problem. It's almost as it knows which simcard is in it.

without sim card - When it boots it gets to the lineageOS logo then reboots.
with different simcard - boots into welcome screen then freezes and reboots

Did xiaomi start linking phone numbers to phones in order to boot into them?



What is your--
LineageOS version: lineage-17.1-20210927-nightly-ginkgo-signed.zip
LineageOS Download url: https://download.lineageos.org/ginkgo
Gapps version: im not using gapps

Did you--
wipe: yes
restore with titanium backup: no
reboot after having the issue:

Are you using--
a task killer: no
a non-stock kernel: im using lineageOS 17.1
other modifications: lineage-17.1-20210927-recovery-ginkgo.img

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

If i put in the simcard that works, boot into lineageOS then put the phone into airplane i can reboot and it boots into lineageOS fine. But as soon as i take it off airplane off. It freezes and reboots then just reboots over and over again.

I wont work with anyother simcard. Only the simcard which i unlocked the phone with when i first bought it,
 
Last edited:

Uluru25

Senior Member
Nov 27, 2016
260
102
Samsung Galaxy S7
Samsung Galaxy A6
My xiaomi 8 won't boot into lineageOS unless i have my sim in it.
I tried a different simcard but same problem. It's almost as it knows which simcard is in it.

without sim card - When it boots it gets to the lineageOS logo then reboots.
with different simcard - boots into welcome screen then freezes and reboots

Did xiaomi start linking phone numbers to phones in order to boot into them?



What is your--
LineageOS version: lineage-17.1-20210927-nightly-ginkgo-signed.zip
LineageOS Download url: https://download.lineageos.org/ginkgo
Gapps version: im not using gapps

Did you--
wipe: yes
restore with titanium backup: no
reboot after having the issue:

Are you using--
a task killer: no
a non-stock kernel: im using lineageOS 17.1
other modifications: lineage-17.1-20210927-recovery-ginkgo.img

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

If i put in the simcard that works, boot into lineageOS then put the phone into airplane i can reboot and it boots into lineageOS fine. But as soon as i take it off airplane off. It freezes and reboots then just reboots over and over again.

I wont work with anyother simcard. Only the simcard which i unlocked the phone with when i first bought it,
Very strange! If you are not getting help here try the telegram support group for DarkJoker360 Roms: https://t.me/ginkgodev
 

dracojah

New member
Aug 27, 2018
1
0
Hi,

I recently got some hearing aids. I tried to look for a way to connect them to my Redmi note 8.

When I use the search feature in my phone settings I can find an entry "Hearing aids" in accessibility settings. However, when I click on it or go to Accessibility menu the entry doesn't exist.

How can I manage to access this setting?

Thank you for your help and for your work on this rom.
 

helloyello

Senior Member
Feb 11, 2020
100
9
Hello,

I own a Xiaomi Redmi Note 8 - EU Model - 11.2020 batch, running the latest LOS 17.1 lineage-17.1-20211011-nightly-ginkgo-signed.zip and the front camera doesn't work.

I noticed in the LOS 17.1 changelog that the support for the new front camera was added and then removed (reverted). The explanation is beyond my understanding - given the (lack of) details provided in the revert entry.
Here it was added:
And here reverted:

Given it was reverted on Aug 29 2021, that's a Sunday, I believe it didn't make it into the LOS17.1 build from that night. Anyways, that old LOS 17.1 build is not available for download anymore.

I tried the Magisk Module - front camera fix (drivers and firmware) from this thread:
And the front camera started working. But as soon as the phone entered standby mode and I woke it up, I wasn't able to record videos anymore, with all the cameras and all the camera apps - file corrupted / there was a problem saving the recording. I believe the data stream the camera service is providing the camera app is corrupted. Taking photos and saving them works with all the cameras, just the video recording is broken.
More details provided in this post (#26):

I'm wondering why the LOS17.1 devs team removed the support for this new front camera and I'd be very thankful if they put it back - "revert the revert":

Many thanks in advance!

Edit: corrections
 
Last edited:

tablord

Senior Member
Mar 21, 2012
122
29
Hi, I tryed both LOS17.1 and LOS18.1. I found LOS17.1 works well with old XIAOMI firmware, while LOS18.1 works well only with latest xiaomi firmware. I was on 17.1, made clean flash of 18.1 and nothing worked until flashed latest firmware...
Maybe the cause of bootlops could be the firmware...
Which exact firmwares did you use or flash to make LOS17.1 and LOS18.1 work properly? I can not seem to find one that allows me to flash and run LOS17.1. Bootloop issue...
 
Sep 14, 2021
20
5
39
italy
Which exact firmwares did you use or flash to make LOS17.1 and LOS18.1 work properly? I can not seem to find one that allows me to flash and run LOS17.1. Bootloop issue...
Hi, LOS17.1 worked well with the original firmware of the phone; i think if you flash a firmware released in 2020 with emui based on Android, is ok to have LOs17.1 work properly.
In august I upgraded to LOS18.1 (with clean flash), and nothing worked until i flashed the newest firmware, based on Android11
 
Dec 23, 2019
7
0
sometimes the package installer has problems
1.package installer has been stopped
2.i installed apps from the play store, when it was installed and when I opened it, a pop up app was not installed
 

oneser

Member
Oct 4, 2019
7
1
I cant install the rom. It says



and



I'm coming from Miui 12 12.0.2 android 11. I also tried TWRP got no error but doesn't boot to system it just redirect to recovery

 
2okPze5.png


LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.


Are you using--
a task killer:
a non-stock kernel:
other modifications:
What das "increase performance" technically means. Then I need to know, what is the relationship between increasing performance and the design you wrote.

And even this aspect of technical function of reliability, I wanna know.

Nice greatings 😉😋

I hope a little bit no one else asked this, Otherway please Link it. 🙄😅

And what should I know about Kerneling?
 

Fyahipoh

Senior Member
Aug 1, 2015
124
9
Official lineageOS for gincko / willow will never evolve from Android 10 to 11?
It is not official, but it is the same developer of version 10
 

mdude22

Senior Member
Sep 25, 2014
86
8
My xiaomi 8 won't boot into lineageOS unless i have my sim in it.
I tried a different simcard but same problem. It's almost as it knows which simcard is in it.

without sim card - When it boots it gets to the lineageOS logo then reboots.
with different simcard - boots into welcome screen then freezes and reboots

Did xiaomi start linking phone numbers to phones in order to boot into them?



What is your--
LineageOS version: lineage-17.1-20210927-nightly-ginkgo-signed.zip
LineageOS Download url: https://download.lineageos.org/ginkgo
Gapps version: im not using gapps

Did you--
wipe: yes
restore with titanium backup: no
reboot after having the issue:

Are you using--
a task killer: no
a non-stock kernel: im using lineageOS 17.1
other modifications: lineage-17.1-20210927-recovery-ginkgo.img

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

If i put in the simcard that works, boot into lineageOS then put the phone into airplane i can reboot and it boots into lineageOS fine. But as soon as i take it off airplane off. It freezes and reboots then just reboots over and over again.

I wont work with anyother simcard. Only the simcard which i unlocked the phone with when i first bought it,


I ended up fixing my problem.

The problem was xiaomi account with the xiaomi cloud enabled

What i had to do was revert back to stock rom. Sign in with my xiaomi account and xiaomi cloud. Go on my computer and log into the xiaomi cloud and remove the device from the xiaomi cloud. Then after an hour i signed out of my xiami account from the phone and factory reset.

Then installed lineageOS and i did not have that problem anymore.

I installed different simcards and even without a simcard and it does not freeze.

It seemed the xiaomi cloud locked my phone to that specific sim card.

What i don't understand is since i erased the stockrom is where does it save this information to lock my simcard? I thought the lock settings would be saved inside the stock rom.

Anyways everything is good now. It seems strange how that worked. Make sure everyone to sign out of your xiaomi and cloud before erasing the stock and installing lineageOS
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the Redmi Note 8

    Contributors
    DarkJoker360, erfanoabdi
    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status: Nightly

    Created 2020-09-28
    Last Updated 2020-09-28
    3
    if it helps with anything:

    BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
    Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

    What is your--
    LineageOS version: 17.1
    LineageOS Download url: https://mirrorbits.lineageos.org/fu...neage-17.1-20210125-nightly-ginkgo-signed.zip (also updated to 20210201 but doesn't matter)
    Gapps version: open_gapps-arm64-10.0-nano-20210127 (also tried installing without gapps, no diff)

    Did you--
    wipe: yes, step by step using the guide
    restore with titanium backup: no
    reboot after having the issue: did many times

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk but doesn't matter

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    before flashing,
    updated to the latest MIUI Global 12.0.3 Stable (QCOMIXM)
    kernel version 4.24.227-perf+
    Model: M1908C3JG, the 4GB 128GB model

    Stock camera: doesn't show the camera switch button, logcat: https://file.io/NGERieHfjn63
    Google camera (installed from Play Store): stops/crashes on switching, logcat: https://file.io/6yFQ7KyVRmpX
    OpenCamera: no front camera
    Most apps: crash

    Bump!
    I have the same issue. Phone mfg batch 2020.11
    On the original MIUI 12.0.1.0 (QCOEUXM) ROM, the kernel (QKQ1.200114.002) reports the front camera linux module as being an OmniVIsion OV13B10 (ov13b10_ginkgo) in Device Info HW App. Also "Supported" is listed as 20 (maybe the number of bundled camera kernel driver modules).

    On LOS17.1 the entry is missing, and "Supported" is 17

    Maybe the missing kernel driver can be included in the LOS17.1 kenel tree.
    3
    LineageOS 18.1 oficial?? when?

    tank you for job a lot
    2
    I'm liking this ROM very much. Now using for about 2 months since it came out, and so far it is fine.

    No real issues whatsoever, and the battery is good. Which is what I want. So I will be sticking with it for the foreseeable future. Android 11 is not ready for primetime, and I have no wish to waste my time on it.

    All this nonsense about GPS and fast charging not working is very annoying NOISE. I have no desire to read this rubbish. And that is what it is - rubbish from the clueless, feckless, unwashed and inept.
    2
    You have China version? My phone PCOCNXM - China version and fastcharge doesn't work!
    I have the China version too. Fast charge works only in recovery (orangefox). I've had this problem for months now.