[ROM][OFFICIAL][ginkgo][10] LineageOS 17.1 for Redmi Note 8 / 8T

Search This thread

loopypalm

Senior Member
Jul 8, 2016
1,078
1
298
Osaka
I ended up fixing my problem.

The problem was xiaomi account with the xiaomi cloud enabled

What i had to do was revert back to stock rom. Sign in with my xiaomi account and xiaomi cloud. Go on my computer and log into the xiaomi cloud and remove the device from the xiaomi cloud. Then after an hour i signed out of my xiami account from the phone and factory reset.

Then installed lineageOS and i did not have that problem anymore.

I installed different simcards and even without a simcard and it does not freeze.

It seemed the xiaomi cloud locked my phone to that specific sim card.

What i don't understand is since i erased the stockrom is where does it save this information to lock my simcard? I thought the lock settings would be saved inside the stock rom.

Anyways everything is good now. It seems strange how that worked. Make sure everyone to sign out of your xiaomi and cloud before erasing the stock and installing lineageOS
This is very strange, and i don't think what you did is what fixed the problem
if you did a clean flash with wipe system vendor + format data this shouldn't happen ...
I'm no expert, but I reckon it was recorded somewhere in the vendor or persist partitions...
if you mean SIMLOCK it's stored in the sim itself (can be removed with security option)
persist does not have this kind of info
vendor (if not wiped during the flash) get overwriten with the rom vendor img
 

mbeibz

Member
Aug 22, 2020
31
4
This rom is perfect
Can you add screenshot and video recorder on next update? Thx
 
Last edited:

wellyeah

New member
Mar 1, 2022
3
0
Hi,

I am a newbee on installation Lineage OS on my Redmin Note 8.

I am struggeling with TWRP. Or in other words: Where do I find a DETAILLED installation guide for Lineage OS installtion on Redmi Note 8 with TWRP?

Best, Bastian
You could just install LineageOS Recovery instead of TWRP.
I'm sorry but I have no clue how TWRP is installed.

This rom is perfect
Can you add screenshot and video recorder on next update? Thx
LineageOS has a video recorder, just open the "Recorder" app and it has the option to "Record screen".
The screenshot was always there, just press "Volume Down" + "lock" buttons.
 

anenasa

New member
Mar 2, 2022
4
1
Xiaomi 11 Lite 5g NE

moralesnery

Senior Member
Aug 27, 2014
652
368
  • Like
Reactions: g000n

helloyello

Senior Member
Feb 11, 2020
100
9
Noticed in the LOS 17.1 Changelog that support for the OV13B10 (Omnivision) front camera was added:
Performed an update with the latest LOS image - lineage-17.1-20220214-nightly-ginkgo-signed.zip
just to learn that it still doesn't work.
In this older thread I wrote that I'm using a Magisk Module as a partial workaround, partial because it only works when I boot the phone and before a standby-wake cycle.

I inspected the Magisk Module and learned that in addition to the camera sensor blobs, there are some changes to the camera service init files and also to the camera app itself. I presume that only adding the blobs doesn't really resolve the issue.
Wondering if there will be some more effort to fix this in LOS 17.1, since LOS 17.1 looks to be no longer supported. Well, the changelog for LOS 17.1 still looks to be updated (still supported).
 

kevinsatria

New member
Oct 1, 2017
4
0
How to decrease the system storage? My device take much storage on system storage. It's take 20 GB of storage
 

Attachments

  • Screenshot_20220311-114115_Updater.png
    Screenshot_20220311-114115_Updater.png
    70.6 KB · Views: 61
  • Screenshot_20220311-113923_Settings.png
    Screenshot_20220311-113923_Settings.png
    111.4 KB · Views: 61

dennisms

Member
Mar 11, 2022
13
4
I installed the latest build(2022-02-14) and there is a slow charging problem. Ampere values are between 120-270 mA. It was between 1660-1690 mA on stock A10 MIUI 12 ROM, with the same charger I'm using now.

I haven't flashed any custom kernels etc. Why is this happening, how can I solve it?
 

Tortitas

New member
Mar 26, 2022
1
0
I am having the same problem. With these charging speeds the phone is kind of unusable.
I flashed the 2022-02-14 build with twrp and gapps from here. Note that those gapps where the only ones that worked and didn't cause bootloop. Am I missing something?

Edit: If someone finds itself on the same situation I flashed pixel experience and it works fine, It is also android 12 :D
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the Redmi Note 8

    Contributors
    DarkJoker360, erfanoabdi
    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status: Nightly

    Created 2020-09-28
    Last Updated 2020-09-28
    3
    if it helps with anything:

    BUG REPORT - front camera not detected in any app including the stock camera app and Camera2 API Probe, normally causes apps that require camera to stop working.
    Flashing ANXCamera doesn't fix it but based on people's comments, it should work out of the box.

    What is your--
    LineageOS version: 17.1
    LineageOS Download url: https://mirrorbits.lineageos.org/fu...neage-17.1-20210125-nightly-ginkgo-signed.zip (also updated to 20210201 but doesn't matter)
    Gapps version: open_gapps-arm64-10.0-nano-20210127 (also tried installing without gapps, no diff)

    Did you--
    wipe: yes, step by step using the guide
    restore with titanium backup: no
    reboot after having the issue: did many times

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk but doesn't matter

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    before flashing,
    updated to the latest MIUI Global 12.0.3 Stable (QCOMIXM)
    kernel version 4.24.227-perf+
    Model: M1908C3JG, the 4GB 128GB model

    Stock camera: doesn't show the camera switch button, logcat: https://file.io/NGERieHfjn63
    Google camera (installed from Play Store): stops/crashes on switching, logcat: https://file.io/6yFQ7KyVRmpX
    OpenCamera: no front camera
    Most apps: crash

    Bump!
    I have the same issue. Phone mfg batch 2020.11
    On the original MIUI 12.0.1.0 (QCOEUXM) ROM, the kernel (QKQ1.200114.002) reports the front camera linux module as being an OmniVIsion OV13B10 (ov13b10_ginkgo) in Device Info HW App. Also "Supported" is listed as 20 (maybe the number of bundled camera kernel driver modules).

    On LOS17.1 the entry is missing, and "Supported" is 17

    Maybe the missing kernel driver can be included in the LOS17.1 kenel tree.
    3
    LineageOS 18.1 oficial?? when?

    tank you for job a lot
    2
    I'm liking this ROM very much. Now using for about 2 months since it came out, and so far it is fine.

    No real issues whatsoever, and the battery is good. Which is what I want. So I will be sticking with it for the foreseeable future. Android 11 is not ready for primetime, and I have no wish to waste my time on it.

    All this nonsense about GPS and fast charging not working is very annoying NOISE. I have no desire to read this rubbish. And that is what it is - rubbish from the clueless, feckless, unwashed and inept.
    2
    You have China version? My phone PCOCNXM - China version and fastcharge doesn't work!
    I have the China version too. Fast charge works only in recovery (orangefox). I've had this problem for months now.